AlterServ

Otros Servers => Otros => Mensaje iniciado por: JVProducciones en Junio 16, 2016, 09:58:18 am

Título: HandyCache Rev 5 en español (20/06/2016)
Publicado por: JVProducciones en Junio 16, 2016, 09:58:18 am
Handycache Rev5


Hola apreciados amigos, esta vez les traigo aquí esta nueva revisión de Handycache, también me disculpo por tener muy abandonados estos temas ya que no he tenido tiempo por trabajo y salud, sin embargo hay que seguir siempre para adelante….

Notas a considerar antes de usar:
    + El https (ssl) se encuentra activado lo cual permite ahora hacer cache de este protocolo (puede ser desactivado)
    + Compatible con el anterior cache almacenado, solo bastará con indicar la ruta del cache existente. (De manera predeterminada está en "D:/Cache")
    + Agregadas más reglas de bloqueo de publicidad y bloqueo de páginas peligrosas para sus clientes...
    + Agregadas más reglas de redireccionamiento utilizados para redireccionar páginas de inicio diferentes a google, generalmente cambiados sin que el cliente se dé cuenta por algún programa malicioso...
    + Mejorado la traducción
    + Para Youtube seguirá siendo predeterminada la extensión "Youtube Cache Flash y Html5 360p (actualizado)" la cual guarda los videos en mp4 de manera completa  (podrán usar el que deseen) (no recomiendo el html5 en partes ya que las partes casi nunca coinciden, si desean hacerlo en partes les recomendaría hacerlo en flash)
    + Multicolor (según acción tomada) y breve descripción de contenido (según tipo) (nuevo)
    + Aun no compatible con la nueva versión de Handycache (RC4 1.0.0.644)
    + No es recomendable usar Firewall de Windows ni antivirus (solo para usuarios avanzados)
    + Recomiendo usar Windows 8.1 64 bits pero se puede trabajar en cualquier SO windows o en Linux con Wine
    + Recomiendo seguir usando la "Nueva forma de redirección" para todo lo que es https usando servidor apache y el script wpad.pac explicada en HandyCache Rev 4 en español (28/02/2016) (http://www.alterserv.com/foros/index.php?topic=2185.0)

(http://fotowisp.net/img/2016/06/19/Handycache.jpg)

Nueva forma de trabajo (probado en producción alrededor de 100 clientes http y 30 de ellos en https)

Integración de Privoxy como Proxy Padre:
Un amigo muy entusiasta llamado Jhoel comenzó a hacer comentarios y pruebas con diferentes Proxys y me habló del programa Privoxy el cual me llamó la atención…
Privoxy es un proxy web que tiene capacidad de modificar el contenido de las páginas web, administrar cookies, controlar accesos y eliminar anuncios, banners, ventanas emergentes y otros elementos indeseados de Internet. En realidad todo eso puede hacerlo Handycache sin ningún problema, pero Handycache no administra bien el número de conexiones llegando a llenarse en el transcurso del día y alcanzar rápidamente las 400 conexiones seguidamente de la saturación en las respuestas de Handycache (así sea la versión modificada), la alternativa era abrir varios Handycaches (he llegado a usar 8 handycaches para mis más de 90 usuarios) y gracias a este programa a lo mucho he usado 2 Handycaches uno para http y otro para https, Privoxy administra muy bien las conexiones y le quita gran carga de conexiones a Handycache (se sorprenderán) para ello modifiqué gran parte de la configuración original de privoxy según mi criterio, y ahora , comparto mi versión (claro está que pueden usas sus propias configuraciones)

     Privoxy y HandyCache Rev5 (http://http://www.handycache-jv.com/)

Dentro de este paquete encontraremos 2 carpetas (Handycache y Privoxy) y un programa llamado hcmon.exe que administrará a los dos programas

Hcmon.exe
Este Programa lo creo nuestro amigo colaborador JedKiller (Gexel) y tiene detalles importantes:
 +Inicio Automático
 +Bloqueo de Ping a detener el Programa proxy
 +Controla el puerto de escucha tanto de Handycache y Privoxy y los monitorea (en caso de cierre inesperado o cuelgue inesperado)
 +Reinicios automáticos en un horario determinado (puesto de manera predeterminada a las 4 am)

(http://fotowisp.net/img/2016/06/19/Hcmon.jpg)

Privoxy
No explicaré mucho del tema solo lo que nos concierne:
 +Privoxy escuchará de manera predeterminada el puerto 8118 (podrán cambiarlo a su criterio dentro del archivo de texto config.txt o con hcmon.exe)
 +Privoxy Redireccionará de manera predeterminada a http al puerto de escucha de handycache 7070 (podrán cambiarlo a su criterio dentro del archivo de texto config.txt)
 +Privoxy Redireccionará de manera predeterminada a https al puerto de escucha de handycache 8080 (podrán cambiarlo a su criterio dentro del archivo de texto config.txt)
 +Privoxy no hará más que redireccionar el tráfico a handycache (aquí radica la magia)
 +"max-client-connections 256" es el número de conexiones por cliente el cual puse 256, ajusten según su criterio ya que un cliente con virus o malicioso puede generar miles de conexiones....

(http://fotowisp.net/img/2016/06/19/Privoxyconfig.jpg)

Nota: Al usar la redireccion https por medio del Script wpad.pac, este deberá indicar el puerto de escucha 8118 de privoxy.

Configuración en Mikrotik
Mantendremos solo una regla de redirección Nat  siendo 10.0.0.222 la dirección IP de nuestro server donde corren privoxy y handycache y 8118 el puerto de escucha de privoxy (ya no se redireccionará directamente a  handycache (privoxy lo hará)
Regla Nat

Código: [Seleccionar]
/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=!10.0.0.222 dst-port=80,8080,8888,8880,8777,3477,33301 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=8118


Con esto ya deberíamos tener trabajando nuestros servidores...


Gracias a Todos en especial a Diosito Lindo...
Título: Re:HandyCache Rev 5 en español (19/06/2016)
Publicado por: walther en Junio 18, 2016, 06:34:35 pm
esperando amigo ...!
Título: Re:HandyCache Rev 5 en español (19/06/2016)
Publicado por: damian007 en Junio 19, 2016, 07:51:25 pm
Excelente trabajo brother, solo una inquietud, se segira usando el certificado en los navegadores, siegue siendo obligatorio para las paginas HTTPS.

Gracias.
Título: Re:HandyCache Rev 5 en español (19/06/2016)
Publicado por: Enrrike87 en Junio 19, 2016, 08:25:00 pm
Excelente trabajo brother, solo una inquietud, se segira usando el certificado en los navegadores, siegue siendo obligatorio para las paginas HTTPS.

Gracias.
Si la instalacion es obligatoria pero esta forma trae muchos beneficios!! excelente aportaso a JV
Título: Re:HandyCache Rev 5 en español (19/06/2016)
Publicado por: ninohwifi en Junio 19, 2016, 09:57:13 pm
Se ve excelente hermano.. !!
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: system_urrutia en Junio 20, 2016, 07:02:10 am
Saludos y gracias por el aporte gran amigo JVP, y a todo el elenco de desarrolladores de mejoras para el beneficio de toda una gran comunidad así como el betatester o conejitos de india jajajaj, solo quería acotar que a los que descarguen el HCRV5 en la parte del Privoxy Especificamente el el apartado (Options==>Edit Main Configuration) deben cambiar los puertos ya que por defecto vienen de la siguiente manera y deben acoplarlos a como dice el amigo JVP en la descripción o guía de instalación y funcionamiento.
listen-address  :8118
forward / 127.0.0.1:8080
forward :443 127.0.0.1:8081
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: JVProducciones en Junio 20, 2016, 08:55:07 am
Saludos y gracias por el aporte gran amigo JVP, y a todo el elenco de desarrolladores de mejoras para el beneficio de toda una gran comunidad así como el betatester o conejitos de india jajajaj, solo quería acotar que a los que descarguen el HCRV5 en la parte del Privoxy Especificamente el el apartado (Options==>Edit Main Configuration) deben cambiar los puertos ya que por defecto vienen de la siguiente manera y deben acoplarlos a como dice el amigo JVP en la descripción o guía de instalación y funcionamiento.
listen-address  :8118
forward / 127.0.0.1:8080
forward :443 127.0.0.1:8081
Gracias..... ya lo corregí...atento a la jugada!!
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 20, 2016, 12:46:12 pm
hola poniendo las reglas al mk me quedo sin internet porq sera ???
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 20, 2016, 01:11:21 pm
ya parece estar solucionado...
a hora alguien q pruebe si se le demora en hacer es test

http://beta.speedtest.net/run
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: hackersito en Junio 20, 2016, 02:24:47 pm
ya parece estar solucionado...
a hora alguien q pruebe si se le demora en hacer es test

http://beta.speedtest.net/run




lo probe normal me realiza el test rapido sin problemas
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: jeyb2007 en Junio 20, 2016, 02:50:56 pm
JV Ante todo, Felicitaciones y muy agradecido por este gran aporte a la comunidad ISP, Seria bueno publicar un esquema de la implementacion, para poder visualizar con mas claridad como se conectan los equipos y los rangos IP de los componentes entre otros - tengo dudas sobre el servidor interno Apache, si se implementa en una pc nueva o en la misma pc del HandyCache...
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 20, 2016, 04:12:59 pm
JV Ante todo, Felicitaciones y muy agradecido por este gran aporte a la comunidad ISP, Seria bueno publicar un esquema de la implementacion, para poder visualizar con mas claridad como se conectan los equipos y los rangos IP de los componentes entre otros - tengo dudas sobre el servidor interno Apache, si se implementa en una pc nueva o en la misma pc del HandyCache...


lo usas en el mismo hc
http://www.alterserv.com/foros/index.php?topic=2185.0
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 20, 2016, 04:13:38 pm
una pregunta como hago para q una ip por decir 192.168.1.12 no pase por el hc
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: JVProducciones en Junio 20, 2016, 10:16:25 pm
una pregunta como hago para q una ip por decir 192.168.1.12 no pase por el hc
lo harás con dos reglas:

la regla nat (deberá ir arriba de la regla de redirección del proxy handycache)
Código: [Seleccionar]
/ip firewall nat
add chain=dstnat comment="Sacar listas IPs Web Fuera del Proxy" dst-address-list=IPs_Fuera

Address List (Listas ips las cuales no pasarán por el proxy)(este ejemplo es para la página Ivpaste)
Código: [Seleccionar]
/ip firewall address-list
add address=109.236.81.213 comment=ivpaste list=IPs_Fuera
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 21, 2016, 08:06:05 am
lo harás con dos reglas:

la regla nat (deberá ir arriba de la regla de redirección del proxy handycache)
Código: [Seleccionar]
/ip firewall nat
add chain=dstnat comment="Sacar listas IPs Web Fuera del Proxy" dst-address-list=IPs_Fuera

Address List (Listas ips las cuales no pasarán por el proxy)(este ejemplo es para la página Ivpaste)
Código: [Seleccionar]
/ip firewall address-list
add address=109.236.81.213 comment=ivpaste list=IPs_Fuera

gracias probare ya q necesito hacer eso por el sistema de cobro
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 21, 2016, 12:10:10 pm
hasta ahora bien pero... lo q veo esq demora en cargar un poquito las paguina ?
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: josemanuel155 en Junio 21, 2016, 01:42:38 pm
un saludo a todos
la rv5 esta bien solo que carga lento las paginas y a veces deja sin internet tube que volver a la rv4 :'( :'( :'(
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: ninohwifi en Junio 21, 2016, 04:04:13 pm
a cuantas conecciones llega esta rev ?? la estoy probando y he visto que llega hasta 469 no se si mas??
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 21, 2016, 05:20:54 pm
a cuantas conecciones llega esta rev ?? la estoy probando y he visto que llega hasta 469 no se si mas??

con cuantos clientes men porq yo tengo 30 y solo me llega hasta 10/45   el otro q tenia me llegaba hasta 300

y lo q decia mas arriba de lo lento se vuelve un poquito al abrir las paguinas.....

compañero JV porque sera ?????
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: JHOELIT en Junio 21, 2016, 05:36:52 pm
 ??? Fue algo difícil  :-X bastante trabajo en handy  :'( agradezco a JVProducciones por todo su esfuerzo en ello... Hace un año pasó que por primera ves use handycache paralelo a mikrotik, cuando aun youtube funcionaba en http:// después de poco tiempo llegamos a usar la función del wpad. Quedó muy satisfecho, opcional mente eh trabajado en handy y pronto lo decidí compartir con JV, para que quede al beneficio de todos ustedes...

Por cierto vamos a seguir aportando para mejorar esta versión 5 de HC

Saludos...
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 21, 2016, 08:43:03 pm
tuve q desacticarlo por completo porq me ponia lenta la navegacion aveces...
nose si es ami solo q me pasa eso o a alguien mas le sucede
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: eskior en Junio 22, 2016, 04:54:02 pm
Lo han probado en windows server?
Si no es asi, ya les contare  ;D

Por cierto, como va eso de la lentitud de las paginas?

saludos.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: jcfranco0001 en Junio 22, 2016, 08:03:42 pm
ola JVProducciones quisiera consultar si se puede liberar el full cache en https
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: jcfranco0001 en Junio 22, 2016, 08:48:13 pm
alguno de ustedes a cacheado netflix
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: jamo en Junio 23, 2016, 05:09:24 pm
Como se le puede hacer para que handy no haga cache de los  objetos js y css de facebook
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: JVProducciones en Junio 23, 2016, 06:09:10 pm
tuve q desacticarlo por completo porq me ponia lenta la navegacion aveces...
nose si es ami solo q me pasa eso o a alguien mas le sucede
prueba cambiando en privoxy config.txt la opción "max-client-connections 256" aumentando la cifra o borrando toda la linea....saludos
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: JVProducciones en Junio 23, 2016, 06:10:44 pm
Como se le puede hacer para que handy no haga cache de los  objetos js y css de facebook
la regla ya está puesta en lista blanca
Código: [Seleccionar]
#10#~#True#~#(\.(css|js))(\?(.*)|$)#~##~#.*(fbcdn|afcdn|enfemenino)\.(net|com)#~#True#~#True#~#True#~#False#~#False#~#True
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 23, 2016, 10:20:07 pm
prueba cambiando en privoxy config.txt la opción "max-client-connections 256" aumentando la cifra o borrando toda la linea....saludos
ok mañana comento como me va ya q lo tengo apagado el hc
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 24, 2016, 10:24:31 am
como puedo hacer para que me funcione el full cache en qtree ...
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: saintdave en Junio 24, 2016, 10:56:03 am
como puedo hacer para que me funcione el full cache en qtree ...
el full cache en https solo te funcionara si no usas mikrotik.
nota: en simple va bien, en queue tree nunca probe.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 24, 2016, 11:24:15 am
el full cache en https solo te funcionara si no usas mikrotik.

pero ni en http funca en qtree
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: ninohwifi en Junio 24, 2016, 09:23:08 pm
JV como hago para redireccionar privoxy a tres handys que trabajen con https ??
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: josemanuel155 en Junio 28, 2016, 11:42:47 am
un saludo a todo tengo este problema en mi torre cayo un rayo y se funcdieron todo asi que decidi nuevamente instalar mikrotik en otra pc pentieum 4 con 512 ram
todo perfecto
pero a la hora de colocar las reglas para handy cache no jala internet no cache la pelotica no camina y solo avanza si coloco en el navegador la direccion ip del servidor handy

ante me funcionaba bien con las reglas que publicaron primero y esa misma he intentado hacerlo pero no jala que podria estar pasandome he pasado todo el dia dandole para que el servidor handy funcione como lo tenia ante corriendo paginas http
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: josemanuel155 en Junio 28, 2016, 02:28:28 pm
ya resolvi coloque esta regla
/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=\
    ! 192.168.10.2 dst-port=80 in-interface="LAN" protocol=tcp \
    to-addresses=192.168.10.2 to-ports=8080
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Junio 28, 2016, 05:47:44 pm
Saludos JV para las pruebas de los videos de youtube se queda pensando en chrome e ie mas no asi en firefox que si me esta funcionando alguna novedad con otros que esten usando handy full cache https y http?

MAs reporte. Me pasa muy seguido. debo refrescar para que cargue normal

(http://i63.tinypic.com/2s1r4ig.jpg)
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 29, 2016, 12:17:10 pm
Saludos JV para las pruebas de los videos de youtube se queda pensando en chrome e ie mas no asi en firefox que si me esta funcionando alguna novedad con otros que esten usando handy full cache https y http?

MAs reporte. Me pasa muy seguido. debo refrescar para que cargue normal

(http://i63.tinypic.com/2s1r4ig.jpg)

si igual pero refresco y anda bien
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: JOE2D en Junio 29, 2016, 01:41:50 pm

Buen dia amigos estoy tratando de implementar  el handy segun el video
http://www.alterserv.com/foros/index.php?topic=1605.0
pero me da este error
http://subefotos.com/ver/?6f5e282b50dcf70d65881289f6e6748do.jpg
 (http://subefotos.com/ver/?6f5e282b50dcf70d65881289f6e6748do.jpg)
si alguien pudiera darme una manito por favor
una consulta el handy cache me serviria para el Dota2??
gracias de antemano que tengan buen dia
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Junio 30, 2016, 09:57:04 am
HC off dando problema.... no habren las paguina y si habre demoran en cargar
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: zheephy en Julio 03, 2016, 12:40:15 am
Help!
cuando abro con Firefox, me dice, "Conexión Insegura"
El propietario de www.youtube.com ha configurado su sitio web de manera incorrecta. Para evitar que su información sea robada, Firefox no ha conectado con este sitio web.

Este sitio usa Seguridad estricta de transporte de HTTP (HSTS) para especificar que Firefox sólo se conecte a él de modo seguro. Como resultado, no es posible añadir una excepción para este certificado.

Creo que es el tema de los Certificados... Como han hecho ustedes para que nos les salga ese mensaje?, solo me sale en HTTPS, en HTTP ingresa normal.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Julio 04, 2016, 07:47:34 am
tuve q desacticarlo por completo porq me ponia lenta la navegacion aveces...
nose si es ami solo q me pasa eso o a alguien mas le sucede

Que cantidad de clientes estas manejando? por los momentos y solo los reportes que he pasado me esta funcionando bien
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Julio 04, 2016, 07:49:58 am
el full cache en https solo te funcionara si no usas mikrotik.
nota: en simple va bien, en queue tree nunca probe.

Saludos. como dices que te funciona bien y simple queue? que has hecho yo uso simple y va con la velocidad asignada al cliente
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: rifranco202325 en Julio 04, 2016, 09:05:00 pm
Que cantidad de clientes estas manejando? por los momentos y solo los reportes que he pasado me esta funcionando bien

solo 20 clientes
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: jamo en Julio 06, 2016, 09:03:10 am
esta version pr alguna razón hace lenta la navegacion, al menos yo lo tengo inplementado en una LAN de 8 maquinas configuradas en proxy directo al servidor. Solo que cambie de version por que tenia corriendo la Rev.3 y varios videos de youtube no hacian cache (aun con las mismas extensiones de esta version) y con esta version todos si hacen cache.

saludos
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: gexel88 en Julio 06, 2016, 05:13:22 pm
Bueno amigos yo logre estabilizar la Rev5 para una cantidad considerable de clientes (400 ;D), pero tuve que dejar de lado el privoxy... uso la redireccion por NAT con PCC para redirigir hacia múltiples instancias de HandyCache...
Redireccion NAT-PCC
Código: [Seleccionar]
/ip firewall nat
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/0 protocol=tcp to-addresses=192.168.10.2 to-ports=1010
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/1 protocol=tcp to-addresses=192.168.10.2 to-ports=1011
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/2 protocol=tcp to-addresses=192.168.10.2 to-ports=1012
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/3 protocol=tcp to-addresses=192.168.10.2 to-ports=1013
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/4 protocol=tcp to-addresses=192.168.10.2 to-ports=1014
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/5 protocol=tcp to-addresses=192.168.10.2 to-ports=1015
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/6 protocol=tcp to-addresses=192.168.10.2 to-ports=1016
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/7 protocol=tcp to-addresses=192.168.10.2 to-ports=1017
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/8 protocol=tcp to-addresses=192.168.10.2 to-ports=1018
add action=dst-nat chain=dstnat comment="HandyCache Redirect" dst-address-list=!no-cache dst-port=80,8080,8888,8880,8777,3477,33301 in-interface=Lan \
    per-connection-classifier=both-addresses-and-ports:10/9 protocol=tcp to-addresses=192.168.10.2 to-ports=1019

En las reglas suponemos que todo lo que esté en el address-list llamado no-cache, no pasará por HandyCache, muy util para cuando se tienen sistemas administrativos como Mikrowisp que no deben pasar por alli...
Se debe configurar HandyCache Monitor de esta manera:
(http://fotowisp.net/img/2016/07/06/b0bfdbe4513eb9a7da68bd86716918f1.png)

Esta redireccion usada solo sirve para el contenido en http... uso otro método para hacer cache del contenido https el cual publicaré pronto.

Lo que me dá un poco de risa es que este server está de vacaciones ;D
(http://fotowisp.net/img/2016/07/06/212a088094f245e01ee0197fbdcb9668.png)
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: erwef1 en Julio 13, 2016, 11:59:15 am
HOLA TENGO PROBLEMAS CON EL JUEGO LEAGUE OF LEGENDS APESAR DE QUE LAS REGLAS YA ESTAN NO DA CACHE Y MIRANDO EL MONITOR EN RESPUESTA ME SALE 304 NOT MODIFIED
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Enrrike87 en Julio 13, 2016, 04:20:14 pm
HOLA TENGO PROBLEMAS CON EL JUEGO LEAGUE OF LEGENDS APESAR DE QUE LAS REGLAS YA ESTAN NO DA CACHE Y MIRANDO EL MONITOR EN RESPUESTA ME SALE 304 NOT MODIFIED
Uhm lsos archivos k extension tienen?
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: erwef1 en Julio 13, 2016, 05:22:29 pm
termina en .json que podria ser?
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: erwef1 en Julio 13, 2016, 05:26:09 pm
Uhm lsos archivos k extension tienen?

termina en .json que podria ser?
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: WALYN en Julio 29, 2016, 07:24:13 pm
el  HandyCache Rev 5 se podría configurar en modo gateway?....
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: esleyter2010 en Julio 30, 2016, 08:32:29 pm
el  HandyCache Rev 5 se podría configurar en modo gateway?....
si amigo perfectamente
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: esleyter2010 en Julio 30, 2016, 08:33:53 pm
termina en .json que podria ser?
son objetos de java
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: WALYN en Julio 30, 2016, 09:23:41 pm
si amigo perfectamente
DIME COMO
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: WALYN en Julio 30, 2016, 10:57:08 pm
HandyCache Rev 5 ...que tipo de cache usa..usa el plugin dinámico? o squid ...
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: juan26779 en Agosto 02, 2016, 10:04:20 pm
 ??? pregunto si existe una posibilidad de instalar certificados ssl en celulares android, por que ya esta empezando abundar muchos celulares y tablet y ya estoy empezando alquilar internet en celulares. :-X los mas navegados son face y youtube en sus celulares aparte de wasap y menseenger que todo es por https. y si existiese un tutorial. por que ay que aceptar que no solo las Pc dominan también otros aparatos como smart tv que consumen el youtube y ps3 o 4 para actualizaciones de juegos.
yo se que es mucho pedir pero las ay?  :-[
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: orlando0007 en Agosto 03, 2016, 02:29:51 pm
Amigos una pregunta como desactivo el cache https en esta version ya que en extenciones no aparece la opcion??? de antemano gracias
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Agosto 04, 2016, 08:50:02 pm
Amigos una pregunta como desactivo el cache https en esta version ya que en extenciones no aparece la opcion??? de antemano gracias

Te hace cache https fuera de FB/You?
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: fitosoft29 en Agosto 17, 2016, 09:00:08 am
Hola a todos, yo quisiera preguntar que version de .net framework se debe instalar en windows 7 de 64 bits para que funcione bien el hcmon, esto porque me marca errores al momento de querer iniciar el servicio, gracias.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: fitosoft29 en Agosto 17, 2016, 01:11:32 pm
He notado otra cosa en cuestión del bloqueo de publicidad, por ejemplo cuando alguien quiere descargar algo de mega, y tiene que presionar sobre varias pruebas para demostrar que es humano, y se abren páginas tras páginas hasta llegar al enlace (no se si me explico), pero en muchas ocasiones no carga la página, ¿alguna ayuda? gracias
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: fitosoft29 en Agosto 18, 2016, 11:00:09 pm
Adjunto imagen de fallo, al instalar esta nueva version, e iniciar hcmon. Instalé .net framework 4.0, en 32 bits y no funcionó. LUego en 64 bits y el problema persiste, alguna idea? gracias. Por cierto eso de poder subir imagenes de hasta 15 KB no es suficiente, tuve que recortar casi todo.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: fitosoft29 en Agosto 19, 2016, 09:54:53 am
Usando handy me doy cuenta o no se porque, pero cuando veo un video para almacenarlo en el cache entro a la cuenta de youtbe, se carga el video en el cache y ya lo veo después. Luego salgo de la cuenta y se supone que el mismo video ya debería estar listo para poder verlo, pero lo vuelve a cargar desde cero, entonces reviso el contenido del cahe y ahí está (v=ZWoH1G15xvMitag=18), luego me doy cuenta de que lo está volviendo a almacenar pero con una variante (v=ZWoH1G15xvMitag=43.mp4), entonces no se como remediar esto, ¿ayuda?

Luego al revisar de nuevo en cache veo que está guardado el archivo nuevo (v=ZWoH1G15xvMitag=43), intento reproducirlo pero me marca error.

Al buscarle más, noto que creó 16 archivos de otros 16 videos distintos, son mas de 300 MB, entonces estos no sirven y hay que borrarlos para que no hagan espacio.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Agosto 20, 2016, 09:08:31 am
Adjunto imagen de fallo, al instalar esta nueva version, e iniciar hcmon. Instalé .net framework 4.0, en 32 bits y no funcionó. LUego en 64 bits y el problema persiste, alguna idea? gracias. Por cierto eso de poder subir imagenes de hasta 15 KB no es suficiente, tuve que recortar casi todo.

esto se debe a la carpeta donde esta almacenando no es la correcta verifica y chequea
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Agosto 20, 2016, 09:09:22 am
Usando handy me doy cuenta o no se porque, pero cuando veo un video para almacenarlo en el cache entro a la cuenta de youtbe, se carga el video en el cache y ya lo veo después. Luego salgo de la cuenta y se supone que el mismo video ya debería estar listo para poder verlo, pero lo vuelve a cargar desde cero, entonces reviso el contenido del cahe y ahí está (v=ZWoH1G15xvMitag=18), luego me doy cuenta de que lo está volviendo a almacenar pero con una variante (v=ZWoH1G15xvMitag=43.mp4), entonces no se como remediar esto, ¿ayuda?

Luego al revisar de nuevo en cache veo que está guardado el archivo nuevo (v=ZWoH1G15xvMitag=43), intento reproducirlo pero me marca error.

Al buscarle más, noto que creó 16 archivos de otros 16 videos distintos, son mas de 300 MB, entonces estos no sirven y hay que borrarlos para que no hagan espacio.

Verfica con cual extension estas guardando los videos, usa solo una
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: debian en Agosto 21, 2016, 01:11:33 am
Hola amigos tengo una pregunta y disculpen recien estoy aprendiendo estuve tratando de configura el mikrotik 6, y en las reglas me sale una duda:
/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=!10.0.0.222 dst-port=80,8080,8888,8880,8777,3477,33301 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=8118

AHI HAY UNA PALABRA QUE DICE "Clienets internet", aque se refieres y como lo configuro porque el HC no corre. agradeceri que me espondieran y muchisimas gracias.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: guaco12 en Agosto 21, 2016, 09:42:37 am
"Clientes internet" sustituir  por el rango de IP de tu red interna del mikrotik ejemplo : 192.168.10.0/24 . sin las comillas .
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: debian en Agosto 21, 2016, 01:20:55 pm
POR FAVOR ALGUIEN ME PUEDE AYUDAR NO LOGRO CORRER EL HANDYCHACHE MI MIKROTIK ES UNA RB450 YA INSERTE LAS REGLAS Y NADA, ALGUIEN POR FAVOR PARA QUE ME AYUDE POR EL TEAMWIVER, SE LOS AGRADECERIA........
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: guaco12 en Agosto 21, 2016, 02:44:49 pm
Para correr... antes debes aprender a caminar... por favor lee este tema y los comentarios de los foristas

Instalación de HandyCache paralelo a Mikrotik (14/05/2015)

http://www.alterserv.com/foros/index.php?topic=1605.0
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Shadowofvilla en Agosto 22, 2016, 08:32:25 am
Saludos y gracias por el aporte gran amigo JVP, y a todo el elenco de desarrolladores de mejoras para el beneficio de toda una gran comunidad así como el betatester o conejitos de india jajajaj, solo quería acotar que a los que descarguen el HCRV5 en la parte del Privoxy Especificamente el el apartado (Options==>Edit Main Configuration) deben cambiar los puertos ya que por defecto vienen de la siguiente manera y deben acoplarlos a como dice el amigo JVP en la descripción o guía de instalación y funcionamiento.
listen-address  :8118
forward / 127.0.0.1:8080
forward :443 127.0.0.1:8081

Amigo una ayuda en esta parte porfavor, como aumentaria en esta configuracion mas puertos?
listen-address  :8118
forward / 127.0.0.1:7070,7071
forward :443 127.0.0.1:8080,8081
algo asi seria? para abrir las HC de los dos, he estado leendo pero no entendi muy bien
gracias
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: fitosoft29 en Agosto 22, 2016, 08:36:35 am
esto se debe a la carpeta donde esta almacenando no es la correcta verifica y chequea


Hola amigo, al decir la carpeta dond esta almacenado te refieres al handy o al .net framework?

Porque ese es el problema que arranca el programa pero no deja iniciar, la carpeta esta en la unidad D, todo está por default, saludos.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Agosto 22, 2016, 10:41:26 am

Hola amigo, al decir la carpeta dond esta almacenado te refieres al handy o al .net framework?

Porque ese es el problema que arranca el programa pero no deja iniciar, la carpeta esta en la unidad D, todo está por default, saludos.

Si,  lo vas a configurar en el HCMON detienes los servicios y le das examinar las carpetas donde esta el handy y la carpeta donde esta alojado es todo
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: asag1195 en Agosto 24, 2016, 02:33:07 am
BUENAS QUISIERA SABER COMO PUEDO HACER FUNCIONAR EL PUERTO QUE ALMACENA O CACHEA LAS PAGINAS DE HTTPS YA QUE ME NO REACCIONA NI ALMACENA NADA
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: fitosoft29 en Agosto 28, 2016, 05:32:10 pm
Si,  lo vas a configurar en el HCMON detienes los servicios y le das examinar las carpetas donde esta el handy y la carpeta donde esta alojado es todo

Gracias Tony, se resolvió :)
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: fitosoft29 en Agosto 28, 2016, 05:33:00 pm
BUENAS QUISIERA SABER COMO PUEDO HACER FUNCIONAR EL PUERTO QUE ALMACENA O CACHEA LAS PAGINAS DE HTTPS YA QUE ME NO REACCIONA NI ALMACENA NADA

Hola Asag, sugiero instales el certificado como indica la guía, de esta manera funcionará, saludos :)
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: fitosoft29 en Agosto 28, 2016, 06:49:33 pm
Hola a todos, ¿alguien sabe como puedo hacer para iniciar automaticamente hcmon?

Tengo dos discos duros, en el secundario tengo la carpeta de handycache 5, y dentro de ella hcmon, ya active la opción de inicio automático pero el programa no se inicia con windows 7, ya intenté crear un acceso directo y arrastrarlo en la carpeta Inicio de windows pero tampoco funciona. Intenté editar las opciones del acceso directo y activar Propiedades-----Compatibilidad-------Ejecutar este programa como administrador, pero tampoco se inicia al prender la computadora, la ayuda será muy apreciada, gracias a todos por leer :)
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: esleyter2010 en Agosto 30, 2016, 10:37:38 am
Para correr... antes debes aprender a caminar... por favor lee este tema y los comentarios de los foristas

Instalación de HandyCache paralelo a Mikrotik (14/05/2015)

http://www.alterserv.com/foros/index.php?topic=1605.0
jaja yo creo que primero se gatea...
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: eudyespinoza en Septiembre 01, 2016, 09:54:07 am
Tengo 2 problemas implementando el HC...
1). cuando veo un video largo, comienza a guardar y de pronto dice cliente desconectado y detiene la grabacion incluso si el cliente no se ha desconectado
2). Cuando ejecuto mas de 1 HC, ninguno hace cache de videos
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Septiembre 01, 2016, 04:04:14 pm
Hola a todos, ¿alguien sabe como puedo hacer para iniciar automaticamente hcmon?

Tengo dos discos duros, en el secundario tengo la carpeta de handycache 5, y dentro de ella hcmon, ya active la opción de inicio automático pero el programa no se inicia con windows 7, ya intenté crear un acceso directo y arrastrarlo en la carpeta Inicio de windows pero tampoco funciona. Intenté editar las opciones del acceso directo y activar Propiedades-----Compatibilidad-------Ejecutar este programa como administrador, pero tampoco se inicia al prender la computadora, la ayuda será muy apreciada, gracias a todos por leer :)
Debes crear un acceso directo del hcmon y luego arrastras ese acceso al inicio de windows
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Shadowofvilla en Septiembre 03, 2016, 12:07:18 am
Amigos una gran favor, tengo problemas con los juegos de facebook como dragoncity, no carga se queda como en la imagen para todos los usuarios, cual puede ser el problema?, gracias
(http://i64.tinypic.com/2akl1ko.jpg)
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: dishjuarez en Septiembre 06, 2016, 10:03:44 am
De donde lo puedo bajar? ???
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Septiembre 12, 2016, 05:10:11 pm
Amigos una gran favor, tengo problemas con los juegos de facebook como dragoncity, no carga se queda como en la imagen para todos los usuarios, cual puede ser el problema?, gracias
(http://i64.tinypic.com/2akl1ko.jpg)

Por los momentos desactive el https ya que generaban errores Gral por ahora http
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: omar1-1 en Septiembre 21, 2016, 09:57:59 pm
tengo una maquina con handycache y ahi mismo quiero poner el privoxy, me conecto desde un cliente con direccion 192.168.20.253   y mi handy tiene 10.0.0.222    desde el cliente me rende pong 10.0.0.222  por tanto no puedo tener acceso a la carpteta de mi servidor de internet que lo tengo en la misma maquina de handy es decir en 10.0.0.222  instale xamp

como le hago??
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Oscar en Septiembre 25, 2016, 10:10:39 pm
Saludos, probando el HandyCache en Rev 5 tengo problemas al cargar facebook usando chrome o firefox, youtube y el cache trabaja perfecto al igual que otras paginas https pasan por el handy y sin problema.

(http://i66.tinypic.com/2mfykxh.jpg)

 :-X :-X
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Oscar en Septiembre 25, 2016, 10:11:42 pm
Adjunto imagen de fallo, al instalar esta nueva version, e iniciar hcmon. Instalé .net framework 4.0, en 32 bits y no funcionó. LUego en 64 bits y el problema persiste, alguna idea? gracias. Por cierto eso de poder subir imagenes de hasta 15 KB no es suficiente, tuve que recortar casi todo.
Amigo prueba esto:

http://www.taringa.net/post/hazlo-tu-mismo/18682339/Solucion-Excepcion-No-Controlada-En-La-Aplicacion-Net-F.html (http://www.taringa.net/post/hazlo-tu-mismo/18682339/Solucion-Excepcion-No-Controlada-En-La-Aplicacion-Net-F.html)

A mi me funciono  :-*
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Oscar en Septiembre 26, 2016, 01:21:22 pm
Bueno haciendo pruebas con un teléfono android, configure el proxy, instale el certificado, desde el navegador abro youtube y quiero ver un vídeo pero tengo este error "Client disconnected":

(http://i66.tinypic.com/k1s9ox.jpg)

 :-\ :-\

Con el navegador chrome no pasa eso  :-*

Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Oscar en Septiembre 28, 2016, 12:35:06 pm
Saludos, probando el HandyCache en Rev 5 tengo problemas al cargar facebook usando chrome o firefox, youtube y el cache trabaja perfecto al igual que otras paginas https pasan por el handy y sin problema.

(http://i66.tinypic.com/2mfykxh.jpg)

 :-X :-X

Resulta que habia modificado el archivo wpad.pac y agregado esta linea:

Código: [Seleccionar]
if (shExpMatch(url, "https://*.facebook.com/*"))

Esto fue lo que ocasiono la falla con facebook, solo la elimine ahora todo trabajando normal  :-* deje el wpad.pac original para evitar fallas.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Septiembre 30, 2016, 10:08:59 am
Oscar yo por los momentos lo tengo descativado ya que en youtube  muchos clientes me llamaban que los videos se quedaban en espera por mucho tiempo o no cargaban por ahora solo http y todo bien
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Oscar en Octubre 12, 2016, 02:21:34 am
Saludos, algún instalar de certificado y configuración del proxy para los clientes?? sencillo de solo ejecutar y ya, que el cliente no tenga que darle al botón instalar, ademas que no requiera .net??? Gracias!
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: anedzagu en Octubre 14, 2016, 12:46:37 pm
mis saludos a todos aquellos que aporta ideas para buscar la solucion, tambien a quienes estan empesando yo tengo el HC Rev 5 funcionando tanto en http y https con mikrotik, apache y multiproxy, el unico proble que veo es que hay momentos que se pone lento el navegador, alguna solucion
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Octubre 18, 2016, 02:04:13 pm
Sera que el amigo JV pasara por aca con alguna nueva?  ??? :( ;) :-*
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: CarlosFD en Octubre 18, 2016, 07:11:28 pm
Hola, tengo problemas cuando intento abrir una web con https:// no me deja verla muestra lo siguiente.

soy nuevo.

(http://image.prntscr.com/image/40c720052fe24cc4bb9756078bfeb088.png)

Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: ewing en Octubre 19, 2016, 03:18:40 am
 ;)Si no se recomienda antivirus cual es la mejor configuracion para que tu windows no se infecte con los virus que se bajan y almacenan?

Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: testcache en Noviembre 06, 2016, 03:44:22 pm
Saludos A todos, Recien instalo el Handycache, todo bien según la guia... solo un detalle que facebook no me cachea... youtube si; eso es lo raro; alguien me puede dar una guia que sera lo que pasa gracias de ante mano
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: ISPsuperspeed en Noviembre 06, 2016, 11:22:06 pm
Saludos A todos, Recien instalo el Handycache, todo bien según la guia... solo un detalle que facebook no me cachea... youtube si; eso es lo raro; alguien me puede dar una guia que sera lo que pasa gracias de ante mano
sera quisas por que no tienes activado el ssl?
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: testcache en Noviembre 07, 2016, 12:48:32 am
esta activado, tengo años tratando de cachear face consume casi todo el ancho de banda de mi red, repito para youtube me funciona... introduje manualmente la dirección proxy, me funciono para internet explorer, los otros navegadores cargaban mal las imágenes tal como están posteadas unos comentarios antes...
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: testcache en Noviembre 07, 2016, 12:51:36 am
funciono de manera manual ... aunque mal... con el scrip solo funciona youtube, y face pasa bypass...
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: jm2k7 en Noviembre 07, 2016, 09:07:23 pm
Bueno lo he probado y solo hace caché en la lista del wpad.pac.

alguien tiene una guía para arreglar lo del face?, he intentado de todo para que haga cache correctamente y sigue dañando la pagina.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: jm2k7 en Noviembre 09, 2016, 06:22:32 pm
Bueno lo he probado y solo hace caché en la lista del wpad.pac.

alguien tiene una guía para arreglar lo del face?, he intentado de todo para que haga cache correctamente y sigue dañando la pagina.

Bueno creo que encontré la solución para lo del Facebook,

sustituí los archivos dentro de la carpeta:

D:\HandyCacheRev5\HandyCache, por la versión del hilo handycache rev4 (http://www.alterserv.com/foros/index.php?topic=2185.0). Y listo funciona bien el cacheo del facebook.

Espero que sea de ayuda.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Noviembre 09, 2016, 06:53:52 pm
Seguro alguna extensión o alguna archivo modificado del HC
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: josemanuel155 en Noviembre 10, 2016, 09:57:19 am
Bueno creo que encontré la solución para lo del Facebook, sustituí los archivos dentro de la carpeta: D:\HandyCacheRev5\HandyCache, por la versión del hilo handycache rev4 (http://www.alterserv.com/foros/index.php?topic=2185.0). Y listo funciona bien el cacheo del facebook. Espero que sea de ayuda.


hermano saludo yo tengo el mismo problema que tu podrias si se puede subir la extencion que modificaste
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: debian en Noviembre 10, 2016, 06:18:46 pm
HOLA A TODO ACABO DE COMPRARME TRES ANTENAS SECTORIALES CADA UNO CON SU AP RESPECTIVO, LA PREGUNTA ES COMO LE CONFIGURO CADA UNO COMO AP O COMO REPETIDOR, QUICIERA QUE POR FAVOR ME RESPONDAN GRACIAS.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: jm2k7 en Noviembre 10, 2016, 09:20:12 pm

hermano saludo yo tengo el mismo problema que tu podrias si se puede subir la extencion que modificaste

okey viejo, acá le comparto el handy rev v5 con rev v4.

HandyCache Rev5 con Rev4 (https://mega.nz/#!l1Nk1YIZ!WnK4k0mOHpI7-A9FVh-q7bQsucPwmjn0gh9odBHi0w0)

si quieres que haga cache completo con el wpad.pac, lo pones así:

Código: [Seleccionar]
function FindProxyForURL(url,host) {

if (shExpMatch(url, "http://*.*/*"))
  return "PROXY XXX.XXX.XXX.XXX:8118";
if (shExpMatch(url, "https://*.*/*"))
  return "PROXY XXX.XXX.XXX.XXX:8118";
}

sustituir la XXX.XXX.XXX.XXX por la ip de handycache

ojo destaco que este proxy es algo problemático, por falta de conocimiento ayudaría más, pero al menos se resuelve algo, no hay mucho soporte que digamos pero se agradece lo que hay. También se agradece todo el soporte que se brindó desde esta página y a los colegas de JVProductions y allegados.

Esperando futuras revisiones y uno que otra chuchería o conejillo de indias jeje.

Bueno ni modo. Cagandola se aprende jeje.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: testcache en Noviembre 11, 2016, 02:30:27 am
Gracias al parecer funciona... Sin embargo tuve que dejar algunos otros archivos del rev 5... Voy a probar bien ... Y comento .... Gracias ...
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: josemanuel155 en Noviembre 11, 2016, 07:19:36 am
okey viejo, acá le comparto el handy rev v5 con rev v4. HandyCache Rev5 con Rev4 (https://mega.nz/#!l1Nk1YIZ!WnK4k0mOHpI7-A9FVh-q7bQsucPwmjn0gh9odBHi0w0) si quieres que haga cache completo con el wpad.pac, lo pones así:
Código: [Seleccionar]
function FindProxyForURL(url,host) { if (shExpMatch(url, "http://*.*/*")) return "PROXY XXX.XXX.XXX.XXX:8118"; if (shExpMatch(url, "https://*.*/*")) return "PROXY XXX.XXX.XXX.XXX:8118"; } sustituir la XXX.XXX.XXX.XXX por la ip de handycache ojo destaco que este proxy es algo problemático, por falta de conocimiento ayudaría más, pero al menos se resuelve algo, no hay mucho soporte que digamos pero se agradece lo que hay. También se agradece todo el soporte que se brindó desde esta página y a los colegas de JVProductions y allegados. Esperando futuras revisiones y uno que otra chuchería o conejillo de indias jeje. Bueno ni modo. Cagandola se aprende jeje.



gracias hermano agradecido ya lo voy a probar
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: testcache en Noviembre 11, 2016, 08:18:37 am
todo se puso lento... con la versión 5 con 4
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: ServiCenter en Noviembre 11, 2016, 09:24:54 am
buenas, tengo instalado el handy y para q esta trabajando bien, solo es el problemas del certificado y yo trabajo con hospost (MIKROTIK), el tema es q cuando direcciono a un cliente a servidor por conexion PROXY, ya no hace el HOSPOST, pasa libre y otro q no reconoce el certificado para paginas de bancos u otras instituciones. alguna ayuda q puedan brindarme. o ya hay una version q corrija esos pequeños problemitas.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: kalingthor en Noviembre 23, 2016, 11:45:33 am
Alguien sabe cuando estara listo la rev.6 xD
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tonyvzla en Noviembre 23, 2016, 10:56:58 pm
Alguien sabe cuando estara listo la rev.6 xD

Ya lo esta pero vale 90 Usd
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: amashan en Noviembre 28, 2016, 11:34:18 pm
BUENAS A ALGUIEN LE A COMENZADO A DAR FALLAS QUE NO GUARDA TODOS LOS VIDEOS DE YOUTUBE EN HTML5?   POR QUE A MI NO ME GUARDA LOS VIDEOS SOLO ALGUNOS PS
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Krma en Noviembre 29, 2016, 06:44:56 pm
buenas, cada vez que quiero ver un video de youtube tengo q cerrar y abrir el navegador, alguien sabe que puede ser? ya borre chache y todo del navegador y sigue igual, termina un video, pasa al otro y no se reproduce da error, pero cierro y abro el navegador y funciona bien, lo guarda y busca en cache de 10, pero mas de eso no, estoy usando YT a flash en partes,
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: amashan en Diciembre 02, 2016, 05:35:24 pm
flash en partes aveces no ubica bien el video mil veces usarlo en html5 aunque actual tiene fallas no se si sera el certificado que caduco pero ya no guarda todos los videos PIDO A JV PRODUCCIONES O ALGUN MODERADOR QUE NOS AYUDE PORFAVOR....
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: cruzitohop en Diciembre 05, 2016, 08:53:32 pm
Excelente aporte, pero tengo una pequeña duda como configurar A mis clientes que estan enlazados con su antena UBIQUITI en modo ROUTER

CONFIGURACION MIKROTIK:

WAN: 192.168.1.2 
GATEWAY: 192.168.1.1
----------------------------------
LAN: 192.168.2.1
PROXY HANDY: 192.168.0.1
SERVIDOR HANDY: 192.168.0.254
----------------------------------
- TODOS MIS CLIENTES QUE TENGO DIRECTO CON 192.168.2.X (EXELENTE)
- PERO TENGO VARIOS CLIENTES QUE SE CONECTAN CON ANTENAS MODO ROUTER 
EJM: 
- IP WAN: 192.168.2.65
- IP LAN: 192.168.10.1  
---- MI DUDA ES COMO CONFIGURAR PARA QUE LAS PCs DE 192.168.10.x puedan hacer el cache

-----------------------------------
GRACIAS DE ANTEMANO
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Guaipa en Marzo 25, 2017, 07:12:01 am
Help!
cuando abro con Firefox, me dice, "Conexión Insegura"
El propietario de www.youtube.com ha configurado su sitio web de manera incorrecta. Para evitar que su información sea robada, Firefox no ha conectado con este sitio web.

Este sitio usa Seguridad estricta de transporte de HTTP (HSTS) para especificar que Firefox sólo se conecte a él de modo seguro. Como resultado, no es posible añadir una excepción para este certificado.

Creo que es el tema de los Certificados... Como han hecho ustedes para que nos les salga ese mensaje?, solo me sale en HTTPS, en HTTP ingresa normal.

Hola tenia el mismo problema estaba confundido pense que el Certificado era la direccion que conecta con el Servidor Apache osea http://10.0.0.222/wpad.pac y no hermano el certificado esta en la carpeta "HandyCache Rev5\HandyCache" es el archivo "root-public-crt" nuestro amigo JVProducciones lo explica bien detallado aca: http://www.alterserv.com/foros/index.php?topic=2185.0
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: kalingthor en Marzo 30, 2017, 10:41:36 pm
HandyCache Rev5 ya no me hace caching al youtube, alguien mas le pasa lo mismo.
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: tralachaca en Abril 03, 2017, 12:51:31 am
me sucede lo mismo alguien podria decirme  que fue loque sucedio  no me cachea  los videos de youtube  tampoco  me hace hit a todos los  videos que ya tenia guardados  que podra ser :(
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Guaipa en Abril 06, 2017, 07:58:03 pm
HandyCache Rev5 ya no me hace caching al youtube, alguien mas le pasa lo mismo.
a mi tambien me pasa lo mismo solo funciona con http y todo lo e echo bien antes funcionaba de maravilla no se que hacer para que vuelva a redireccionar el privoxy hacia el handy para https
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: Amaximun en Abril 16, 2017, 01:58:50 pm
hola soy nuevo saludos a todos: 

ire al grano...descargue el handycache v5 lo que deseo es poder guardar las actualizaciones del dota 2...mi pregunta es la siguiente:

es obligatorio abrir los puertos para que el handy funcione?

no tengo acceso al router y no lo tendre no puedo abrir puertos....existe alguna forma en la cual pueda guardar las actualizaciones del dota 2 con el handycache sin abrir los puertos? ya que este juego se actualiza casi a diario y cuando actualiza se chupa toda la linea....y de verdad que es muy molestoso eso....

si alguien me puede ayudar estare muy agradecido....
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: JHOELIT en Abril 25, 2017, 09:51:21 am
NUEVO SERVIDOR CACHE - AUTOR JHOELIT ;)

Se te agradece infinitamente JVProducciones por tus logros en la web es una pena enorme que se haya
descontinuado el soporte libre o free. Toda la historia queda registrado, fue mas por motivo de estafas.

:(

Les comparto parte de mis proyectos que fue posible gracias al camino que hizo nuestro amigo y colega.
Si desean hacer consultas enviar inbox sobre mis trabajos o aportes soy colaborador oficial de Privoxy.

Grupo oficial buscar como HC+MK+REDES en Google
(http://i68.tinypic.com/sxbolz.jpg)

Actualización de HandyCache Rev5.1 al Rev5.3 Gratis
http://www.facebook.com/groups/handycachemikrotikredes/

(http://i63.tinypic.com/11biw7d.png)

Actualización de Pago HandyCache Rev5.4 al Rev5.9 PRO
http://www.ryohnosuke.com/foros/index.php?threads/23879/


Dios les Bendiga !!! :) 
Título: Re:HandyCache Rev 5 en español (20/06/2016)
Publicado por: alex543 en Mayo 24, 2017, 02:09:10 pm
amigo que funcion cumple apache serve y privoxy