Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - roxdng

Páginas: 1
1
Mangle & Queues / Re:bloquear paginas de adultos
« : Abril 26, 2016, 10:53:21 pm »
Usa los dns de opendns con control parental o algo similar. Automáticamente bloqueará contenido de adultos sin importar el protocolo de navegación, o bien implementa un script de búsqueda de dns donde se vayan agregando a una address list posterior mente bloqueas

Enviado desde Oneplus One


2
Hola a todos, he creado esta guía para evitar ensuciar los otros hilos con las mismas preguntas sobre como instalar.

esta basado en Mikrotik V6, pero solo hay que adaptar una linea para que sea funcional en V5.


Redireccion por mangle (mas eficiente que por NAT), ademas posee failover nativo a través de ping (cuando NO hay ping hacia nuestro servidor cache, se des-habilita el ruteo)

(modificar IP_DE_RAPTOR por la ip correspondiente)

Código:
  1. /ip route
  2. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=IP_DE_RAPTOR routing-mark=raptor_route scope=30 target-scope=10

estas reglas deben estar al inicio del mangle (en esta versión existe solo una marca)

(modificar LAN por su interfaz correspondiente)
Código:
  1. /ip firewall mangle
  2. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" disabled=no dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=no protocol=tcp
  3. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" disabled=no new-connection-mark=raptor-connection passthrough=yes
  4. add action=mark-packet chain=forward connection-mark=raptor-connection disabled=no new-packet-mark=raptor-packs passthrough=no

Ahora nuestro Queue

primero creamos un tipo de Queue, Esto en palabras simples crea un Queue que da como máximo 5MB por usuario (adapte según su red)

Código:
  1. /queue type
  2. add kind=pcq name=PCQ_LIMIT pcq-classifier=dst-address pcq-dst-address6-mask=\
  3.     64 pcq-limit=64 pcq-rate=5M pcq-src-address6-mask=64 pcq-total-limit=3k

y ahora lo implementamos en nuestro simple queue (adapte máximo según su red), este simple queue se recomienda ponerlo al inicio.
 
Mikrotik V6

Código:
  1. /queue simple
  2. add max-limit=4M/15M name=Cache packet-marks=raptor-packs queue=\
  3.     default-small/PCQ_LIMIT target=""

cual es la diferencia?. Tengo un ancho de banda máximo de 15MB para Raptor2, pero son solo 5MB por usuario.

Ahora modificamos firewall en Raptor2

Donde "192.168.1.0/24" es el segmento de red de los usuarios y "eth0" es el nombre de la interface del servidor Raptor


En el caso se tenga varios segmentos de red de usuarios


Luego Reiniciar el Firewall

si todo esta OK, ya deberíamos ver nuestro trafico en raptor2.

Un saludo

Páginas: 1