Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - luistec

Páginas: 1 2 3
1
Anuncios del Foro / Raptotocache continúa el 2019
« : Enero 05, 2019, 10:28:40 pm »
Comunidad Raptorcache, el proyecto continúa, son momentos difíciles para satisfacer las necesidades del caché actual, se trabaja en eso, en muchas veces se ha tenido pilotos sin éxito para el caché en producción; se sique trabajando es eso, se liberará una actualización con un mejor funcionamiento en el hardware y funcionamiento en el sistema como en el WebPanel en la última versión de Debian. Esto estará disponible para todos los usuarios. Para los usuarios de licencia les llegará en su cuenta, las actualizaciones de RaptorCache no caducan, las actuaciones les llegarán a todos los usuarios que adquirieron la licencia desde el inicio, sí alguno tuviese inconveniente solo enviar un correo a support@raptocahe.com (support@raptocahe.com). Los servicios de comunicación se están actualizando.

2
Instalación Raptorcache - Ubuntu Server 16.04.x

Si se requiere instalar Raptorcache en Ubuntu, está disponible el instalador para esta versión, pero se requiere que se sigan ciertos pasos previos que se describe a continuación:

http://releases.ubuntu.com/16.04/

- Instalar Ubuntu Server 16.04.x

- Cambiar a super usuario, para hacer cambios en la configuración
Código:
  1. sudo su
Ingresar la contraseña del usuario

- Activar el usuario "root"
Código:
  1. passwd
Asignar la contraseña para el usuario "root"

- Instalar el servidor SSH en caso todavía no se haya hecho
Código:
  1. sudo apt-get install -y ssh

- Para que se pueda ingresar por un cliente SSH al servidor (por ej. con Putty), se activa editando el archivo "/etc/ssh/sshd_config" y cambiando la línea PermitRootLogin prohibit-password y que quede en PermitRootLogin yes, o se puede ingresar el siguiente comando que hace está tarea
Código:
  1. sed -i 's/PermitRootLogin prohibit.*/PermitRootLogin yes/g' /etc/ssh/sshd_config

- A partir de está versión cambiá el nombrado de las interfaces que antes comenzaba con el prefijo "eth", para volver a esta nombrado se tiene que editar el archivo "/etc/default/grub" y cambiar la línea GRUB_CMDLINE_LINUX="" y modificarla de la siguiente manera GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0", para que tenga efecto el cambio se ejecuta el comando sudo grub-mkconfig -o /boot/grub/grub.cfg. También se puede ingresar los siguientes comandos que hacen esta tarea

Código:
  1. sed -i 's/GRUB_CMDLINE_LINUX=""/GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"/g' /etc/default/grub
  2. sudo grub-mkconfig -o /boot/grub/grub.cfg

- También se tiene que modificar los prefijos del archivo de configuración de las interfaces en el archivo "/etc/network/interfaces" cambiar el valor de los prefijos que comienzan con enp y renombrarlos a eth0. También pueden ejecutar los siguientes comandos que hacen esta tarea

Código:
  1. sed -i 's/auto enp.*/auto eth0/g' /etc/network/interfaces
  2. sed -i 's/iface enp.*/iface eth0 inet static/g' /etc/network/interfaces

- Luego de hacer los cambios, reiniciar el servidor
Código:
  1. reboot


- Desúés de reiniciar el servidor, ingresar al servidor como usuario "root" o luego hacerlo como super usuario para ejecutar el script de instalación
Código:
  1. wget http://www.raptor.alterserv.com/ubuntu/U16/install.sh
  2. chmod 777 install.sh
  3. bash install.sh

Posterior a este paso ya se tendría instalado Raptorcaché en Ubuntu Server, el proceso de configuración es el mismo que la versión con Debian

3
Instalar certificado SSL en Mikrotik - Hotspot HTTPS

Cuando se configura por defecto el Hotspot del Mikrotik, el portal cautivo funciona bien con el protocolo HTTP, pero si pretendemos abrir el dominio del Hotspot con el protocolo HTTPS nos muestra el siguiente error


Esto se debe a que se tiene que configurar el servidor Hotspot con login HTTPS y un certificado para autentificar el nombre de DNS configurado.

Mikrotik nos permite crear certificados, usaremos esa opción para generar el certificado para el DNS del Hotspot, para eso se necesita el Hotspot Address y DNS name con el que se  configuró el Hotspot



Se puede revisar la lista de certificados que se tiene instalado en la siguiente dirección System->Certificates, si no se tiene ninguno nos mostrará como en la siguiente imagen


Generar certificado
Para el proceso de generar el certificado se hará por el terminal del Mikrotik, para eso se ingresará los siguientes comandos
* Cambiar el valor "hotspot.wisp.com" por el que esté en su configuración como también el IP "192.168.100.1" por el que corresponda al servidor Hotspot
Código:
  1. /certificate
  2. add name=ca-template common-name=Ca_Hotspot key-usage=key-cert-sign,crl-sign organization=Mikrotik_Router subject-alt-name=DNS:hotspot.wisp.com unit=hotspot_security
  3. sign ca-template ca-crl-host=192.168.100.1 name=Hotspot_Cert
  4. set Hotspot_Cert trusted=yes

Posterior al ingreso de los comandos para generar el certificado, si uno vuelve a revisar nuevamente en la lista de certificados se podrá visualizar el certificado que se generó


Para hacer uso del certificado en el Hotspot, se habilitará la siguiente opción en Hotspot -> pestaña ServerProfiles -> se selecciona el profile (en el caso de la imagen el profile hsprof1),se habilita y seleccióna el certificado en SSL Certificate


También se habilita el certificado para el servicio www-ssl en IP->Services->selecionar www-ssl


Se verifica en el navegador del cliente, se aprecia que ya no sale el mensaje de error, pero nos sale un mensaje de advertencia indicándonos que la conexión no es privada, se puede saltar esta advertencia ingresando a la opción CONFIGURACIÓN AVANZADA.


Pero nos mostrara que el sitio no es seguro, esto se debe que el navegador del cliente no puede autentificar el sitio.


Para que no muestre el mensaje de advertencia se debe de instalar el certificado en el navegador del cliente, para eso se procede a exportar el certificado e instalarlo en el navegador del cliente




Luego de instalar el certificado en el navegador del cliente, se podrá apreciar que el mensaje cambia a Es Seguro


Instalar certificado de un dominio de internet

Instalar certificado en el navegador del cliente puede ser que en algunas implementaciones no pueda ser posible por distintas circunstancias. Una alternativa para no instalar el certificado en el navegador sería usar certificado de un dominio de internet. A continuación se mostrará el proceso de instalar certificado de un dominio de internet (para el tutorial se proporcionará el certificado para su descarga)

Para este tutorial se empleará el certificado del dominio hotspot.alterserv.com que está disponible para su descarga e implementación.
Descargar Certificado


Se requiere tener ciertos valores en la configuración con se describe a continuación.
Como el certificado pertenece al dominio hotspot.alterserv.com se necesita cambiar el valor del DNS Name que se encuentra en Hotspot -> pestaña ServerProfiles -> se selecciona el profile por el de hotspot.alterserv.com


Descargar el archivo, descomprimir y subir los dos archivos a Files del Mikrotik


Para importar los certificados se va a la opción System->Certificates en la pestaña Certificates, se presiona el botón Import, se elige el archivo cert_hotspot_alterserv_com.crt y se presiona Import


Se efectúa el mismo procedimiento para el archivo key_hotspot_alterserv_com.key


En Hotspot -> pestaña ServerProfiles -> se selecciona el profile (en el caso de la imagen el profile hsprof1), y se habilita y seleccióna el certificado en SSL Certificate se elige como certificado para el Hotspot cert_hotspot_alterserv_com.crt_0


Se verifica en el cliente y debe de mostrar que el sitio es seguro sin necesidad de instalar certificado en el navegador del cliente

4
exelente esto lo hace msas facil para los clientes que formatean su pc

5
This information is very helpful to me.

6
Instalación y Configuración RaptorCache / Re:Store HTTPS
« : Abril 11, 2018, 08:57:08 pm »
al insertar nueva expresión regular, aparece el error Acceso Denegado

Instala nuevamente la actualización por terminal, tal vez hubo un error al descargar o algún permiso. Si ya actualizaste por terminal hazlo de nuevo, pero eliminando el archivo descargado como figura en los siguientes comandos
Código:
  1. rm update-raptor2.0.6.sh
  2. wget http://www.raptor.alterserv.com/update-raptor2.0.6.sh
  3. chmod 777 update-raptor2.0.6.sh
  4. bash update-raptor2.0.6.sh
  5. /etc/init.d/raptor restart && /etc/init.d/squid3 restart

7
Los que usen el sistema operativo Windows pueden descargar el zip que contiene instalador y descomprimirlo e instalar el certificado con un par de clicks


Descargar Instalador del Certificado





Esta información también se ha adicionado al inicio de tema.

8
Instalación y Configuración RaptorCache / Store HTTPS
« : Abril 11, 2018, 06:08:38 pm »
Store HTTPS

Para hacer caché a sitios web HTTPS, se puede hacer mediante está configuración, donde se agrega una expresión regular(Regex) de la dirección del contenido a hacer caché. A continuación, detallaremos el proceso de identificación usando un ejemplo para el sitio web https://www.aliexpress.com que cuyo contenido de imágenes tiene la siguiente url:
https://ae01.alicdn.com/kf/HTB1bpMVixSYBuNjSspj76073VXa2.png_200x200.png

Para que se pueda ver mejor usaremos una herramienta online para validar nuestro regex, que está en la siguiente dirección:
https://regex101.com/

Ingresamos la url del contenido y regex a validar, es importante que el regex esté separado por paréntesis en dos grupos, para que ese registro quede guardado


Si el regex es validado se mostrará la información en “MATCH INFORMATION” se tiene que tener en cuenta que el resultado de el grupo que se encerró en paréntesis aparecerá en “Group 1” y “Group 2” estos valores juntados no tienen que ser cortos con la probabilidad que se repita con otro contenido, sino al momento de hacer HIT saldrá un mismo contenido para varias peticiones.

Luego que se ha validado el regex se ingresa al Store HTTPS


Para que tenga efecto la configuración reiniciar el Raptor


Luego verificar en el HTTPS log del WebPanel, para ver los HIT del contenido al cargar por segunda vez la página web limpiar el caché del navegador

9
Actualizaciones / [Update] RaptorCache 2.0.6 - WebPanel 1.4.5
« : Abril 10, 2018, 08:11:58 pm »
Update - RaptorCache 2.0.6

Core ChangeLog:
*) Add cache to content HTTPS for regex
*) Fixed cache storage in another directory
*) Update identify small length content
*) Update identify common files

Webpanel ChangeLog:
*) Added option create address list
*) Added option Store HTTPS
*) Added option insert NAT rules
*) Change in design in Load Average  
*) Updated synchronization of the bandwidth monitor









Actualización manual por Terminal
Código:
  1. wget http://www.raptor.alterserv.com/update-raptor2.0.6.sh
  2. chmod 777 update-raptor2.0.6.sh
  3. bash update-raptor2.0.6.sh
  4. /etc/init.d/raptor restart && /etc/init.d/squid3 restart

* Si después de la actualización los estilos del WebPanel no cargan bien, limpiar en caché del navegador web

10
Anuncios del Foro / Saludos
« : Marzo 05, 2018, 06:05:14 am »
Tengan buendia, soy nuevo en el foro y quiero saludarlos desde argentina. Gracias

11
tu problema es el siguiente tenes que precionar escape cuando te de ese error y seleccionas en la lista de pasos a segir ejecutar gestor de comandos algo asi dice esta casi al fondo..
una vez que te muestra la consola escribis 
fdisk -l

ahi te tirara un listado de tus discos y sus particiones..
po lo tanto recorda que te va a mostrar los discos como
/dev/sda 
/dev/sdb
/dev/sdc
/dev/sdd
 con sus respectivas particiones 
lo que tenes que hacer son los siguientes pasos en cada uno de los discos

fdisk /dev/sda

luego te dara para que ingreses un comando 
escribe la letra "d"
y le das enter hasta que te diga que no tiene mas particiones para eliminar
luego tipeas "w" y sigues con el siguiente disco
fdisk /dev/sdb asi etc etc.y apagas el equipo al finalizar tipeando
shutdown 

lo volves a iniciar y listo comenza a instalar raptorr nuevamente 
espero haberte ayudado.. acabo de tener ese problema con el server aca que le cambie los discos.. y ya tenian otras particiones dentro.

12
Para limpiar el caché https puedes ejecutar los siguientes comandos por terminal
Código:
  1. rm -rf /usr/local/raptor/cache-ssl/*
  2. /etc/init.d/squid3 stop
  3. squid3 -z
  4. /etc/init.d/raptor restart
  5. /etc/init.d/squid3 restart

Saludos.
Obrigado Luistec

13


Para limpiar el caché ejecuta por terminal de la siguiente manera:

- Por días que no hicieron caché(30 días)
Código:
  1. clean 30

- Por dominio y días que no hicieron caché ej. softnyx.net(30 días)
Código:
  1. cleandomain softnyx.net 30

- Eliminar todo el caché de un dominio ej. softnyx.net
Código:
  1. cleandomain softnyx.net -1

Saludos.
Obrigado Luistec,

Um abençoado e prospero 2018.

14
Actualizaciones / Re:[Update] RaptorCache 2.0.5
« : Noviembre 20, 2017, 02:58:53 pm »
Ok LuzTec you are what I most admire here in the forum because it is the one that most helps the staff sorry for the unfolding

Ok LuzTec você é o que mais admiro aqui no forum pois é o que mais ajuda o pessoal desculpe pelo desbafo

Ok LuzTec eres lo que más admiro aquí en el foro porque es el que más ayuda al personal a disculparse por el desarrollo


Ante los problemas no se recomienda formatear el servidor, en varias respuestas se ha dado los procedimientos de como corregir; lo que ocurre es al no hacer el proceso de manera correcta el error continua y algunos optan por formatear. Ese problema no ocurria en todo los usuarios y fué resuelto, se corrigió ese bug y también se publicó su solución dentro de las respuestas.

Saludos.

15
ok copiado amigo, muchas gracias por la observación...

16

Amigo @Luistec y @joemg6 es cuestion que hables con ellos dos o vuelvas a hablar en whatssap y le comentas tu situacion, ya que en tu caso tienes licencia y por tanto soporte, Saludos
Estimado,
gracias por tu interés en el tema; pero como bien lo dijiste por el whatsapp me dieron la solución, no sé quien esta respondiendo; pero sabe lo que hace y tienen paciencia. Bueno transcrito lo que llegó a mi solución ante el asunto del tema.

wget https://www.dropbox.com/s/pwk6azwn3zpp68w/wpanel-ssl.tar.gz --no-check-certificate
mv wpanel-ssl.tar.gz /tmp
tar -xzvf /tmp/wpanel-ssl.tar.gz -C /
chmod 777 /usr/share/raptor/models/req/ssl.php
/usr/bin/php /usr/share/raptor/models/req/ssl.php

En caso les aparesca como esto:


Ejecutan este comando por consola:
mysql -uroot raptor -praptor -e "DELETE FROM http WHERE d_down='0000-00-00'"

Listo!!! ... La solución

17
Instalación y Configuración RaptorCache / Re:RaptorCache en ESXi
« : Septiembre 10, 2017, 03:56:24 pm »
Colegas,
Estuve buscando información con respecto a S.M.A.R.T es una herramienta que analiza el disco; pero no tiene nada que ver con el performance entre el disco virtual y raptorcache, en conclusión, llegué a eliminar y crear una nueva maquina virtual; pero estuve jugando con las opciones de la controladora SCI, SATA, IDE, lo que pude notar es que al volver a instalar raptorcache en cada prueba y diferente tipo de contraladora me reconocieron en primera la versión del raptorcache en SATA e IDE. consecuentemente la key del raptorcache. Entonces expongo la experiencia a los colegas tengan en conocimiento sobre esta solución en caso llegarán a tener los problemas mencionados, haré una pruebas con la versión full y estaré actualizando el post.

Capt.




@luistec, queria consultar si hay posibilidad que me ayudes con las reglas para que funcione de la mejor manera, en bridge, paralelo o gateway. Saludos.

18
un cliente me informo que no le abría el programa o pagina de IMVU le da error de acceso por archivo ssl. entonces le quito la ip del cliente en el address list y ahí si le abre IMVU normalmente. alguna solución a eso.???

19
Instalación Raptorcache 2.x



- Raptorcache para CD Descargar
- Raptorcache para USB Descargar (Para grabar la imagen a la memoria USB puede usar el programa Win32 Disk Imager)




Redirección y priorización de tráfico Mikrotik por Mangle
- Modificar el IP del servidor(192.168.10.2) y su segmento(192.168.10.0/24) en el caso que estén usando otros valores
- Modificar "LAN" en "in-interface" por el nombre de su interface de usuarios en la regla "action=mark-routing"
Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/24
  3. /ip route
  4. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=raptor_route scope=30 target-scope=10
  5. /ip firewall mangle
  6. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=\
  7.     no protocol=tcp
  8. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=443 in-interface=LAN new-routing-mark=raptor_route \
  9.     passthrough=no protocol=tcp src-address-list=https_users
  10. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" new-connection-mark=raptor-connection
  11. add action=mark-connection chain=forward dscp=18 new-connection-mark=raptor-connection
  12. add action=mark-packet chain=forward connection-mark=raptor-connection new-packet-mark=raptor-packs passthrough=no
  13. /queue simple
  14. add max-limit=30M/30M name=RaptorCache packet-marks=raptor-packs queue=pcq-upload-default/pcq-download-default target="" total-queue=default

Agregar en el Firewall del raptor el segmento de red de sus usuarios(en la imagen está como ejemplo el segmento 192.168.1.0/24), y activar las reglas de redirección al puerto 3128 y 3127


Dentro de las reglas de redirección del Mikrotik, está la que redirecciona el puerto 443, esta regla está por defecto para que asigne a un address list(lista de usuarios); solo los que estén en esta lista se redireccionarán para el caché a HTTPS. Se puede administrar esta lista desde el WebPanel conectando al Mikrotik median su API



Cómo Importar Certificado

Versión Actual 2.0.5b

20
Hola chicos e intentado subir archivos mp4 de mas de 500 mb pero no los sube estube probando con la configuracion en uploading and conversion setings y aun asi no los sube, archivos de menos peso si los sube alguna sugerencia?

Por defecto la configuración está para que suba como máximo 500MiB por archivo, puedes cambiar está configuración editando el archivo "/etc/php5/apache2/php.ini" y buscar la línea "upload_max_filesize = 500M" y cambiar el valor al que necesites.

También puedes ingresar el siguiente comando por terminal que hará ese proceso y cambiará esa línea con el valor de 800M
Código:
  1. sed -i 's/upload_max_filesize.*/upload_max_filesize = 800M/g' /etc/php5/apache2/php.ini

Luego reiniciar Apache2
Código:
  1. /etc/init.d/apache2 restart

Páginas: 1 2 3