Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - venezu

Páginas: 1
1
Anuncios del Foro / Raptotocache continúa el 2019
« : enero 05, 2019, 10:28:40 pm »
Comunidad Raptorcache, el proyecto continúa, son momentos difíciles para satisfacer las necesidades del caché actual, se trabaja en eso, en muchas veces se ha tenido pilotos sin éxito para el caché en producción; se sique trabajando es eso, se liberará una actualización con un mejor funcionamiento en el hardware y funcionamiento en el sistema como en el WebPanel en la última versión de Debian. Esto estará disponible para todos los usuarios. Para los usuarios de licencia les llegará en su cuenta, las actualizaciones de RaptorCache no caducan, las actuaciones les llegarán a todos los usuarios que adquirieron la licencia desde el inicio, sí alguno tuviese inconveniente solo enviar un correo a support@raptocahe.com (support@raptocahe.com). Los servicios de comunicación se están actualizando.

2
Crontab Generator The personal cron home page application is determined on Linux / UNIX. Cron is a way to run regularly scheduled flights. A cron agenda is created by way of placing a list of instructions and their schedules in a simple text record. The file is then referred to as the cron desk.
 
The cron will can help you schedule tasks for precise instances, even though you're no longer round. a few servers offer to cPanel with the cron task interface that helps you to configure the times it'll execute.
 
Your cron access should be introduced to your crontab file. Run crontab -e, save and then exit. Scripts with output will generate. The cron desk file must be uploaded for your server. After uploading this, telnet (which could installation inside the terminal) to your server. eleven the server solutions you kind crontab 'filename', which is in which you substitute the call of your wonderful report for 'filename' as it is far here, here registering your cron desk.
 
To verify that the cron gadget has registered your cron desk type crontab -l. this may gift to show of all presently registered cron schedules. If there may be no interface, you need to create crontab instances with a command line terminal. In this case, start a console window and run crontab -e.

Crontab Generator help you to create your crontab command and also help you and give you information about crontab with examples and syntax.


https://crontabgenerator.org

3
buen dia , como siempre aportando a este proyecto.

Habran notado que youtube a aperturado una nueva web

https://music.youtube.com

el problema q sucede es que cuando se intenta reproducir algun video que esta almacenado en cache desde la pagina web normal, no reproduce o lo hace con herrores, y viceversa

https://www.youtube.com

la solucion la encontre al mejorar el codigo en store-id.pl
hay que agregar a la lista: @c = m/[&?]c\=([^\&\s]*)/;
asi:
} elsif ($_ =~ m/^https?\:\/\/.*(youtube|googlevideo).*videoplayback.*source=youtube.*/){
        @range = m/[&?](range\=[^\&\s]*)/;
        @lmt = m/[&?]lmt\=([^\&\s]*)/;
        @clen = m/[&?]clen\=([^\&\s]*)/;
        @cpn = m/[&?]cpn\=([^\&\s]*)/;
        @mime = m/[&?](mime\=[^\&\s]*)/;
        @c = m/[&?]c\=([^\&\s]*)/;
            
y tambien aqui:


}$out="OK store-id=http://video-srv.squid.internal/@itag&cpn=@cpn&@c&@lmt&@clen&@mime&@range"


esto traera en consecuencia q toda la cahe almacenada quede inutil, pero todo lo nuevo ya no tendra problema, y podremos almacenar el video de ambas paginas de youtube

4
Instalación y Configuración RaptorCache / configurado
« : noviembre 18, 2018, 09:37:31 pm »
hola una disculpa creo que ya quedo veo log de http solo falta ver los https.... en http dise miss 200 aun no veo ni un hitt perocreo que es por que solo estoy conectado yo y apenas esta guardando en cache... la solucion fue EL DNS DE WEB PANEL no lo tenia bien y al poner el DNS comenso a cachear hace falta ver el https  buen fin de semana...

5

gracias por tu respuesta, te envio imagenes de la configuracion a ver si tengo algo mal:

https://ibb.co/k5SOcf
https://ibb.co/gMv9Hf
https://ibb.co/m2sdA0

las subi en estos links porque el foro no me permite subirlas
Si te deja sin internet al activar las reglas, es porque uno de los valores de la regla de redirección no está bién. Al revisar tus imágenes parece estar en orden, aunque un poco más de información sobre tus reglas de Mikrotik sería de ayuda para darte una mejor respuesta, también sube una captura de Configuración->Network del webpanel para ver si hay un conflicto con la interface o el IPcache

Saludos.

6
Instalación Raptorcache - Ubuntu Server 16.04.x

Si se requiere instalar Raptorcache en Ubuntu, está disponible el instalador para esta versión, pero se requiere que se sigan ciertos pasos previos que se describe a continuación:

http://releases.ubuntu.com/16.04/

- Instalar Ubuntu Server 16.04.x

- Cambiar a super usuario, para hacer cambios en la configuración
Código:
  1. sudo su
Ingresar la contraseña del usuario

- Activar el usuario "root"
Código:
  1. passwd
Asignar la contraseña para el usuario "root"

- Instalar el servidor SSH en caso todavía no se haya hecho
Código:
  1. sudo apt-get install -y ssh

- Para que se pueda ingresar por un cliente SSH al servidor (por ej. con Putty), se activa editando el archivo "/etc/ssh/sshd_config" y cambiando la línea PermitRootLogin prohibit-password y que quede en PermitRootLogin yes, o se puede ingresar el siguiente comando que hace está tarea
Código:
  1. sed -i 's/PermitRootLogin prohibit.*/PermitRootLogin yes/g' /etc/ssh/sshd_config

- A partir de está versión cambiá el nombrado de las interfaces que antes comenzaba con el prefijo "eth", para volver a esta nombrado se tiene que editar el archivo "/etc/default/grub" y cambiar la línea GRUB_CMDLINE_LINUX="" y modificarla de la siguiente manera GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0", para que tenga efecto el cambio se ejecuta el comando sudo grub-mkconfig -o /boot/grub/grub.cfg. También se puede ingresar los siguientes comandos que hacen esta tarea

Código:
  1. sed -i 's/GRUB_CMDLINE_LINUX=""/GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"/g' /etc/default/grub
  2. sudo grub-mkconfig -o /boot/grub/grub.cfg

- También se tiene que modificar los prefijos del archivo de configuración de las interfaces en el archivo "/etc/network/interfaces" cambiar el valor de los prefijos que comienzan con enp y renombrarlos a eth0. También pueden ejecutar los siguientes comandos que hacen esta tarea

Código:
  1. sed -i 's/auto enp.*/auto eth0/g' /etc/network/interfaces
  2. sed -i 's/iface enp.*/iface eth0 inet static/g' /etc/network/interfaces

- Luego de hacer los cambios, reiniciar el servidor
Código:
  1. reboot


- Desúés de reiniciar el servidor, ingresar al servidor como usuario "root" o luego hacerlo como super usuario para ejecutar el script de instalación
Código:
  1. wget http://www.raptor.alterserv.com/ubuntu/U16/install.sh
  2. chmod 777 install.sh
  3. bash install.sh

Posterior a este paso ya se tendría instalado Raptorcaché en Ubuntu Server, el proceso de configuración es el mismo que la versión con Debian

7
Instalación Raptorcache 2.0.5b

Changelog:

Instalación en Debian 8
https://cdimage.debian.org/mirror/cdimage/archive/8.10.0/amd64/iso-cd/debian-8.10.0-amd64-netinst.iso


Para usar Putty con el usuario root en Debian 8
Despues de instalar el ssh en el servidor("apt-get install ssh") se necesita configurar el ssh para el accesso al usuario "root" que por defecto está deshabilitado en Debian 8.
Editar por terminal el archivo de configuración del ssh, para eso efectuamos los siguientes comandos
Código:
  1. nano /etc/ssh/sshd_config

Dentro del editor buscar la línea "PermitRootLogin Without-Password" y cambiarlo a "PermitRootLogin yes" guardar con Ctrl + o y salir Ctrl + x , luego reiniciar el ssh
Código:
  1. /etc/init.d/ssh restart
y con eso se tendría acceso a Putty con el usuario root.

Instalar Raptor
Ejecutar los siguientes comandos para iniciar la instalación de Raptor, el proceso es automático hasta que finalice la instalación.
Código:
  1. wget http://www.raptor.alterserv.com/install_raptor2_d8.sh
  2. chmod 777 install_raptor2_d8.sh
  3. bash install_raptor2_d8.sh

Redirección y priorización de tráfico Mikrotik por Mangle
- Modificar el IP del servidor(192.168.10.2) y su segmento(192.168.10.0/24) en el caso que estén usando otros valores
- Modificar "LAN" en "in-interface" por el nombre de su interface de usuarios en la regla "action=mark-routing"
Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/24
  3. /ip route
  4. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=raptor_route scope=30 target-scope=10
  5. /ip firewall mangle
  6. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=\
  7.     no protocol=tcp
  8. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=443 in-interface=LAN new-routing-mark=raptor_route \
  9.     passthrough=no protocol=tcp src-address-list=https_users
  10. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" new-connection-mark=raptor-connection
  11. add action=mark-connection chain=forward dscp=18 new-connection-mark=raptor-connection
  12. add action=mark-packet chain=forward connection-mark=raptor-connection new-packet-mark=raptor-packs passthrough=no
  13. /queue simple
  14. add max-limit=30M/30M name=RaptorCache packet-marks=raptor-packs queue=pcq-upload-default/pcq-download-default target="" total-queue=default

Agregar en el Firewall del raptor el segmento de red de sus usuarios(en la imagen está como ejemplo el segmento 192.168.1.0/24), y activar las reglas de redirección al puerto 3128 y 3127


Dentro de las reglas de redirección del Mikrotik está la que redirecciona el puerto 443, esta regla está por defecto para que asigne a un address list(lista de usuarios); solo los que estén en esta lista se redireccionarán para el caché a HTTPS. Se puede administrar esta lista desde el WebPanel conectando al Mikrotik median su API



Cómo Importar Certificado

Versión Actual 2.0.5b
antes de bajar el achivo debe de hacer login como root y despues mandar un comando de 
cd /root
wget http://www.raptor.alterserv.com/install_raptor2_d8.sh
chmod 777 install_raptor2_d8.sh
bash install_raptor2_d8.sh

si no se hace el cd /root no funciona

8
hola grupo
tengo este problema al instalar
que estoy haciendo mal
si me pueden ayudar
gracias


Intenta reiniciando por terminal para ver que resultado muestra
Código:
  1. /etc/init.d/raptor restart

También reinicia el mysql para ver su estado
Código:
  1. /etc/init.d/mysql restart

Si no reinicia el Raptor, ejecuta los siguientes comandos para instalar manualmente el raptor
Código:
  1. wget https://www.dropbox.com/s/xxk28dg50dsu2e8/core_2.0.6.tar.gz --no-check-certificate
  2. mv core_2.0.6.tar.gz /tmp
  3. tar -xzvf /tmp/core_2.0.6.tar.gz -C /
  4. chmod a+x /usr/sbin/raptor

Si no te aparecen las interfaces verifica ejecutando el siguiente comando por terminal
Código:
  1. ifconfig -a -s

Saludos.

9
Disculpen, tengo un problema al conectar la API de raptor con mi router Mikrotik, a que se debe este problema. Ya intente con distintos navegadores y comprobe cambiando el usuario y la contraseña de router, pero el problema persiste.

Puede ser haya producido una desconexión al momento de instalar y no se haya instalado correctamente, intenta ingresando los siguientes comandos por terminal
Código:
  1. wget http://www.raptor.alterserv.com/var/path206.tar.gz
  2. mv path206.tar.gz /tmp
  3. tar -xzvf /tmp/path206.tar.gz -C /

Saludos.

10
hola instale el rapto y no me sale el consumo uso esta tarjeta de red  TX:0 bytesRX:0 bytes

Si la nueva interface lleva un nombre diferente a "eth0" tienes que cambiar el nombre de la interface en el archivo "/usr/share/raptor/main/settings.php", cambia el valor de la variable $eth_input_server por el que tengas asignado. 

Saludos.

11
Hotspot (Portal Cautivo) / Configurar Hotspot Mikrotik
« : mayo 11, 2018, 08:03:31 pm »
Configurar Hotspot Mikrotik

El Hotspot de Mikrotik es un sistema que permite redireccionar a nuestros clientes a un portal para que pueda autentificarse. Al autentificarse el cliente, este puede acceder al servicio de internet. A continuación se va ha describir el proceso de configuración inicial del Hotspot.

Para inicar vamos a IP -> Hotspot 


Luego se selecciona la pestaña Servers y se presiona el botón Hotspot Setup, para iniciar con el asistente de configuración, donde se elige la interface a la que se asignará el funcionamiento del Hotspot 


Se ingresará el ip y segmento que usará el Hotspot
El check box de Masquerade Network se desmarca si ya se cuenta configurado el Mikrotik con acceso a internet.


Address Pool of Network, asignará un rango de IP's para el uso de los clientes para que así obtengan un IP
automáticamente. Este paso activa el DHCP Server para el Hotspot.


Carga certificado si se cuenta con un certificado de seguridad para HTTPS, de lo contrario elegir none


De tener implementado el servidor SMTP asignar el IP, sino dejar con el valor 0.0.0.0


Se configura los DNS que usará el Hotspot


Se configura el nombre de dominio que usará el portal cautivo


Usuario y password


Todo el proceso sería de la siguiente manera



12
I believe that this information will make many people know and understand more.

13
Acceso remoto SSH a Raptorcache con Putty o WinSCP

Instalar y conectar con Putty
PuTTy es un cliente de red que soporta los protocolos SSH, Telnet y Rlogin y sirve para iniciar una sesión remota con otra computadora personal o servidor.
A continuación, detallaremos los pasos para conectar PuTTy con el servidor Raptorcache por medio del protocolo SSH.

Primero se debe descargar el programa cliente PuTTy de su sitio web que está en la siguiente dirección:
https://www.putty.org/
https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html

 
Se hace doble click en el ejecutable descargado


Se abrirá el panel de configuración y acceso, donde ingresamos el IP del servidor Raptor y el puerto 22 que es para la conexión ssh, y presionar el botón Open.

 
Luego mostrará el Terminal donde se tiene que ingresar el usuario (login as) como root y la contraseña que se le puso al servidor Raptor durante su instalación.


Si el proceso es correcto, se conectará al servidor y ahí podrá ingresar los comandos de ejecución al servidor Raptor




Instalar y conectar con WinSCP
En caso de requerir un entorno gráfico para navegar por los directorios y archivos del servidor(más amigable para usuarios principiantes), se puede instalar el programa WinSCP
- Descargar Instalador WinSCP
https://winscp.net/eng/download.php

Luego de la instalación del programa WinSCP, al ejecutar el programa mostrará la ventana para hacer la conexión con el servidor donde se ingresan los datos del servidor, como por ej. se muestra en la siguiente imagen


Después se conectará y mostrará una interface gráfica parecida al explorador de Windows, donde se puede interactuar por los directorios y archivos del servidor

14
Indice de tutoriales y preguntas frecuentes


FAQ (Preguntas Frecuentes)
Sobre las licencias Raptorcache
Las licencias no expiran son de por vida, el pago es único que incluye asistencia en la implementación y configuración hasta el funcionamiento en producción del servidor.

¿Se pueden migrar las licencias?
Sí, se pueden migrar las licencias solo agregando el monto de diferencia de la licencia del siguiente nivel.

¿Qué es un thread?
Un thread es un proceso que se abre para atender a cada petición de contenido que se hace al servidor caché.

¿Cuantos threads libres tiene Raptorcache?
Los threads libres o gratuitos son 80 que viene en la instalación por defecto.

¿Los threads libres para cuantos usuarios soporta?
La cobertura de usuarios con los threads libres es relativo, va de acuerdo al consumo de conexiones de los usuarios, pero se puede calcular como un aproximado como máximo 30 usuarios activos.

¿Cómo verifico que Raptorcache está haciendo caché?
Se puede revisar por el WebPanel en el Log que se encuentra en en la opciones de Utilidades que se esté listando del tráfico del contenido, y también revisar la estadística que se esté almacenando en la base de datos de dominios.

¿Cómo formatear y montar discos duros?
Este procedimiento se puede hacer desde el WebPanel en la opción "Configuración -> Mount Disk"

¿Cómo probar la conexión con la base de datos?
Esto se puede hacer por el navegador Web, por ej. si el IP del servidor es 192.168.10.2 ingresamos la dirección.
Código:
  1. http://192.168.10.2:82/test_db.php

No puedo entrar al WebPanel
Si no puede ingresar al WenPanel, primero sería revisar la conectividad con la base de datos. El usuario y contraseña por defecto es "admin"

Como restaurar la contraseña por defecto del WebPanel
Ejecutar el siguiente comando por terminal
Código:
  1. mysql -u root -praptor << eof
  2. UPDATE raptor.user SET passUser = '21232f297a57a5a743894a0e4a801fc3' WHERE user.loginUser = 'admin';
  3. eof

¿Qué es el L.A. en el WebPanel?
El Load Average es la carga promedio del equipo, no específicamente la carga del CPU. El load average es la cantidad de procesos que están encolados, calculados sobre un cierto período de tiempo, se puede ver más detalles sobre el Load Average en el siguiente link

Mi red está lenta despues de implementar Raptor ¿que es lo primero que debo verificar?
Lo primero que se debe de verificar es la configuración de los DNS, y hacer una prueba de los tiempos de respuesta. Configurar el DNS con el que mejor respuesta tenga.

¿Cómo limpiar el cache?
Limpiar todo el contenido
Código:
  1. clean -1
Limpiar por el tiempo de permanencia sin HIT en el caché, por ej. si queremos hacer al contenido que esté almacenado 45 días sin hacer caché.
Código:
  1. cleanhit 45
Limpiar todo el contenido de un dominio específico, entonces ejecutamos por terminal el siguiente comando, por ej. en el caso de avast.com
Código:
  1. cleandomain avast.com -1

15
Redirección Mikrotik - Bridge, PPPoE y Vlans Vlans

Para el proceso de redirección en paralelo a Mikrotik se puede hacer de distintas maneras y de acuerdo a la necesidad que se requiera. Vamos a mostrar algunos ejemplos de redirección en distintas implementaciones.
La regla que se encarga de la redirección del tráfico al servidor Raptor, es la que se encuentra en el Mangle que hace el «mark routing», entonces nos enfocaremos en esa regla para hacer las modificaciones de acuerdo a las distintas implementaciones.

Implementaciones en Bridge
Si se tiene una red de clientes en bridge, se tiene que hacer la siguiente modificación en la regla de redirección en Mangle; cambiar la interface de entrada «In. Interface» que por defecto está con la interface LAN, en este caso cambiaremos por el nombre de la interface bridge a la que se esté usando. También tener en cuenta que la interface en al que está asignada el servidor Raptor tiene que estar fuera del bridge.


Implementaciones en PPPoE y Vlan
Algo parecido a la implementación en bridge también se aplica para la PPPoE, se cambia la interface de entrada «In. Interface» por el nombre de la interface.




Implementación por rangos
Se puede hacer la redirección hacia el servidor direccionando solo un segmento de red, para eso se desmarca la interface de entrada y se asigna mediante el «Src. Address» y se ingresa el rango. Si se requiere usar varios rangos, se puede crear varias reglas de redirección asignando los distintos rangos.   


Implementación por Address List
En caso que se quiera redireccionar ciertas IPs Podemos usar el Address Lists


Se pueden crear varias reglas de redirección de ser necesario para asignar a distintos interfaces o segmentos.
En redes que se esté usando routers para sus clientes, solo asignar el IP del router para hacer la redirección hacia el servidor.

16
Instalación de Raptorcache

Antes de instalar el servidor se debe revisar el tipo de esquema de red que va a utilizar. El servidor necesita un puerto de red y su segmento de red independiente al que tiene que estar conectado para su acceso a internet, ya que se descargarán paquetes durante la instalación.

Por ej. En el caso de del modo paralelo a Mikrotik se usará una interface configurada con el segmento 192.168.10.0/24 en el Mikrotik con IP 192.168.10.1 que será la puerta de enlace para el servidor Raptor

- Raptorcache para CD Descargar
- Raptorcache para USB Descargar (Para grabar la imagen a la memoria USB puede usar el programa Win32 Disk Imager)

Posterior a la revisión del modo y conexión del servidor a la red, se tiene que configurar el arranque del servidor en el bios para que inicie por el CD o USB de acuerdo a la imagen que vaya a usar.

Al iniciar el proceso de instalación se muestra la pantalla de instalación donde se elige la opción Install
Luego de iniciar la instalación se configurará los valores de red del servidor.
En este tutorial se le asigna el IP 192.168.10.2 ya que pertenece al mismo segmento de red que se muestra en el esquema al que se conectará.
Se configura la máscara de red que por defecto es 255.255.255.0
Se ingresa la puerta de enlace (Pasarela) que es el IP de la interface del router en la que está conectado el servidor.
Se ingresa los DNS. En el tutorial se usa el DNS de Google 8.8.8.8 que también puede ser reemplazarlo por el de su proveedor de internet si los tiempos de respuestas son mejores.
Se elige el disco duro donde se instalará el sistema
Se configura la contraseña para acceso al servidor por terminal
Luego procede a descargar paquetes necesarios e instalar el sistema
Si el proceso se hizo de manera correcta finalizará con el siguiente mensaje y se reiniciará para seguir con la instalación
Despues de reiniciar el servidor se iniciará con la peticion de usuario y password para el acceso al terminal.
Se ingresa el usuario como root y la contraseña es la que se le asignó durante la instalación
Luego de ingresar al terminal se digita el comando bash config.sh para que se proceda a configurar el servidor
Al finalizar este proceso, el servidor quedará instalado.
Para acceder al Panel de configuración se hace por medio del navegador web ingresando la dirección IP del servidor y el puerto 82 por ej. En el caso del tutorial 192.168.10.2:82
El usuario por defecto es admin y la contraseña admin

17
en que version del raptorcache me funciona esto?
Estas opciones de configuración está disponible desde la versión del core 2.0.6 y Webpanel 1.4.5

18
Actualizaciones / Re:[Update] RaptorCache 2.0.6 - WebPanel 1.4.5
« : abril 14, 2018, 06:26:12 pm »
Hola, ya actualice todo correcto, como acemos los que tenemos licencia. porque me quedo free..
Saludos Gracias..
En breve se les va ha enviar la actualización de sus licencias, se les enviará un correo cuando el proceso esté listo y también está figurará en su panel de cliente.

19
Instalación y Configuración RaptorCache / Re:Store HTTPS
« : abril 13, 2018, 12:20:30 am »
Eh intentado realizar el store a www.xvideos.com pero al momento de hacer cache reemplaza todas las imagenes solo unas cuantas.-  

este es el regex

^https?:\/\/img\-(l3|hw|egc)\.(xvideos-cdn|xvideos)\.com\/videos\/thumbs(169|169l|169ll)\/([a-z0-9]+)\/.*\/(.*\.([0-9]+)\.(webp|jpg|gif|png))$


no se si me puedan ayudar

Los datos del contenido a guardar tienen que estar en dos grupos por paréntesis y para que puedas validar usa la herramienta online





Regex usado para el ejemplo de xvideos-cdn.com
Código: [Seleccionar]
^https:\/\/.*\.xvideos-cdn\.com\/videos\/thumbs(.*)\.(jpg|gif|png)$
Saludos.


20
Hola dime con que link comienzo la instalacion e instalacion de disco
Revisa por este link
http://www.alterserv.com/foros/index.php?topic=2447.0

Saludos.

Páginas: 1