Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/alterser/public_html/foros/Sources/Subs.php on line 3847

Notice: Trying to access array offset on value of type null in /home/alterser/public_html/foros/Sources/Load.php on line 168

Deprecated: Function create_function() is deprecated in /home/alterser/public_html/foros/Sources/Load.php on line 178

Deprecated: Function create_function() is deprecated in /home/alterser/public_html/foros/Sources/Load.php on line 183

Deprecated: Function create_function() is deprecated in /home/alterser/public_html/foros/Sources/Load.php on line 184

Deprecated: Function create_function() is deprecated in /home/alterser/public_html/foros/Sources/Load.php on line 220

Deprecated: Function create_function() is deprecated in /home/alterser/public_html/foros/Sources/Load.php on line 223

Deprecated: Function create_function() is deprecated in /home/alterser/public_html/foros/Sources/Load.php on line 235

Deprecated: Function create_function() is deprecated in /home/alterser/public_html/foros/Sources/Load.php on line 250

Deprecated: Function create_function() is deprecated in /home/alterser/public_html/foros/Sources/Load.php on line 268
Mostrar Mensajes - jecc84

Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - jecc84

Páginas: 1
1
Instalación y Configuración RaptorCache / Store HTTPS
« : abril 11, 2018, 06:08:38 pm »
Store HTTPS

Para hacer caché a sitios web HTTPS, se puede hacer mediante está configuración, donde se agrega una expresión regular(Regex) de la dirección del contenido a hacer caché. A continuación, detallaremos el proceso de identificación usando un ejemplo para el sitio web https://www.aliexpress.com que cuyo contenido de imágenes tiene la siguiente url:
https://ae01.alicdn.com/kf/HTB1bpMVixSYBuNjSspj76073VXa2.png_200x200.png

Para que se pueda ver mejor usaremos una herramienta online para validar nuestro regex, que está en la siguiente dirección:
https://regex101.com/

Ingresamos la url del contenido y regex a validar, es importante que el regex esté separado por paréntesis en dos grupos, para que ese registro quede guardado


Si el regex es validado se mostrará la información en “MATCH INFORMATION” se tiene que tener en cuenta que el resultado de el grupo que se encerró en paréntesis aparecerá en “Group 1” y “Group 2” estos valores juntados no tienen que ser cortos con la probabilidad que se repita con otro contenido, sino al momento de hacer HIT saldrá un mismo contenido para varias peticiones.

Luego que se ha validado el regex se ingresa al Store HTTPS


Para que tenga efecto la configuración reiniciar el Raptor


Luego verificar en el HTTPS log del WebPanel, para ver los HIT del contenido al cargar por segunda vez la página web limpiar el caché del navegador

2
Actualizaciones / [Update] RaptorCache 2.0.5
« : julio 17, 2017, 08:23:19 pm »
Update - RaptorCache 2.0.5

Core ChangeLog:
- Fixed up X-Forwarded-For content block
- Update detection Dota 2 content steamcontent server
- Update detection Youtube content
- Update core identify common files

Webpanel ChangeLog:
- Fixed up statistic error in economy
- Update update server
- Add domain form in Whitelist
- Best Informational Messaging System
- Fixed up File Size in Logs


Código:
  1. wget http://www.raptor.alterserv.com/update-raptor2.0.5.sh
  2. chmod 777 update-raptor2.0.5.sh
  3. bash update-raptor2.0.5.sh
  4. /etc/init.d/raptor restart && /etc/init.d/squid3 restart

3
Aquí la Solución para lo del Disco Cache... para eso estamos para ayudarnos


4
Instalación Raptorcache 2.0.5b

Changelog:

Instalación en Debian 8
https://cdimage.debian.org/mirror/cdimage/archive/8.10.0/amd64/iso-cd/debian-8.10.0-amd64-netinst.iso


Para usar Putty con el usuario root en Debian 8
Despues de instalar el ssh en el servidor("apt-get install ssh") se necesita configurar el ssh para el accesso al usuario "root" que por defecto está deshabilitado en Debian 8.
Editar por terminal el archivo de configuración del ssh, para eso efectuamos los siguientes comandos
Código:
  1. nano /etc/ssh/sshd_config

Dentro del editor buscar la línea "PermitRootLogin Without-Password" y cambiarlo a "PermitRootLogin yes" guardar con Ctrl + o y salir Ctrl + x , luego reiniciar el ssh
Código:
  1. /etc/init.d/ssh restart
y con eso se tendría acceso a Putty con el usuario root.

Instalar Raptor
Ejecutar los siguientes comandos para iniciar la instalación de Raptor, el proceso es automático hasta que finalice la instalación.
Código:
  1. wget http://www.raptor.alterserv.com/install_raptor2_d8.sh
  2. chmod 777 install_raptor2_d8.sh
  3. bash install_raptor2_d8.sh

Redirección y priorización de tráfico Mikrotik por Mangle
- Modificar el IP del servidor(192.168.10.2) y su segmento(192.168.10.0/24) en el caso que estén usando otros valores
- Modificar "LAN" en "in-interface" por el nombre de su interface de usuarios en la regla "action=mark-routing"
Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/24
  3. /ip route
  4. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=raptor_route scope=30 target-scope=10
  5. /ip firewall mangle
  6. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=\
  7.     no protocol=tcp
  8. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=443 in-interface=LAN new-routing-mark=raptor_route \
  9.     passthrough=no protocol=tcp src-address-list=https_users
  10. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" new-connection-mark=raptor-connection
  11. add action=mark-connection chain=forward dscp=18 new-connection-mark=raptor-connection
  12. add action=mark-packet chain=forward connection-mark=raptor-connection new-packet-mark=raptor-packs passthrough=no
  13. /queue simple
  14. add max-limit=30M/30M name=RaptorCache packet-marks=raptor-packs queue=pcq-upload-default/pcq-download-default target="" total-queue=default

Agregar en el Firewall del raptor el segmento de red de sus usuarios(en la imagen está como ejemplo el segmento 192.168.1.0/24), y activar las reglas de redirección al puerto 3128 y 3127


Dentro de las reglas de redirección del Mikrotik está la que redirecciona el puerto 443, esta regla está por defecto para que asigne a un address list(lista de usuarios); solo los que estén en esta lista se redireccionarán para el caché a HTTPS. Se puede administrar esta lista desde el WebPanel conectando al Mikrotik median su API



Cómo Importar Certificado

Versión Actual 2.0.5b

5
RaptorCache en General / Re:Raptorcache con squidguard
« : julio 24, 2016, 04:51:29 pm »
como lo hicieron iluminennos porfavor

6
Bueno jovenes ya salio la nueva version de Raptor, esperando que les paresca lo nuevo que JOemg6 trae y que lo puedan probar, asi como tambien que como dijo Joemg6 que esta version de Raptor no es compatible con la version 1.06b esto quiere decir que para usar la nueva version deberan instalar desde cero, ya que el cache que teneis con la version anterior no les funcionara y para algunos se termino la espera, Saludos

7
Otros / Re:Proyecto DebianCache (Modificacion de RaptorCache)
« : junio 10, 2015, 11:50:10 pm »
Que buen debate

jajajaja, pues claro en toda sociedad y en toda comunidad abierta es bueno el debate, muchas veces para dejar las cosas claras, creo que al final se salio de contexto, ya que se empezo, por lo del Webpanel y termino saliendo a luz mi manera o forma de moderar, ya que con Luistec hemos moderado este foro por casi tres años sin ningun problema, pero ni modo, como en cualquier otro foro o comunidad personas van y personas vienen, pero al final bien dicen que el que persevera alcanza, y amigo espero que este agarrado cuando salga la nueva actualizacion, de verdad viene excelente, jajajajja, Saludos

8
Otros / Re:Proyecto DebianCache (Modificacion de RaptorCache)
« : junio 08, 2015, 08:26:48 pm »
Bueno a los que le gustaba la idea asi hubiese quedado finalmente:


amigo no se si serias tan amable de compartirnos tu proyecto... p probarlo. saludos

9
Otros / Re:Proyecto DebianCache (Modificacion de RaptorCache)
« : junio 08, 2015, 12:47:47 pm »
Bueno a los que le gustaba la idea asi hubiese quedado finalmente:


10
Otros / Proyecto DebianCache (Modificacion de RaptorCache)
« : junio 05, 2015, 07:38:43 pm »
Les presento mi version modificada de Raptorcache
Orientada Especialmente para usar con dos tarjetas de red
Una hacia internet y otra a la red interna
la he llamado DebianCache:





INFORMACION
   

¿Porque una version modificada de raptor sin raptor?



Antes que nada he de Aclarar que Raptor funciona excelentemente bien para lo que fue diseñado, no hay problema con eso, esto lo hice debido a mis necesidades y lo comparto por si le sirve a alguien.


Porque lo modifique:


1) No tengo router ni mikrotik! solo un pc con dos tarjetas de red y un ISP que trabaja asignando Ips aleatoriamente, por tanto no puedo trabajar con ip fija por ejemplo.

2) los principales contenidos que necesitamos realmente cachear, no se pueden cachear ni por Raptor ni Squid por ser paginas cifradas, facebook, twitter, google por ejemplo.

4) Squid por si solo cache todo lo que raptor pueda cachear, Principalmente porque raptor no cuenta con plugins que verdaderamenten hagan lo que no hace squid, cache de contenidos dinamicos... a exepcion de los plugins videos, que a mi punto de vista es solo util para redes muy grandes ya que la probabilidad de que en una red pequeña un cliente vea el mismo video es minima, por eso vemos disco con 100 gb de cache de video y solo 5% ahorro.

5) Como mencione antes, Los plugins de raptor referentes a otras web que no sea de videos son a mi punto de vista innecesarios. Squid hace cache de los mismo sin necesidad de Raptor ni plugins.
 
6) Raptor solo hace cache de los video de youtube QUE SE VEAN DESDE YOUTUBE.COM, si vemos un video de youtube insertado en otra web no le hara cache, imaginate que cantidad de videos se saltan el cache.

7) El webPanel ofrece informacion suficiente, no hay necesidad de cacti ocupando memoria y espacio, ademas configurarlo no es nada facil y viene un poco mal configurado.

8) Bind es un buen servidor DNS, pero en mi pais suelen tener problemas los dns y ademas los de google pueden tardar algo en respoder, con powerDNS se gana la misma o quizas mas velocidad que bind ademas que el cache no se pierde al reiniciar ni al recargar el proceso por tanto se soluciona el problema.

9) Otro problema muy peculiar en mi pais, es que despues de cierto tiempo se pierde la conexion a internet porque la puerta de enlace que asigna el ISP deja de funcionar, la solucion es Renovar la ip asi que me vi en la necesidad de copiar algunas cosas del Proyecto BrazilFW para solucionar ese detalle.



¿Que se incluye y que se a eliminado de la version de JOEMG?



1) Eliminado Raptor junto con sus bases de datos y diferentes scripts y asociaciones al webpanel
2) Squid.conf optimizado y con con reglas para limitar y bloquear
3) Servidor Bind sustituido por PowerDNS (Cache permanente en disco, no se borra al reiniciar como bind)
4) Scripts para monitorizar los procesos de PowerDNS y Squid y evitar que dejen de funcionar
5) Incluida Herramienta "PingerIP" tomada del addon de Brazilfw "WatchdogIp" y repotenciada para monitorizar la conexion a internet y la resolucion de nombres
           

  • Con esta herramienta se comprueba si se esta conectado a internet
    y si PowerDNS resuelve correctamente las peticiones DNS de tal manera que si
    falla la prueba se Renueva la concesion Ip que nos otroga nuestro ISP o se
    reinicia el servidor DNS cual sea el caso.


6) Eliminado Cacti
7) Incluido Servidor DHCP
8) Incluido Cache Manager para Squid
9) Corregido muchos errores del Webpanel y Modificado.
10) Eliminado Script que monitorea la memoria cache, permitiendo que Squid use toda la memoria y evite leer del disco Constantemente (El sistema por si solo se encargara de no quedarse sin memoria para los procesos)




¿Que funcionalidades ofrece esta Modificacion?



1) Instalacion limpia y organizada principalmente
2) Version configurada especialmente para los que no quieren depender de un Router (Mikrotik por ejemplo), solo conectar por una interfaz de red el internet y por la otra los clientes.
3) Script de monitore de servicios
4) Cache solo de imagenes de youtube.com
5) Manejo desde el webpanel de las siguientes configuraciones:
   
  • PowerDNS
  • Dominios y extensiones limitadas y bloqueadas por Squid
  • Borrado y Limpieza del cache de Squid
  • Reglas de Firewall
  • TCP/IP Configuracion
  • Servidor Dhcp
  • PingerIP
   


6) Estadisticas que se pueden visualizar desde el Webpanel:
   
  • Estado de PowerDNS
  • Estado de Squid
  • Usuarios y conexiones Activas a Squid
  • Conexiones Tcp Activas
  • Usuarios Activos
  • Numero de objetos en el cache de Squid
  • Estado de reglas NAT y MANGLE
  • Procesos activos
  • Estado de las interfaces de red
   


7) Registros que se pueden vizualizar desde el Webpanel:
   
  • Registro del proceso Squid
  • Registro de acceso a Squid
  • Registro del sistema
  • Registro de PingerIP (Cortes de internet y dns)
  • Registro de Procesos (Caidas de PowerDNS y Squid)
  • Registro del WebPanel




Algunas Capturas



















Proximamente el script de instalacion. Por ahora Falta pulir el QoS.

11
Hermano no es el raptor que se le cambia la hora eso es uin sistema acoplado al debian el debian es la base de todo y eso se hace por consola de esta manera

Podemos cambiar la hora del sistema y la hora de la bios del equipo.

Para cambiar la hora del sistema usaremos el comando date, pero hemos de tener en cuenta que al reinicializar el ordenador, éste cogerá la hora de la BIOS y nos volverá a colocar la hora anterior, para evitar esto cambiaremos también la hora de la BIOS con el comando hwclock como se detalla a continuación:

Suponemos que queremos colocar la
Código: [Seleccionar]
fecha: 25-Feb-2000 y la hora 16:25.Esto lo haremos como root:

Código: [Seleccionar]
# date --set "2000-02-25 16:25"
Fri Feb 25 16:25:00 CET 2000

Ahora realizaremos el mismo cambio para actualizar la fecha en la BIOS.

Código: [Seleccionar]
# hwclock --set --date="2000-02-25 16:25"
Para comprobarlo tecleamos:

Código: [Seleccionar]
# hwclock
Fri Feb 25 16:25:06 2000 -0.010586 seconds

Eso es todo y espero que te sirva.


No olvides darle Like

Páginas: 1