Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Temas - joemg6

Páginas: 1 2 3 4
1
Anuncios del Foro / Raptotocache continúa el 2019
« : Enero 05, 2019, 10:28:40 pm »
Comunidad Raptorcache, el proyecto continúa, son momentos difíciles para satisfacer las necesidades del caché actual, se trabaja en eso, en muchas veces se ha tenido pilotos sin éxito para el caché en producción; se sique trabajando es eso, se liberará una actualización con un mejor funcionamiento en el hardware y funcionamiento en el sistema como en el WebPanel en la última versión de Debian. Esto estará disponible para todos los usuarios. Para los usuarios de licencia les llegará en su cuenta, las actualizaciones de RaptorCache no caducan, las actuaciones les llegarán a todos los usuarios que adquirieron la licencia desde el inicio, sí alguno tuviese inconveniente solo enviar un correo a support@raptocahe.com (support@raptocahe.com). Los servicios de comunicación se están actualizando.

2
Instalación Raptorcache - Ubuntu Server 16.04.x

Si se requiere instalar Raptorcache en Ubuntu, está disponible el instalador para esta versión, pero se requiere que se sigan ciertos pasos previos que se describe a continuación:

http://releases.ubuntu.com/16.04/

- Instalar Ubuntu Server 16.04.x

- Cambiar a super usuario, para hacer cambios en la configuración
Código:
  1. sudo su
Ingresar la contraseña del usuario

- Activar el usuario "root"
Código:
  1. passwd
Asignar la contraseña para el usuario "root"

- Instalar el servidor SSH en caso todavía no se haya hecho
Código:
  1. sudo apt-get install -y ssh

- Para que se pueda ingresar por un cliente SSH al servidor (por ej. con Putty), se activa editando el archivo "/etc/ssh/sshd_config" y cambiando la línea PermitRootLogin prohibit-password y que quede en PermitRootLogin yes, o se puede ingresar el siguiente comando que hace está tarea
Código:
  1. sed -i 's/PermitRootLogin prohibit.*/PermitRootLogin yes/g' /etc/ssh/sshd_config

- A partir de está versión cambiá el nombrado de las interfaces que antes comenzaba con el prefijo "eth", para volver a esta nombrado se tiene que editar el archivo "/etc/default/grub" y cambiar la línea GRUB_CMDLINE_LINUX="" y modificarla de la siguiente manera GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0", para que tenga efecto el cambio se ejecuta el comando sudo grub-mkconfig -o /boot/grub/grub.cfg. También se puede ingresar los siguientes comandos que hacen esta tarea

Código:
  1. sed -i 's/GRUB_CMDLINE_LINUX=""/GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"/g' /etc/default/grub
  2. sudo grub-mkconfig -o /boot/grub/grub.cfg

- También se tiene que modificar los prefijos del archivo de configuración de las interfaces en el archivo "/etc/network/interfaces" cambiar el valor de los prefijos que comienzan con enp y renombrarlos a eth0. También pueden ejecutar los siguientes comandos que hacen esta tarea

Código:
  1. sed -i 's/auto enp.*/auto eth0/g' /etc/network/interfaces
  2. sed -i 's/iface enp.*/iface eth0 inet static/g' /etc/network/interfaces

- Luego de hacer los cambios, reiniciar el servidor
Código:
  1. reboot


- Desúés de reiniciar el servidor, ingresar al servidor como usuario "root" o luego hacerlo como super usuario para ejecutar el script de instalación
Código:
  1. wget http://www.raptor.alterserv.com/ubuntu/U16/install.sh
  2. chmod 777 install.sh
  3. bash install.sh

Posterior a este paso ya se tendría instalado Raptorcaché en Ubuntu Server, el proceso de configuración es el mismo que la versión con Debian

3
Instalar certificado SSL en Mikrotik - Hotspot HTTPS

Cuando se configura por defecto el Hotspot del Mikrotik, el portal cautivo funciona bien con el protocolo HTTP, pero si pretendemos abrir el dominio del Hotspot con el protocolo HTTPS nos muestra el siguiente error


Esto se debe a que se tiene que configurar el servidor Hotspot con login HTTPS y un certificado para autentificar el nombre de DNS configurado.

Mikrotik nos permite crear certificados, usaremos esa opción para generar el certificado para el DNS del Hotspot, para eso se necesita el Hotspot Address y DNS name con el que se  configuró el Hotspot



Se puede revisar la lista de certificados que se tiene instalado en la siguiente dirección System->Certificates, si no se tiene ninguno nos mostrará como en la siguiente imagen


Generar certificado
Para el proceso de generar el certificado se hará por el terminal del Mikrotik, para eso se ingresará los siguientes comandos
* Cambiar el valor "hotspot.wisp.com" por el que esté en su configuración como también el IP "192.168.100.1" por el que corresponda al servidor Hotspot
Código:
  1. /certificate
  2. add name=ca-template common-name=Ca_Hotspot key-usage=key-cert-sign,crl-sign organization=Mikrotik_Router subject-alt-name=DNS:hotspot.wisp.com unit=hotspot_security
  3. sign ca-template ca-crl-host=192.168.100.1 name=Hotspot_Cert
  4. set Hotspot_Cert trusted=yes

Posterior al ingreso de los comandos para generar el certificado, si uno vuelve a revisar nuevamente en la lista de certificados se podrá visualizar el certificado que se generó


Para hacer uso del certificado en el Hotspot, se habilitará la siguiente opción en Hotspot -> pestaña ServerProfiles -> se selecciona el profile (en el caso de la imagen el profile hsprof1),se habilita y seleccióna el certificado en SSL Certificate


También se habilita el certificado para el servicio www-ssl en IP->Services->selecionar www-ssl


Se verifica en el navegador del cliente, se aprecia que ya no sale el mensaje de error, pero nos sale un mensaje de advertencia indicándonos que la conexión no es privada, se puede saltar esta advertencia ingresando a la opción CONFIGURACIÓN AVANZADA.


Pero nos mostrara que el sitio no es seguro, esto se debe que el navegador del cliente no puede autentificar el sitio.


Para que no muestre el mensaje de advertencia se debe de instalar el certificado en el navegador del cliente, para eso se procede a exportar el certificado e instalarlo en el navegador del cliente




Luego de instalar el certificado en el navegador del cliente, se podrá apreciar que el mensaje cambia a Es Seguro


Instalar certificado de un dominio de internet

Instalar certificado en el navegador del cliente puede ser que en algunas implementaciones no pueda ser posible por distintas circunstancias. Una alternativa para no instalar el certificado en el navegador sería usar certificado de un dominio de internet. A continuación se mostrará el proceso de instalar certificado de un dominio de internet (para el tutorial se proporcionará el certificado para su descarga)

Para este tutorial se empleará el certificado del dominio hotspot.alterserv.com que está disponible para su descarga e implementación.
Descargar Certificado


Se requiere tener ciertos valores en la configuración con se describe a continuación.
Como el certificado pertenece al dominio hotspot.alterserv.com se necesita cambiar el valor del DNS Name que se encuentra en Hotspot -> pestaña ServerProfiles -> se selecciona el profile por el de hotspot.alterserv.com


Descargar el archivo, descomprimir y subir los dos archivos a Files del Mikrotik


Para importar los certificados se va a la opción System->Certificates en la pestaña Certificates, se presiona el botón Import, se elige el archivo cert_hotspot_alterserv_com.crt y se presiona Import


Se efectúa el mismo procedimiento para el archivo key_hotspot_alterserv_com.key


En Hotspot -> pestaña ServerProfiles -> se selecciona el profile (en el caso de la imagen el profile hsprof1), y se habilita y seleccióna el certificado en SSL Certificate se elige como certificado para el Hotspot cert_hotspot_alterserv_com.crt_0


Se verifica en el cliente y debe de mostrar que el sitio es seguro sin necesidad de instalar certificado en el navegador del cliente

4
Hotspot (Portal Cautivo) / Configurar Hotspot Mikrotik
« : Mayo 11, 2018, 08:03:31 pm »
Configurar Hotspot Mikrotik

El Hotspot de Mikrotik es un sistema que permite redireccionar a nuestros clientes a un portal para que pueda autentificarse. Al autentificarse el cliente, este puede acceder al servicio de internet. A continuación se va ha describir el proceso de configuración inicial del Hotspot.

Para inicar vamos a IP -> Hotspot 


Luego se selecciona la pestaña Servers y se presiona el botón Hotspot Setup, para iniciar con el asistente de configuración, donde se elige la interface a la que se asignará el funcionamiento del Hotspot 


Se ingresará el ip y segmento que usará el Hotspot
El check box de Masquerade Network se desmarca si ya se cuenta configurado el Mikrotik con acceso a internet.


Address Pool of Network, asignará un rango de IP's para el uso de los clientes para que así obtengan un IP
automáticamente. Este paso activa el DHCP Server para el Hotspot.


Carga certificado si se cuenta con un certificado de seguridad para HTTPS, de lo contrario elegir none


De tener implementado el servidor SMTP asignar el IP, sino dejar con el valor 0.0.0.0


Se configura los DNS que usará el Hotspot


Se configura el nombre de dominio que usará el portal cautivo


Usuario y password


Todo el proceso sería de la siguiente manera



5
Acceso remoto SSH a Raptorcache con Putty o WinSCP

Instalar y conectar con Putty
PuTTy es un cliente de red que soporta los protocolos SSH, Telnet y Rlogin y sirve para iniciar una sesión remota con otra computadora personal o servidor.
A continuación, detallaremos los pasos para conectar PuTTy con el servidor Raptorcache por medio del protocolo SSH.

Primero se debe descargar el programa cliente PuTTy de su sitio web que está en la siguiente dirección:
https://www.putty.org/
https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html

 
Se hace doble click en el ejecutable descargado


Se abrirá el panel de configuración y acceso, donde ingresamos el IP del servidor Raptor y el puerto 22 que es para la conexión ssh, y presionar el botón Open.

 
Luego mostrará el Terminal donde se tiene que ingresar el usuario (login as) como root y la contraseña que se le puso al servidor Raptor durante su instalación.


Si el proceso es correcto, se conectará al servidor y ahí podrá ingresar los comandos de ejecución al servidor Raptor




Instalar y conectar con WinSCP
En caso de requerir un entorno gráfico para navegar por los directorios y archivos del servidor(más amigable para usuarios principiantes), se puede instalar el programa WinSCP
- Descargar Instalador WinSCP
https://winscp.net/eng/download.php

Luego de la instalación del programa WinSCP, al ejecutar el programa mostrará la ventana para hacer la conexión con el servidor donde se ingresan los datos del servidor, como por ej. se muestra en la siguiente imagen


Después se conectará y mostrará una interface gráfica parecida al explorador de Windows, donde se puede interactuar por los directorios y archivos del servidor

6
Indice de tutoriales y preguntas frecuentes


FAQ (Preguntas Frecuentes)
Sobre las licencias Raptorcache
Las licencias no expiran son de por vida, el pago es único que incluye asistencia en la implementación y configuración hasta el funcionamiento en producción del servidor.

¿Se pueden migrar las licencias?
Sí, se pueden migrar las licencias solo agregando el monto de diferencia de la licencia del siguiente nivel.

¿Qué es un thread?
Un thread es un proceso que se abre para atender a cada petición de contenido que se hace al servidor caché.

¿Cuantos threads libres tiene Raptorcache?
Los threads libres o gratuitos son 80 que viene en la instalación por defecto.

¿Los threads libres para cuantos usuarios soporta?
La cobertura de usuarios con los threads libres es relativo, va de acuerdo al consumo de conexiones de los usuarios, pero se puede calcular como un aproximado como máximo 30 usuarios activos.

¿Cómo verifico que Raptorcache está haciendo caché?
Se puede revisar por el WebPanel en el Log que se encuentra en en la opciones de Utilidades que se esté listando del tráfico del contenido, y también revisar la estadística que se esté almacenando en la base de datos de dominios.

¿Cómo formatear y montar discos duros?
Este procedimiento se puede hacer desde el WebPanel en la opción "Configuración -> Mount Disk"

¿Cómo probar la conexión con la base de datos?
Esto se puede hacer por el navegador Web, por ej. si el IP del servidor es 192.168.10.2 ingresamos la dirección.
Código:
  1. http://192.168.10.2:82/test_db.php

No puedo entrar al WebPanel
Si no puede ingresar al WenPanel, primero sería revisar la conectividad con la base de datos. El usuario y contraseña por defecto es "admin"

Como restaurar la contraseña por defecto del WebPanel
Ejecutar el siguiente comando por terminal
Código:
  1. mysql -u root -praptor << eof
  2. UPDATE raptor.user SET passUser = '21232f297a57a5a743894a0e4a801fc3' WHERE user.loginUser = 'admin';
  3. eof

¿Qué es el L.A. en el WebPanel?
El Load Average es la carga promedio del equipo, no específicamente la carga del CPU. El load average es la cantidad de procesos que están encolados, calculados sobre un cierto período de tiempo, se puede ver más detalles sobre el Load Average en el siguiente link

Mi red está lenta despues de implementar Raptor ¿que es lo primero que debo verificar?
Lo primero que se debe de verificar es la configuración de los DNS, y hacer una prueba de los tiempos de respuesta. Configurar el DNS con el que mejor respuesta tenga.

¿Cómo limpiar el cache?
Limpiar todo el contenido
Código:
  1. clean -1
Limpiar por el tiempo de permanencia sin HIT en el caché, por ej. si queremos hacer al contenido que esté almacenado 45 días sin hacer caché.
Código:
  1. cleanhit 45
Limpiar todo el contenido de un dominio específico, entonces ejecutamos por terminal el siguiente comando, por ej. en el caso de avast.com
Código:
  1. cleandomain avast.com -1

7
Redirección Mikrotik - Bridge, PPPoE y Vlans Vlans

Para el proceso de redirección en paralelo a Mikrotik se puede hacer de distintas maneras y de acuerdo a la necesidad que se requiera. Vamos a mostrar algunos ejemplos de redirección en distintas implementaciones.
La regla que se encarga de la redirección del tráfico al servidor Raptor, es la que se encuentra en el Mangle que hace el «mark routing», entonces nos enfocaremos en esa regla para hacer las modificaciones de acuerdo a las distintas implementaciones.

Implementaciones en Bridge
Si se tiene una red de clientes en bridge, se tiene que hacer la siguiente modificación en la regla de redirección en Mangle; cambiar la interface de entrada «In. Interface» que por defecto está con la interface LAN, en este caso cambiaremos por el nombre de la interface bridge a la que se esté usando. También tener en cuenta que la interface en al que está asignada el servidor Raptor tiene que estar fuera del bridge.


Implementaciones en PPPoE y Vlan
Algo parecido a la implementación en bridge también se aplica para la PPPoE, se cambia la interface de entrada «In. Interface» por el nombre de la interface.




Implementación por rangos
Se puede hacer la redirección hacia el servidor direccionando solo un segmento de red, para eso se desmarca la interface de entrada y se asigna mediante el «Src. Address» y se ingresa el rango. Si se requiere usar varios rangos, se puede crear varias reglas de redirección asignando los distintos rangos.   


Implementación por Address List
En caso que se quiera redireccionar ciertas IPs Podemos usar el Address Lists


Se pueden crear varias reglas de redirección de ser necesario para asignar a distintos interfaces o segmentos.
En redes que se esté usando routers para sus clientes, solo asignar el IP del router para hacer la redirección hacia el servidor.

8
Instalación de Raptorcache

Antes de instalar el servidor se debe revisar el tipo de esquema de red que va a utilizar. El servidor necesita un puerto de red y su segmento de red independiente al que tiene que estar conectado para su acceso a internet, ya que se descargarán paquetes durante la instalación.

Por ej. En el caso de del modo paralelo a Mikrotik se usará una interface configurada con el segmento 192.168.10.0/24 en el Mikrotik con IP 192.168.10.1 que será la puerta de enlace para el servidor Raptor

- Raptorcache para CD Descargar
- Raptorcache para USB Descargar (Para grabar la imagen a la memoria USB puede usar el programa Win32 Disk Imager)

Posterior a la revisión del modo y conexión del servidor a la red, se tiene que configurar el arranque del servidor en el bios para que inicie por el CD o USB de acuerdo a la imagen que vaya a usar.

Al iniciar el proceso de instalación se muestra la pantalla de instalación donde se elige la opción Install
Luego de iniciar la instalación se configurará los valores de red del servidor.
En este tutorial se le asigna el IP 192.168.10.2 ya que pertenece al mismo segmento de red que se muestra en el esquema al que se conectará.
Se configura la máscara de red que por defecto es 255.255.255.0
Se ingresa la puerta de enlace (Pasarela) que es el IP de la interface del router en la que está conectado el servidor.
Se ingresa los DNS. En el tutorial se usa el DNS de Google 8.8.8.8 que también puede ser reemplazarlo por el de su proveedor de internet si los tiempos de respuestas son mejores.
Se elige el disco duro donde se instalará el sistema
Se configura la contraseña para acceso al servidor por terminal
Luego procede a descargar paquetes necesarios e instalar el sistema
Si el proceso se hizo de manera correcta finalizará con el siguiente mensaje y se reiniciará para seguir con la instalación
Despues de reiniciar el servidor se iniciará con la peticion de usuario y password para el acceso al terminal.
Se ingresa el usuario como root y la contraseña es la que se le asignó durante la instalación
Luego de ingresar al terminal se digita el comando bash config.sh para que se proceda a configurar el servidor
Al finalizar este proceso, el servidor quedará instalado.
Para acceder al Panel de configuración se hace por medio del navegador web ingresando la dirección IP del servidor y el puerto 82 por ej. En el caso del tutorial 192.168.10.2:82
El usuario por defecto es admin y la contraseña admin

9
Instalación y Configuración RaptorCache / Store HTTPS
« : Abril 11, 2018, 06:08:38 pm »
Store HTTPS

Para hacer caché a sitios web HTTPS, se puede hacer mediante está configuración, donde se agrega una expresión regular(Regex) de la dirección del contenido a hacer caché. A continuación, detallaremos el proceso de identificación usando un ejemplo para el sitio web https://www.aliexpress.com que cuyo contenido de imágenes tiene la siguiente url:
https://ae01.alicdn.com/kf/HTB1bpMVixSYBuNjSspj76073VXa2.png_200x200.png

Para que se pueda ver mejor usaremos una herramienta online para validar nuestro regex, que está en la siguiente dirección:
https://regex101.com/

Ingresamos la url del contenido y regex a validar, es importante que el regex esté separado por paréntesis en dos grupos, para que ese registro quede guardado


Si el regex es validado se mostrará la información en “MATCH INFORMATION” se tiene que tener en cuenta que el resultado de el grupo que se encerró en paréntesis aparecerá en “Group 1” y “Group 2” estos valores juntados no tienen que ser cortos con la probabilidad que se repita con otro contenido, sino al momento de hacer HIT saldrá un mismo contenido para varias peticiones.

Luego que se ha validado el regex se ingresa al Store HTTPS


Para que tenga efecto la configuración reiniciar el Raptor


Luego verificar en el HTTPS log del WebPanel, para ver los HIT del contenido al cargar por segunda vez la página web limpiar el caché del navegador

10
Configuración Firewall - RaptorCache

Raptorcache trabaja conjuntamente con iptables que es un potente firewall en el cual se pueden hacer muchas configuraciones. Vamos a mostrar unos ejemplos de configuración en el firewall.

Aceptar un segmento de usuarios
Por ej. el segmento 192.168.1.0/24


Redireccionar el tráfico del puerto 80 hacia el 3128(Raptor) por interface


Redireccionar el tráfico del puerto 443 hacia el 3127(Raptor HTTPS) por interface


Redireccionar el tráfico del puerto 443 hacia el 3127(Raptor HTTPS) por address list
Para eso primero se crea una lista de usuarios, entonces nos dirigimos en el WebPanel en la opción Raptor->AddressList y creamos la lista


Luego agregamos las direcciones o segmentos de IP a la lista


Ahora creamos la regla para redireccionar por address list en el Firewall, que solo los IPs de la lista pasen por el puerto 443 se redirijan al cache HTTPS


Redireccionar el tráfico de Youtube del puerto 443 hacia el 3127(Raptor HTTPS) por address list


Es importante agregar una regla de enmascardo para el contenido que no pasa por el caché para que continúe su flujo.  


Para que tenga efecto la configuración es necesario reiniciar el Firewall


Si todo está bien se puede verificar el tráfico por el HTTPS log en el WebPanel


* Esto solo son unos ejemplos de configuraciones que se pueden hacer, esto puede variar de acuerdo a las necesidades. Posteriormente iremos agregando más ejemplos de configuraciones

11
Actualizaciones / [Update] RaptorCache 2.0.6 - WebPanel 1.4.5
« : Abril 10, 2018, 08:11:58 pm »
Update - RaptorCache 2.0.6

Core ChangeLog:
*) Add cache to content HTTPS for regex
*) Fixed cache storage in another directory
*) Update identify small length content
*) Update identify common files

Webpanel ChangeLog:
*) Added option create address list
*) Added option Store HTTPS
*) Added option insert NAT rules
*) Change in design in Load Average  
*) Updated synchronization of the bandwidth monitor









Actualización manual por Terminal
Código:
  1. wget http://www.raptor.alterserv.com/update-raptor2.0.6.sh
  2. chmod 777 update-raptor2.0.6.sh
  3. bash update-raptor2.0.6.sh
  4. /etc/init.d/raptor restart && /etc/init.d/squid3 restart

* Si después de la actualización los estilos del WebPanel no cargan bien, limpiar en caché del navegador web

12
Instalación Raptorcache 2.x



- Raptorcache para CD Descargar
- Raptorcache para USB Descargar (Para grabar la imagen a la memoria USB puede usar el programa Win32 Disk Imager)



Redirección y priorización de tráfico Mikrotik por Mangle
- Modificar el IP del servidor(192.168.10.2) y su segmento(192.168.10.0/24) en el caso que estén usando otros valores
- Modificar "LAN" en "in-interface" por el nombre de su interface de usuarios en la regla "action=mark-routing"
Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/24
  3. /ip route
  4. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=raptor_route scope=30 target-scope=10
  5. /ip firewall mangle
  6. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=\
  7.     no protocol=tcp
  8. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=443 in-interface=LAN new-routing-mark=raptor_route \
  9.     passthrough=no protocol=tcp src-address-list=https_users
  10. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" new-connection-mark=raptor-connection
  11. add action=mark-connection chain=forward dscp=18 new-connection-mark=raptor-connection
  12. add action=mark-packet chain=forward connection-mark=raptor-connection new-packet-mark=raptor-packs passthrough=no
  13. /queue simple
  14. add max-limit=30M/30M name=RaptorCache packet-marks=raptor-packs queue=pcq-upload-default/pcq-download-default target="" total-queue=default

Agregar en el Firewall del raptor el segmento de red de sus usuarios(en la imagen está como ejemplo el segmento 192.168.1.0/24), y activar las reglas de redirección al puerto 3128 y 3127


Dentro de las reglas de redirección del Mikrotik está la que redirecciona el puerto 443, esta regla está por defecto para que asigne a un address list(lista de usuarios); solo los que estén en esta lista se redireccionarán para el caché a HTTPS. Se puede administrar esta lista desde el WebPanel conectando al Mikrotik median su API



Cómo Importar Certificado

Versión Actual 2.0.5b

13
Instalación Servidor de Videos - Clipbucket 2.8.x


La instalación se debe de efectuar en la distribución de Linux Debian 8.x, si tienen problemas de como realizar este proceso pueden ver en el tutorial de instalación de Raptor hasta la parte de tener acceso a Putty con el usuario root.
http://www.alterserv.com/foros/index.php?topic=2065.0

La mayor parte de la instalación se encargará el script, ahí está automatizado el proceso de instalación de las dependencias, para eso ejecutamos el script por terminal como usuario "root"  
Código:
  1. wget http://www.videoserver.alterserv.com/clipbucket/install.sh
  2. chmod 777 install.sh
  3. bash install.sh

Se continua la instalación por el navegador Web, ingresando a la siguiente dirección
http://TU_IP_SERVER/clipbucket/
Y se sigue como se muestra en las siguientes imágenes



















En la instalación incluye el Plugin Upload_MP4(autoría propia), el plugin tiene la función de subir videos en formato MP4 sin la necesidad de codificarlos nuevamente, ya que si se hace este proceso por el panel por defecto de Clipbucket se hace lento porque codifica nuevamente a los videos a subir lo que ahorra tiempo al momento de subir contenido.

Para activar el plugin realizarlo desde el panel de administración como se muestra en la siguiente imagen





En caso se requiera cambiar la contraseña de la base de datos pueden ver el proceso en el siguiente link
http://www.alterserv.com/foros/index.php?topic=2143.0

14
Actualizaciones / [Update] RaptorCache 2.0.5
« : Julio 17, 2017, 08:23:19 pm »
Update - RaptorCache 2.0.5

Core ChangeLog:
- Fixed up X-Forwarded-For content block
- Update detection Dota 2 content steamcontent server
- Update detection Youtube content
- Update core identify common files

Webpanel ChangeLog:
- Fixed up statistic error in economy
- Update update server
- Add domain form in Whitelist
- Best Informational Messaging System
- Fixed up File Size in Logs


Código:
  1. wget http://www.raptor.alterserv.com/update-raptor2.0.5.sh
  2. chmod 777 update-raptor2.0.5.sh
  3. bash update-raptor2.0.5.sh
  4. /etc/init.d/raptor restart && /etc/init.d/squid3 restart

15
Raptorcache 2 - Modo Bridge

A partir de la versión 2.0.4.x ya trae por defecto la configuración de gateway desde el WebPanel en la opción "Configuración -> Network" en el botón "Bridge Mode"


A continuación un ejemplo de cómo configurar Raptorcache en este modo, para lo cual lo haremos de acuerdo al esquema


Despues de hacer el bridge de las interfaces, reiniciar el servidor



Reglas iptables
Código:
  1. iptables -A INPUT -s 192.168.1.0/24 -j ACCEPT
  2. iptables -t nat -A PREROUTING -i br0 -p tcp --dport 80 -j REDIRECT --to-port 3128
  3. iptables -t nat -A PREROUTING -i br0 -p tcp --dport 443 -j REDIRECT --to-port 3127
  4. iptables -A INPUT -i br0 -p tcp --dport 3128 -j ACCEPT
  5. iptables -A INPUT -i br0 -p tcp --dport 3127 -j ACCEPT


Si solo se quiere hacer pasar cierto rango de IPs por el cache HTTPS, cambiar la regla "REDIRECT --to-port 3127", por ej.
Código:
  1. iptables  -t nat -A PREROUTING -i br0 -m iprange --src-range 192.168.1.3-192.168.1.30 -p tcp --dport 443 -j REDIRECT --to-port 3127


Cómo Importar Certificado

16
Raptorcache 2 - Modo Gateway

A partir de la versión 2.0.4.x ya trae por defecto la configuración de gateway desde el WebPanel en la opción "Configuración -> Network" en el botón "Gateway Mode"


A continuación un ejemplo de cómo configurar Raptorcache en este modo, para lo cual lo haremos de acuerdo al esquema


Despues de configurar las dos interfaces para el gateway, reiniciar el servidor



Reglas iptables
Código:
  1. iptables -A INPUT -s 192.168.1.0/24 -j ACCEPT
  2. iptables -t nat -A POSTROUTING -o eth0 -j SNAT --to 192.168.10.2
  3. iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128
  4. iptables  -t nat -A PREROUTING -i eth1 -p tcp --dport 443 -j REDIRECT --to-port 3127
  5. iptables -A INPUT -i eth0 -p tcp --dport 3128 -j ACCEPT
  6. iptables  -I INPUT -p tcp -m tcp --dport 3127 -j ACCEPT


Si solo se quiere hacer pasar cierto rango de IPs por el cache HTTPS, cambiar la regla "REDIRECT --to-port 3127", por ej.
Código:
  1. iptables  -t nat -A PREROUTING -i eth1 -m iprange --src-range 192.168.1.3-192.168.1.30 -p tcp --dport 443 -j REDIRECT --to-port 3127


Cómo Importar Certificado

17
Importar Certificados en el Navegador Web

Los que usen el sistema operativo Windows pueden descargar el zip que contiene instalador y descomprimirlo e instalar el certificado con un par de clicks


Descargar Instalador del Certificado




 

Instalación manual del certificado en el navegador Chrome


Instalación manual del certificado en el navegador Mozilla Firefox


El proceso es similar en otros navegadores web.


Descargar Certificado

18
Instalación Raptorcache 2.0.5b

Changelog:

Instalación en Debian 8
https://cdimage.debian.org/mirror/cdimage/archive/8.10.0/amd64/iso-cd/debian-8.10.0-amd64-netinst.iso


Para usar Putty con el usuario root en Debian 8
Despues de instalar el ssh en el servidor("apt-get install ssh") se necesita configurar el ssh para el accesso al usuario "root" que por defecto está deshabilitado en Debian 8.
Editar por terminal el archivo de configuración del ssh, para eso efectuamos los siguientes comandos
Código:
  1. nano /etc/ssh/sshd_config

Dentro del editor buscar la línea "PermitRootLogin Without-Password" y cambiarlo a "PermitRootLogin yes" guardar con Ctrl + o y salir Ctrl + x , luego reiniciar el ssh
Código:
  1. /etc/init.d/ssh restart
y con eso se tendría acceso a Putty con el usuario root.

Instalar Raptor
Ejecutar los siguientes comandos para iniciar la instalación de Raptor, el proceso es automático hasta que finalice la instalación.
Código:
  1. wget http://www.raptor.alterserv.com/install_raptor2_d8.sh
  2. chmod 777 install_raptor2_d8.sh
  3. bash install_raptor2_d8.sh

Redirección y priorización de tráfico Mikrotik por Mangle
- Modificar el IP del servidor(192.168.10.2) y su segmento(192.168.10.0/24) en el caso que estén usando otros valores
- Modificar "LAN" en "in-interface" por el nombre de su interface de usuarios en la regla "action=mark-routing"
Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/24
  3. /ip route
  4. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=raptor_route scope=30 target-scope=10
  5. /ip firewall mangle
  6. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=\
  7.     no protocol=tcp
  8. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=443 in-interface=LAN new-routing-mark=raptor_route \
  9.     passthrough=no protocol=tcp src-address-list=https_users
  10. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" new-connection-mark=raptor-connection
  11. add action=mark-connection chain=forward dscp=18 new-connection-mark=raptor-connection
  12. add action=mark-packet chain=forward connection-mark=raptor-connection new-packet-mark=raptor-packs passthrough=no
  13. /queue simple
  14. add max-limit=30M/30M name=RaptorCache packet-marks=raptor-packs queue=pcq-upload-default/pcq-download-default target="" total-queue=default

Agregar en el Firewall del raptor el segmento de red de sus usuarios(en la imagen está como ejemplo el segmento 192.168.1.0/24), y activar las reglas de redirección al puerto 3128 y 3127


Dentro de las reglas de redirección del Mikrotik está la que redirecciona el puerto 443, esta regla está por defecto para que asigne a un address list(lista de usuarios); solo los que estén en esta lista se redireccionarán para el caché a HTTPS. Se puede administrar esta lista desde el WebPanel conectando al Mikrotik median su API



Cómo Importar Certificado

Versión Actual 2.0.5b

19
Actualizaciones / [Update] RaptorCache 2.0.3
« : Diciembre 29, 2015, 06:48:56 pm »
Update - RaptorCache 2.0.3
ChangeLog:
- Mejorando la carga de objetos en la base de datos.
- Corrección en la identificación de actualizaciones Kaspersky.
- Corrección en la identificación de actualizaciones Softnyx.
- Conteo de threads en la base de datos por días.

Antes de realizar la actualización ingresar los siguientes comandos por terminal, ya que son necesarios para el buen funcionamiento de la actualización.
Código:
  1. mysql -uroot raptor -praptor << eof
  2. ALTER TABLE  raptor ADD  thread_usage INT(8) NOT NULL AFTER last_request;
  3. ALTER TABLE  raptor ADD  ip varchar(30) NOT NULL AFTER ext;
  4. eof
  5. apt-get install -y ioping
  6. chmod 777 /etc/fstab

Código:
  1. wget https://dl.dropboxusercontent.com/u/74360564/raptor2/update/raptor2.0.3_update.tar.gz
  2. mv raptor2.0.3_update.tar.gz /tmp
  3. tar -xzvf /tmp/raptor2.0.3_update.tar.gz -C /
  4. service raptor restart && service squid3 restart

Update RaptorWebPanel 1.3
ChangeLog:
- Implementación de visualización carga I/O CPU
- Implementación de detalles I/O Discos Duros
- Gráfica de uso de threads
- Control Ping de DNS
- Formatear y montar discos por el WebPanel
- Basic config squid
- Corrección de reporte de tiempo de espera del disco duro.

Código:
  1. rm -rf raptorpanel.tar.gz
  2. wget https://dl.dropboxusercontent.com/u/74360564/raptor2/raptorpanel.tar.gz
  3. mv /usr/share/raptor/ /usr/share/raptor_old/
  4. tar -xzvf raptorpanel.tar.gz
  5. mv raptorpanel /usr/share/
  6. mv /usr/share/raptorpanel/ /usr/share/raptor

20
Actualizaciones / [Update] RaptorCache 2.0.2
« : Noviembre 14, 2015, 10:08:28 am »
Update - RaptorCache 2.0.2
ChangeLog
- Mejorado en la identificación de objetos.
- Optimización de liberado de la memoria RAM

Código:
  1. wget https://dl.dropboxusercontent.com/u/74360564/raptor2/update/raptor2.0.2_update.tar.gz
  2. mv raptor2.0.2_update.tar.gz /tmp
  3. tar -xzvf /tmp/raptor2.0.2_update.tar.gz -C /
  4. service raptor restart && service squid3 restart

Páginas: 1 2 3 4