Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Temas - roxdng

Páginas: 1
1
Otros / Asistencia Mikrotik Gratuita
« : Octubre 26, 2015, 11:47:01 pm »
Hola a todos, ofrezco asistencia gratuita para todo tipo de configuraciones mikrotik, por un tiempo limitado, la razón es que deseo practicar en infraestructuras nuevas para futura certificación.

El soporte lo haría a través de teamviewer, en un horario que me acomode.

Soy Chileno, Ingeniero Informático con conocimiento avanzado en redes.


Interesados enviar MP.

Un saludo.


Enviado desde mi iPad con Tapatalk

2
Hola a todos, he creado esta guía para evitar ensuciar los otros hilos con las mismas preguntas sobre como instalar.

esta basado en Mikrotik V6, pero solo hay que adaptar una linea para que sea funcional en V5.


Redireccion por mangle (mas eficiente que por NAT), ademas posee failover nativo a través de ping (cuando NO hay ping hacia nuestro servidor cache, se des-habilita el ruteo)

(modificar IP_DE_RAPTOR por la ip correspondiente)

Código:
  1. /ip route
  2. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=IP_DE_RAPTOR routing-mark=raptor_route scope=30 target-scope=10

estas reglas deben estar al inicio del mangle (en esta versión existe solo una marca)

(modificar LAN por su interfaz correspondiente)
Código:
  1. /ip firewall mangle
  2. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" disabled=no dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=no protocol=tcp
  3. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" disabled=no new-connection-mark=raptor-connection passthrough=yes
  4. add action=mark-packet chain=forward connection-mark=raptor-connection disabled=no new-packet-mark=raptor-packs passthrough=no

Ahora nuestro Queue

primero creamos un tipo de Queue, Esto en palabras simples crea un Queue que da como máximo 5MB por usuario (adapte según su red)

Código:
  1. /queue type
  2. add kind=pcq name=PCQ_LIMIT pcq-classifier=dst-address pcq-dst-address6-mask=\
  3.     64 pcq-limit=64 pcq-rate=5M pcq-src-address6-mask=64 pcq-total-limit=3k

y ahora lo implementamos en nuestro simple queue (adapte máximo según su red), este simple queue se recomienda ponerlo al inicio.
 
Mikrotik V6

Código:
  1. /queue simple
  2. add max-limit=4M/15M name=Cache packet-marks=raptor-packs queue=\
  3.     default-small/PCQ_LIMIT target=""

cual es la diferencia?. Tengo un ancho de banda máximo de 15MB para Raptor2, pero son solo 5MB por usuario.

Ahora modificamos firewall en Raptor2

Donde "192.168.1.0/24" es el segmento de red de los usuarios y "eth0" es el nombre de la interface del servidor Raptor


En el caso se tenga varios segmentos de red de usuarios


Luego Reiniciar el Firewall

si todo esta OK, ya deberíamos ver nuestro trafico en raptor2.

Un saludo

3
Squid 2.7 & Squid 3.x / Solucion a Windows Update con Squid
« : Agosto 10, 2013, 12:57:46 pm »
Foreros hace tiempo que el plugins de windows update esta fallando, por lo mismo vamos a forzar a squid a cachearlo.

Al grano, necesitamos modificar nuestro squid.conf

agregamos lo siguiente

Código: [Seleccionar]
range_offset_limit -1
quick_abort_min -1

esto fuerza a descargar las actualizaciones aun cuando el cliente se haya desconectado, como contra si poseemos un ancho de banda limitado lo saturara hasta que haya terminado la descarga. (esto se puede solucionar con un marcado y queue three dando prioridad baja)

Código: [Seleccionar]
maximum_object_size 200 MB
Necesitamos modificar el tamaño a cachear ya que algunas actualizaciones son superiores a 200 MB, por defecto viene con 30MB

Código: [Seleccionar]
refresh_pattern -i microsoft.com/.*\.(cab|exe|ms[i|u|f]|asf|wm[v|a]|dat|zip) 4320 80% 43200 reload-into-ims

refresh_pattern -i windowsupdate.com/.*\.(cab|exe|ms[i|u|f]|asf|wm[v|a]|dat|zip) 4320 80% 43200 reload-into-ims

refresh_pattern -i my.windowsupdate.website.com/.*\.(cab|exe|ms[i|u|f]|asf|wm[v|a]|dat|zip) 4320 80% 43200 reload-into-ims

Ahora el refresh, forzamos a squid a cachear todo lo que salga de windows update, microsoft a cachear, también podemos agregar mas regex, actualizar etc.

Código: [Seleccionar]
acl windowsupdate dstdomain windowsupdate.microsoft.com
acl windowsupdate dstdomain .update.microsoft.com
acl windowsupdate dstdomain download.windowsupdate.com
acl windowsupdate dstdomain redir.metaservices.microsoft.com
acl windowsupdate dstdomain images.metaservices.microsoft.com
acl windowsupdate dstdomain c.microsoft.com
acl windowsupdate dstdomain www.download.windowsupdate.com
acl windowsupdate dstdomain wustat.windows.com
acl windowsupdate dstdomain crl.microsoft.com
acl windowsupdate dstdomain sls.microsoft.com
acl windowsupdate dstdomain productactivation.one.microsoft.com
acl windowsupdate dstdomain ntservicepack.microsoft.com

acl CONNECT method CONNECT
acl wuCONNECT dstdomain www.update.microsoft.com
acl wuCONNECT dstdomain sls.microsoft.com

http_access allow CONNECT wuCONNECT localnet
http_access allow windowsupdate localnet

Por ultimo agregamos las acl para los cuadros de avisos de actualizaciones, confirmaciones etc..

 Espero que les sirva, en algunas redes que administro windows update consume alrededor del 15% de la banda ancha, por lo mismo esto no es menor, si lo ahorráramos.

4
Discución General / QoS restrictivo para Heavy user en debian
« : Abril 04, 2013, 10:07:19 pm »
Estimados les dejo una excelente herramienta para los que administran en debian o ubuntu junto con el thunder y/o raptor, se trata de un proyecto opensource, que clasifica a los usuarios por su nivel de descargas, bajando la prioridad a los heavy user y penalizandolos, se basa en HTB, ademas genera estadísticas del consumo diario, mensual etc.

Código: [Seleccionar]
To install SVN in Debian, just type:

apt-get install subversion

Subversion repository at dev.arachne.cz is called /repos/prometheus , ie. anonymous checkout commandline is:

svn co https://dev.arachne.cz/repos/prometheus

If you register to our Track/SVN using some username (eg. "nick") and ask us for access rights (eg. create New Ticket for xchaos), checkout commandline will be:

svn co --username nick https://dev.arachne.cz/repos/prometheus

mas info https://dev.arachne.cz/svn/prometheus

5
Otros / Guia- Gestor Descargas Torrent
« : Diciembre 28, 2012, 01:22:13 am »
Estimados, les dejo esta guía como instalar un gestor torrent para aprovechar el webserver que viene integrado en el thunder, en este caso transmission, por que transmission y no otro? Bueno por que a mi gusto es el que menos recursos consume, a plena carga no consume mas de un 5% de mi cpu en este caso un APU E350.

manos a la obra... mediante consola, putty o cualquier administrador similar.

Código: [Seleccionar]
apt-get install transmission-daemon
apt-get install transmission-common
apt-get install transmission-cli

con esto ya instalamos transmission en nuestro sistema.

paramos el demonio

Código: [Seleccionar]
service transmission-daemon stop
creamos una carpeta para las descargas incompletas

Código: [Seleccionar]
mkdir /var/www/web/Documents/incompletos
chmod 777 /var/www/web/Documents/incompletos

ahora a retocar la configuración default de transmission.

Accedemos al archivo de configuración en /etc/transmission-daemon, llamado "settings.json" (usar nano o vi). Debemos cambiar las siguientes líneas:

Código: [Seleccionar]
"download-dir": "/var/www/web/Documents",
"incomplete-dir": "/var/www/web/Documents/incompletos",
"rpc-whitelist": "127.0.0.1,192.168.10.2",
"rpc-whitelist-enabled": false,
"rpc-password": "nuestra contraseña",
"rpc-username": "nuestro usuario",

guardamos, cerramos y volvemos a arrancar nuestro demonio

Código: [Seleccionar]
service transmission-daemon start
ahora con nuestro navegador web vamos a la gui de transmission 192.168.10.2:9091 ingresamos nuestro usuario y contraseña

y listo... a disfrutar de su gestor de descargas.

para visualizar el contenido via web lo hacen con webserver en http://192.168.10.2/web/ usuario y contraseña root.

pronto guía como montar un servidor ftp, jdownloader y el famoso lvm para montar mas de un disco en el thunder..

Saludos comunidad.

6
Squid  bloquea  www.scribd.com, para deshabilitar dicho bloquea editar la configuración de Squid.conf en el aparato virus.

7
Squid 2.7 & Squid 3.x / optimizacion squid
« : Noviembre 04, 2012, 03:11:45 am »
hace poco me tope con el siguiente hilo optimizacion sistema

donde encontré cosas interesantes para agilizar nuestro sistema, por ende también squid.

recalco lo interesante

Optimizaciones y acceso a discos

Después de muchas investigaciones se descubrió que el acceso al cache cuando es utilizado o reiserfs llega a ser 20% más rapido que otros filesystem, por ejemplo ext3, ext2.

Se aconseja a todos que cuando efectúen la instalación del SO dejen una partición solamente para el cache, eso agiliza la lectura de los datos .

--------------------------------------

Otro consejos para montar el filesystem "/cache" añadir notail, noatime (eso agiliza mucho a la hora de lectura y escritura una vez que el squid tenga su propio tiempo, usando estas funciones usted evita que el sistema al guardar un archivo lo haga 2 veces).

Entre al directorio "/etc/fstab" y agregue:

/dev/sda5 /cache reiserfs defaults,notail,noatime 1 2
-----------------------------------------------------

Optimización del SO
Vamos a ir mostrando como optimizar el sistema para que el mismo acepte que varias conexiones sean realizadas en varios archivos utilizando los file descriptors. Muchas personas que instalan el squid terminan pasando por ese problema, el sistema bloque para que el maximo 1024 instancias de archivos sean abiertas.

Para comprobar cuántos archivos pueden ser abiertos por el sistema operativo, sólo tienes que escribir en la consola:

# ulimit -n
# ulimit -a

Vamos a comenzar con la optimización:

acceda a "/etc/sysctl.conf", y agregue la siguiente linea:


fs.file-max = 65535


Despues escribimos en la consola:

# sysctl -p

Despues accedemos en "/etc/security/limits.conf", adicionamos las siguientes linas al final del archivo;

root soft nofile 16384
root hard nofile 32768
* soft nofile 16384
* hard nofile 32768


Mucha gente pregunta que despues de hacer esas modificaciones el sistema aplica las configuraciones, pero una vez que le damos reboot al SO el limite vuele para 1024. Para resolver ese problema solo agregamos la siguiente linea de comando en"/etc/pam.d/common-account":

session required pam_limits.so


Hecho esto cuando el sistema operativo inicia el cambio sera puesto a punto"startado" y todo el sistema estará optimizado para recibir las solicitudes.

Finalizando la verificación de las optimizaciones
Al final de estas guias vamos a confirmar si el sistema arranco con todas las optimizaciones y si el servidor esta listo para recibir altas tasas de conexiones simultaneas.

En primer lugar vamos a la consola y vemos lo siguiente:

# ulimit -a
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 16382
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 16384
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) unlimited
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited

Vemos que el SO ahora está permitieneo que 16384 archivos sean abiertos a lo que anteriormente solo eran 1024.

Despues en el archivo "cache.log" del squid:

# cat cache.log
2011/07/11 14:19:07| Starting Squid Cache version 3.1.14 for x86_64-unknown-linux-gnu...
2011/07/11 14:19:07| Process ID 31325
2011/07/11 14:19:07| With 16000 file descriptors available
-------------------------------------------------------------

por otro lado también el refresh ideal para sistemas de alta concurrencias con respecto a imágenes seria este.

# Para imagenes – tiempo de 1 día y un máximo 3 para descargar nuevamente.
refresh_pattern -i \.gif$ 1440 80% 4320
refresh_pattern -i \.tiff?$ 1440 80% 4320
refresh_pattern -i \.bmp$ 1440 80% 4320
refresh_pattern -i \.jpe?g$ 1440 80% 4320
refresh_pattern -i \.xbm$ 1440 80% 4320
refresh_pattern -i \.png$ 1440 80% 4320
refresh_pattern -i \.wrl$ 1440 80% 4320
refresh_pattern -i \.ico$ 1440 80% 4320
refresh_pattern -i \.pnm$ 1440 80% 4320
refresh_pattern -i \.pbm$ 1440 80% 4320
refresh_pattern -i \.pgm$ 1440 80% 4320
refresh_pattern -i \.ppm$ 1440 80% 4320
refresh_pattern -i \.rgb$ 1440 80% 4320
refresh_pattern -i \.ppm$ 1440 80% 4320
refresh_pattern -i \.rgb$ 1440 80% 4320
refresh_pattern -i \.xpm$ 1440 80% 4320
refresh_pattern -i \.xwd$ 1440 80% 4320
refresh_pattern -i \.pict?$ 1440 80% 4320


Espero que les sirva, saludos.

8
Plugins para ThunderCache 3.1.2 / plugin speedtest
« : Noviembre 01, 2012, 12:27:42 pm »
Hola, he estado creando plugins específicamente el de speedtest, el gran problema es que usa distintos servidores, como puedo agregarlos todos bajo el dominio speedtest en el regex?

Páginas: 1