Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Temas - david_domh

Páginas: 1 2 3 4
1
Firewall & NAT / Utilizar Export
« : diciembre 05, 2013, 12:12:20 am »
Código:
  1. /ip firewall mangle export file=Poner Nombre
  2. /ip proxy access export file=Poner Nombre
  3. / ip firewall filter export file=Poner Nombre
  4. /queue tree export file=Poner Nombre

sirve para exportar nuestras reglas a un block de notas

2
Firewall & NAT / Videos de como config Mikrotik y balancear lineas ==
« : diciembre 04, 2013, 11:47:54 pm »
Ojala les sirva estos videitos que me ayudaron bastante ami en mis comienzos para config Mikrotik


https://mega.co.nz/#!wYxlgaDT!YZxcQVd41c2NbfQZHJ_sfxO7EEd5ZwxqzFORDzgz_o0



Saludos

David M.

3
Firewall & NAT / Redreccionar puertos a Rb Mikrotik Admin
« : diciembre 04, 2013, 11:35:09 pm »
Si por ejemplo tuvieramos un RB750 balanceando varias lineas de internet, y un RB450G administrador manejando a los clientes, para dedicar todos los puertos de una linea al RB administrador.

En el RB750:
Código:
  1. /ip firewall nat
  2. add chain=dstnat in-interface=pppoe-out3 action=dst-nat to-address=192.168.5.2



En este caso le estamos diciendo al RB750, que todo tenga destino pppoe-out3, que lo envie al IP 192.168.5.2,
obviamente este IP es WAN IP de nuestro RB450G administrador. Luego de esto, se pueden hacer las redirecciones necesarias a los clientes del RB450G.


David M.

4
Firewall & NAT / Limitar los P2P
« : diciembre 04, 2013, 11:29:20 pm »
limitar los p2p

primero marcando el trafico de los P2P:
Código:
  1. /ip firewall mangle add chain=forward p2p=all-p2p action=mark-connection new-connection-mark=p2p_conn
  2.  
  3. /ip firewall mangle add chain=forward connection-mark=p2p_conn action=mark-packet new-packet-mark=p2p

Luego asignándole un prioridad baja y ademas asignándole muy poco ancho de banda (64kbps) de nuestro total de 1 mega:

Código:
  1. /queue tree add parent=2 RED LAN packet-mark=p2p limit-at=3000 max-limit=64000 priority=8
  2.  
  3. /queue tree add parent=2 RED LAN packet-mark=p2p limit-at=3000 max-limit=64000 priority=8


Saludos

David M

Personalmente recomiendo estas reglas en una red que solo se utilize para navegaciòn Web, ya que hay algunos juegos q utilizan la tecnologia p2p (punto a punto ) y puede ocasionar lag en aquellos juegos online como por ejemplo los de softnyx

5
Firewall & NAT / instalar winbox en Rb Mikrotik
« : diciembre 04, 2013, 11:25:31 pm »
alguna vez les a pasado que se vuela el sistema operativo de mikrotik = Winbox??????????????


este video muestra como utilizar Netinstall para darle soluciòn


https://mega.co.nz/#!xBpWjCJD!QOLNEhHRFB6eLMJ2mxuPqyAvp24cb3M08pD_RvvCqyc


David M.

Saludos

6
Firewall & NAT / Poner Hora / Fecha actual en Mikrotik
« : diciembre 04, 2013, 10:46:53 am »
Código:
  1. /system ntp client
  2. set enabled=yes mode=unicast primary-ntp=200.189.40.8 secondary-ntp=\
  3.     200.59.8.234
  4.  
  5.  
  6. /system clock
  7. set time-zone-name=America/Lima
  8. /system clock manual
  9. set dst-delta=+00:00 dst-end="jan/01/1970 00:00:00" dst-start=\
  10.     "jan/01/1970 00:00:00" time-zone=+00:00

7
Firewall & NAT / DAR PRORIDAD A Rakion - SoftnyX
« : diciembre 04, 2013, 10:45:30 am »
Código:
  1. ip firewall mangle
  2. add action=mark-packet chain=prerouting disabled=no dst-port=\
  3.     1100-1399,2300-2399,40706-40737,50817,8500 new-packet-mark=rakion \
  4.     passthrough=yes protocol=tcp
  5.  
  6.  
  7.  
  8. /queue tree
  9.  
  10. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  11.     max-limit=0 name=rakion packet-mark=rakion parent=global-total priority=2 \
  12.     queue=default

8
Firewall & NAT / Limitar youtube a 1Mb
« : diciembre 04, 2013, 10:43:25 am »
Estas reglas en Mikrotik Limitan al youtube a 1Mb , asi no satura la red

Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=prerouting comment=Youtube content=youtube disabled=no new-connection-mark=youtube_in  passthrough=yes
  3. add action=mark-packet chain=prerouting comment="" connection-mark=youtube_in disabled=no new-packet-mark=youtube_in passthrough=no
  4.  
  5. /queue tree
  6. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=youtube_down packet-mark=youtube_in parent=global-in priority=1 queue=default

9
Firewall & NAT / Bloqueo de Porn II
« : diciembre 04, 2013, 10:21:06 am »
Código:
  1. /ip proxy
  2. set enabled=yes
  3. set src-address=0.0.0.0
  4. set port=8080
  5. set parent-proxy=0.0.0.0
  6. set parent-proxy-port=0
  7. set cache-administrator="webmaster"
  8. set max-cache-size=none
  9. set cache-on-disk=no
  10. set max-client-connections=600
  11. set max-server-connections=600
  12. set max-fresh-time=3d
  13. set always-from-cache=no
  14. set cache-hit-dscp=4
  15. set serialize-connections=no


Código:
  1. /ip firewall nat
  2. add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080

Código:
  1. /ip firewall filter
  2. add chain=input in-interface=ether2 protocol=tcp dst-port=8080 action=drop


10
https://mega.co.nz/#!5IwTzLRY!MGCdsG_4i4cHqqZWx-U90Bn690FAZSnZDmi3oJXeLjA


Fijense en el minuto 7 como la pelicula se corre hasta el ultimo minuto yluego de unos minutos mas la peli se cuelga y se corrompe

Ayuda Porfavor


David M.

Saludos a todos y de antemano se agradece su ayuda

11
Plugins para ThunderCache 3.1.2 / log plugin axeso5 _ firecold
« : octubre 29, 2013, 02:13:35 pm »


este es el log amigo firecold
https://mega.co.nz/#!NU5llSzZ!ehsBAgvmQhBW483Bok--Y2bou55ngvz5DrOtx-dcHW4

para asì concluir con este plugin que a dado mucho problema


Saludos



David_domh

12
Plugins para ThunderCache 3.1.2 / Mis plugins a postear
« : octubre 28, 2013, 12:25:00 pm »

13
Plugins para ThunderCache 3.1.2 / Maple Story : Nexon - Plugin
« : octubre 25, 2013, 09:15:21 pm »
Ni bien termina el testeo lo estarè posteando este plugin que me lo pideron



David M

Saludos

14
Plugins para ThunderCache 3.1.2 / Combat Arms Plugin
« : octubre 25, 2013, 07:46:58 pm »
Código:
  1. #include <cstring>
  2. #include <string>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. using namespace std;
  7.      
  8.     // g++ -I. -fPIC -shared -g -o nexoneu.com.so nexoneu.com.cpp
  9.     // regex
  10.     // http.*\.nexoneu\.com.*(\.jpg|\.png|\.gif|\.mp3|\.swf|\.jpeg|\.mp4|\.exe|\.rar|\.zip|\.flv|\.rez)
  11.    
  12.     string dominiotxt="Combat-Arms";
  13.     string get_filename(string url) {
  14.       vector<string> resultado;
  15.                 if (url.find("?") != string::npos) {
  16.                         stringexplode(url, "?", &resultado);
  17.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  18.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  19.                 } else {
  20.                         stringexplode(url, "/", &resultado);
  21.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  22.                 }
  23.     }
  24.      
  25.     extern "C" resposta getmatch(const string url) {
  26.         resposta r;
  27.  
  28.  
  29.     if ( (url.find("/Game/") != string::npos)
  30.        ) {
  31.     dominiotxt="Combat-Arms/Updates";
  32.     }              
  33.     if ( (url.find(".nexoneu.com/") != string::npos) and
  34.      ((url.find(".jpg")!= string::npos) or
  35.      (url.find(".png") != string::npos) or
  36.      (url.find(".gif") != string::npos) or
  37.      (url.find(".mp3") != string::npos) or
  38.      (url.find(".swf") != string::npos) or
  39.      (url.find(".jpeg") != string::npos) or
  40.      (url.find(".mp4") != string::npos) or
  41.      (url.find(".exe") != string::npos) or
  42.      (url.find(".rar") != string::npos) or
  43.      (url.find(".zip") != string::npos) or
  44.      (url.find(".flv") != string::npos) or
  45.      (url.find(".rez")!= string::npos))  
  46.        ) {
  47.                    
  48.                 r.file = get_filename(url);
  49.                     if (!r.file.empty()) {
  50.                             r.match = true;
  51.                              r.domain = dominiotxt;
  52.                     } else {
  53.                             r.match = false;
  54.                     }
  55.             } else {
  56.                     r.match = false;
  57.             }
  58.             return r;
  59.     }
  60.  

Me pidieron este plugin ya esta testeado y funcionando full perfectamente


David M.


Saludos a todos
y a seguir aportando plugins

15
Plugins para ThunderCache 3.1.2 / Plugin corregido de Nvidia drivers
« : octubre 25, 2013, 04:56:53 pm »
Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <string>
  4. #include <vector>
  5. #include "../utils.cpp"
  6.  
  7. using namespace std;
  8.      
  9.     // g++ -I. -fPIC -shared -g -o nvidia.com.so nvidia.com.cpp
  10.     // regex
  11.     // http.*\.nvidia\.com.*(\.jpg|\.png|\.gif|\.mp3|\.swf|\.jpeg|\.mp4|\.exe|\.rar|\.zip)
  12.  
  13.  
  14. bool in_array(const string &needle, const vector< string > &haystack) {
  15.     int max = haystack.size();
  16.  
  17.     if (max == 0) return false;
  18.  
  19. for (int iii = 0; iii < max; iii++) {
  20.         if (regex_match(haystack[iii], needle) != "") {
  21.             return true;
  22. }
  23. }
  24.     return false;
  25. }
  26.      
  27.     string get_filename(string url) {
  28.       vector<string> resultado;
  29.                 if (url.find("?") != string::npos) {
  30.                         stringexplode(url, "?", &resultado);
  31.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  32.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  33.                 } else {
  34.                         stringexplode(url, "/", &resultado);
  35.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  36.                 }
  37.     }
  38.      
  39.     extern "C" resposta getmatch(const string url) {
  40.         resposta r;
  41.  
  42. vector<string> black_list;
  43. black_list.push_back ("confirmation.php");
  44.  
  45.             if ((url.find(".nvidia.com/") != string::npos) and (in_array(url, black_list) == false)        
  46.             ){
  47.                    
  48.                 r.file = get_filename(url);
  49.                     if (!r.file.empty()) {
  50.                             r.match = true;
  51.                             r.domain = "Nvidia";
  52.                     } else {
  53.                             r.match = false;
  54.                     }
  55.             } else {
  56.                     r.match = false;
  57.             }
  58.             return r;
  59.     }

Me percate que habìa un error en este plugin ya està corregido el bug


Saludos


David M.

A seguir aportando plugins .....................

16
Plugins para RaptorCache / Ayuda con Base de Datos Y Webpanel
« : octubre 23, 2013, 10:12:05 am »
el amigo firecold desea estos archivos porfas màndenselo ya que yo sigo trabajando con thunder y no con raptor
 

report.php, repext.php, repdate.php, repdreq.php, reptot.php

fast

Saludos


David M.

17
Plugins para ThunderCache 3.1.2 / Mas plugins
« : octubre 19, 2013, 01:17:59 pm »
Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o aclst.com.so aclst.com.cpp
  8. // regex
  9. // http.*\.aclst\.com.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".aclst.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "youtube-mp3.org";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;
  41. }


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o apple.com.so apple.com.cpp
  8. // regex
  9. // http.*\.apple\.com.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3|\.exe)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".apple.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "itunes/apple.com";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;  
  39.    }
  40.    return r;  
  41. }

Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o bearshare.com.so bearshare.com.cpp
  8. // regex
  9. // http.*\.bearshare\.com.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3|\.exe)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".bearshare.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "bearshare.com/Music-Mp3";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;  
  39.    }
  40.    return r;  
  41. }

Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o force-download.com.so force-download.com.cpp
  8. // regex
  9. // http.*\.force-download\.com.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".force-download.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);  
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "force-download.com";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;  
  41. }


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o freemake.com.so freemake.com.cpp
  8. // regex
  9. // http.*\.freemake\.com.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".freemake.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "freemake.com";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;  
  41. }


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o horizondatasys.com.so horizondatasys.com.cpp
  8. // regex
  9. // http.*\.horizondatasys\.com.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3|\.exe)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".horizondatasys.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "horizondatasys.com";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;      
  39.    }
  40.    return r;  
  41. }


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o livefilestore.com.so livefilestore.com.cpp
  8. // regex
  9. // http.*\.livefilestore\.com.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".livefilestore.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "mp3xd.com";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;  
  41. }

Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o mp3jam.org.so mp3jam.org.cpp
  8. // regex
  9. // http.*\.mp3jam\.com.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3|\.exe)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".mp3jam.org/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "mp3jam.org";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;  
  41. }


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o mp3rocket.me.so mp3rocket.me.cpp
  8. // regex
  9. // http.*\.mp3rocket\.me.*(\.swf|\.jpg|\.png|\.gif|\.rar|\.zip|\.mp4|\.mp3|\.exe)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".mp3rocket.me/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "mp3rocket.me/Music-Mp3";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;  
  39.    }
  40.    return r;  
  41. }

Saludos a toda la gente


18
Plugins para ThunderCache 3.1.2 / Plugin Corregido de uefa.com
« : octubre 18, 2013, 08:37:07 pm »
aca si hace full cache todos los videos de esta pagina muy visitada por mi

Código:
  1.  #include <iostream>
  2.     #include <cstring>
  3.     #include <vector>
  4.     #include "../utils.cpp"
  5.      
  6.     // g++ -I. -fPIC -shared -g -o uefa.com.so uefa.com.cpp
  7.     // regex
  8.     // http.*\.uefa\.com.*(\.jpg|\.png|\.gif|\.mp3|\.swf|\.flv|\.exe|\.rar|\.zip|\.wav|\.mp4|\.m4v|\.x-m4v)
  9.      
  10.     string get_filename(string url) {
  11.                     vector<string> resultado;
  12.                     if (url.find("?") != string::npos) {
  13.                             stringexplode(url, "?", &resultado);
  14.                             stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  15.                             return resultado.at(resultado.size()-1);          
  16.                     } else {
  17.                             stringexplode(url, "/", &resultado);
  18.                             return resultado.at(resultado.size()-1);
  19.                     }
  20.     }
  21.      
  22.     extern "C" resposta getmatch(const string url) {
  23.         resposta r;
  24.      
  25.             if ( (url.find(".uefa.com/") != string::npos) and
  26.             ( (url.find(".jpg") != string::npos) or
  27.             (url.find(".png") != string::npos) or
  28.             (url.find(".gif")!= string::npos) or
  29.             (url.find(".mp3")!= string::npos) or
  30.             (url.find(".swf")!= string::npos) or
  31.             (url.find(".flv")!= string::npos) or
  32.             (url.find(".exe")!= string::npos) or
  33.             (url.find(".rar")!= string::npos) or
  34.             (url.find(".zip")!= string::npos) or
  35.             (url.find(".wav")!= string::npos) or
  36.             (url.find(".mp4")!= string::npos) or
  37.             (url.find(".m4v")!= string::npos) or
  38.             (url.find(".x-m4v")!= string::npos))
  39.             ){
  40.                    
  41.                 r.file = get_filename(url);
  42.                     if (!r.file.empty()) {
  43.                             r.match = true;
  44.                             r.domain = "Uefa-Videos";
  45.                     } else {
  46.                             r.match = false;
  47.                     }
  48.             } else {
  49.                     r.match = false;
  50.             }
  51.             return r;
  52.     }


David M.

19
Todo lo referente a autocad y sus herramientas

Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o autodesk.com.so autodesk.com.cpp
  8. // regex
  9. // http.*\.autodesk\.com.*(\.swf|\.jpg|\.png|\.gif|\.exe|\.rar|\.zip|\.mp4|\.mp3)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".autodesk.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "Autodesk.com";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;
  41. }

Todo lo referente corel draw programa de diseño grafico y utilitarios
Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o corel.com.so corel.com.cpp
  8. // regex
  9. // http.*\.corel\.com.*(\.swf|\.jpg|\.png|\.gif|\.exe|\.rar|\.zip|\.mp4|\.mp3)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".corel.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "Corel_Draw";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;
  41. }

Estos dos plugins hacen cache a los que personalmente considero el mejor lugar para conseguir toda clase de drivers


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o helpdrivers.com.so helpdrivers.com.cpp
  8. // regex
  9. // http.*\.helpdrivers\.com.*(\.swf|\.jpg|\.png|\.gif|\.exe|\.rar|\.zip)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".helpdrivers.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "Helpdrivers.com/Descargas";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;
  41. }


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o solodrivers.com.so solodrivers.com.cpp
  8. // regex
  9. // http.*\.solodrivers\.com.*(\.swf|\.jpg|\.png|\.gif|\.exe|\.rar|\.zip)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".solodrivers.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "solodrivers.com/Descargas";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;
  41. }


Servidores que alojan sus videos : peru.com  /  comercio.pe

Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o peru.com.so peru.com.cpp
  8. // regex
  9. // http.*\.peru\.com.*(\.flv|\.mp4|\.x-flv|\.swf)
  10.  
  11. string get_filename(string url) {
  12.         vector<string> resultado;
  13.         if (url.find("?") != string::npos) {
  14.             stringexplode(url, "?", &resultado);
  15.             stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  16.             return resultado.at(resultado.size()-4) + "_" + resultado.at(resultado.size()-3) + "_" + resultado.at(resultado.size()-2) + "_" +resultado.at(resultado.size()-1);          
  17.         } else {
  18.             stringexplode(url, "/", &resultado);
  19.             return resultado.at(resultado.size()-4) + "_" + resultado.at(resultado.size()-3) + "_" + resultado.at(resultado.size()-2) + "_" +resultado.at(resultado.size()-1); ;
  20.         }
  21. }
  22.  
  23. extern "C" resposta getmatch(const string url) {
  24.     resposta r;  
  25.  
  26. if ( (url.find(".peru.com/") != string::npos)
  27.    ) {
  28.      
  29.        r.file = get_filename(url);
  30.       if (!r.file.empty()) {
  31.          r.match = true;        
  32.          r.domain = "Peru.com-Videos";
  33.       } else {
  34.          r.match = false;
  35.       }
  36.    } else {
  37.       r.match = false;
  38.    }
  39.    return r;
  40. }
  41.  


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o sambatech.com.br.so sambatech.com.br.cpp
  8. // regex
  9. // http.*\.sambatech\.com\.br.*(\.flv|\.mp4|\.x-flv|\.swf)
  10.  
  11. string get_filename(string url) {
  12.         vector<string> resultado;
  13.         if (url.find("?") != string::npos) {
  14.             stringexplode(url, "?", &resultado);
  15.             stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  16.             return resultado.at(resultado.size()-4) + "_" + resultado.at(resultado.size()-3) + "_" + resultado.at(resultado.size()-2) + "_" +resultado.at(resultado.size()-1);          
  17.         } else {
  18.             stringexplode(url, "/", &resultado);
  19.             return resultado.at(resultado.size()-4) + "_" + resultado.at(resultado.size()-3) + "_" + resultado.at(resultado.size()-2) + "_" +resultado.at(resultado.size()-1); ;
  20.         }
  21. }
  22.  
  23. extern "C" resposta getmatch(const string url) {
  24.     resposta r;  
  25.  
  26. if ( (url.find(".sambatech.com.br/") != string::npos)
  27.    ) {
  28.      
  29.        r.file = get_filename(url);
  30.       if (!r.file.empty()) {
  31.          r.match = true;        
  32.          r.domain = "Comercio.pe/peru.com-Videos2";
  33.       } else {
  34.          r.match = false;
  35.       }
  36.    } else {
  37.       r.match = false;
  38.    }
  39.    return r;
  40. }
  41.  

Esta pagina muy conocida por alojar videos y .gif graciosos y peculiares muy utilizada ùltimamente


Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o tumblr.com.so tumblr.com.cpp
  8. // regex
  9. // http.*\.tumblr\.com.*(\.swf|\.jpg|\.png|\.gif|\.exe|\.rar|\.zip|\.flv)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".tumblr.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "tumblr.com";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;
  41. }


Web de descargas de .mp3

Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. // use this line to compile
  7. // g++ -I. -fPIC -shared -g -o mp3buscador.com.so mp3buscador.com.cpp
  8. // regex
  9. // http.*\.mp3buscador\.com.*(\.swf|\.jpg|\.png|\.gif|\.exe|\.rar|\.zip|\.mp4|\.mp3)
  10.  
  11.  
  12. string get_filename(string url) {
  13.       vector<string> resultado;
  14.                 if (url.find("?") != string::npos) {
  15.                         stringexplode(url, "?", &resultado);
  16.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);          
  18.                 } else {
  19.                         stringexplode(url, "/", &resultado);
  20.                         return resultado.at(resultado.size()-3)+"_"+resultado.at(resultado.size()-2)+"_"+resultado.at(resultado.size()-1);
  21.                 }
  22.     }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.     resposta r;  
  26.  
  27. if ( (url.find(".mp3buscador.com/") != string::npos)
  28.    ) {
  29.      
  30.        r.file = get_filename(url);
  31.       if (!r.file.empty()) {
  32.          r.match = true;        
  33.          r.domain = "mp3buscador.com";
  34.       } else {
  35.          r.match = false;
  36.       }
  37.    } else {
  38.       r.match = false;
  39.    }
  40.    return r;
  41. }

Saludos

David M.

20
alguien me puede pasar porfavor los .cpp de estos dos plugin?

lo que pasa es que he notado que hay varias paginas que alojan videos en este servidor
como lo son los videos de foxsportsla y espn
deseo esos .cpp para poder añadir al plugin y pueda hacer cache a los videos de dichas paginas


de antemano se agradece su ayuda


David M.

Saludos

Páginas: 1 2 3 4