Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Temas - robertjs

Páginas: 1
1
Otros / HandyCache Repack 2015 update 1
« : Marzo 04, 2015, 03:25:46 pm »
Hola a todos, como les prometi por aqui les traigo el HC el cual lo titule "Repack 2015", porque lo puse ese nombre, por la simple razon ...
De que use el HC cache que public nuesto amigo "JVProducciones".. y solo agrege algunas extenciones y reglas, aparte de eso que reordene un poco y borre lo que no se utilizaba.

Hay aun cosas por pulir y optimizar mas, pero ya les comparto lo que tengo,
Version HC 1.0.0.551 (El que ya usamos)

Dejare una guia de instalacion de nuestro amigo "JVProducciones"

Cita
Instalación de HandyCache paralelo a Mikrotik

Después de hacer diversas pruebas y viendo los resultados brindados por este simple pero eficiente programa les comparto esta información recopilada de varios foros y paginas en otros idiomas (ruso y indonesio)

Detallo algunas de las funciones:

1.- Descargamos los videos de youtube en el formato flv o mp4 (como era anteriormente) puedes pausar y el video seguirá descargando.
2.- El video no cambiará automáticamente de resolución si esta en 360p al maximizar seguirá siendo 360p y un único archivo (actualmente cambia de múltiples resoluciones empeorando así el cacheo de partes)
3.- Se puede hacer que el video siempre cargue en 240p al maximizar seguirá siendo 240p (para isp que ofrecen velocidades inferiores a 1 mega al cliente, esto es excelente)
4.- bloqueo de publicidad y redireccionamientos  (implementación de reglas de bloqueo y redirección sin hacer que la red se torne lenta como pasa con el webproxy de mikrotik)
5.- Cache a https con instalación de certificados (instalando certificados a cada unos de los clientes se podría hacer cache a https Youtube, facebook y otros)
6.- manejo de extensiones escritos en código Lua q aumenta grandemente su capacidad
7.- lista Blanca para sitios donde no se quiere que pase por handycache o alguna de sus funciones

Reglas utilizadas:
Regla N° 1
Redireccionamiento:
Código:
  1. /ip firewall nat
  2. add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=\
  3.     ! 192.168.10.2 dst-port=80,8080,8888,8880,8777,3477 in-interface="LAN" protocol=tcp \
  4.     to-addresses=192.168.10.2 to-ports=8080
Muchos me preguntan si es posible redireccionar el puerto 443 (https), hasta el momento no se ha podido hacer ni creo que se pueda. si lo que quieren es usar https en los clientes se tendrá que hacer la redireccion de manera manual en cada uno de los clientes agregando ip del proxy y el puerto a usar..

Regla N° 2
Marcado de paquetes:
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=HandyCache content=\
  3.     "Server: HandyCache" new-connection-mark=handy-connection protocol=tcp \
  4.     src-address=192.168.10.2
  5. add action=mark-packet chain=postrouting connection-mark=handy-connection \
  6.     new-packet-mark=handy-packs

Regla N° 3
y ahora el Fulcache:
Version 6.x
Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" limit-at=15M/15M max-limit=5M/5M name=\
  3.     HandyCache packet-marks=handy-packs priority=6/6 queue=default/default \
  4.     target=""

Regla N° 3.1
Version 5.x (aun no lo e probado)
Código:
  1. /queue tree
  2. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  3.     max-limit=5M name=HandyCache packet-mark=handy-packs parent=\
  4.     global-out priority=4 queue=default

Opcional: Recomendado


Una regla que uso
La verdad que para mi dejar una regla general para fullcache no me llama mucho la atención así que utilizo una pequeña variante que hace que cada uno de mis clientes tenga 5 megas de fullcache y limito a 10 megas como máximo de salida general de la cache, les dejo una imagen para que se guíen mejor:
Se los recomiendo

Código:
  1. /queue type
  2. add kind=pcq name=UserHC pcq-classifier=dst-address pcq-dst-address6-mask=64 \
  3.     pcq-rate=5M pcq-src-address6-mask=64
  4.  
Si usan esta regla opcional entonces no usen la regla N° 3 usen la siguiente regla.. que solo es la mikrotik Ver. 6.xxx

Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" max-limit=15M/15M name=HandyCache \
  3.     packet-marks=handy-packs priority=6/6 queue=default/UserHC
  4.  

Video de instalacion:
Pendiente... Cargando....









Link de descarga: -----> HandyCache Repack 2015

Update 1
-----> Update 1 / 11-03-2015
Cita
Mejoras:
+ Se agrego una mejora en el UserAgente "manipulacion de user egent de usuario para youtube y google". [El anterior user agente esta desactivado/no fue borrado]
+ Ahora youtube guarda los videos en partes, y incluso si cambias de resolucion, y esa parte guardada en el cache automaticamente carga del cache.
+ Se agrego una nueva extension donde algunas reglas no guardan archivos de algunas paginas dinamicas "Esta en modo fase prueba - pendiente para mejorar y optimizar mejor las reglas".

Cita
Pendientes:
* Aun no se pudo mantener la resolucion.
* Optimizar el cache de antivirus avast.
* HTML5 El firefox pendiente, aun no guarda en cache.

Cita
Recomendaciones:
- No olviden siempre hacer un back del HC anterior que tengan, o renombrar para hacer las pruebas necesarias con el nuevo.
- Si fuera posible hagan uso de la herramienta "HandyCache Cache Cleaner" que esta en la carpeta HC, para limpiar arechivos ya pasados, no utilizables.



Agradecimientos:
Especiales por dejarnos publicar.
* Joemg6     --> Dueño del foro
* Moderadores           --> pongo moderadores porque no se cuanto hay :)

* JVProducciones
* HandyCache
*  Komunitas
*
* Otros que ya apareceran :)

EDITADO: Por Firecold



2
RaptorCache en General / Plugin Youtube? Solucionado?
« : Junio 14, 2014, 05:39:13 pm »
Hola como estan, despues de tiempo por aqui...


Bueno mi consulta es la siguiente...
Alguien ya pudo armas un plugins de Youtube y googlevideo?

Haber si es asi, seria tan amable de compartirme los plugins necesarios para el chacheo de youtube..!!

Se los agradeceria mucho... porque tal ves nuestro amigo Joe se demore mas de lo esperado o no lo se,

Eh trato de adaptar el plugins de thunder que mejoraron dicen y que anda bien, el tal forkThunder o algo asi...
la cosa que pude complilar los cpp, pero no me funcionan.. tal ves no lo hice la manera correcta :c
porque las paginas em dejan en blanco :C

Espero sus respuestas

3
Hola a todos.. bueno estaba haciendo pruebas de un pluging nuevos.. y me di cuenta que el squid3 me da todo solo puro MISS

aqui unas imagenes y la configuracion .. uso squid3 TOS12



Haber quien me ayuda.. en la configuracion correcta del TOS12

4
Plugins de juegos / Ayuda a crear pluging de Legend Online
« : Mayo 19, 2014, 07:04:13 pm »
Hola a todos.. como dice el titulo quiero que me ayuden a hacer un pluging de esta pagina de juego online via Flash .. o algo asi es creo yo..

esta es la web Legend Online

E tratado de hacerlo con el programita que publicaron.. puse el link oasgames.com

pero revisando con el chrome ..

salen estas direciones con oasgames.com:8080  Ejemplos de algunas capturas..

http://res72sqsa.oasgames.com:8080/sounds/BGM102506.flv
http://res72sqsa.oasgames.com:8080/images/mapName/1131.png?lv=c4da9d2fabf061bd8a906532cbf850db&
http://res72sqsa.oasgames.com:8080/images/head/19.swf?lv=076f8daf50d13b8449c591f51b2f835d&

y asi sucesivamente.. todo...

haber un buen samaritano que me ayude.. Gracias..!!!




5
Hola como dice el titulo.. quiero hacer que la pagina movistar no pase por raptor..
haber si alguien me ayuda con una regla en espesifica.. para que esa pagina u otras no pases por raptor..

6
Hola.
como dice el titulo.. quiero instalar este sistema en el servidor debian..

MikroWISP Manager

Queria saber si instalando de la forma en que ellos explican afectaria algo al raptor o al panel de control..

esper sus opiniones..

lo quiero instalar para llevar un mejor control en mi hotspot ..

saludos.

7
Hola.. navegando y buscando informacion sobre como hacer fullcache a las paginas https:

Me logre encontrar esto.. que decian que seria posible hacerlo mediante squid3 ..

haber si algun experto revise y nos ayude :)

configure HTTPS support in squid3 debian

Saludos a todos...

8
Hola.. a toda la comunidad-- haber si me pueden ayudar con este plugin ..
Aqi estan jugando el juego plantas vs zombies aventure..

aqui les dejo el link del juego..

Plantas Vs Zombies

Espero me ayuden.. gracias de ante mano

9
Hola a todos .. tengo un problema.. el plugin socialpointgames.com no me hace nada .. o mejor dicho raptor no hace nada..

el plugin que uso es este

Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.cpp"
  5.  
  6. using namespace std;
  7.  
  8. // regex
  9. // http.*\.socialpointgames\.com.*(\.jpg|\.png|\.swf|\.mp3)
  10. // use this line to compile
  11. // g++ -I. -fPIC -shared -g -o socialpointgames.com.so socialpointgames.com.cpp
  12.  
  13. string dominiotxt="socialpg";
  14. string get_filename(string url) {
  15.                 vector<string> resultado;
  16.                 if (url.find("?") != string::npos) {
  17.                         stringexplode(url, "?", &resultado);
  18.                         stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  19.                         return resultado.at(resultado.size()-1);          
  20.                 } else {
  21.                         stringexplode(url, "/", &resultado);
  22.                         return resultado.at(resultado.size()-1);
  23.                 }
  24. }
  25.  
  26. extern "C" resposta getmatch(const string url) {
  27.     resposta r;
  28.  
  29.     if ( (url.find("/dragoncity/") != string::npos)
  30.        ) {
  31.     dominiotxt="socialpg/dragoncity";
  32.     }
  33.     if ( (url.find("/socialwars/") != string::npos)
  34.        ) {
  35.     dominiotxt="socialpg/socialwars";
  36.     }
  37.     if ( (url.find("/socialempires/") != string::npos)
  38.        ) {
  39.     dominiotxt="socialpg/socialempires";
  40.     }
  41.     if ( (url.find(".socialpointgames.com/") != string::npos) and
  42.    ((url.find(".jpg")!= string::npos) or
  43.    (url.find(".png")!= string::npos) or
  44.    (url.find(".mp3")!= string::npos) or
  45.    (url.find(".swf")!= string::npos))
  46.        ) {
  47.  
  48.            r.file = get_filename(url);
  49.                 if (!r.file.empty()) {
  50.                         r.match = true;
  51.                        r.domain = dominiotxt;
  52.                 } else {
  53.                         r.match = false;
  54.                 }
  55.         } else {
  56.                 r.match = false;
  57.         }
  58.         return r;
  59. }

no se si esta bien o esta mal.. porque no trabaja nada ni me almacena.. en dominios no se muestra nada

a alguien le sucede lo mismo?

10
Firewall & NAT / [Ayuda] Acceder a accespoint de un ether2 a ether3
« : Agosto 12, 2013, 11:47:49 am »
Hola hola a todos.. bueno ase tiempo tengo un dilema .. e buscado e leido y asta el momento no e logrado acceder a mi accespoint remotamente se podria decir..

tengo mi mikrotik rb750gl y lo que kiero es ingresar a mi accespoint que lo tengo en hotspot.

trabajo con pppoe .. mi conexiones estan asi..

ether1= wan
ether2= lan
ether3= hotspot
ether4 raptorcache.

la cosa es como hagoa para ingresar a mi accespoint del erther2 al ether3

lei sobre amarres de mac ip bling de nat y cosas asi.. pero me enriedo :) haber si me tiene paciencia y me puede ayudar

el ip de mi accespoint es 192.168.1.200

el ip de mi lan es 192.168.15.1
el ip de hotspot 192.168.25.1

.. espero me aya podido explicar y me ayuden ..!! gracias.

11
Plugins de Antivirus / [Aporte] Plugin de kaspersky
« : Agosto 12, 2013, 11:12:34 am »
Hola a todos, aqi les traigo el plugin funcional del kaspersky antivirus. espero les sea de mucha utilidad para algunos.

PD: Aun no se como poner los codigos de forma correcta pero lo pondre en en Quote.



Código:
  1. #include <iostream>
  2. #include <cstring>
  3. #include <vector>
  4. #include "../utils.h"
  5. #include "../utils.cpp"
  6.  
  7. // use this line to compile
  8. // g++ -I. -fPIC -shared -g -o kaspersky.com.so kaspersky.com.cpp
  9. // Regex
  10. // http.*\.kaspersky\.com.*(\.bz2|\.avc|\.kdc|\.dat|\.kd1|\.klz|\.exe|\.kfb|\.dif|\.kdz|\.diffs)
  11.  
  12. string get_filename(string url) {
  13.  vector<string> resultado;
  14.  if (url.find("?") != string::npos) {
  15.  stringexplode(url, "?", &resultado);
  16.  stringexplode(resultado.at(resultado.size()-2), "/", &resultado);
  17.  return resultado.at(resultado.size()-1);          
  18.  } else {
  19.  stringexplode(url, "/", &resultado);
  20.  return resultado.at(resultado.size()-1);
  21.  }
  22. }
  23.  
  24. extern "C" resposta getmatch(const string url) {
  25.  resposta r;
  26.  
  27.  if ( (url.find(".bz2") != string::npos) or (url.find("/diffs/") != string::npos) or (url.find(".avc") != string::npos) or
  28.  (url.find(".kdc") != string::npos) or (url.find(".klz") != string::npos) or (url.find(".dif") != string::npos) or
  29.  (url.find(".dat") != string::npos) or (url.find(".exe") != string::npos) or (url.find(".kdz") != string::npos) or
  30.  (url.find(".kdl") != string::npos) or (url.find(".kfb") != string::npos)
  31.  ) {
  32.  
  33.     r.file = get_filename(url);
  34.  if (!r.file.empty()) {
  35.  r.match = true;
  36.  r.domain = "kaspersky";
  37.  } else {
  38.  r.match = false;
  39.  }
  40.  } else {
  41.  r.match = false;
  42.  }
  43.  
  44.  return r;
  45. }


Aqui un video de muestra de que funciona.


Bueno eso seria todo. espero les sirva.

PD: Conforme aprenda mas y encuentres mas cosas de utilidad y no esten aqi compartire. saludos

12
Plugins para RaptorCache / [Aporte] Video Guia de como subir plugins
« : Agosto 03, 2013, 01:45:13 pm »
Hola a todos comparto este video para todos aquellos que no saben agregar plugin.
El vídeo no puedo tener un nivel de excelencia.. pero aunque sea tiene la opción de guiar a aquellos que no son nuevo y quieran aprender a agregar plugin.!

Disculpen por no explicar mejor y las ortografías. es que como podrán ver lo hice rápido xD.!!


13
Plugins de Antivirus / Ayuda con plunigs de Karpesky
« : Agosto 02, 2013, 12:52:18 pm »
hola .. como dice el titulo me podrian ayudar a hacer un plunigs de el antvirus karpesky

por defaul el raptor viene con el plunigs de avats y me parece bien.. pero kisiera el karpesky ya que tambien algunas Pcs trabajo con tal antivirus.. gracias por su ayuda..

Páginas: 1