Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Temas - leandro1979

Páginas: 1
1
Instalación y Configuración RaptorCache / raptor https
« : Septiembre 30, 2016, 11:22:37 am »
Buenos dias

mi consulta es la siguiente ejemplo le tengo un router de cliente con al ip 192.168.1.2
cual es el procedimiento ya que por ejemplo le pongo el certificadi a mi pc interna
y agrego al raptor la ip 192.168.1.2 de mi router para que intercepte el https
en caso que me quiera conectar con una portatil al wifi o telefonos o venga un amigo con su portatil
que ocurre ahi
debo instalar a cada pc telefono y portatil que se conecte a mi router el certificado
o el raptor detecta el certofocado por conexion ejemplo pc que no tenga el certificado va direcyo a internet y pc que tenga el certificado va al raptor
como manejan esto ya que si tengo que instalar a todos los pc celulares portatiles y tables que tenga atraz de un router no creo que sea possible ni factible ni una solucion ya que seria algo imposible de manejar

si tengo que instalar certificado avtodo sino no navegaran los que se conectan a un wifi no tiene sentido ya que eso hace cualquier proxy
porfavor espero su respuesta sobre este tema
Modificar mensaje

2
RaptorCache en General / Problemas Archivo Serv
« : Junio 07, 2013, 10:01:21 pm »
Buenas noches

tengo el siguiente problema instalo raptor para debian 7 y raptor para ubuntu
por mas que el archivo SERV que es el que limpia la ram se encuantra en /user/bin

el momento que lo corro manualmente dice que no existe

root@ubuntu:~# serv
-bash: /usr/bin/serv: No such file or directory
root@ubuntu:~#

alguna solucion para este problema ya que el cache pasa al 995 la ram siempre

Saludos Cordiales,
Leandro Segovia

3
Discución General / ubuntu y thunder
« : Noviembre 29, 2012, 01:29:56 pm »
Buenas tardes
las instalaciones con ubuntu server fallan
por lo general y me ha pasado al rededor de 4 veces con el miso servidor
problema numero 1
no encuentra las librerias para que thunder corra

libmysqlclient.so.16
libmysqlclient.so.16.0.0

numero 2 no crea la carpeta /var/run/thunder

donde se almacena el PID

esto ocurre con ubuntu ya que con debian la instalación es limpia y sin problemas

que se debería de hacer en caso para las instalaciones de ubuntu server
ya que ubuntu es mas estable y fiable que debian al utilizar squid

otra falla es que he tratado de crear la carpeta /var/run/thunder
infinidad de veces pero no el momento de reiniciar ya no esta por ende el thunder.pid no puede ser creado

si alguien ya depuro estos inconvenientes seria bueno que lo publique para que arreglen el script o crear 2 script diferentes

saludos
leandro

4
Squid 2.7 & Squid 3.x / compilacion y configuracion squid3 tproxy
« : Noviembre 14, 2012, 10:03:27 am »
Buenos días adjunto mi compilación personalizada de squid3

en caso que alguien tenga una mejor configuracion o compilacion por favor postearla
Una vez instalado el script de joemg seguir los siguientes pasos:´

#apt-get remove squid3
#apt-get purge squid3
#aptitude install build-essential libcap2-dev libltdl-dev ebtables bridge-utils
#cd /usr/src
#apt-get build-dep squid3

#wget -c http://www.squid-cache.org/Versions/v3/3.1/squid-3.1.21.tar.bz2
#tar xvfj squid-3.1.21.tar.bz2
#cd squid-3.1.21
#ulimit -HSn 819200
#ulimit -HSd unlimited

./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=/usr/include --infodir=/usr/share/info --localstatedir=/var --libexecdir=/usr/lib/squid3 --disable-maintainer-mode --disable-dependency-tracking --disable-silent-rules --srcdir=. --datadir=/usr/share/squid3 --sysconfdir=/etc/squid3 --mandir=/usr/share/man --with-cppunit-basedir=/usr --enable-inline --enable-async-io=128 --enable-storeio=ufs,aufs,diskd --enable-removal-policies=lru,heap --enable-useragent-log --enable-referer-log --enable-delay-pools --enable-cache-digests --enable-zph-qos --enable-underscores --enable-icap-client --enable-follow-x-forwarded-for --enable-auth=basic,digest,ntlm,negotiate --enable-basic-auth-helpers=LDAP,MSNT,NCSA,PAM,SASL,SMB,YP,getpwnam,multi-domain-NTLM --enable-digest-auth-helpers=ldap,password --enable-negotiate-auth-helpers=squid_kerb_auth --enable-external-acl-helpers=ip_user,ldap_group,session,unix_group,wbinfo_group --enable-arp-acl --enable-snmp --enable-http-violations --with-filedescriptors=819200 --with-large-files --enable-large-cache-files --with-default-user=proxy --enable-epoll --enable-linux-netfilter

# make
# make install

# mkdir -p /var/spool/squid3
# chown proxy:proxy /var/spool/squid3
# mkdir -p /var/log/squid3
# chown proxy:proxy /var/log/squid3

Copiar el archivo squid adjunto en la carpeta /etc/init.d/
correr el comando
#update-rc.d squid defaults

reemplazar squid.conf en la carpeta /etc/squid3/
reemplazar limits.conf en la carpeta /etc/security/
reemplazar sysctl.conf en la carpeta /etc/

correo
#squid -z

crear un archivo en /root
#nano /root/iptables-TPROXY

Código: [Seleccionar]
# Generated by nDasJoWo
*nat
REROUTING ACCEPT [541:35450]
OSTROUTING ACCEPT [796:56114]
:OUTPUT ACCEPT [795:56050]
COMMIT
# Completed
# Generated by nDasJoWo
*mangle
REROUTING ACCEPT [51:11203]
:INPUT ACCEPT [5711:2016323]
:FORWARD ACCEPT [3:1580]
:OUTPUT ACCEPT [8347:3818817]
OSTROUTING ACCEPT [8350:3820397]IVERT - [0:0]
-A PREROUTING -p tcp -m socket -j DIVERT
-A PREROUTING -p tcp -m tcp --dport 80 -j TPROXY --on-port 3129 --on-ip 0.0.0.0 --tproxy-mark 0x1/0xffffffff
-A DIVERT -j MARK --set-xmark 0x1/0xffffffff
-A DIVERT -j ACCEPT
COMMIT
# Completed

editar rc.local
#nano /etc/rc.local
Código: [Seleccionar]
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
ip rule add fwmark 1 lookup 100
ip route add local 0.0.0.0/0 dev lo table 100
iptables-restore < /root/iptables-TPROXY
exit 0

Reiniciar
#shutdown -r now

verificar si squid esta corriendo sin errores
#squid -d1

una vez realizado esto ingresar a mikrotik y configurar en mangle lo sigueinte

Código: [Seleccionar]
/ip route add dst-address=0.0.0.0/0 gateway=(ip-proxy) routing-mark="VIA_TPROXY"
/ip firewall mangle add chain=prerouting protocol=tcp dst-port=80 in-interface=(ether-clientes) action=mark-routing new-routing-mark=VIA_TPROXY
/ip firewall mangle add chain=prerouting in-interface=(ether-proxy) action=mark-connection new-connection-mark=VIA_TPROXY
/ip firewall add chain=prerouting in-interface=(ether-internet) connection-mark=VIA_TPROXY action=mark-routing new-routing-mark=VIA_TPROXY

esto es para tener tu thundercache 3.1.2 con soporte de tproxy

saludos y espero les sirva, espero comentarios y si hay alguien que sabe hacerlo de otra forma por favor comunicarme

saludos
leandro

PD: Joemg como puedes ver la linea
cache_peer 192.168.10.2 parent 8080 3130 proxy-only no-digest no-tproxy
esta para que no haga tproxy sobre el parent que es thunder
ese es mi inconveniente hace tproxy de todo menos cuando ingresa a thunder al ponerlo sin no-tproxy
el sistema deja de funcionar por ahi debo de hacer algun cambio en la configuracion del parent o en el thunder.conf pero en realidad no se cual sea

saludos
leandro

Páginas: 1