Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - Nessa

Páginas: 1 2
1
Firewall & NAT / Re:Ataque
« : Abril 10, 2016, 09:40:23 am »
Solo cambia el puerto SSH en tu router, y deshabilita el telnet en services sino lo usas, con eso cortas los ataques de raíz, lo que muestra tu log es un ataque de robot por fuerza bruta.

2
Estimados amigos del foro, en estos últimos días se me ha presentado un problema con el raptor cache. De repente deja de funcionar y la navegación se pone bastante lenta en la red mientras esto sucede.

El log de squid3 muestra lo siguiente:

Cita
2014/10/16 09:50:04| Adding nameserver 127.0.0.1 from squid.conf
2014/10/16 09:50:04| Adding nameserver 8.8.8.8 from squid.conf
2014/10/16 09:50:04| Accepting  intercepted HTTP connections at 10.10.0.8:3128, FD 12.
2014/10/16 09:50:04| Accepting  HTTP connections at 10.10.0.8:3129, FD 17.
2014/10/16 09:50:04| HTCP Disabled.
2014/10/16 09:50:04| Configuring Parent 127.0.0.1/8080/0
2014/10/16 09:50:04| Loaded Icons.
2014/10/16 09:50:04| Ready to serve requests.
2014/10/16 10:05:43| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:05:43| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:05:43| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:05:47| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:05:47| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:05:47| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:06:07| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:06:08| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:06:34| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:06:44| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:06:44| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:06:56| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:07:06| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:07:36| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:07:36| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:07:36| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:09:55| Detected DEAD Parent: 127.0.0.1
2014/10/16 10:09:55| Detected REVIVED Parent: 127.0.0.1
2014/10/16 10:09:57| TCP connection to 127.0.0.1/8080 failed
2014/10/16 10:09:59| TCP connection to 127.0.0.1/8080 failed
.
.
.

Así hasta que reinicio el servicio de raptor con el comando service raptor restart. Pasará cerca de una hora hasta que vuelve a fallar nuevamente. Desafortunadamente el log del raptor no muestra ningún mensaje que indique cual es el problema.

He probado borrando toda la cache del raptor, tanto como la base de datos de mysql. Descargue nuevamente la última versión del raptor, pero el problema continua durante los últimos días. He optado por deshabilitarlo hasta encontrar una solución al problema.

3
Discución General / Re:pc se Frizza o se apaga solo
« : Abril 06, 2014, 09:45:55 am »
Sencillo, compra otra memoria y quita la que esta dando problemas.

Tu mismo indicas que al sacarla el problema desaparece, quiere decir que ese módulo no esta bien.

4
RaptorCache en General / Re:error en LIBRERIA
« : Marzo 27, 2014, 09:12:14 am »
Estimados, me uno al reporte del error en las librerías de Mysql.

Les comento mi caso, el fin de semana mi servidor que lo venía trabajando con Ubuntu server 12.04 murió, sencillamente no quería arrancar, lo tuve operativo por casi 2 años sin problemas trabajando, la última actualización la realicé al raptor 1.0.4b con la versión de Debian 6.

En vista del problema decidí cambiar mi servidor a Debian 7, para poder actualizar el raptor a la versión 1.0.5b y contar con los paquetes más actualizados tanto de squid como de Mysql, etc.

He aquí mi reporte, la instalación se realizó sin problemas, y puse a trabajar nuevamente mi servidor, pero a la hora de trabajo el internet se puse realmente lento. Revisando los logs me encuentro con lo siguiente:
Cita
Mar 23 18:01:18 proxy kernel: [  316.978620] raptor[14035]: segfault at 100000000 ip 00007f4bbb5f8883 sp 00007fff65326d90 error 4 in libmysqlclient.so.18.0.0[7f4bbb5a5000+2bf000]

En squid:
Cita
2014/03/23 18:01:20| Detected DEAD Parent: 127.0.0.1
2014/03/23 18:01:20| TCP connection to 127.0.0.1/8080 failed
2014/03/23 18:01:20| TCP connection to 127.0.0.1/8080 failed
2014/03/23 18:01:20| Detected REVIVED Parent: 127.0.0.1
2014/03/23 18:01:21| TCP connection to 127.0.0.1/8080 failed
2014/03/23 18:01:21| TCP connection to 127.0.0.1/8080 failed

Pero el log del raptor:

Cita
tail -f /var/log/raptor/error.log

En blanco.

Como con Ubuntu server, y la versión 1.0.4b no me daba problemas, decidí instalar nuevamente esa versión para realizar las pruebas, pero he aquí los resultados:

Cita
tail -f /var/log/syslog | grep raptor
Mar 24 18:40:04 proxy kernel: [10760.515374] raptor[553]: segfault at 8 ip 00007feb1515f137 sp 00007fff040b0070 error 4 in libmysqlclient.so.16.0.0[7feb150d2000+1cf000]

Squid:
Cita
2014/03/24 18:41:42| TCP connection to 127.0.0.1/8080 failed
2014/03/24 18:41:42| TCP connection to 127.0.0.1/8080 failed
2014/03/24 18:41:42| Detected DEAD Parent: 127.0.0.1
2014/03/24 18:41:42| TCP connection to 127.0.0.1/8080 failed
2014/03/24 18:41:42| TCP connection to 127.0.0.1/8080 failed
2014/03/24 18:41:42| TCP connection to 127.0.0.1/8080 failed

El log del raptor solo dice lo siguiente:

Cita
tail -f /var/log/raptor/sys.log
24/03/2014 21:32:01 Starting Raptor Process ID: 23885
24/03/2014 04:00:36 Starting Raptor Process ID: 3196
25/03/2014 05:14:01 Starting Raptor Process ID: 12406
25/03/2014 07:58:01 Starting Raptor Process ID: 19952
25/03/2014 09:26:01 Starting Raptor Process ID: 7385

La única diferencia entre las 2 vesiones, es que con la 1.0.4 se demora más tiempo en aparecer el problema, toma como alrededor de 4 horas aproximadamente, mientras que con la 1.0.5 aparece casi a los 20 minutos.

El internet se pone muy lento, y la gente empieza a quejarse.

5
Actualizaciones / Re:[Update] RaptorCache 1.0.5b
« : Enero 04, 2014, 03:37:08 pm »
Disculpen, pero saldrá la actualización para los que usamos Debian 6 de 64bits?

6
Actualizaciones / Re:[Update] RaptorCache 1.0.5b
« : Enero 03, 2014, 09:27:33 am »
RaptorCache 1.0.5b

- Actualización para los nuevos request de YouTube
- Adicion de URL_LOG


Debian 7 - 64 bits
Código:
  1. wget http://www.raptorcache.com/install/update/bin64/raptor_105b_64_d7.tar.gz
  2. rm -rf /usr/sbin/raptor
  3. mv raptor_105b_64_d7.tar.gz /tmp
  4. tar -xzvf /tmp/raptor_105b_64_d7.tar.gz -C /
  5. chmod a+x /usr/sbin/raptor
  6. /etc/init.d/raptor restart && /etc/init.d/squid3 restart

Si se quiere activar el URL_LOG, se tiene que adicionar en el raptor.conf la siguiente directiva
Código: [Seleccionar]
URL_LOG 1El uso de esta directiva tiene como mayor propósito obtener las url de los videos de YouTube, ya que el access.log del squid como del raptor no muestra la dirección completa. En el caso de tener un problema con los videos se activa la directiva y se tendrá los logs con las direcciones completas de los videos y esto ayudará a tener un mejor reporte.

Funciona con debian 6 de 64 bits?

7
Plugins para RaptorCache / Re:Plugin telconet ecuador
« : Enero 01, 2014, 04:12:46 pm »
Muchas gracias, funciona!

8
Plugins para RaptorCache / Plugin telconet ecuador
« : Diciembre 31, 2013, 01:42:22 pm »
Buenos días amigos del foro.

Por favor me pueden ayudar con el código de speedtest del servidor telconet de Ecuador.

He intentado con el siguiente código, pero no me está funcionando el caché:

Código: [Seleccionar]
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include "../utils.cpp"
 
using namespace std;
 
// use this line to compile
//  g++ -I. -fPIC -shared -g -o speedtest1.telconet.net.so speedtest1.telconet.net.cpp
// Regex
// http.*\.speedtest1\.telconet\.net.*(\.jpg|\.png)
 
string get_filename(string url) {
                vector<string> resultado;
        string retorna = "";
        stringexplode(url, "/", &resultado);
        retorna = resultado.at(resultado.size()-2) + "-"+resultado.at(resultado.size()-1);
        return retorna;
}
 
extern "C" resposta getmatch(const string url) {
        resposta r;       
               
  if ( (url.find("speedtest1.telconet.net//") != string::npos)
     ) {
      r.file = get_filename(url);
      if (!r.file.empty()) {
         r.match = true;
         r.domain = "speedtest1.telconet";       
      } else {
         r.match = false;
      }
   }
   else
   {
      r.match = false;
   }
   return r;
}

Cuando realizo las pruebas el squid me muestra lo siguiente:

Código: [Seleccionar]
1388514789.876     24 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514789.980     23 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514790.107     24 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514790.211     26 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514790.306     21 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514790.396     13 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514790.497     14 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514790.600     13 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514791.625    938 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514791.735     21 192.168.0.10 TCP_MISS/200 376 GET http://speedtest1.telconet.net/speedtest/latency.txt? - HIER_DIRECT/186.101.5.254 text/plain
1388514792.306    520 192.168.0.10 TCP_MISS/200 245747 GET http://speedtest1.telconet.net/speedtest/random350x350.jpg? - HIER_DIRECT/186.101.5.254 image/jpeg
1388514792.389    586 192.168.0.10 TCP_MISS/200 245747 GET http://speedtest1.telconet.net/speedtest/random350x350.jpg? - HIER_DIRECT/186.101.5.254 image/jpeg
1388514799.554   6673 192.168.0.10 TCP_MISS/200 1118373 GET http://speedtest1.telconet.net/speedtest/random750x750.jpg? - HIER_DIRECT/186.101.5.254 image/jpeg
1388514800.803   7941 192.168.0.10 TCP_MISS/200 1118373 GET http://speedtest1.telconet.net/speedtest/random750x750.jpg? - HIER_DIRECT/186.101.5.254 image/jpeg
1388514801.253   8336 192.168.0.10 TCP_MISS/200 1118373 GET http://speedtest1.telconet.net/speedtest/random750x750.jpg? - HIER_DIRECT/186.101.5.254 image/jpeg
1388514801.722   8804 192.168.0.10 TCP_MISS/200 1118373 GET http://speedtest1.telconet.net/speedtest/random750x750.jpg? - HIER_DIRECT/186.101.5.254 image/jpeg
1388514802.260    191 192.168.0.10 TCP_MISS/200 304 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514802.292    198 192.168.0.10 TCP_MISS/200 304 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514802.559    156 192.168.0.10 TCP_MISS/200 304 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514802.858    436 192.168.0.10 TCP_MISS/200 304 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514806.793   2648 192.168.0.10 TCP_MISS/200 305 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514808.114   3942 192.168.0.10 TCP_MISS/200 305 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514809.985   1736 192.168.0.10 TCP_MISS/200 305 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514810.191   1928 192.168.0.10 TCP_MISS/200 305 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514812.233   1850 192.168.0.10 TCP_MISS/200 305 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514812.334   1968 192.168.0.10 TCP_MISS/200 305 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514814.434   1953 192.168.0.10 TCP_MISS/200 305 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html
1388514814.449   1904 192.168.0.10 TCP_MISS/200 305 POST http://speedtest1.telconet.net/speedtest/upload.php? - HIER_DIRECT/186.101.5.254 text/html

Pero no se por que no funciona, use el mismo código con el servidor de la cnt, y con ese si registro HIT de parte del raptor.

Desde ya muchas gracias por su respuesta, y que tengan un feliz año!

9
Squid 2.7 & Squid 3.x / Re:Solucion a Windows Update con Squid
« : Diciembre 03, 2013, 05:19:47 pm »
Debo decir que un compañero implementó esas reglas en su red, y casi la colapsa por completo.

El problema está en que el squid empieza a bajar las actualizaciones de windows, y no para de descargar hasta que no este almacenada en caché, si ponemos un promedio de 100 usuarios, por 10 actualizaciones cada uno, tenemos un número significativo de actualizaciones, todas bajando por completo y a full velocidad en la red.

Cita
Código: [Seleccionar]

range_offset_limit -1
quick_abort_min -1


esto fuerza a descargar las actualizaciones aun cuando el cliente se haya desconectado, como contra si poseemos un ancho de banda limitado lo saturara hasta que haya terminado la descarga. (esto se puede solucionar con un marcado y queue three dando prioridad baja)

La parte que está en negrita es muy muy importante, o tendremos al squid saturando por completo el ancho de banda al descargar las actualizaciones.

10
Excelente aporte!

De pronto has probado si están funcionando bien los plugins de windows update, avast y el del nod32?

11
Si pudieras indicar como instalar en Centos te ganas el cielo Joemg, me encanta ese S.O, para mi es de lo mejor para servidores.

12
Plugins de música & videos / Re:Aporte : Plugin de googlevideo.com
« : Octubre 09, 2013, 10:23:18 pm »
servidor anime id.tv

1.= googlevideo   si hay plugin
2.= videobam      si hay plugin
3.= novamov       si hay plugin
4.= nowvideo      si hay plugin

los demas servidores tratare de crear su respectivo plugin espero que no sean ips publicas

pero hoy dia he seguido haciendo pruebas y todo full cache por aca con el plugin googlevideo


Saludos

David M

Muchas gracias por tus aportes, estoy probando los plugins que has subido a la página y de momento todos funcionan de maravilla.

13
Squid 2.7 & Squid 3.x / Re:Upgrade squid3-3.3.8 Solo Ubuntu
« : Octubre 03, 2013, 07:51:40 pm »
Muchas gracias por compartir tus experiencias. Seguiré de cerca tus avances.

14
Squid 2.7 & Squid 3.x / Re:Actualizar Squid 3.x cualquier versión
« : Septiembre 25, 2013, 10:09:35 pm »




Al final lo deje en 3, como dije todavia en pruebas, aunque claramente hay una mejoria en procesamiento, veremos que pasa en los proximos dias, ya que todavia requiere un mes de pruebas de rigor que tiene que cumplir, Saludos

Excelente, yo también voy a probar con una maquinita que tengo, aunque me quedan mis dudas si la velocidad de lectura del disco se verá afectada al tener a más procesos escribiendo y leyendo al mismo tiempo.

De pronto rendiría mas si se les asigna particiones diferentes.

15
Squid 2.7 & Squid 3.x / Re:Actualizar Squid 3.x cualquier versión
« : Septiembre 23, 2013, 10:35:12 pm »
Tambien si quieres experimentar puedes usar ubuntu 13.10 el cual traera nativamente squid3.3.8, el cual trae la nueva funcionalidad de multi-core, que se llama workers, desplegando un proceso de squid independiente, no un subproceso, por cada nucleo, Saludos

Disculpa firecold, me puedes explicar un poco cómo se utiliza esa directiva? Tengo un squid 3.2.4 en una máquina i7, y quiero probar si existe algún cambio habilitando los 8 núcleos del procesador. Solo puse en mi squid.conf una línea que dice: workers 8

O algún comando para comprobar que en realidad el squid está utilizando varios procesos al mismo tiempo. Utilizo el top, pero veo solo 1 proceso activo.


16
Segun veo en el log tienes varios problemas, uno es en apache2 en la linea 24 y 47, corrigelos por favor, la verdad no se que es habria que ver el archivo en cuestion, el otro es:

Código: [Seleccionar]
Accepting  intercepted HTTP connections at 10.10.0.8:3128, FD 10.
Accepting  intercepted HTTP connections at 172.16.228.1:3128, FD 11.

Estas aceptando dos redes diferentes en un mismo puerto y apuntando a diferentes ips, por eso el squidaio_queue_request: WARNING - Queue congestion, y que no tengas internet en las maquinas cliente, me imagino que cada ip esta vinculada a una tarjeta de red, y para cada tarjeta de red una redireccion diferente en puerto, ip y tarjeta de red, esto ultimo con iptables, raptor miro que te sale offline, me puedes poner un enlace de los logs de raptor, especifico el error.log, espero solucionar tu problema lo mas pronto posible, Saludos

Hola firecold, gracias por tu ayuda, ya corregí los errores del apache. Te cuento que el error.log está vacío, no me sale nada =(

Código: [Seleccionar]
login as: root
root@proxy:~# tail -f  /var/log/raptor/error.log
^C
root@proxy:~# tail -f  /var/log/raptor/error.log

Crees que sea algun problema con el bind? Se me ocurre que se está saturando por alguna razón y por eso el squid no logra conectarse. Ahora modifique el valor de los file descriptors, se me presenta el problema igual, pero ahora con menos frecuencia.

17
reinicias primero bind9, porque este error se trata de la mala comunicacion de bind9 y squid3, luego raptor, despues squid y por ultimo apache2, de esta manera:

Código: [Seleccionar]
sudo service bind9 restart
sudo service raptor restart
sudo service squid3 restart
sudo service apache2 restart

me avisas, para saber si te funciono o hay que escarbar mas en tus logs, saludos

Hola, realicé los cambios como me indicabas, pero sigo con el problema, aunque ahora el error no sale en el log del squid3, sino en el syslog.

Cita
root@proxy:/sbin# cd /root/
root@proxy:~# ./reinicios.sh
 * Stopping domain name service... bind9                                                                                                                     rndc: connect failed: 127.0.0.1#953: connection refused
                                                                                                                                                      [ OK ]
 * Starting domain name service... bind9                                                                                                              [ OK ]
Restarting Raptor ...
Starting Raptor 1.0b
squid3 stop/waiting
squid3 start/running, process 24941
 * Restarting web server apache2                                                                                                                             [Tue Apr 02 16:34:13 2013] [warn] The Alias directive in /etc/apache2/conf.d/apc.conf at line 24 will probably never match because it overlaps an earlier Alias.
[Tue Apr 02 16:34:13 2013] [warn] The Alias directive in /etc/apache2/conf.d/apc.conf at line 47 will probably never match because it overlaps an earlier Alias.
 ... waiting [Tue Apr 02 16:34:14 2013] [warn] The Alias directive in /etc/apache2/conf.d/apc.conf at line 24 will probably never match because it overlaps an earlier Alias.
[Tue Apr 02 16:34:14 2013] [warn] The Alias directive in /etc/apache2/conf.d/apc.conf at line 47 will probably never match because it overlaps an earlier Alias.
                                                                                                                                                      [ OK ]
root@proxy:/sbin# tail -f /var/log/squid3/cache.log
2013/04/02 15:10:41| Store logging disabled
2013/04/02 15:10:41| DNS Socket created at [::], FD 7
2013/04/02 15:10:41| DNS Socket created at 0.0.0.0, FD 8
2013/04/02 15:10:41| Adding nameserver 127.0.0.1 from squid.conf
2013/04/02 15:10:41| Accepting  intercepted HTTP connections at 10.10.0.8:3128, FD 10.
2013/04/02 15:10:41| Accepting  intercepted HTTP connections at 172.16.228.1:3128, FD 11.
2013/04/02 15:10:41| HTCP Disabled.
2013/04/02 15:10:41| Configuring Parent 10.10.0.8/8080/0
2013/04/02 15:10:41| Loaded Icons.
2013/04/02 15:10:41| Ready to serve requests.
2013/04/02 15:12:22| squidaio_queue_request: WARNING - Queue congestion
2013/04/02 15:15:00| squidaio_queue_request: WARNING - Queue congestion
2013/04/02 15:19:26| ctx: enter level  0: 'http://vap5dfw1.lijit.com/www/delivery/lg.php?bannerid=24997&campaignid=232&cids=232&bids=24997&zoneid=186523&tid=86523_13649339582457ed0eab4e456&channel_ids=,&loc=http%3A%2F%2Fmips.tv%2Fembedplayer%2Fhjkkkfg%2F1%2F550%2F400&referer=http%3A%2F%2Fmips.tv%2Fembedplayer%2Fhkkkfg%2F1%2F550%2F400&cb=b4d4769914'
2013/04/02 15:19:26| WARNING: unparseable HTTP header field {: }
2013/04/02 15:24:37| ctx: exit level  0

root@proxy:~# tail -f /var/log/syslog | grep DNS
Apr  2 16:08:04 proxy named[24907]: generating session key for dynamic DNS
Apr  2 16:11:43 proxy named[17014]: DNS format error from 8.8.8.8#53 resolving bdcrqgonzmwuehky.nl/AAAA for client 127.0.0.1#44300: invalid response
Apr  2 16:11:45 proxy named[17014]: DNS format error from 8.8.8.8#53 resolving google.com/AAAA for client 127.0.0.1#44300: invalid response
Apr  2 16:11:46 proxy named[17014]: DNS format error from 190.12.61.2#53 resolving hotmail.com/AAAA for client 127.0.0.1#44300: invalid response
Apr  2 16:11:46 proxy named[17014]: DNS format error from 8.8.8.8#53 resolving bdcrqgonzmwuehky.nl/AAAA for client 127.0.0.1#44300: invalid response
Apr  2 16:25:59 proxy named[17014]: DNS format error from 8.8.8.8#53 resolving st-listas.20minutos.es/AAAA for client 127.0.0.1#44300: invalid response


Pero sigo con el mismo error en los navegadores de los clientes:



Adiciono una imagen con los detalles del equipo:

18
Sale en el log del squid3, exactamente en el:

tail -f /var/log/squid3/cache.log

Cuando aparece en el navegador también aparece un mensaje de error al navegar, he buscado en google sobre el error pero no encuentro nada que evite que salga, además he probado cambiando tanto en el squid la parte de:

Cita
dns_nameservers 8.8.8.8 8.8.4.4

Dejando solo 1, también colocando los de mi proveedor, hasta quitando la línea del squid.conf y nada, siempre me sale ese mensaje.

19
Bueno amigo lo prometido es deuda, en este ya viene cambiado lo del Pid, tambien lo de la libreria que hace falta en ubuntu ya que en debian no hay problema, una cosa que tienes que revisar antes de instalar es abrir el archivo y en todas las partes donde dice IPSERV= CAMBIALE A LA IP QUE TU QUIERAS, y por ultimo para terminar lo del pid, ir al /etc/init.d/raptor, abrirlo y la parte donde dice PIDFILE, cambiar a PIDFILE=/var/run/raptor.pid, el script ya viene modificado para cree, el pid en ese lugar, por lo demas cualquier duda, preguntar no cuesta nada, Saludos

De pronto has probado si tienes el problema de los dns que dice:

Código: [Seleccionar]
dns_internal.cc(717) idnsInitVCConnected: Failed to connect to nameserver 127.0.0.0 using TCP
Me ha pasado en 3 instalaciones diferentes, todas con ubuntu server 12.04.2.

Simplemente las páginas no cargan y sale mensaje de error en el navegador.

20
Muchas gracias por la respuesta, voy a probar el script. Aunque estoy pensando seriamente migrar a debian mejor. Saludos

Páginas: 1 2