Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - guzmanweb

Páginas: 1
1
Actualizaciones / Re:[Update] RaptorCache 2.0.5
« : Julio 19, 2017, 10:55:30 am »
Estas usando la versión 7.11 de Debian, para esta versión de Raptor tienes que usar la versión de Debian 8.

Saludos.
hola ya actualice a Debian 8.8

al actualizar me sale esto

Código: [Seleccionar]
root@raptor:~# /etc/init.d/raptor restart && /etc/init.d/squid3 restart
Restarting Raptor ...
terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::substr: __pos (which is 4) > this->size() (which is 1)
Aborted
root@raptor:~#

Saludos

2
Actualizaciones / Re:[Update] RaptorCache 2.0.3
« : Julio 19, 2017, 08:42:31 am »
Intenta actualizar nuevamente, pero antes de actualizar borrar los archivos de la carpeta "/tmp/"
Código: [Seleccionar]
rm -rf /tmp/*
wget https://dl.dropboxusercontent.com/u/74360564/raptor2/update/raptor2.0.3_update.tar.gz
mv raptor2.0.3_update.tar.gz /tmp
tar -xzvf /tmp/raptor2.0.3_update.tar.gz -C /
service raptor restart && service squid3 restart

Saludos.


Hola Amigo este archivo wget https://dl.dropboxusercontent.com/u/74360564/raptor2/update/raptor2.0.3_update.tar.gz ya no esta disponible, quiero actualizarla por favor si me podes pasar si tuvieras por favor gracias!

3
Actualizaciones / Re:[Update] RaptorCache 2.0.5
« : Julio 19, 2017, 07:55:16 am »
Hola amigos al actualizar me sale esto:

Código: [Seleccionar]
Warning: Using a password on the command line interface can be insecure.
END UPDATE
root@raptor:~# /etc/init.d/raptor restart && /etc/init.d/squid3 restart
Restarting Raptor ...
/usr/sbin/raptor: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/sbin/raptor)
/usr/sbin/raptor: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/sbin/raptor)

usando

root@raptor:~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 7.11 (wheezy)
Release:        7.11
Codename:       wheezy


falta la libreria me parece...

Saludos

4
Hola @joemg6

Gracias por todo el trabajo que hiciste, soy de argentina, aquí también esta muy complicado para tener los billetes verdes, habrá otras formas de pago?
Tengo una duda publique esto http://www.alterserv.com/foros/index.php?topic=2058.0  hace un par de días me podes orientar que puedo hacer? desde ya estaré muy agradecido Saludos y éxitos!

5
Hola

Busca en tu disco C: la carpeta amigo.

Saludos

6
Hola @angelsantana

Lo tengo hecho casi igual como la guía expuesta aquí  http://www.alterserv.com/foros/index.php?topic=2036.0
la única diferencia es que tiene la parte del TOS de Squid3 no creo que afecte mucho eso, lo voy a desactivar.

paso algunos pantallazos



Firewal de raptor



Aquí tengo una duda es necesario agregar la red de Raptor? me parece que no, pero agrego!

Como figura en la imagen tengo tres segmentos de redes y las agregue todas y pasan por raptor sin problemas excepto los usuarios que mando por la linea_ADSL,  los usuarios que sale por la Linea_ADSL no logro que pase por raptor ese es mi problema, paso algunas imágenes que raptor cachea muy bien hasta hora..



Saludos

Ricardo

7
Hola para solucionar esto debes bajar el servicio de Windows Update y luego renombrar la carpeta (SoftwareDistribution) donde baja las actualizaciones, y volver a subir el servicio, va volver a crear la carpeta y baja de nuevo las actualizaciones, y que ademas borrar todo le que cacheo, en este caso raptor.

8
Hola

Me gustaría si me pueden echarme un cable,  tengo dos conexión a Internet una es con IP Fija (fibra) y la otra es ADSL (pppoe-out1) no tiene balanceo carga, quiero que sean independientes

el temas es que quiero mandarle  10 Usuarios por la linea ADSL a su ves pase por raptor, el resto de los usuarios de sale por (fibra) pasa normal por raptor sin  problema, a continuación expongo las reglas que tengo:

Raptor IP 192.168.200.2

Usuarios que quiero pasar por la linea ADSL

Código:
  1. /ip firewall address-list
  2. add address=192.168.20.43 disabled=no list=Linea_ADSL
  3. add address=192.168.20.70 disabled=no list=Linea_ADSL
  4. add address=192.168.20.71 disabled=no list=Linea_ADSL
  5. add address=192.168.20.72 disabled=no list=Linea_ADSL
  6. add address=192.168.20.73 disabled=no list=Linea_ADSL
  7. add address=192.168.20.74 disabled=no list=Linea_ADSL
  8. add address=192.168.20.75 disabled=no list=Linea_ADSL
  9. add address=192.168.20.76 disabled=no list=Linea_ADSL
  10.  
  11. /ip firewall address-list
  12. add address=192.168.200.0/30 disabled=no list=OtrasRedes
  13. add address=192.168.21.0/24 disabled=no list=OtrasRedes
  14.  
  15. /ip firewall mangle
  16. add action=accept chain=prerouting disabled=no dst-address-list=OtrasRedes src-address=192.168.20.0/24
  17.  
  18. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" disabled=no dst-port=80 \
  19.     in-interface=LAN new-routing-mark=raptor_route passthrough=yes protocol=tcp
  20.  

Esta seria la regla  para que  los usuarios que mencione arriba salga por la  linea ADSL, ademas probé poner encima de la regla de "Raptor - mangle"

Código:
  1. [color=red]add action=mark-routing chain=prerouting disabled=no new-routing-mark=ADSL_route passthrough=no src-address-list=Linea_ADSL[/color]
  2.  
  3. add action=mark-connection chain=forward comment="================== CACHE ====================" content=\
  4.     "X-Cache-Raptor: HIT from Raptor" disabled=no new-connection-mark=raptor-connection passthrough=yes
  5. add action=mark-packet chain=forward connection-mark=raptor-connection \
  6.     disabled=no new-packet-mark=raptor-packs passthrough=no
  7. add action=mark-connection chain=forward comment="==SQUID - TOS 12==" \
  8.     disabled=no dscp=12 new-connection-mark=squid-connection passthrough=yes
  9. add action=mark-packet chain=forward connection-mark=squid-connection \
  10.     disabled=no new-packet-mark=squid-packs passthrough=yes
  11.  
  12.  
  13. /ip route
  14. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
  15.     192.168.200.2 routing-mark=raptor_route scope=30 target-scope=10
  16. [color=red]add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ADSL routing-mark=ADSL_route scope=30 target-scope=10[/color]
  17. add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=190.189.117.X scope=30 target-scope=10
  18. add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ADSL scope=30 target-scope=10

actualmente los usuarios de lista Linea_ADSL tienen Internet normal, pero no logro que pase por raptor.

Mis agradecimientos anticipadas, si falta algún dato no dude pedírmelo!

Saludos

Ricardo

PD: perdón si no es adecuado la publicación por este sector!


9
me falto decir que la IP del Raptor es 192.168.200.2

mi red es 192.168.20.0/24

Saludos

10
Buenas tarde integrantes del Foro,

La parte de NAT tengo agregado esto:

Código:
  1. /ip firewall nat
  2. add action=masquerade chain=srcnat comment="Red Proxy" disabled=no \
  3. out-interface=ether1-WAN src-address=192.168.200.0/30

Si no tiene este, no navega raptor estoy en lo correcto con esta regla? y ustedes como la tienen?

Saludos

11
Hola, gracias por responder, me pasa con windows 7, no se con los demás windows!

Saludos

12
Hola muy buenas

Tengo funcionando RaptorCache hace una semana funcionando sin problemas, pero cuando bajan actualización de windows el mismo no se actualiza bien cada dos por tres sale error XXXXX entonces le puse en Whitelist como sugiere en https://support.microsoft.com/es-es/kb/896226  algo asi:



ya me dejo actualizar, por otra parte vi que esta http://wiki.squid-cache.org/SquidFaq/WindowsUpdate se puede agregar?

Saludos

Ricardo

13
entonces me esta faltando los scripts de Iptables a parte del mikrotik? de ser asi cuales el script que debo usar en el IPtables...

muchas gracias por tu colaboracion..


saludos

14
gracias por responder firecold!

En el principio de post esta las configuraciones de las interfaces de red y tanto los DNS. y el script de dirección tambien aqui uso el Mikrotik para redireccionar el mismo esta en este post..

muchas gracias nuevamnete, espero resolver este problema que estoy estancado.

Saludos Cordiales..

15
disculpen por la demora. estuve con mucho trabajo.. aqui les pego la configuracion... no toque nada ah solo cambien la ip de mi server que tenia originalmente 192.168.10.2 por 192.168.20.110.. aqui pego la conf

disculpen no pude pegar el codigo pero subi aqui http://pastebin.com/download.php?i=y4SSENm6

muchas gracias por su tiempo y comentarios

saludos

16
aqui esta el cache.log http://guzman.com.ar/archivos/imagenes/cache.log.png

esi se llena con la ip del servidor  inifinito se llena en unos 30 min ya se llena el disco.

alguna pista ?

muchas gracias por tu tiempo y respuesta..

saludos

17
Gracias por tu respuesta abcwarbot.

Cuando instale  funcionaba perfecto, una semana anduvo sin problemas. un dia para el otro se lleno el disco y en el cache.log que sale en la imagen que publique tenia casi ocupaba todo el disco yo creo que el problema es otro. la ip de mi servidor es 192.168.20.110.

Me quede preocupado por este problema ya lo habia puesto en produccion. ahora esta quedo apagado....

Voy a probar con lo que mencionas  a ver como me fue, despues les aviso...


gracias nuevamente por tu respuesta

Saludos

18
Hola amigos del Foro mi Raptor cache venia funcionando bien así una semana desde que instale pero un día para el otro se puso el disco al 99% me doy cuenta por que ya no tenia Internet. empece a revisar los logs  me doy cuenta que el archivo cache.log pesaba 89GB. cuando le libero lo reinicio el servidor ya funciona pero cuando hago

 tail -f /var/log/squid3/cache.log

es como que hace un loop qui una imagen




NAT

/ip firewall nat
add action=masquerade chain=srcnat comment="Red LAN" disabled=no src-address=192.168.20.0/24
add action=dst-nat chain=dstnat comment="Redirect Thunder 3.1.x" disabled=yes dst-port=80 in-interface=SWITCH protocol=tcp src-address=!192.168.20.110 to-addresses=\
    192.168.20.110 to-ports=3128


Mi mangle

/ip firewall mangle
add action=passthrough chain=forward comment="by Guzman" disabled=no
add action=mark-connection chain=forward comment="Guzman Lan" content="X-Cache: HIT" disabled=no new-connection-mark=cacheconn passthrough=yes
add action=mark-packet chain=forward connection-mark=cacheconn disabled=no new-packet-mark=cacheconn passthrough=no

mi config de mi tarjeta de red

auto eth0 lo
iface lo inet loopback
iface eth0 inet static
   address 192.168.20.110
   netmask 255.255.255.0
   network 192.168.20.0
   broadcast 192.168.20.255
   gateway 192.168.20.1
   # dns-* options are implemented by the resolvconf package, if installed
   #dns-nameservers 192.168.20.1
   #dns-search proxy.os.com

en mi archivo resolv.conf

search proxy.os.com
nameserver 127.0.0.1
nameserver 192.168.20.1


alguien me puede dar una luz o alguna idea...
si hace falta mas datos por favor no olviden pedirmelo

desde ya muchas gracias

19
Muchas gracias por compartir sos groso sabelo!!!

Páginas: 1