Mensajes recientes

Páginas: 1 2 3 4 5 6 7 ... 10
21
    Bueno , buenas a todos.

    hoy voy a compartir unas mejoras en relacion a raptor cache, que espero pronto incluyan en el software.
    (creo q me merecere una licencia gratis XD)

    bueno:
    como sabemos raptor funciona bien en el 85% de paginas web https, en la ultima actualizacion incluyeron un apartado en el cual podriamos agregar los link o regex que no queriamos q pasen por raptor.

    entre estas paginas estan los servicios moviles de youtube, whatsapp, facebook, google play, y el juego de LoL, movistar play, etc....

    algunos de estos servicios se solucionaron con la opcion antes mencionada, pero aun asi es nulo para algunas aplicaciones.

    Entonces: La solucion que encontre para estas paginas es el de evitar que pasen por raptor server ( es decir que ni siquiera haga el intento ), esto trae 2 ventajas principales.
               - evita sobrecargar el server raptor con trafico inesesario
               - soluciona el problema de webs y servicios.
    y para esto es necesario tener un mikrotik de router. en donde modificaremos (mejoraremos) las reglas:

    estas son las que existen
    • /ip firewall mangle
    • add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=\
    •    no protocol=tcp
    • add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=443 in-interface=LAN new-routing-mark=raptor_route \
    •    passthrough=no protocol=tcp src-address-list=https_users
    al modificar deben terminar asi:


    • como se ve, hay una lista llamada "no-cache-sitios" que es la lista donde incluiremos el link que queremos que evite pasar por el server de raptor. ( cabe resaltar que el hacer esto evita que pase todo el contenido que va redirecionado hacia la ip del link)
    • Hecho lo anterior. ya podemos empesar a agregar en /ip firewall address-list los link que queremos evitar que pasen por el server de raptor de manera directa como si no existiera un raptor en la red.
    • empecemos:
    • Para que funcionen los moviles con youtube y playstore facebook (aun se requiere el certificado instalado en el movil para la cache del resto de contenido)

    • add address=android.l.google.com list=no-cache-sitios
    • add address=safebrowsing.cache.l.google.com list=no-cache-sitios
    • add address=googleapis.l.google.com list=no-cache-sitios
      add address=video-stats.l.google.com list=no-cache-sitios
            add address=youtube-ui.l.google.com list=no-cache-sitios
    • add address=fblive.facebook.com disabled=yes list=no-cache-sitios
    • add address=star.c10r.facebook.com disabled=yes list=no-cache-sitios
    • add address=scontent.xx.fbcdn.net disabled=yes list=no-cache-sitios
    • add address=instagram.c10r.facebook.com disabled=yes list=no-cache-sitios
      add address=mqtt.c10r.facebook.com disabled=yes list=no-cache-sitios
      add address=z-m.c10r.facebook.com disabled=yes list=no-cache-sitios
      add address=z-p42-instagram.c10r.facebook.com disabled=yes list=no-cache-sitios
      add address=a.ns.t.fbcdn.net disabled=yes list=no-cache-sitios
      add address=b.ns.t.fbcdn.net disabled=yes list=no-cache-sitios


    para league of legends

    add address=auth.riotgames.com list=no-cache-sitios
    add address=entitlements.auth.riotgames.com list=no-cache-sitios
    add address=lq.la2.lol.riotgames.com list=no-cache-sitios
    add address=playerpreferences.riotgames.com list=no-cache-sitios
    add address=us.edge.rms.si.riotgames.com list=no-cache-sitios
    add address=la2.cap.riotgames.com list=no-cache-sitios
    add address=acs.leagueoflegends.com list=no-cache-sitios
    add address=contenttargeting.leagueoflegends.com list=no-cache-sitios
    add address=loadouts.la2.leagueoflegends.com list=no-cache-sitios

    Otros:

    add address=ucweb.movistarplay.com.pe comment="login movistarplay" disabled=yes list=no-cache-sitios
    add address=wvcypherdrm.gvp.telefonica.com comment="online movistarplay" disabled=yes list=no-cache-sitios
    add address=mum.mikrotik.com disabled=yes list=no-cache-sitios

    [/li]
Hecho esto ustedes ya podran ingresar y loguearse sin problemas en los distintos sitios web propuestos, esto no perjudica el contenido que nos interesa almacenar en cache, ya que las ip que estamos evitando hacer pasar por el servidor de cache son links de identificacion, resolucion, conexion a base de datos, y otros, pero los links  e ips del contenido cacheable seguiran pasando por el server de raptor

*************************************************************************************
league of legends ............................ :)
para finalizar voy a indicar una actualizacion que se tendra que realizar en el servidor raptor cache  para poder realizar el cache de todas la imagenes y videos de league of legends (que por cierto no son nada livianos, ni poquitos)

comencemos:

para ello usaremos puty

y ingresamos en nano /etc/raptor/brsts.lst
y agregamos:

\.whatsapp\.com
w[0-9]\.web\.whatsapp\.com
web\.whatsapp\.com
\.wikipedia\.org
\.instagram\.com
\.github\.com
\.riotgames\.com
\.leagueoflegends\.com
ll[0-9]+\.dragonbound\.net

luego en nano /etc/raptor/peers

y buscamos esta parte

#;
refresh_pattern -i ^http.*rp\.os.* 10080 80%  79900 override-expire override-lastmod ignore-reload ignore-no-store ignore-must-revalidate ignore-private ignore-auth
refresh_pattern ^http://([a-zA-Z0-9\-]+)\.squid\.internal/.* 241920 99% 241920 override-lastmod override-expire ignore-reload ignore-private ignore-no-store ignore-must-revalidate reload-into-ims ignore-auth store-stale
refresh_pattern ^ftp:           1440    20%     10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern -i (/cgi-bin/|\?) 0     0%      0
#refresh_pattern .               0       20%     4320
#;

donde agregamos lo siguiente en la parte superior

refresh_pattern -i ^https?:\/\/.*lolstatic.*\/(.*\.(webp|jpg|png)).* 3000 99% 252858 override-lastmod override-expire ignore-reload ignore-private ignore-no-store igno$

listo, con esto sera un relampago al habrir lol

seguiere trabajano espero lo y me consideren gracias
22
Squid 2.7 & Squid 3.x / squid 3 y mikrotik varios
« Último mensaje por ccarrion78 diciembre 07, 2018, 12:19:12 pm »
Buen dia.

Actualmente mi infraestructura de red tiene un squid...(en el  cual manejo los permisos de navegación de los usuarios y la habilitación de las paginas para navegar) y un mikrotik que se encarga de todos los mascarade y las reglas de firewall.

Todo trafico que tenga como destino el puerto 80 es direccionado al squid, hora me surge una duda. Hace poco empece a aplicar simple queues and queues tree.

Y veo que todos los usuarios que navegan por proxy no les impacta ningún cambio de simple queue al igual que al mirar  la interfaz de Lan donde veo que el que consume ancho de banda es la ip del squid... y no veo la ip de los usuarios detrás del proxy.

Se puede hacer algo para poder trabajar con squid y mikrotik?

O directamente el proxy de mkt bastaría... aproximadamente tengo 300 usuarios de los cuales 30 son los que pueden navegar libremente.

Alguna idea o sugerencia?

Gracias!

SAludos.
23
Otros / Re:Portal Hotspot Navida
« Último mensaje por venezu diciembre 05, 2018, 07:28:51 pm »
24
Instalación y Configuración RaptorCache / Re:Actualizacion de raptor cache sobre youtube
« Último mensaje por jesger diciembre 05, 2018, 10:45:01 am »
XD


bueno para editar aqui,

nano /etc/raptor/idst.pl

 ojo:
* yo uso nano para la edicion
* solo modifique esta parte del codigo
* es probable q lo encuentren en linea recta todo, asi que tendran que buscar detalladamente y modificarlo, lo pueden ordenar de la manera propuesta sin problema.


espero usen esta recomendacion en la siguiente actualizacion de raptor.
25
Squid 2.7 & Squid 3.x / Re:SQUID HTTPS MP3
« Último mensaje por Hydarbill diciembre 04, 2018, 02:11:41 am »
Simplification of the design so that the effect is that we get the facts straight and do not be afraid to have false information.
26
Instalación y Configuración ThunderCache 3.1.2 / Re:aun sigue en funcionamiento TC 3.1.2?
« Último mensaje por Hydarbill diciembre 04, 2018, 02:11:01 am »
There are more great content to make up the creek we come here all the time for several hours.
27
Instalación y Configuración RaptorCache / Re:Actualizacion de raptor cache sobre youtube
« Último mensaje por ingjaab diciembre 03, 2018, 05:18:49 pm »
=( no donde esta store- id
28
Discución General / Re:ayuda configuracion mikrotik
« Último mensaje por ingjaab diciembre 03, 2018, 05:14:20 pm »
hola me podrian ayudar a configurar mi rb750 paralelo con raptor cache, no e logrado configurarlo bien. si alquilen quiere ayudarme por medio de sesión teamviewer  gracias
no sea malo en rb 750 muy tela
29
Instalación y Configuración RaptorCache / Re:Actualizacion de raptor cache sobre youtube
« Último mensaje por Kainaki diciembre 03, 2018, 03:11:51 am »
I like these things that you have posted so much.
30
Discución General / Re:ayuda configuracion mikrotik
« Último mensaje por Kainaki diciembre 03, 2018, 03:11:45 am »
We accept and love very much for what you are offering.
Páginas: 1 2 3 4 5 6 7 ... 10