Otros Servers > Otros

HandyCache - Instalación paralelo a Mikrotik (14/05/2015)

(1/133) > >>

JVProducciones:
Instalación de HandyCache paralelo a Mikrotik (14/05/2015)
Después de hacer diversas pruebas y viendo los resultados brindados por este simple pero eficiente programa les comparto esta información recopilada de varios foros y paginas en otros idiomas (ruso y indonesio)

Detallo algunas de las funciones:

1.- Descargamos los videos de youtube en el formato flv o mp4 (como era anteriormente) puedes pausar y el video seguirá descargando(tambien podrás hacerlo por partes).
2.- El video no cambiará automáticamente de resolución si esta en 360p al maximizar seguirá siendo 360p y un único archivo (actualmente cambia de múltiples resoluciones empeorando así el cacheo de partes)
3.- Se puede hacer que el video siempre cargue en 240p al maximizar seguirá siendo 240p (para isp que ofrecen velocidades inferiores a 1 mega al cliente, esto es excelente)
4.- bloqueo de publicidad y redireccionamientos  (implementación de reglas de bloqueo y redirección sin hacer que la red se torne lenta como pasa con el webproxy de mikrotik)
5.- Cache a https con instalación de certificados (instalando certificados a cada unos de los clientes se podría hacer cache a https Youtube, facebook y otros)
6.- manejo de extensiones escritos en código Lua q aumenta grandemente su capacidad
7.- lista Blanca para sitios donde no se quiere que pase por handycache o alguna de sus funciones


Instalacion de HandyCache:
HandyCache funciona en entorno windows (xp, vista, 7, 8 y 8.1) ya sea 32 o 64 bits, de manera personal sugiero usarlo en windows 8.1.
Videos de Instalación
Hecho por el compañero thunder
Descarga aquí el Programa HandyCache

Esquema de instalación:

Tome el mismo esquema para thundercache


Reglas Básicas utilizadas:
El muy importante enmascarado WAN

--- Código: ---/ip firewall nat
add action=masquerade chain=srcnat comment="Conexion a Internet" out-interface=WAN
--- Fin del código ---


--- Código: ---/ip address
add address=10.0.0.1/24 interface=PROXY
--- Fin del código ---
10.0.0.1/24 es la puerta de enlace para HandyCache (imagen)
PROXY es el nombre de la interfaz de red en Mikrotik que va hacia HandyCache

Creando Lista de Ips y redireccionamiento Transparente:
*Si preguntan si es posible redireccionar el puerto 443 (https), hasta el momento no se ha podido hacer (ni creo que se pueda)
*Si lo que quieren es usar cacheo https en los clientes se tendrá que hacer la redirección de manera manual en cada uno de ellos (los cliente), agregando ip del proxy y el puerto a usar en sus navegadores.(ya no necesitarían hacer ningún redireccionamiento NAT)..
continuando...
Primero Creamos la lista de clientes

--- Código: ---/ip firewall address-list
add address=192.168.10.0/24 list="Clientes Internet"
--- Fin del código ---
*192.168.10.0/24 es todo el rango IPs de nuestros clientes LAN
*Si tenemos mas rangos de clientes bastará  con repetir la regla con los rangos que queramos adicionarles y el redireccionamiento los tomará de manera automática ya que son "Clientes Internet"

Ahora hacemos el redireccionamiento: Publicaré 2 Formas (escojan según su necesidad)
1ra Forma - Simple Nat:

--- Código: ---/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=!10.0.0.222 dst-port=80,8080,8888,8880,8777,3477,33301 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=1010
--- Fin del código ---

*Esta es la forma mas simple y limitado a solo 400 conexiones del único handycache que tendrían corriendo

2da Forma - PCC Nat: en esta Forma se puede usar cuantos Handys quieran usar, aumentando así el número de conexiones, pondré como ejemplo 4 Handys corriendo en el server (4 x 400 conexiones = 1600 Conexiones) Uds tendrán que abrir 4 Handys en su server con distintos puertos escucha yo usaré los puertos 1010,2020,3030 y 4040.

--- Código: ---/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=!10.0.0.0/24 dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:4/0 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=1010
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=!10.0.0.0/24 dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:4/1 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=2020
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=!10.0.0.0/24 dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:4/2 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=3030
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=!10.0.0.0/24 dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:4/3 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=4040
--- Fin del código ---
*Ojo....Con esta manera yo no es necesario separar por grupos a nuestros usuarios ya que ellos se repartirán de manera equitativa entre los handys abiertos.
Debería de quedar algo así


Marcado de paquetes:

--- Código: ---/ip firewall mangle
add action=mark-connection chain=postrouting comment=HandyCache content="Server: HandyCache" new-connection-mark=handy-connection protocol=tcp src-address= 10.0.0.222
add action=mark-packet chain=postrouting connection-mark=handy-connection new-packet-mark=handy-packs
--- Fin del código ---

y ahora el Simple Fulcache: Una velocidad General para Todos los clientes
Version 6.x

--- Código: ---/queue simple
add comment="Servidor Proxy HC" limit-at=5M/5M max-limit=5M/5M name=HandyCache packet-marks=handy-packs priority=6/6 queue=default/default target=""
--- Fin del código ---
Version 5.x

--- Código: ---/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=5M name=HandyCache packet-mark=handy-packs parent=global-out priority=4 queue=default
--- Fin del código ---

Una regla que uso
La verdad que para mi dejar una regla general para fullcache no me llama mucho la atención así que utilizo una pequeña variante que hace que cada uno de mis clientes tenga 5 megas de fullcache y limito a 10 megas como máximo de salida general de la cache, les dejo una imagen para que se guíen mejor:



con esto ya tendremos trabajando nuestro programa  pero ¿que pasa si el servidor donde tienes instalado HandyCache se apaga?
Implementamos esta otra regla Netwatch:

--- Código: ---/tool netwatch
add comment=Handycache disabled=no down-script="/ip firewall nat set [find comment=\"Redirect Handycache\"] disabled=yes" host= 10.0.0.222 interval=2s timeout=2s up-script="/ip firewall nat set [find comment=\"Redirect Handycache\"] disabled=no"
--- Fin del código ---
*Deben de tener habilitado la respuesta Ping en su Windows, si no saben como hacer Sigan está Guia Habilitar "solicitud echo entrante ICMP" para PING en Windows XP, 7/8.1

Bloqueo de QUIC (Quick UDP Internet Connection) de Google Chrome (Manteniendo http)
por Requium (lista generada automáticamente)

--- Código: ---/ip firewall layer7-protocol add name=Google regexp="^.*(google|youtube)\..*"
/ip firewall mangle add action=add-dst-to-address-list address-list=Google chain=postrouting out-interface="WAN" layer7-protocol=Google
/ip firewall filter add action=drop chain=forward comment="Bloqueo udp Chrome" dst-address-list=Google dst-port=!53  protocol=udp
--- Fin del código ---
Ojo: en versiones de mikrotik 6.x debemos poner la regla Layer 7 de manera manual: regexp:"^.*(google|youtube)\..*" y Name: "Google"....todo sin comillas....

tenemos que considerar un consumo mayor de procesador de nuestros Mikrotiks, tal vez usarlo durante unas horas para que se creen las listas ip y luego desactivar la regla mangle para bajar el consumo o si tiene un rb Mikrotik como balanceo de carga pues sugiero que coloquen las reglas allí y dupliquen la regla mangle según el numero de WANs que usen....

Esperamos seguir Implementado este maravilloso Programa, Un Gran Abrazo a todos...

Temas de Interés
HandyCache JV - Nueva Versión

07350286:
Amigo tengo las siguientes preguntas veo que es bueno el sistema cache.

1.-  Se puede trabajar HandyCache con mikrotik.
2.- Se instala cada maquina para hacer el cache o se instala una sola maquina por ejemplo un ciber si tengo 7 maquinas las 7 maquinas le tengo que instalar ese programa de cache, o es una sola maquina.
3.- Hace cache te facebook, porque ahí mencionaste que https tambien
4.- Lo de la velocidad de cache ya viene por defecto alguna velocidad o el usuario pone su propia velocidad.
5.- Que paginas hace cache, hace cache de paginas dinamicas y estaticas
6.- Depende de Plugins para hacer cache de paginas.

JVProducciones:
siguiendo con mas información, les comento que HandyCache es free, su limitaciones son:
- 400 conexiones activas.(superado este problema al usar varios handys en las misma maquina con diferentes puertos de escucha)

Si quieren apoyar al proyecto
el costo de una licencia de paga según su creador mai62 (ruso) es de solo $20 dólares.....

trucos para tener mas conexiones:
Según el mismo creador el programa puede ejecutarse cuantas veces necesites solo se cambia de puerto de escucha (sigue guardando en la misma carpeta cache) esto significa que si ejecuto el programa 3 veces seria 1200 conexiones.
Todo esto es gratis.....
Saludos...

JVProducciones:
Yo publico esto en este foro x q se que hay muchas personas con conocimiento de regex y la programación, lo q se es por q lo he googleado pero estoy muy limitado necesito q gente como firecold o joemg6 heche la mano ha este programa y descubra sus secretos.... Ojala lean esto

07350286:
si  puedes hacer un video de como tienes junto con mikrotik, y como trabaja en mikrotik

Navegación

[0] Índice de Mensajes

[#] Página Siguiente

Ir a la versión completa