HandyCache Repack 2015 update 1

Desconectado robertjs

  • Full Member
  • ***
  • Mensajes: 163
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
HandyCache Repack 2015 update 1
« : Marzo 04, 2015, 03:25:46 pm »
Hola a todos, como les prometi por aqui les traigo el HC el cual lo titule "Repack 2015", porque lo puse ese nombre, por la simple razon ...
De que use el HC cache que public nuesto amigo "JVProducciones".. y solo agrege algunas extenciones y reglas, aparte de eso que reordene un poco y borre lo que no se utilizaba.

Hay aun cosas por pulir y optimizar mas, pero ya les comparto lo que tengo,
Version HC 1.0.0.551 (El que ya usamos)

Dejare una guia de instalacion de nuestro amigo "JVProducciones"

Cita
Instalación de HandyCache paralelo a Mikrotik

Después de hacer diversas pruebas y viendo los resultados brindados por este simple pero eficiente programa les comparto esta información recopilada de varios foros y paginas en otros idiomas (ruso y indonesio)

Detallo algunas de las funciones:

1.- Descargamos los videos de youtube en el formato flv o mp4 (como era anteriormente) puedes pausar y el video seguirá descargando.
2.- El video no cambiará automáticamente de resolución si esta en 360p al maximizar seguirá siendo 360p y un único archivo (actualmente cambia de múltiples resoluciones empeorando así el cacheo de partes)
3.- Se puede hacer que el video siempre cargue en 240p al maximizar seguirá siendo 240p (para isp que ofrecen velocidades inferiores a 1 mega al cliente, esto es excelente)
4.- bloqueo de publicidad y redireccionamientos  (implementación de reglas de bloqueo y redirección sin hacer que la red se torne lenta como pasa con el webproxy de mikrotik)
5.- Cache a https con instalación de certificados (instalando certificados a cada unos de los clientes se podría hacer cache a https Youtube, facebook y otros)
6.- manejo de extensiones escritos en código Lua q aumenta grandemente su capacidad
7.- lista Blanca para sitios donde no se quiere que pase por handycache o alguna de sus funciones

Reglas utilizadas:
Regla N° 1
Redireccionamiento:
Código:
  1. /ip firewall nat
  2. add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=\
  3.     ! 192.168.10.2 dst-port=80,8080,8888,8880,8777,3477 in-interface="LAN" protocol=tcp \
  4.     to-addresses=192.168.10.2 to-ports=8080
Muchos me preguntan si es posible redireccionar el puerto 443 (https), hasta el momento no se ha podido hacer ni creo que se pueda. si lo que quieren es usar https en los clientes se tendrá que hacer la redireccion de manera manual en cada uno de los clientes agregando ip del proxy y el puerto a usar..

Regla N° 2
Marcado de paquetes:
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=HandyCache content=\
  3.     "Server: HandyCache" new-connection-mark=handy-connection protocol=tcp \
  4.     src-address=192.168.10.2
  5. add action=mark-packet chain=postrouting connection-mark=handy-connection \
  6.     new-packet-mark=handy-packs

Regla N° 3
y ahora el Fulcache:
Version 6.x
Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" limit-at=15M/15M max-limit=5M/5M name=\
  3.     HandyCache packet-marks=handy-packs priority=6/6 queue=default/default \
  4.     target=""

Regla N° 3.1
Version 5.x (aun no lo e probado)
Código:
  1. /queue tree
  2. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  3.     max-limit=5M name=HandyCache packet-mark=handy-packs parent=\
  4.     global-out priority=4 queue=default

Opcional: Recomendado


Una regla que uso
La verdad que para mi dejar una regla general para fullcache no me llama mucho la atención así que utilizo una pequeña variante que hace que cada uno de mis clientes tenga 5 megas de fullcache y limito a 10 megas como máximo de salida general de la cache, les dejo una imagen para que se guíen mejor:
Se los recomiendo

Código:
  1. /queue type
  2. add kind=pcq name=UserHC pcq-classifier=dst-address pcq-dst-address6-mask=64 \
  3.     pcq-rate=5M pcq-src-address6-mask=64
  4.  
Si usan esta regla opcional entonces no usen la regla N° 3 usen la siguiente regla.. que solo es la mikrotik Ver. 6.xxx

Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" max-limit=15M/15M name=HandyCache \
  3.     packet-marks=handy-packs priority=6/6 queue=default/UserHC
  4.  

Video de instalacion:
Pendiente... Cargando....









Link de descarga: -----> HandyCache Repack 2015

Update 1
-----> Update 1 / 11-03-2015
Cita
Mejoras:
+ Se agrego una mejora en el UserAgente "manipulacion de user egent de usuario para youtube y google". [El anterior user agente esta desactivado/no fue borrado]
+ Ahora youtube guarda los videos en partes, y incluso si cambias de resolucion, y esa parte guardada en el cache automaticamente carga del cache.
+ Se agrego una nueva extension donde algunas reglas no guardan archivos de algunas paginas dinamicas "Esta en modo fase prueba - pendiente para mejorar y optimizar mejor las reglas".

Cita
Pendientes:
* Aun no se pudo mantener la resolucion.
* Optimizar el cache de antivirus avast.
* HTML5 El firefox pendiente, aun no guarda en cache.

Cita
Recomendaciones:
- No olviden siempre hacer un back del HC anterior que tengan, o renombrar para hacer las pruebas necesarias con el nuevo.
- Si fuera posible hagan uso de la herramienta "HandyCache Cache Cleaner" que esta en la carpeta HC, para limpiar arechivos ya pasados, no utilizables.



Agradecimientos:
Especiales por dejarnos publicar.
* Joemg6     --> Dueño del foro
* Moderadores           --> pongo moderadores porque no se cuanto hay :)

* JVProducciones
* HandyCache
*  Komunitas
*
* Otros que ya apareceran :)

EDITADO: Por Firecold



Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 30
Re:HandyCache Repack 2015 marzo
« Respuesta #1 : Marzo 04, 2015, 05:14:52 pm »
No tengo nada en contra del proyecto Handy, ni nada por el estilo, pero veo un pequeño detalle, por ejemplo: Thundercache 7.x, tiene su propio foro y creeme no se comenta mucho de nosotros, Haarp Cache tiene su propio sitio y volvemos a lo mismo, no se comenta mucho de nosotros y me imagino que HC tiene su propio foro y te aseguro no se comenta mucho de nosotros, como dije  no tenga nada con el proyecto ni con los usuarios.

Ya que soy participe de las opciones y como ven no he borrado ninguno de sus temas y mucho menos bloquearlos, de hecho algunas veces me hecho un colazo por sus temas, como tambien por el foro de ThunderCache 7.x, como tambien Haarp, entre otros, por curiosidad y como sabes no es bueno tener los ojos cerrados a otras opciones.

Aunque hace poco vi un comentario que no me gusto, sonaba asi:

Cita
Hola nuevamente mi amigo JVProducciones: estoy muy admirado de usted la das grandes ayudas que usted nos ofreces a todos en este gra y maravilloso forro que usted abrio,,,

Algo que quiero dejar claro es: en ningun momento he dicho que dejen de publicar o aportar a Handy en este foro, si no que corrijan a sus nuevos usuarios que utilizan este foro, ya que hay que darle honor al que honor merece y todos sabemos que este foro es gracias a Joemg6, por lo demas sigan adelante, Saludos

Desconectado ISPsuperspeed

  • Newbie
  • *
  • Mensajes: 36
  • Ubicación: AQP
    • Ver Perfil
  • Me Gusta: 1
Re:HandyCache Repack 2015 marzo
« Respuesta #2 : Marzo 04, 2015, 06:00:42 pm »
Hola a todos, como les prometi por aqui les traigo el HC el cual lo titule "Repack 2015", porque lo puse ese nombre, por la simple razon ...
De que use el HC cache que public nuesto amigo "JVProducciones".. y solo agrege algunas extenciones y reglas, aparte de eso que reordene un poco y borre lo que no se utilizaba.

Hay aun cosas por pulir y optimizar mas, pero ya les comparto lo que tengo,
Version HC 1.0.0.551 (El que ya usamos)

Dejare una guia de instalacion de nuestro amigo "JVProducciones"

Reglas utilizadas:
Regla N° 1
Redireccionamiento:
Código:
  1. /ip firewall nat
  2. add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=\
  3.     ! 192.168.10.2 dst-port=80,8080,8888,8880,8777,3477 in-interface="LAN" protocol=tcp \
  4.     to-addresses=192.168.10.2 to-ports=8080
Muchos me preguntan si es posible redireccionar el puerto 443 (https), hasta el momento no se ha podido hacer ni creo que se pueda. si lo que quieren es usar https en los clientes se tendrá que hacer la redireccion de manera manual en cada uno de los clientes agregando ip del proxy y el puerto a usar..

Regla N° 2
Marcado de paquetes:
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=HandyCache content=\
  3.     "Server: HandyCache" new-connection-mark=handy-connection protocol=tcp \
  4.     src-address=192.168.10.2
  5. add action=mark-packet chain=postrouting connection-mark=handy-connection \
  6.     new-packet-mark=handy-packs

Regla N° 3
y ahora el Fulcache:
Version 6.x
Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" limit-at=15M/15M max-limit=5M/5M name=\
  3.     HandyCache packet-marks=handy-packs priority=6/6 queue=default/default \
  4.     target=""

Regla N° 3.1
Version 5.x (aun no lo e probado)
Código:
  1. /queue tree
  2. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  3.     max-limit=5M name=HandyCache packet-mark=handy-packs parent=\
  4.     global-out priority=4 queue=default

Opcional: Recomendado


Una regla que uso
La verdad que para mi dejar una regla general para fullcache no me llama mucho la atención así que utilizo una pequeña variante que hace que cada uno de mis clientes tenga 5 megas de fullcache y limito a 10 megas como máximo de salida general de la cache, les dejo una imagen para que se guíen mejor:
Se los recomiendo

Código:
  1. /queue type
  2. add kind=pcq name=UserHC pcq-classifier=dst-address pcq-dst-address6-mask=64 \
  3.     pcq-rate=5M pcq-src-address6-mask=64
  4.  
Si usan esta regla opcional entonces no usen la regla N° 3 usen la siguiente regla.. que solo es la mikrotik Ver. 6.xxx

Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" max-limit=15M/15M name=HandyCache \
  3.     packet-marks=handy-packs priority=6/6 queue=default/UserHC
  4.  

Video de instalacion:
Pendiente... Cargando....









Link de descarga: -----> HandyCache Repack 2015

Agradecimientos:

* JVProducciones
* HandyCache
*  Komunitas
* Otros que ya apareceran :)

con esta actualización sigue guardando youtube en la misma carpeta? o hay que cachear todo de nuevo... saludos

Desconectado robertjs

  • Full Member
  • ***
  • Mensajes: 163
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 marzo
« Respuesta #3 : Marzo 05, 2015, 10:32:32 am »
No tengo nada en contra del proyecto Handy, ni nada por el estilo, pero veo un pequeño detalle, por ejemplo: Thundercache 7.x, tiene su propio foro y creeme no se comenta mucho de nosotros, Haarp Cache tiene su propio sitio y volvemos a lo mismo, no se comenta mucho de nosotros y me imagino que HC tiene su propio foro y te aseguro no se comenta mucho de nosotros, como dije  no tenga nada con el proyecto ni con los usuarios.

Ya que soy participe de las opciones y como ven no he borrado ninguno de sus temas y mucho menos bloquearlos, de hecho algunas veces me hecho un colazo por sus temas, como tambien por el foro de ThunderCache 7.x, como tambien Haarp, entre otros, por curiosidad y como sabes no es bueno tener los ojos cerrados a otras opciones.

Aunque hace poco vi un comentario que no me gusto, sonaba asi:

Algo que quiero dejar claro es: en ningun momento he dicho que dejen de publicar o aportar a Handy en este foro, si no que corrijan a sus nuevos usuarios que utilizan este foro, ya que hay que darle honor al que honor merece y todos sabemos que este foro es gracias a Joemg6, por lo demas sigan adelante, Saludos

Hola, saludos amigo firecold, lei tu incomodidad y lo entiendo a la perfeccion,
pero se comparte aqui porque esta en la opcion de "otros serves".

Y sobre el comentario que dices, si tienes mucha razon, pero en realidad yo no me fije en eso. esperamos que nuestro amigo JV lo pueda corregirlo, ...

El foro es de nuestro amigo Joemg6 espero me disculpe si por algun motivo incomode, si es asi me hagan saber para poder corregirlo.

Edito el post para agregar los agradecciomientos, por si me olvido algo o se pasa, porfavor corrigelo o asmelo saber, porfavor.

Y gracias al administrador y moderadores que nos permiten publicar aqui en este foro..
Gracias y exitos :)

Desconectado robertjs

  • Full Member
  • ***
  • Mensajes: 163
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 marzo
« Respuesta #4 : Marzo 05, 2015, 10:38:37 am »
con esta actualización sigue guardando youtube en la misma carpeta? o hay que cachear todo de nuevo... saludos

Si amigo puedes usar el mismo cache, pero claro si estas usando la ultima extenxion que se compartio, donde el video se guarda en partes y no como un solo archivo .flv

te recomiendo por seguridad que no borres el que tienes, porque tal ves no te guste o no lo se, te recomiendo que hagas un back del HC anterior que tengas una ves hecho eso. borra ya el que tienes y usa este HC y configuras a tu red y probas..
Saludos y exitos

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 30
Re:HandyCache Repack 2015 marzo
« Respuesta #5 : Marzo 05, 2015, 04:58:53 pm »
Hola, saludos amigo firecold, lei tu incomodidad y lo entiendo a la perfeccion,
pero se comparte aqui porque esta en la opcion de "otros serves".

Y sobre el comentario que dices, si tienes mucha razon, pero en realidad yo no me fije en eso. esperamos que nuestro amigo JV lo pueda corregirlo, ...

El foro es de nuestro amigo Joemg6 espero me disculpe si por algun motivo incomode, si es asi me hagan saber para poder corregirlo.

Edito el post para agregar los agradecciomientos, por si me olvido algo o se pasa, porfavor corrigelo o asmelo saber, porfavor.

Y gracias al administrador y moderadores que nos permiten publicar aqui en este foro..
Gracias y exitos :)

Gracias mi amigo por entender mi incomodidad, como dije no me incomodo que publiquen, de hecho esta para que lo hagan, el unico detalle que me incomodo como dije fue el comentario de un usuario y que no se le corrigiera, de hecho lo publique aqui en tu tema para no tirar mala vibra en el tema principal de HC y que el usuario en cuestión no se sintiera mal, disculpe si lo hice en su tema, pero no queria crear un tema por algo tan trivial, pero me imagino que JVProducciones leera su post y tome control de su tema, por lo demas disculpe mi intromision en su tema, Saludos

Desconectado JVProducciones

  • Sr. Member
  • ****
  • Mensajes: 448
  • Ubicación: AQP
  • Intentando lo imposible se realiza lo posible!!
    • Ver Perfil
  • Me Gusta: 2
Re:HandyCache Repack 2015 marzo
« Respuesta #6 : Marzo 05, 2015, 05:40:48 pm »
No tengo nada en contra del proyecto Handy, ni nada por el estilo, pero veo un pequeño detalle, por ejemplo: Thundercache 7.x, tiene su propio foro y creeme no se comenta mucho de nosotros, Haarp Cache tiene su propio sitio y volvemos a lo mismo, no se comenta mucho de nosotros y me imagino que HC tiene su propio foro y te aseguro no se comenta mucho de nosotros, como dije  no tenga nada con el proyecto ni con los usuarios.

Ya que soy participe de las opciones y como ven no he borrado ninguno de sus temas y mucho menos bloquearlos, de hecho algunas veces me hecho un colazo por sus temas, como tambien por el foro de ThunderCache 7.x, como tambien Haarp, entre otros, por curiosidad y como sabes no es bueno tener los ojos cerrados a otras opciones.

Aunque hace poco vi un comentario que no me gusto, sonaba asi:

Algo que quiero dejar claro es: en ningun momento he dicho que dejen de publicar o aportar a Handy en este foro, si no que corrijan a sus nuevos usuarios que utilizan este foro, ya que hay que darle honor al que honor merece y todos sabemos que este foro es gracias a Joemg6, por lo demas sigan adelante, Saludos
Caray, creo que el 99% de miembros de este foro sabe que el que inicio esto es joel maguiña (joemg6) con raptor cache.... Y donde está ese comentario? La verdad que ni recuerdo a verlo leido....... Saludos....
Ya me alucinaba dueño de este foro....jajajajaja (un chistesito) .....

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 30
Re:HandyCache Repack 2015 marzo
« Respuesta #7 : Marzo 06, 2015, 12:29:11 am »
Caray, creo que el 99% de miembros de este foro sabe que el que inicio esto es joel maguiña (joemg6) con raptor cache.... Y donde está ese comentario? La verdad que ni recuerdo a verlo leido....... Saludos....
Ya me alucinaba dueño de este foro....jajajajaja (un chistesito) .....

Estoy mas que el 100% seguro que no todos saben quien es Joemg6, por otro lado aqui esta el Comentario.

Es muy importante que recuerde los mensajes de su propio tema, o por lo menos leerlos cautelosamente, por lo demas no es mi intencion causar controversia, ni pleito, espero que sigan adelante ya que todo proyecto o ayuda a cualquier proyecto conlleva tiempo y esfuerzo, Saludos

Desconectado andret1719

  • Full Member
  • ***
  • Mensajes: 114
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 marzo
« Respuesta #8 : Marzo 06, 2015, 07:01:20 pm »
Caray, creo que el 99% de miembros de este foro sabe que el que inicio esto es joel maguiña (joemg6) con raptor cache.... Y donde está ese comentario? La verdad que ni recuerdo a verlo leido....... Saludos....
Ya me alucinaba dueño de este foro....jajajajaja (un chistesito) .....

amigo mira instale el handy y como que va bien pero lo instale en mi pc de mea y por rato e pone lentooo y el ventilador parece que e quisiera salir jejejeje, quisiera saber i lo tengo bien configurado o me falta algo, instale el q publica el amigo que dice marzo 2015

Desconectado JVProducciones

  • Sr. Member
  • ****
  • Mensajes: 448
  • Ubicación: AQP
  • Intentando lo imposible se realiza lo posible!!
    • Ver Perfil
  • Me Gusta: 2
Re:HandyCache Repack 2015 marzo
« Respuesta #9 : Marzo 06, 2015, 07:16:09 pm »
amigo mira instale el handy y como que va bien pero lo instale en mi pc de mea y por rato e pone lentooo y el ventilador parece que e quisiera salir jejejeje, quisiera saber i lo tengo bien configurado o me falta algo, instale el q publica el amigo que dice marzo 2015
pues para que el procesador se dispare hay algo que va mal.... abre el administrador de tareas de windows y ve que consume tantos recursos del procesador..... saludos

Desconectado andret1719

  • Full Member
  • ***
  • Mensajes: 114
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 marzo
« Respuesta #10 : Marzo 06, 2015, 07:22:46 pm »
pues para que el procesador se dispare hay algo que va mal.... abre el administrador de tareas de windows y ve que consume tantos recursos del procesador..... saludos

ya lo deje trabajando voy a mirar a ver cuando vuelva a pegarce

Desconectado robertjs

  • Full Member
  • ***
  • Mensajes: 163
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 marzo
« Respuesta #11 : Marzo 07, 2015, 11:23:38 am »
amigo mira instale el handy y como que va bien pero lo instale en mi pc de mea y por rato e pone lentooo y el ventilador parece que e quisiera salir jejejeje, quisiera saber i lo tengo bien configurado o me falta algo, instale el q publica el amigo que dice marzo 2015

hola, bueno como dice nuestro amigo JV tienes que abrir el administrador de tarear y ver cual es el que te consume muchos recursos, y de paso danos tu especificaciones de la pc que lo estas probando... saludos


Desconectado ninohwifi

  • Jr. Member
  • **
  • Mensajes: 61
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 marzo
« Respuesta #12 : Marzo 08, 2015, 03:17:40 pm »
Hola a todos, como les prometi por aqui les traigo el HC el cual lo titule "Repack 2015", porque lo puse ese nombre, por la simple razon ...
De que use el HC cache que public nuesto amigo "JVProducciones".. y solo agrege algunas extenciones y reglas, aparte de eso que reordene un poco y borre lo que no se utilizaba.

Hay aun cosas por pulir y optimizar mas, pero ya les comparto lo que tengo,
Version HC 1.0.0.551 (El que ya usamos)

Dejare una guia de instalacion de nuestro amigo "JVProducciones"

Reglas utilizadas:
Regla N° 1
Redireccionamiento:
Código:
  1. /ip firewall nat
  2. add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=\
  3.     ! 192.168.10.2 dst-port=80,8080,8888,8880,8777,3477 in-interface="LAN" protocol=tcp \
  4.     to-addresses=192.168.10.2 to-ports=8080
Muchos me preguntan si es posible redireccionar el puerto 443 (https), hasta el momento no se ha podido hacer ni creo que se pueda. si lo que quieren es usar https en los clientes se tendrá que hacer la redireccion de manera manual en cada uno de los clientes agregando ip del proxy y el puerto a usar..

Regla N° 2
Marcado de paquetes:
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=HandyCache content=\
  3.     "Server: HandyCache" new-connection-mark=handy-connection protocol=tcp \
  4.     src-address=192.168.10.2
  5. add action=mark-packet chain=postrouting connection-mark=handy-connection \
  6.     new-packet-mark=handy-packs

Regla N° 3
y ahora el Fulcache:
Version 6.x
Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" limit-at=15M/15M max-limit=5M/5M name=\
  3.     HandyCache packet-marks=handy-packs priority=6/6 queue=default/default \
  4.     target=""

Regla N° 3.1
Version 5.x (aun no lo e probado)
Código:
  1. /queue tree
  2. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  3.     max-limit=5M name=HandyCache packet-mark=handy-packs parent=\
  4.     global-out priority=4 queue=default

Opcional: Recomendado


Una regla que uso
La verdad que para mi dejar una regla general para fullcache no me llama mucho la atención así que utilizo una pequeña variante que hace que cada uno de mis clientes tenga 5 megas de fullcache y limito a 10 megas como máximo de salida general de la cache, les dejo una imagen para que se guíen mejor:
Se los recomiendo

Código:
  1. /queue type
  2. add kind=pcq name=UserHC pcq-classifier=dst-address pcq-dst-address6-mask=64 \
  3.     pcq-rate=5M pcq-src-address6-mask=64
  4.  
Si usan esta regla opcional entonces no usen la regla N° 3 usen la siguiente regla.. que solo es la mikrotik Ver. 6.xxx

Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" max-limit=15M/15M name=HandyCache \
  3.     packet-marks=handy-packs priority=6/6 queue=default/UserHC
  4.  

Video de instalacion:
Pendiente... Cargando....









Link de descarga: -----> HandyCache Repack 2015

Agradecimientos:
Especiales por dejarnos publicar.
* Joemg6     --> Dueño del foro
* Moderadores           --> pongo moderadores porque no se cuanto hay :)

* JVProducciones
* HandyCache
*  Komunitas
*
* Otros que ya apareceran :)

EDITADO: Por Firecold


Algo que note con este repack  es que no siempre reproduce los videos de youtube a 360p.. te ha pasado?

Desconectado robertjs

  • Full Member
  • ***
  • Mensajes: 163
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 marzo update 1
« Respuesta #13 : Marzo 11, 2015, 12:27:50 pm »
Post modificado y lanzado un nuevo update.. no olviden leer atentamente.. Saludos

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 update 1
« Respuesta #14 : Marzo 12, 2015, 07:46:39 am »
hermano saludos
yo tengo la version 5.18 de mikrotik pero me interesa las ultimas reglas de full cache a cada clientes pero las reglas no me la acepta para el v5.18 serian tan amable de colocarla para el v 5.18 :) :) :)???
un saludos para todos desde venezuela

Desconectado robertjs

  • Full Member
  • ***
  • Mensajes: 163
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 update 1
« Respuesta #15 : Marzo 12, 2015, 10:58:23 am »
hermano saludos
yo tengo la version 5.18 de mikrotik pero me interesa las ultimas reglas de full cache a cada clientes pero las reglas no me la acepta para el v5.18 serian tan amable de colocarla para el v 5.18 :) :) :)???

Hola por aqui te dejo las reglas que co0mpartio nuestro amigo JV, pero no informo que no los probe ya que y uso la version 6.xx

Cita
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5M name=HandyCache packet-mark=handy-packs parent=\
    global-out priority=4 queue=default

pruebalo y saludos

Psd: Ya viene el update 2 con algunas mejoras.

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 update 1
« Respuesta #16 : Marzo 12, 2015, 04:52:05 pm »
Hola por aqui te dejo las reglas que co0mpartio nuestro amigo JV, pero no informo que no los probe ya que y uso la version 6.xx

pruebalo y saludos

Psd: Ya viene el update 2 con algunas mejoras.

hermano esa es la regla que estoy usando y da full cache pero la regla que a cada cliente le entrega 5m es la que queria pero gracias hermano :)
un saludos para todos desde venezuela

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 update 1
« Respuesta #17 : Marzo 12, 2015, 05:48:43 pm »
un saludos a todos
si son tan amables podrian subir una carpeta del handy que hace de los videos de youtube un solo archivo cuando hace el cache  que no sea en partes es que me gusta que este en un solo video

solo las mejoras gracias  :) :) :) :) :)
un saludos para todos desde venezuela

Desconectado robertjs

  • Full Member
  • ***
  • Mensajes: 163
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Repack 2015 update 1
« Respuesta #18 : Marzo 13, 2015, 11:24:19 pm »
hermano esa es la regla que estoy usando y da full cache pero la regla que a cada cliente le entrega 5m es la que queria pero gracias hermano :)

eso es facil ve donde dice "Queue Type - defaul" y cambialo escogiendo el UserHC y listo

Desconectado JVProducciones

  • Sr. Member
  • ****
  • Mensajes: 448
  • Ubicación: AQP
  • Intentando lo imposible se realiza lo posible!!
    • Ver Perfil
  • Me Gusta: 2
Re:HandyCache Repack 2015 update 1
« Respuesta #19 : Marzo 27, 2015, 01:33:42 pm »
Hola a todos, como les prometi por aqui les traigo el HC el cual lo titule "Repack 2015", porque lo puse ese nombre, por la simple razon ...
De que use el HC cache que public nuesto amigo "JVProducciones".. y solo agrege algunas extenciones y reglas, aparte de eso que reordene un poco y borre lo que no se utilizaba.

Hay aun cosas por pulir y optimizar mas, pero ya les comparto lo que tengo,
Version HC 1.0.0.551 (El que ya usamos)

Dejare una guia de instalacion de nuestro amigo "JVProducciones"

Reglas utilizadas:
Regla N° 1
Redireccionamiento:
Código:
  1. /ip firewall nat
  2. add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=\
  3.     ! 192.168.10.2 dst-port=80,8080,8888,8880,8777,3477 in-interface="LAN" protocol=tcp \
  4.     to-addresses=192.168.10.2 to-ports=8080
Muchos me preguntan si es posible redireccionar el puerto 443 (https), hasta el momento no se ha podido hacer ni creo que se pueda. si lo que quieren es usar https en los clientes se tendrá que hacer la redireccion de manera manual en cada uno de los clientes agregando ip del proxy y el puerto a usar..

Regla N° 2
Marcado de paquetes:
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=HandyCache content=\
  3.     "Server: HandyCache" new-connection-mark=handy-connection protocol=tcp \
  4.     src-address=192.168.10.2
  5. add action=mark-packet chain=postrouting connection-mark=handy-connection \
  6.     new-packet-mark=handy-packs

Regla N° 3
y ahora el Fulcache:
Version 6.x
Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" limit-at=15M/15M max-limit=5M/5M name=\
  3.     HandyCache packet-marks=handy-packs priority=6/6 queue=default/default \
  4.     target=""

Regla N° 3.1
Version 5.x (aun no lo e probado)
Código:
  1. /queue tree
  2. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  3.     max-limit=5M name=HandyCache packet-mark=handy-packs parent=\
  4.     global-out priority=4 queue=default

Opcional: Recomendado


Una regla que uso
La verdad que para mi dejar una regla general para fullcache no me llama mucho la atención así que utilizo una pequeña variante que hace que cada uno de mis clientes tenga 5 megas de fullcache y limito a 10 megas como máximo de salida general de la cache, les dejo una imagen para que se guíen mejor:
Se los recomiendo

Código:
  1. /queue type
  2. add kind=pcq name=UserHC pcq-classifier=dst-address pcq-dst-address6-mask=64 \
  3.     pcq-rate=5M pcq-src-address6-mask=64
  4.  
Si usan esta regla opcional entonces no usen la regla N° 3 usen la siguiente regla.. que solo es la mikrotik Ver. 6.xxx

Código:
  1. /queue simple
  2. add comment="Servidor Proxy HC" max-limit=15M/15M name=HandyCache \
  3.     packet-marks=handy-packs priority=6/6 queue=default/UserHC
  4.  

Video de instalacion:
Pendiente... Cargando....









Link de descarga: -----> HandyCache Repack 2015

Update 1
-----> Update 1 / 11-03-2015


Agradecimientos:
Especiales por dejarnos publicar.
* Joemg6     --> Dueño del foro
* Moderadores           --> pongo moderadores porque no se cuanto hay :)

* JVProducciones
* HandyCache
*  Komunitas
*
* Otros que ya apareceran :)

EDITADO: Por Firecold
Amigo robertjs prueba esta nueva extensión http://www.alterserv.com/foros/index.php?topic=1726.0
No está demás decir que deben desactivar las otras extensiones de youtube
bendiciones....