Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)

Desconectado bacalao

  • Jr. Member
  • **
  • Mensajes: 55
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Buenas a todos aquí les dejo mi aporte, el script me lo paso un amigo Cesar Rivas que tenia la idea y y lo termine modificando. Lo único que pido es que mantenga quien lo envió y quien lo modifico

Este script es muy funcional para los que tenemos mikrotik, que hace muy sencillo el verifica que las lineas de Internet que tengamos (wan) esten operativas, si una de ellas esta caída toma cualquiera que este operativa. Ejemplo:

Tenemos 4 Lineas con las siguientes IP

1.- 186.89.192.1
2.- 190.201.0.1
3.- 190.198.224.1
4.- 190.201.160.1

Se pierde la ip de la linea 2
1.- 186.89.192.1
2.-
3.- 190.198.224.1
4.- 190.201.160.1

entonces el script revisa y te asigna la ip de la linea 1 quedando asi
1.- 186.89.192.1
2.- 186.89.192.1
3.- 190.198.224.1
4.- 190.201.160.1


Script para la linea 1
Código:
  1. #SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
  2.  
  3. #Se toman las variables de las interfaces donde esten conectados la WAN
  4. :global GA [/ip dhcp-client get [find interface=ether2-gateway1] gateway]
  5. :global GB [/ip dhcp-client get [find interface=ether3-gateway2] gateway]
  6. :global GC [/ip dhcp-client get [find interface=ether4-Gateway3] gateway]
  7. :global GD [/ip dhcp-client get [find interface=ether5-Gateway4] gateway]
  8.  
  9. #creamos variables globales
  10. :global pingresultA
  11. :global pingresultB
  12. :global pingresultC
  13. :global pingresultD
  14. :global access 0
  15.  
  16.  
  17. :if ([:len $GA] != 0) do={
  18.                 :global pingresultA  [/ping $GA interface=ether2-gateway1 count=4]
  19. } else={
  20.                :global pingresultA 0
  21. }
  22.  
  23. #Si WAN1 esta activo:
  24.  
  25. :if ($pingresultA>0) do={
  26.     :local gatewayNuevo [/ip dhcp-client get [find interface=ether2-gateway1] gateway ]
  27.     :local gatewayActivo [/ip route get [find routing-mark=to_Wan1] gateway ]
  28.     :if ($gatewayNuevo != $gatewayActivo) do={
  29.         /ip route set [find routing-mark=to_Wan1] gateway=[/ip dhcp-client get [find interface=ether2-gateway1] gateway ]
  30.         :log info "Wan1 activo y se actualiza Gateway"
  31.     }  
  32.    
  33. }
  34.  
  35. #Si WAN1 se cae:
  36. :if ($pingresultA=0) do={
  37.  
  38.                 :local status [/ip dhcp-client get [/ip dhcp-client find interface=ether2-gateway1] status ]
  39.                  :if ($status="bound") do={
  40.                                  /ip dhcp-client set [find interface=ether2-gateway1] disabled=yes
  41.                                 :local d [/ip dhcp-client get [/ip dhcp-client find interface=ether2-gateway1] disabled ]
  42.                                  :if ($d=true) do={
  43.                                          /ip dhcp-client set [find interface=ether2-gateway1] disabled=no
  44.                                    }
  45.                  }
  46.              
  47.                  :if ([:len $GB] != 0) do={
  48.                        :global pingresultB  [/ping $GB interface=ether3-gateway2 count=4]
  49.                  } else={
  50.                        :global pingresultB 0              
  51.                  }
  52.  
  53.         :if ($pingresultB>0 and $access=0) do={
  54.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether3-gateway2] gateway ]
  55.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan1] gateway ]
  56.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  57.                         /ip route set [find routing-mark=to_Wan1] gateway=[/ip dhcp-client get [find interface=ether3-gateway2] gateway ]
  58.                         :log info "Wan1 inactivo se le asigna el Gateway del Wan2 "
  59.                 }      
  60.                        :global access 1
  61.         }
  62.  
  63.          :if ([:len $GC] != 0) do={
  64.                        :global pingresultC  [/ping $GC interface=ether4-Gateway3 count=4]
  65.                  } else={
  66.                        :global pingresultC 0              
  67.                  }
  68.  
  69.         :if ($pingresultC>0 && $access=0) do={
  70.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether4-Gateway3] gateway ]
  71.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan1] gateway ]
  72.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  73.                         /ip route set [find routing-mark=to_Wan1] gateway=[/ip dhcp-client get [find interface=ether4-Gateway3] gateway ]
  74.                         :log info "Wan1 inactivo se le asigna el Gateway del Wan3 "
  75.                 }      
  76.                        :global access 1        
  77.         }
  78.                :if ([:len $GD] != 0) do={
  79.                        :global pingresultD  [/ping $GD interface=ether5-Gateway4 count=4]
  80.                  } else={
  81.                        :global pingresultD 0              
  82.                  }
  83.  
  84.         :if ($pingresultD>0 && $access=0) do={
  85.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether5-Gateway4] gateway ]
  86.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan1] gateway ]
  87.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  88.                         /ip route set [find routing-mark=to_Wan1] gateway=[/ip dhcp-client get [find interface=ether5-Gateway4] gateway ]
  89.                         :log info "Wan1 inactivo se le asigna el Gateway del Wan4 "
  90.                 }      
  91.                   :global access 1
  92.  
  93.         }
  94. }
  95.  

Script para la linea 2

Código:
  1. #SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
  2.  
  3. :global GA [/ip dhcp-client get [find interface=ether2-gateway1] gateway]
  4. :global GB [/ip dhcp-client get [find interface=ether3-gateway2] gateway]
  5. :global GC [/ip dhcp-client get [find interface=ether4-Gateway3] gateway]
  6. :global GD [/ip dhcp-client get [find interface=ether5-Gateway4] gateway]
  7.  
  8.  
  9. :global pingresultA
  10. :global pingresultB
  11. :global pingresultC
  12. :global pingresultD
  13. :global access 0
  14.  
  15.  
  16. :if ([:len $GB] != 0) do={
  17.                 :global pingresultB  [/ping $GB interface=ether3-gateway2 count=4]
  18. } else={
  19.                :global pingresultB 0
  20. }
  21.  
  22. #Si WAN2 esta activo:
  23. :if ($pingresultB>0) do={
  24.     :local gatewayNuevo [/ip dhcp-client get [find interface=ether3-gateway2] gateway ]
  25.     :local gatewayActivo [/ip route get [find routing-mark=to_Wan2] gateway ]
  26.     :if ($gatewayNuevo != $gatewayActivo) do={
  27.         /ip route set [find routing-mark=to_Wan2] gateway=[/ip dhcp-client get [find interface=ether3-gateway2] gateway ]
  28.         :log info "Wan2 activo y se actualiza Gateway"
  29.     }  
  30.    
  31. }
  32.  
  33. #Si WAN2 se cae:
  34. :if ($pingresultB=0) do={
  35.  
  36.                 :local status [/ip dhcp-client get [/ip dhcp-client find interface=ether3-gateway2] status ]
  37.                  :if ($status="bound") do={
  38.                                  /ip dhcp-client set [find interface=ether3-gateway2] disabled=yes
  39.                                 :local d [/ip dhcp-client get [/ip dhcp-client find interface=ether3-gateway2] disabled ]
  40.                                  :if ($d=true) do={
  41.                                          /ip dhcp-client set [find interface=ether3-gateway2] disabled=no
  42.                                    }
  43.                  }
  44.              
  45.                  :if ([:len $GA] != 0) do={
  46.                        :global pingresultA  [/ping $GA interface=ether2-gateway1 count=4]
  47.                  } else={
  48.                        :global pingresultA 0              
  49.                  }
  50.  
  51.         :if ($pingresultA>0 and $access=0) do={
  52.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether2-gateway1] gateway ]
  53.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan2] gateway ]
  54.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  55.                         /ip route set [find routing-mark=to_Wan2] gateway=[/ip dhcp-client get [find interface=ether2-gateway1] gateway ]
  56.                         :log info "Wan2 inactivo se le asigna el Gateway del Wan1 "
  57.                 }      
  58.                        :global access 1
  59.         }
  60.  
  61.          :if ([:len $GC] != 0) do={
  62.                        :global pingresultC  [/ping $GC interface=ether4-Gateway3 count=4]
  63.                  } else={
  64.                        :global pingresultC 0              
  65.                  }
  66.  
  67.         :if ($pingresultC>0 && $access=0) do={
  68.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether4-Gateway3] gateway ]
  69.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan2] gateway ]
  70.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  71.                         /ip route set [find routing-mark=to_Wan2] gateway=[/ip dhcp-client get [find interface=ether4-Gateway3] gateway ]
  72.                         :log info "Wan2 inactivo se le asigna el Gateway del Wan3 "
  73.                 }      
  74.                        :global access 1        
  75.         }
  76.                :if ([:len $GD] != 0) do={
  77.                        :global pingresultD  [/ping $GD interface=ether5-Gateway4 count=4]
  78.                  } else={
  79.                        :global pingresultD 0              
  80.                  }
  81.  
  82.         :if ($pingresultD>0 && $access=0) do={
  83.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether5-Gateway4] gateway ]
  84.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan2] gateway ]
  85.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  86.                         /ip route set [find routing-mark=to_Wan2] gateway=[/ip dhcp-client get [find interface=ether5-Gateway4] gateway ]
  87.                         :log info "Wan2 inactivo se le asigna el Gateway del Wan4 "
  88.                 }      
  89.                   :global access 1
  90.  
  91.         }
  92. }
  93.  

Script para la linea 3

Código:
  1. #SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
  2.  
  3. :global GA [/ip dhcp-client get [find interface=ether2-gateway1] gateway]
  4. :global GB [/ip dhcp-client get [find interface=ether3-gateway2] gateway]
  5. :global GC [/ip dhcp-client get [find interface=ether4-Gateway3] gateway]
  6. :global GD [/ip dhcp-client get [find interface=ether5-Gateway4] gateway]
  7.  
  8.  
  9. :global pingresultA
  10. :global pingresultB
  11. :global pingresultC
  12. :global pingresultD
  13. :global access 0
  14.  
  15.  
  16. :if ([:len $GC] != 0) do={
  17.                 :global pingresultC  [/ping $GC interface=ether4-Gateway3 count=4]
  18. } else={
  19.                :global pingresultC 0
  20. }
  21.  
  22. #Si WAN3 esta activo:
  23. :if ($pingresultC>0) do={
  24.     :local gatewayNuevo [/ip dhcp-client get [find interface=ether4-Gateway3] gateway ]
  25.     :local gatewayActivo [/ip route get [find routing-mark=to_Wan3] gateway ]
  26.     :if ($gatewayNuevo != $gatewayActivo) do={
  27.         /ip route set [find routing-mark=to_Wan3] gateway=[/ip dhcp-client get [find interface=ether4-Gateway3] gateway ]
  28.         :log info "Wan3 activo y se actualiza Gateway"
  29.     }  
  30.    
  31. }
  32.  
  33. #Si WAN3 se cae:
  34. :if ($pingresultC=0) do={
  35.  
  36.                 :local status [/ip dhcp-client get [/ip dhcp-client find interface=ether4-Gateway3] status ]
  37.                  :if ($status="bound") do={
  38.                                  /ip dhcp-client set [find interface=ether4-Gateway3] disabled=yes
  39.                                 :local d [/ip dhcp-client get [/ip dhcp-client find interface=ether4-Gateway3] disabled ]
  40.                                  :if ($d=true) do={
  41.                                          /ip dhcp-client set [find interface=ether4-Gateway3] disabled=no
  42.                                    }
  43.                  }
  44.              
  45.                  :if ([:len $GA] != 0) do={
  46.                        :global pingresultA  [/ping $GA interface=ether2-gateway1 count=4]
  47.                  } else={
  48.                        :global pingresultA 0              
  49.                  }
  50.  
  51.         :if ($pingresultA>0 and $access=0) do={
  52.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether2-gateway1] gateway ]
  53.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan3] gateway ]
  54.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  55.                         /ip route set [find routing-mark=to_Wan3] gateway=[/ip dhcp-client get [find interface=ether2-gateway1] gateway ]
  56.                         :log info "Wan3 inactivo se le asigna el Gateway del Wan1 "
  57.                 }      
  58.                        :global access 1
  59.         }
  60.  
  61.          :if ([:len $GB] != 0) do={
  62.                        :global pingresultC  [/ping $GB interface=ether3-gateway2 count=4]
  63.                  } else={
  64.                        :global pingresultC 0              
  65.                  }
  66.  
  67.         :if ($pingresultB>0 && $access=0) do={
  68.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether3-gateway2] gateway ]
  69.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan3] gateway ]
  70.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  71.                         /ip route set [find routing-mark=to_Wan3] gateway=[/ip dhcp-client get [find interface=ether3-gateway2] gateway ]
  72.                         :log info "Wan3 inactivo se le asigna el Gateway del Wan2 "
  73.                 }      
  74.                        :global access 1        
  75.         }
  76.                :if ([:len $GD] != 0) do={
  77.                        :global pingresultD  [/ping $GD interface=ether5-Gateway4 count=4]
  78.                  } else={
  79.                        :global pingresultD 0              
  80.                  }
  81.  
  82.         :if ($pingresultD>0 && $access=0) do={
  83.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether5-Gateway4] gateway ]
  84.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan3] gateway ]
  85.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  86.                         /ip route set [find routing-mark=to_Wan3] gateway=[/ip dhcp-client get [find interface=ether5-Gateway4] gateway ]
  87.                         :log info "Wan3 inactivo se le asigna el Gateway del Wan4 "
  88.                 }      
  89.                   :global access 1
  90.  
  91.         }
  92. }
  93.  

Script para la linea 4

Código:
  1. #SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
  2.  
  3. :global GA [/ip dhcp-client get [find interface=ether2-gateway1] gateway]
  4. :global GB [/ip dhcp-client get [find interface=ether3-gateway2] gateway]
  5. :global GC [/ip dhcp-client get [find interface=ether4-Gateway3] gateway]
  6. :global GD [/ip dhcp-client get [find interface=ether5-Gateway4] gateway]
  7.  
  8.  
  9. :global pingresultA
  10. :global pingresultB
  11. :global pingresultC
  12. :global pingresultD
  13. :global access 0
  14.  
  15.  
  16. :if ([:len $GD] != 0) do={
  17.                 :global pingresultC  [/ping $GD interface=ether5-Gateway4 count=4]
  18. } else={
  19.                :global pingresultD 0
  20. }
  21.  
  22. #Si WAN4 esta activo:
  23. :if ($pingresultD>0) do={
  24.     :local gatewayNuevo [/ip dhcp-client get [find interface=ether5-Gateway4] gateway ]
  25.     :local gatewayActivo [/ip route get [find routing-mark=to_Wan4] gateway ]
  26.     :if ($gatewayNuevo != $gatewayActivo) do={
  27.         /ip route set [find routing-mark=to_Wan4] gateway=[/ip dhcp-client get [find interface=ether5-Gateway4] gateway ]
  28.         :log info "Wan4 activo y se actualiza Gateway"
  29.     }  
  30.    
  31. }
  32.  
  33. #Si WAN4 se cae:
  34. :if ($pingresultD=0) do={
  35.  
  36.                 :local status [/ip dhcp-client get [/ip dhcp-client find interface=ether5-Gateway4] status ]
  37.                  :if ($status="bound") do={
  38.                                  /ip dhcp-client set [find interface=ether5-Gateway4] disabled=yes
  39.                                 :local d [/ip dhcp-client get [/ip dhcp-client find interface=ether5-Gateway4] disabled ]
  40.                                  :if ($d=true) do={
  41.                                          /ip dhcp-client set [find interface=ether5-Gateway4] disabled=no
  42.                                    }
  43.                  }
  44.              
  45.                  :if ([:len $GA] != 0) do={
  46.                        :global pingresultA  [/ping $GA interface=ether2-gateway1 count=4]
  47.                  } else={
  48.                        :global pingresultA 0              
  49.                  }
  50.  
  51.         :if ($pingresultA>0 and $access=0) do={
  52.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether2-gateway1] gateway ]
  53.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan4] gateway ]
  54.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  55.                         /ip route set [find routing-mark=to_Wan4] gateway=[/ip dhcp-client get [find interface=ether2-gateway1] gateway ]
  56.                         :log info "Wan4 inactivo se le asigna el Gateway del Wan1 "
  57.                 }      
  58.                        :global access 1
  59.         }
  60.  
  61.          :if ([:len $GB] != 0) do={
  62.                        :global pingresultC  [/ping $GB interface=ether3-gateway2 count=4]
  63.                  } else={
  64.                        :global pingresultC 0              
  65.                  }
  66.  
  67.         :if ($pingresultB>0 && $access=0) do={
  68.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether3-gateway2] gateway ]
  69.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan4] gateway ]
  70.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  71.                         /ip route set [find routing-mark=to_Wan4] gateway=[/ip dhcp-client get [find interface=ether3-gateway2] gateway ]
  72.                         :log info "Wan4 inactivo se le asigna el Gateway del Wan2 "
  73.                 }      
  74.                        :global access 1        
  75.         }
  76.                :if ([:len $GC] != 0) do={
  77.                        :global pingresultC  [/ping $GC interface=ether4-Gateway3 count=4]
  78.                  } else={
  79.                        :global pingresultC 0              
  80.                  }
  81.  
  82.         :if ($pingresultC>0 && $access=0) do={
  83.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=ether4-Gateway3] gateway ]
  84.                 :local gatewayActivoA [/ip route get [find routing-mark=to_Wan4] gateway ]
  85.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  86.                         /ip route set [find routing-mark=to_Wan4] gateway=[/ip dhcp-client get [find interface=ether4-Gateway3] gateway ]
  87.                         :log info "Wan4 inactivo se le asigna el Gateway del Wan3 "
  88.                 }      
  89.                   :global access 1
  90.  
  91.         }
  92. }
  93.  
  94.  

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #1 : marzo 16, 2015, 04:29:42 pm »
gracias mi hermano lo que estaba esperandoo :) :) :) :) :)

una pregunta copio y pego todo esto tal como esta tengo que hacer una modificacion ??

aqui esta ether2 ether3 ether 4 eso lo tendria que cambiar porque lo tengo como wan1 wan2 wan3 wan4
??
un saludos para todos desde venezuela

Desconectado bacalao

  • Jr. Member
  • **
  • Mensajes: 55
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #2 : marzo 16, 2015, 05:20:50 pm »
gracias mi hermano lo que estaba esperandoo :) :) :) :) :)

una pregunta copio y pego todo esto tal como esta tengo que hacer una modificacion ??

aqui esta ether2 ether3 ether 4 eso lo tendria que cambiar porque lo tengo como wan1 wan2 wan3 wan4
??

Hola si por ejemplo los que digan esto :global GA [/ip dhcp-client get [find interface=ether2-gateway1] gateway] y si es como dices lo pasas :global GA [/ip dhcp-client get [find interface=wan1] gateway]

Tienes q estar pendiente de las mayusculas y minusculas

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #3 : marzo 16, 2015, 06:01:05 pm »
Hola si por ejemplo los que digan esto :global GA [/ip dhcp-client get [find interface=ether2-gateway1] gateway] y si es como dices lo pasas :global GA [/ip dhcp-client get [find interface=wan1] gateway]

Tienes q estar pendiente de las mayusculas y minusculas


mi hermano gracia por ayudarme aqui modifique el primer scrip para ver si esta bien



 #SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
     
    #Se toman las variables de las interfaces donde esten conectados la wan
    :global GA [/ip dhcp-client get [find interface=wan2-gateway1] gateway]
    :global GB [/ip dhcp-client get [find interface=wan3-gateway2] gateway]
    :global GC [/ip dhcp-client get [find interface=wan4-Gateway3] gateway]
    :global GD [/ip dhcp-client get [find interface=wan5-Gateway4] gateway]
     
    #creamos variables globales
    :global pingresultA
    :global pingresultB
    :global pingresultC
    :global pingresultD
    :global access 0
     
     
    :if ([:len $GA] != 0) do={
                    :global pingresultA  [/ping $GA interface=wan2-gateway1 count=4]
    } else={
                   :global pingresultA 0
    }
     
    #Si wan1 esta activo:
     
    :if ($pingresultA>0) do={
        :local gatewayNuevo [/ip dhcp-client get [find interface=wan2-gateway1] gateway ]
        :local gatewayActivo [/ip route get [find routing-mark=to_wan1] gateway ]
        :if ($gatewayNuevo != $gatewayActivo) do={
            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan2-gateway1] gateway ]
            :log info "wan1 activo y se actualiza Gateway"
        } 
       
    }
     
    #Si wan1 se cae:
    :if ($pingresultA=0) do={
     
                    :local status [/ip dhcp-client get [/ip dhcp-client find interface=wan2-gateway1] status ]
                     :if ($status="bound") do={
                                     /ip dhcp-client set [find interface=wan2-gateway1] disabled=yes
                                    :local d [/ip dhcp-client get [/ip dhcp-client find interface=wan2-gateway1] disabled ]
                                     :if ($d=true) do={
                                             /ip dhcp-client set [find interface=wan2-gateway1] disabled=no
                                       }
                     }
                 
                     :if ([:len $GB] != 0) do={
                           :global pingresultB  [/ping $GB interface=wan3-gateway2 count=4]
                     } else={
                           :global pingresultB 0             
                     }
     
            :if ($pingresultB>0 and $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan3-gateway2] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan3-gateway2] gateway ]
                            :log info "Wan1 inactivo se le asigna el Gateway del wan2 "
                    }     
                           :global access 1
            }
     
             :if ([:len $GC] != 0) do={
                           :global pingresultC  [/ping $GC interface=wan4-Gateway3 count=4]
                     } else={
                           :global pingresultC 0             
                     }
     
            :if ($pingresultC>0 && $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan4-Gateway3] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan4-Gateway3] gateway ]
                            :log info "Wan1 inactivo se le asigna el Gateway del wan3 "
                    }     
                           :global access 1       
            }
                   :if ([:len $GD] != 0) do={
                           :global pingresultD  [/ping $GD interface=wan5-Gateway4 count=4]
                     } else={
                           :global pingresultD 0             
                     }
     
            :if ($pingresultD>0 && $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan5-Gateway4] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_Wan1] gateway=[/ip dhcp-client get [find interface=wan5-Gateway4] gateway ]
                            :log info "wan1 inactivo se le asigna el Gateway del wan4 "
                    }     
                      :global access 1
     
            }
    }
     
un saludos para todos desde venezuela

Desconectado bacalao

  • Jr. Member
  • **
  • Mensajes: 55
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #4 : marzo 16, 2015, 06:16:32 pm »

mi hermano gracia por ayudarme aqui modifique el primer scrip para ver si esta bien



 #SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
     
    #Se toman las variables de las interfaces donde esten conectados la wan
    :global GA [/ip dhcp-client get [find interface=wan2-gateway1] gateway]
    :global GB [/ip dhcp-client get [find interface=wan3-gateway2] gateway]
    :global GC [/ip dhcp-client get [find interface=wan4-Gateway3] gateway]
    :global GD [/ip dhcp-client get [find interface=wan5-Gateway4] gateway]
     
    #creamos variables globales
    :global pingresultA
    :global pingresultB
    :global pingresultC
    :global pingresultD
    :global access 0
     
     
    :if ([:len $GA] != 0) do={
                    :global pingresultA  [/ping $GA interface=wan2-gateway1 count=4]
    } else={
                   :global pingresultA 0
    }
     
    #Si wan1 esta activo:
     
    :if ($pingresultA>0) do={
        :local gatewayNuevo [/ip dhcp-client get [find interface=wan2-gateway1] gateway ]
        :local gatewayActivo [/ip route get [find routing-mark=to_wan1] gateway ]
        :if ($gatewayNuevo != $gatewayActivo) do={
            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan2-gateway1] gateway ]
            :log info "wan1 activo y se actualiza Gateway"
        } 
       
    }
     
    #Si wan1 se cae:
    :if ($pingresultA=0) do={
     
                    :local status [/ip dhcp-client get [/ip dhcp-client find interface=wan2-gateway1] status ]
                     :if ($status="bound") do={
                                     /ip dhcp-client set [find interface=wan2-gateway1] disabled=yes
                                    :local d [/ip dhcp-client get [/ip dhcp-client find interface=wan2-gateway1] disabled ]
                                     :if ($d=true) do={
                                             /ip dhcp-client set [find interface=wan2-gateway1] disabled=no
                                       }
                     }
                 
                     :if ([:len $GB] != 0) do={
                           :global pingresultB  [/ping $GB interface=wan3-gateway2 count=4]
                     } else={
                           :global pingresultB 0             
                     }
     
            :if ($pingresultB>0 and $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan3-gateway2] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan3-gateway2] gateway ]
                            :log info "Wan1 inactivo se le asigna el Gateway del wan2 "
                    }     
                           :global access 1
            }
     
             :if ([:len $GC] != 0) do={
                           :global pingresultC  [/ping $GC interface=wan4-Gateway3 count=4]
                     } else={
                           :global pingresultC 0             
                     }
     
            :if ($pingresultC>0 && $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan4-Gateway3] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan4-Gateway3] gateway ]
                            :log info "Wan1 inactivo se le asigna el Gateway del wan3 "
                    }     
                           :global access 1       
            }
                   :if ([:len $GD] != 0) do={
                           :global pingresultD  [/ping $GD interface=wan5-Gateway4 count=4]
                     } else={
                           :global pingresultD 0             
                     }
     
            :if ($pingresultD>0 && $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan5-Gateway4] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_Wan1] gateway=[/ip dhcp-client get [find interface=wan5-Gateway4] gateway ]
                            :log info "wan1 inactivo se le asigna el Gateway del wan4 "
                    }     
                      :global access 1
     
            }
    }
   

amigo mio pasame tu id y password del team y te ayudo gustosamente a que este perfecto el failover

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #5 : marzo 16, 2015, 06:30:06 pm »
saludo hermano estaba terminando de modificar todo los scrip

no esta bien la modificacion ??
en estos momento tengo que salir a la iglesia pero regreso en 2 horas y medias lo que subi fue el primer escrip de la linea 1
un saludos para todos desde venezuela

Desconectado bacalao

  • Jr. Member
  • **
  • Mensajes: 55
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #6 : marzo 16, 2015, 06:59:56 pm »
saludo hermano estaba terminando de modificar todo los scrip

no esta bien la modificacion ??
en estos momento tengo que salir a la iglesia pero regreso en 2 horas y medias lo que subi fue el primer escrip de la linea 1
Si tu interface de red se llama wan1.....5 deberia quedar asi
Código:
  1.     :global GA [/ip dhcp-client get [find interface=wan2] gateway]
  2.     :global GB [/ip dhcp-client get [find interface=wan3] gateway]
  3.     :global GC [/ip dhcp-client get [find interface=wan4] gateway]
  4.     :global GD [/ip dhcp-client get [find interface=wan5] gateway]

Desconectado TooR

  • Full Member
  • ***
  • Mensajes: 159
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #7 : marzo 16, 2015, 07:33:57 pm »
Si tu interface de red se llama wan1.....5 deberia quedar asi
Código:
  1.     :global GA [/ip dhcp-client get [find interface=wan2] gateway]
  2.     :global GB [/ip dhcp-client get [find interface=wan3] gateway]
  3.     :global GC [/ip dhcp-client get [find interface=wan4] gateway]
  4.     :global GD [/ip dhcp-client get [find interface=wan5] gateway]

Ademas pendientes con el routing-mark=to_WanX
X= 1, 2, 3, 4  :-*

Si usan la misma to_Wan1, to_Wan2, to_Wan3, to_Wan4 no habrá problema.

Desconectado bacalao

  • Jr. Member
  • **
  • Mensajes: 55
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #8 : marzo 16, 2015, 07:39:44 pm »
Ademas pendientes con el routing-mark=to_WanX
X= 1, 2, 3, 4  :-*

Si usan la misma to_Wan1, to_Wan2, to_Wan3, to_Wan4 no habrá problema.

gracias amigo Toor se me paso decir sobre el routing-mark.

lo mas importante es leer, aprender y aplicar

saludos

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #9 : marzo 16, 2015, 08:57:36 pm »
bueno este es el primer scrip corregido mi wan son wan1 wan2 wan3 wan4 y lan

#SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
     
    #Se toman las variables de las interfaces donde esten conectados la wan
    :global GA [/ip dhcp-client get [find interface=wan2-gateway]
    :global GB [/ip dhcp-client get [find interface=wan3-gateway]
    :global GC [/ip dhcp-client get [find interface=wan4-Gateway]
    :global GD [/ip dhcp-client get [find interface=wan5-Gateway]
     
    #creamos variables globales
    :global pingresultA
    :global pingresultB
    :global pingresultC
    :global pingresultD
    :global access 0
     
     
    :if ([:len $GA] != 0) do={
                    :global pingresultA  [/ping $GA interface=wan2-gateway1 count=4]
    } else={
                   :global pingresultA 0
    }
     
    #Si wan1 esta activo:
     
    :if ($pingresultA>0) do={
        :local gatewayNuevo [/ip dhcp-client get [find interface=wan2-gateway1] gateway ]
        :local gatewayActivo [/ip route get [find routing-mark=to_wan1] gateway ]
        :if ($gatewayNuevo != $gatewayActivo) do={
            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan2-gateway1] gateway ]
            :log info "wan1 activo y se actualiza Gateway"
        } 
       
    }
     
    #Si wan1 se cae:
    :if ($pingresultA=0) do={
     
                    :local status [/ip dhcp-client get [/ip dhcp-client find interface=wan2-gateway1] status ]
                     :if ($status="bound") do={
                                     /ip dhcp-client set [find interface=wan2-gateway1] disabled=yes
                                    :local d [/ip dhcp-client get [/ip dhcp-client find interface=wan2-gateway1] disabled ]
                                     :if ($d=true) do={
                                             /ip dhcp-client set [find interface=wan2-gateway1] disabled=no
                                       }
                     }
                 
                     :if ([:len $GB] != 0) do={
                           :global pingresultB  [/ping $GB interface=wan3-gateway2 count=4]
                     } else={
                           :global pingresultB 0             
                     }
     
            :if ($pingresultB>0 and $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan3-gateway2] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan3-gateway2] gateway ]
                            :log info "Wan1 inactivo se le asigna el Gateway del wan2 "
                    }     
                           :global access 1
            }
     
             :if ([:len $GC] != 0) do={
                           :global pingresultC  [/ping $GC interface=wan4-Gateway3 count=4]
                     } else={
                           :global pingresultC 0             
                     }
     
            :if ($pingresultC>0 && $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan4-Gateway3] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan4-Gateway3] gateway ]
                            :log info "Wan1 inactivo se le asigna el Gateway del wan3 "
                    }     
                           :global access 1       
            }
                   :if ([:len $GD] != 0) do={
                           :global pingresultD  [/ping $GD interface=wan5-Gateway4 count=4]
                     } else={
                           :global pingresultD 0             
                     }
     
            :if ($pingresultD>0 && $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan5-Gateway4] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_Wan1] gateway=[/ip dhcp-client get [find interface=wan5-Gateway4] gateway ]
                            :log info "wan1 inactivo se le asigna el Gateway del wan4 "
                    }     
                      :global access 1
     
            }
    }
     
un saludos para todos desde venezuela

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #10 : marzo 16, 2015, 08:59:24 pm »
scrip linea 2



Cita
#SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
     
    :global GA [/ip dhcp-client get [find interface=wan2-gateway]
    :global GB [/ip dhcp-client get [find interface=wan3-gateway]
    :global GC [/ip dhcp-client get [find interface=wan4-Gateway]
    :global GD [/ip dhcp-client get [find interface=wan5-Gateway]
     
     
    :global pingresultA
    :global pingresultB
    :global pingresultC
    :global pingresultD
    :global access 0
     
     
    :if ([:len $GB] != 0) do={
                    :global pingresultB  [/ping $GB interface=wan3-gateway2 count=4]
    } else={
                   :global pingresultB 0
    }
     
    #Si wan2 esta activo:
    :if ($pingresultB>0) do={
        :local gatewayNuevo [/ip dhcp-client get [find interface=wan3-gateway2] gateway ]
        :local gatewayActivo [/ip route get [find routing-mark=to_wan2] gateway ]
        :if ($gatewayNuevo != $gatewayActivo) do={
            /ip route set [find routing-mark=to_wan2] gateway=[/ip dhcp-client get [find interface=wan3-gateway2] gateway ]
            :log info "wan2 activo y se actualiza Gateway"
        } 
       
    }
     
    #Si wan2 se cae:
    :if ($pingresultB=0) do={
     
                    :local status [/ip dhcp-client get [/ip dhcp-client find interface=wan3-gateway2] status ]
                     :if ($status="bound") do={
                                     /ip dhcp-client set [find interface=wan3-gateway2] disabled=yes
                                    :local d [/ip dhcp-client get [/ip dhcp-client find interface=wan3-gateway2] disabled ]
                                     :if ($d=true) do={
                                             /ip dhcp-client set [find interface=wan3-gateway2] disabled=no
                                       }
                     }
                 
                     :if ([:len $GA] != 0) do={
                           :global pingresultA  [/ping $GA interface=wan2-gateway1 count=4]
                     } else={
                           :global pingresultA 0             
                     }
     
            :if ($pingresultA>0 and $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan2-gateway1] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan2] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan2] gateway=[/ip dhcp-client get [find interface=wan2-gateway1] gateway ]
                            :log info "wan2 inactivo se le asigna el Gateway del wan1 "
                    }     
                           :global access 1
            }
     
             :if ([:len $GC] != 0) do={
                           :global pingresultC  [/ping $GC interface=wan4-Gateway3 count=4]
                     } else={
                           :global pingresultC 0             
                     }
     
            :if ($pingresultC>0 && $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan4-Gateway3] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan2] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan2] gateway=[/ip dhcp-client get [find interface=wan4-Gateway3] gateway ]
                            :log info "wan2 inactivo se le asigna el Gateway del wan3 "
                    }     
                           :global access 1       
            }
                   :if ([:len $GD] != 0) do={
                           :global pingresultD  [/ping $GD interface=wan5-Gateway4 count=4]
                     } else={
                           :global pingresultD 0             
                     }
     
            :if ($pingresultD>0 && $access=0) do={
                    :local gatewayNuevoB [/ip dhcp-client get [find interface=wan5-Gateway4] gateway ]
                    :local gatewayActivoA [/ip route get [find routing-mark=to_wan2] gateway ]
                    :if ($gatewayNuevoB != $gatewayActivoA) do={
                            /ip route set [find routing-mark=to_wan2] gateway=[/ip dhcp-client get [find interface=wan5-Gateway4] gateway ]
                            :log info "wan2 inactivo se le asigna el Gateway del wan4 "
                    }     
                      :global access 1
     
            }
    }
     
     
un saludos para todos desde venezuela

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 30
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #11 : marzo 16, 2015, 09:48:47 pm »
Amigo al principio de su post puede poner una descripcion bastante descriptiva de lo que hace dicho script y su funcionamiento, ya que para los no versados en MK, no nos dice nada, saludos

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #12 : marzo 18, 2015, 09:39:51 pm »
saludo hermanos del forum
gracias a bacalao por su ayuda realize el procedimiento y adjunto imagen de mi balanceador para ver si si esta bien  :D :D :D :D


un saludos para todos desde venezuela

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #13 : marzo 18, 2015, 09:49:11 pm »



un saludos para todos desde venezuela

Desconectado TooR

  • Full Member
  • ***
  • Mensajes: 159
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #14 : marzo 19, 2015, 01:02:20 am »
Saludos,

Si nombra sus interfaces como "wan1, wan2, wan3, wan4"... Por que en los script las tiene con wan2, wan3, wan4, wan5 ???

Código: [Seleccionar]
:global GA [/ip dhcp-client get [find interface=wan2-gateway]
:global GB [/ip dhcp-client get [find interface=wan3-gateway]
:global GC [/ip dhcp-client get [find interface=wan4-Gateway]
:global GD [/ip dhcp-client get [find interface=wan5-Gateway]



Lo otro, es que debido a que el nombre del script lo coloco con espacio "script wan1", al agregarlo al Scheduler el nombre debe ir con comillas:

Código: [Seleccionar]
sys scr run "script wan1"


 :-*

Debería colocar una imagen de lo que tenga en IP - ROUTE, ese es otro punto importante para que el script funcione, esto depende del tipo de balanceo que utiliza.

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #15 : marzo 19, 2015, 08:05:16 am »
ufffff parece que esta mal hay que volver a modificar todo tienes razon mis wan   son wan1  wan2 wan3 wan4  :D
aqui otra imagen del router



un saludos para todos desde venezuela

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #16 : marzo 19, 2015, 08:13:04 am »
saludo hermano entonce deberia de quedar asi

:global GA [/ip dhcp-client get [find interface=wan1-gateway]
:global GB [/ip dhcp-client get [find interface=wan2-gateway]
:global GC [/ip dhcp-client get [find interface=wan3-Gateway]
:global GD [/ip dhcp-client get [find interface=wan4-Gateway]


el problema es que tengo que cambiar todo lo del scrip 
ya corregi lo de las comillas con razon no funciona jejeje pero estoy aprendiendo
un saludos para todos desde venezuela

Desconectado bacalao

  • Jr. Member
  • **
  • Mensajes: 55
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #17 : marzo 19, 2015, 11:54:57 am »
saludo hermano entonce deberia de quedar asi

:global GA [/ip dhcp-client get [find interface=wan1-gateway]
:global GB [/ip dhcp-client get [find interface=wan2-gateway]
:global GC [/ip dhcp-client get [find interface=wan3-Gateway]
:global GD [/ip dhcp-client get [find interface=wan4-Gateway]


el problema es que tengo que cambiar todo lo del scrip 
ya corregi lo de las comillas con razon no funciona jejeje pero estoy aprendiendo


Buenas amigo eso debe quedar asi

Código:
  1. :global GA [/ip dhcp-client get [find interface=wan1]gateway]
  2. :global GB [/ip dhcp-client get [find interface=wan2]gateway]
  3. :global GC [/ip dhcp-client get [find interface=wan3]gateway]
  4. :global GD [/ip dhcp-client get [find interface=wan4]gateway]
  5.  

de los que yo te pase te voy a modificar el script para  la linea 1 y tu modificaras el resto

Código:
  1. #SCRIPT ENVIADO POR CESAR O. RIVAS Y MODIFICADO POR MOHAMED W. HAMMAUD
  2.  
  3. #Se toman las variables de las interfaces donde esten conectados la WAN
  4. :global GA [/ip dhcp-client get [find interface=wan1] gateway]
  5. :global GB [/ip dhcp-client get [find interface=wan2] gateway]
  6. :global GC [/ip dhcp-client get [find interface=wan3] gateway]
  7. :global GD [/ip dhcp-client get [find interface=wan4] gateway]
  8.  
  9. #creamos variables globales
  10. :global pingresultA
  11. :global pingresultB
  12. :global pingresultC
  13. :global pingresultD
  14. :global access 0
  15.  
  16.  
  17. :if ([:len $GA] != 0) do={
  18.                 :global pingresultA  [/ping $GA interface=wan1 count=4]
  19. } else={
  20.                :global pingresultA 0
  21. }
  22.  
  23. #Si WAN1 esta activo:
  24.  
  25. :if ($pingresultA>0) do={
  26.     :local gatewayNuevo [/ip dhcp-client get [find interface=wan1] gateway ]
  27.     :local gatewayActivo [/ip route get [find routing-mark=to_wan1] gateway ]
  28.     :if ($gatewayNuevo != $gatewayActivo) do={
  29.         /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan1] gateway ]
  30.         :log info "Wan1 activo y se actualiza Gateway"
  31.     }  
  32.    
  33. }
  34.  
  35. #Si WAN1 se cae:
  36. :if ($pingresultA=0) do={
  37.  
  38.                 :local status [/ip dhcp-client get [/ip dhcp-client find interface=wan1] status ]
  39.                  :if ($status="bound") do={
  40.                                  /ip dhcp-client set [find interface=wan1] disabled=yes
  41.                                 :local d [/ip dhcp-client get [/ip dhcp-client find interface=wan1] disabled ]
  42.                                  :if ($d=true) do={
  43.                                          /ip dhcp-client set [find interface=wan1] disabled=no
  44.                                    }
  45.                  }
  46.              
  47.                  :if ([:len $GB] != 0) do={
  48.                        :global pingresultB  [/ping $GB interface=wan2 count=4]
  49.                  } else={
  50.                        :global pingresultB 0              
  51.                  }
  52.  
  53.         :if ($pingresultB>0 and $access=0) do={
  54.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=wan2] gateway ]
  55.                 :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
  56.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  57.                         /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan2] gateway ]
  58.                         :log info "Wan1 inactivo se le asigna el Gateway del Wan2 "
  59.                 }      
  60.                        :global access 1
  61.         }
  62.  
  63.          :if ([:len $GC] != 0) do={
  64.                        :global pingresultC  [/ping $GC interface=wan3 count=4]
  65.                  } else={
  66.                        :global pingresultC 0              
  67.                  }
  68.  
  69.         :if ($pingresultC>0 && $access=0) do={
  70.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=wan3] gateway ]
  71.                 :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
  72.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  73.                         /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan3] gateway ]
  74.                         :log info "Wan1 inactivo se le asigna el Gateway del Wan3 "
  75.                 }      
  76.                        :global access 1        
  77.         }
  78.                :if ([:len $GD] != 0) do={
  79.                        :global pingresultD  [/ping $GD interface=wan4 count=4]
  80.                  } else={
  81.                        :global pingresultD 0              
  82.                  }
  83.  
  84.         :if ($pingresultD>0 && $access=0) do={
  85.                 :local gatewayNuevoB [/ip dhcp-client get [find interface=wan4] gateway ]
  86.                 :local gatewayActivoA [/ip route get [find routing-mark=to_wan1] gateway ]
  87.                 :if ($gatewayNuevoB != $gatewayActivoA) do={
  88.                         /ip route set [find routing-mark=to_wan1] gateway=[/ip dhcp-client get [find interface=wan4] gateway ]
  89.                         :log info "Wan1 inactivo se le asigna el Gateway del Wan4 "
  90.                 }      
  91.                   :global access 1
  92.  
  93.         }
  94. }
  95.  

Suerte con la modificacion de los demas

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #18 : marzo 19, 2015, 12:16:39 pm »
gracia mi hermano voy a modificar los demas cuando lo modifico lo subo  jejeje gracias  :)
un saludos para todos desde venezuela

Desconectado jhonnywifi

  • Newbie
  • *
  • Mensajes: 2
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Mi aporte para esta comunidad (SCRIPT FAILOVER PARA 4 LINEAS)
« Respuesta #19 : febrero 25, 2021, 05:11:22 am »
saludos a todos desde trujillo venezuela este hilo todavia esta activo alguien me puede echar una mano...gracias