RaptorCache 2.0 con dos WAN con Mikrotik (sin Balanceo de carga)

Desconectado guzmanweb

  • Newbie
  • *
  • Mensajes: 19
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Hola

Me gustaría si me pueden echarme un cable,  tengo dos conexión a Internet una es con IP Fija (fibra) y la otra es ADSL (pppoe-out1) no tiene balanceo carga, quiero que sean independientes

el temas es que quiero mandarle  10 Usuarios por la linea ADSL a su ves pase por raptor, el resto de los usuarios de sale por (fibra) pasa normal por raptor sin  problema, a continuación expongo las reglas que tengo:

Raptor IP 192.168.200.2

Usuarios que quiero pasar por la linea ADSL

Código:
  1. /ip firewall address-list
  2. add address=192.168.20.43 disabled=no list=Linea_ADSL
  3. add address=192.168.20.70 disabled=no list=Linea_ADSL
  4. add address=192.168.20.71 disabled=no list=Linea_ADSL
  5. add address=192.168.20.72 disabled=no list=Linea_ADSL
  6. add address=192.168.20.73 disabled=no list=Linea_ADSL
  7. add address=192.168.20.74 disabled=no list=Linea_ADSL
  8. add address=192.168.20.75 disabled=no list=Linea_ADSL
  9. add address=192.168.20.76 disabled=no list=Linea_ADSL
  10.  
  11. /ip firewall address-list
  12. add address=192.168.200.0/30 disabled=no list=OtrasRedes
  13. add address=192.168.21.0/24 disabled=no list=OtrasRedes
  14.  
  15. /ip firewall mangle
  16. add action=accept chain=prerouting disabled=no dst-address-list=OtrasRedes src-address=192.168.20.0/24
  17.  
  18. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" disabled=no dst-port=80 \
  19.     in-interface=LAN new-routing-mark=raptor_route passthrough=yes protocol=tcp
  20.  

Esta seria la regla  para que  los usuarios que mencione arriba salga por la  linea ADSL, ademas probé poner encima de la regla de "Raptor - mangle"

Código:
  1. [color=red]add action=mark-routing chain=prerouting disabled=no new-routing-mark=ADSL_route passthrough=no src-address-list=Linea_ADSL[/color]
  2.  
  3. add action=mark-connection chain=forward comment="================== CACHE ====================" content=\
  4.     "X-Cache-Raptor: HIT from Raptor" disabled=no new-connection-mark=raptor-connection passthrough=yes
  5. add action=mark-packet chain=forward connection-mark=raptor-connection \
  6.     disabled=no new-packet-mark=raptor-packs passthrough=no
  7. add action=mark-connection chain=forward comment="==SQUID - TOS 12==" \
  8.     disabled=no dscp=12 new-connection-mark=squid-connection passthrough=yes
  9. add action=mark-packet chain=forward connection-mark=squid-connection \
  10.     disabled=no new-packet-mark=squid-packs passthrough=yes
  11.  
  12.  
  13. /ip route
  14. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
  15.     192.168.200.2 routing-mark=raptor_route scope=30 target-scope=10
  16. [color=red]add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ADSL routing-mark=ADSL_route scope=30 target-scope=10[/color]
  17. add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=190.189.117.X scope=30 target-scope=10
  18. add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ADSL scope=30 target-scope=10

actualmente los usuarios de lista Linea_ADSL tienen Internet normal, pero no logro que pase por raptor.

Mis agradecimientos anticipadas, si falta algún dato no dude pedírmelo!

Saludos

Ricardo

PD: perdón si no es adecuado la publicación por este sector!


Desconectado angelsantana

  • Full Member
  • ***
  • Mensajes: 213
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:RaptorCache 2.0 con dos WAN con Mikrotik (sin Balanceo de carga)
« Respuesta #1 : octubre 25, 2015, 03:19:38 pm »
segun veo esta ultizando laversion 1 de raptor....

add action=mark-packet chain=forward connection-mark=raptor-connection \
    disabled=no new-packet-mark=raptor-packs passthrough=no
add action=mark-connection chain=forward comment="==SQUID - TOS 12==" \
    disabled=no dscp=12 new-connection-mark=squid-connection passthrough=yes
add action=mark-packet chain=forward connection-mark=squid-connection \
    disabled=no new-packet-mark=squid-packs passthrough=yes

ps para que pasen los usarios pasen por raptor tienes que configurar tus iptables
dandoles el rango de ips de tu lan  en "/etc/raptor/" le das permisos  y guardas listo..  :D :D :D

#Aceptamos el localhost
iptables -A INPUT -i lo -j ACCEPT

#Aceptamos la red local
iptables -A INPUT -s 192.168.10.0/24 -j ACCEPT

iptables  -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

echo 1 > /proc/sys/net/ipv4/ip_forward

 
el secreto de las soluciones es leer...

Desconectado guzmanweb

  • Newbie
  • *
  • Mensajes: 19
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:RaptorCache 2.0 con dos WAN con Mikrotik (sin Balanceo de carga)
« Respuesta #2 : octubre 26, 2015, 09:45:50 am »
Hola @angelsantana

Lo tengo hecho casi igual como la guía expuesta aquí  http://www.alterserv.com/foros/index.php?topic=2036.0
la única diferencia es que tiene la parte del TOS de Squid3 no creo que afecte mucho eso, lo voy a desactivar.

paso algunos pantallazos



Firewal de raptor



Aquí tengo una duda es necesario agregar la red de Raptor? me parece que no, pero agrego!

Como figura en la imagen tengo tres segmentos de redes y las agregue todas y pasan por raptor sin problemas excepto los usuarios que mando por la linea_ADSL,  los usuarios que sale por la Linea_ADSL no logro que pase por raptor ese es mi problema, paso algunas imágenes que raptor cachea muy bien hasta hora..



Saludos

Ricardo