HandyCache Rev 5 en español (20/06/2016)

Desconectado JVProducciones

  • Sr. Member
  • ****
  • Mensajes: 448
  • Ubicación: AQP
  • Intentando lo imposible se realiza lo posible!!
    • Ver Perfil
  • Me Gusta: 2
HandyCache Rev 5 en español (20/06/2016)
« : Junio 16, 2016, 09:58:18 am »
Handycache Rev5


Hola apreciados amigos, esta vez les traigo aquí esta nueva revisión de Handycache, también me disculpo por tener muy abandonados estos temas ya que no he tenido tiempo por trabajo y salud, sin embargo hay que seguir siempre para adelante….

Notas a considerar antes de usar:
    + El https (ssl) se encuentra activado lo cual permite ahora hacer cache de este protocolo (puede ser desactivado)
    + Compatible con el anterior cache almacenado, solo bastará con indicar la ruta del cache existente. (De manera predeterminada está en "D:/Cache")
    + Agregadas más reglas de bloqueo de publicidad y bloqueo de páginas peligrosas para sus clientes...
    + Agregadas más reglas de redireccionamiento utilizados para redireccionar páginas de inicio diferentes a google, generalmente cambiados sin que el cliente se dé cuenta por algún programa malicioso...
    + Mejorado la traducción
    + Para Youtube seguirá siendo predeterminada la extensión "Youtube Cache Flash y Html5 360p (actualizado)" la cual guarda los videos en mp4 de manera completa  (podrán usar el que deseen) (no recomiendo el html5 en partes ya que las partes casi nunca coinciden, si desean hacerlo en partes les recomendaría hacerlo en flash)
    + Multicolor (según acción tomada) y breve descripción de contenido (según tipo) (nuevo)
    + Aun no compatible con la nueva versión de Handycache (RC4 1.0.0.644)
    + No es recomendable usar Firewall de Windows ni antivirus (solo para usuarios avanzados)
    + Recomiendo usar Windows 8.1 64 bits pero se puede trabajar en cualquier SO windows o en Linux con Wine
    + Recomiendo seguir usando la "Nueva forma de redirección" para todo lo que es https usando servidor apache y el script wpad.pac explicada en HandyCache Rev 4 en español (28/02/2016)



Nueva forma de trabajo (probado en producción alrededor de 100 clientes http y 30 de ellos en https)

Integración de Privoxy como Proxy Padre:
Un amigo muy entusiasta llamado Jhoel comenzó a hacer comentarios y pruebas con diferentes Proxys y me habló del programa Privoxy el cual me llamó la atención…
Privoxy es un proxy web que tiene capacidad de modificar el contenido de las páginas web, administrar cookies, controlar accesos y eliminar anuncios, banners, ventanas emergentes y otros elementos indeseados de Internet. En realidad todo eso puede hacerlo Handycache sin ningún problema, pero Handycache no administra bien el número de conexiones llegando a llenarse en el transcurso del día y alcanzar rápidamente las 400 conexiones seguidamente de la saturación en las respuestas de Handycache (así sea la versión modificada), la alternativa era abrir varios Handycaches (he llegado a usar 8 handycaches para mis más de 90 usuarios) y gracias a este programa a lo mucho he usado 2 Handycaches uno para http y otro para https, Privoxy administra muy bien las conexiones y le quita gran carga de conexiones a Handycache (se sorprenderán) para ello modifiqué gran parte de la configuración original de privoxy según mi criterio, y ahora , comparto mi versión (claro está que pueden usas sus propias configuraciones)

     Privoxy y HandyCache Rev5

Dentro de este paquete encontraremos 2 carpetas (Handycache y Privoxy) y un programa llamado hcmon.exe que administrará a los dos programas

Hcmon.exe
Este Programa lo creo nuestro amigo colaborador JedKiller (Gexel) y tiene detalles importantes:
 +Inicio Automático
 +Bloqueo de Ping a detener el Programa proxy
 +Controla el puerto de escucha tanto de Handycache y Privoxy y los monitorea (en caso de cierre inesperado o cuelgue inesperado)
 +Reinicios automáticos en un horario determinado (puesto de manera predeterminada a las 4 am)



Privoxy
No explicaré mucho del tema solo lo que nos concierne:
 +Privoxy escuchará de manera predeterminada el puerto 8118 (podrán cambiarlo a su criterio dentro del archivo de texto config.txt o con hcmon.exe)
 +Privoxy Redireccionará de manera predeterminada a http al puerto de escucha de handycache 7070 (podrán cambiarlo a su criterio dentro del archivo de texto config.txt)
 +Privoxy Redireccionará de manera predeterminada a https al puerto de escucha de handycache 8080 (podrán cambiarlo a su criterio dentro del archivo de texto config.txt)
 +Privoxy no hará más que redireccionar el tráfico a handycache (aquí radica la magia)
 +"max-client-connections 256" es el número de conexiones por cliente el cual puse 256, ajusten según su criterio ya que un cliente con virus o malicioso puede generar miles de conexiones....



Nota: Al usar la redireccion https por medio del Script wpad.pac, este deberá indicar el puerto de escucha 8118 de privoxy.

Configuración en Mikrotik
Mantendremos solo una regla de redirección Nat  siendo 10.0.0.222 la dirección IP de nuestro server donde corren privoxy y handycache y 8118 el puerto de escucha de privoxy (ya no se redireccionará directamente a  handycache (privoxy lo hará)
Regla Nat

Código: [Seleccionar]
/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-address=!10.0.0.222 dst-port=80,8080,8888,8880,8777,3477,33301 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=8118


Con esto ya deberíamos tener trabajando nuestros servidores...


Gracias a Todos en especial a Diosito Lindo...

Desconectado walther

  • Newbie
  • *
  • Mensajes: 11
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (19/06/2016)
« Respuesta #1 : Junio 18, 2016, 06:34:35 pm »
esperando amigo ...!

Desconectado damian007

  • Newbie
  • *
  • Mensajes: 18
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (19/06/2016)
« Respuesta #2 : Junio 19, 2016, 07:51:25 pm »
Excelente trabajo brother, solo una inquietud, se segira usando el certificado en los navegadores, siegue siendo obligatorio para las paginas HTTPS.

Gracias.

Desconectado Enrrike87

  • Full Member
  • ***
  • Mensajes: 117
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (19/06/2016)
« Respuesta #3 : Junio 19, 2016, 08:25:00 pm »
Excelente trabajo brother, solo una inquietud, se segira usando el certificado en los navegadores, siegue siendo obligatorio para las paginas HTTPS.

Gracias.
Si la instalacion es obligatoria pero esta forma trae muchos beneficios!! excelente aportaso a JV

Desconectado ninohwifi

  • Jr. Member
  • **
  • Mensajes: 61
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (19/06/2016)
« Respuesta #4 : Junio 19, 2016, 09:57:13 pm »
Se ve excelente hermano.. !!

Desconectado system_urrutia

  • Newbie
  • *
  • Mensajes: 34
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #5 : Junio 20, 2016, 07:02:10 am »
Saludos y gracias por el aporte gran amigo JVP, y a todo el elenco de desarrolladores de mejoras para el beneficio de toda una gran comunidad así como el betatester o conejitos de india jajajaj, solo quería acotar que a los que descarguen el HCRV5 en la parte del Privoxy Especificamente el el apartado (Options==>Edit Main Configuration) deben cambiar los puertos ya que por defecto vienen de la siguiente manera y deben acoplarlos a como dice el amigo JVP en la descripción o guía de instalación y funcionamiento.
listen-address  :8118
forward / 127.0.0.1:8080
forward :443 127.0.0.1:8081

Desconectado JVProducciones

  • Sr. Member
  • ****
  • Mensajes: 448
  • Ubicación: AQP
  • Intentando lo imposible se realiza lo posible!!
    • Ver Perfil
  • Me Gusta: 2
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #6 : Junio 20, 2016, 08:55:07 am »
Saludos y gracias por el aporte gran amigo JVP, y a todo el elenco de desarrolladores de mejoras para el beneficio de toda una gran comunidad así como el betatester o conejitos de india jajajaj, solo quería acotar que a los que descarguen el HCRV5 en la parte del Privoxy Especificamente el el apartado (Options==>Edit Main Configuration) deben cambiar los puertos ya que por defecto vienen de la siguiente manera y deben acoplarlos a como dice el amigo JVP en la descripción o guía de instalación y funcionamiento.
listen-address  :8118
forward / 127.0.0.1:8080
forward :443 127.0.0.1:8081
Gracias..... ya lo corregí...atento a la jugada!!

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #7 : Junio 20, 2016, 12:46:12 pm »
hola poniendo las reglas al mk me quedo sin internet porq sera ???

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #8 : Junio 20, 2016, 01:11:21 pm »
ya parece estar solucionado...
a hora alguien q pruebe si se le demora en hacer es test

http://beta.speedtest.net/run

Desconectado hackersito

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #9 : Junio 20, 2016, 02:24:47 pm »
ya parece estar solucionado...
a hora alguien q pruebe si se le demora en hacer es test

http://beta.speedtest.net/run




lo probe normal me realiza el test rapido sin problemas

Desconectado jeyb2007

  • Newbie
  • *
  • Mensajes: 5
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #10 : Junio 20, 2016, 02:50:56 pm »
JV Ante todo, Felicitaciones y muy agradecido por este gran aporte a la comunidad ISP, Seria bueno publicar un esquema de la implementacion, para poder visualizar con mas claridad como se conectan los equipos y los rangos IP de los componentes entre otros - tengo dudas sobre el servidor interno Apache, si se implementa en una pc nueva o en la misma pc del HandyCache...

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #11 : Junio 20, 2016, 04:12:59 pm »
JV Ante todo, Felicitaciones y muy agradecido por este gran aporte a la comunidad ISP, Seria bueno publicar un esquema de la implementacion, para poder visualizar con mas claridad como se conectan los equipos y los rangos IP de los componentes entre otros - tengo dudas sobre el servidor interno Apache, si se implementa en una pc nueva o en la misma pc del HandyCache...


lo usas en el mismo hc
http://www.alterserv.com/foros/index.php?topic=2185.0

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #12 : Junio 20, 2016, 04:13:38 pm »
una pregunta como hago para q una ip por decir 192.168.1.12 no pase por el hc

Desconectado JVProducciones

  • Sr. Member
  • ****
  • Mensajes: 448
  • Ubicación: AQP
  • Intentando lo imposible se realiza lo posible!!
    • Ver Perfil
  • Me Gusta: 2
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #13 : Junio 20, 2016, 10:16:25 pm »
una pregunta como hago para q una ip por decir 192.168.1.12 no pase por el hc
lo harás con dos reglas:

la regla nat (deberá ir arriba de la regla de redirección del proxy handycache)
Código: [Seleccionar]
/ip firewall nat
add chain=dstnat comment="Sacar listas IPs Web Fuera del Proxy" dst-address-list=IPs_Fuera

Address List (Listas ips las cuales no pasarán por el proxy)(este ejemplo es para la página Ivpaste)
Código: [Seleccionar]
/ip firewall address-list
add address=109.236.81.213 comment=ivpaste list=IPs_Fuera

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #14 : Junio 21, 2016, 08:06:05 am »
lo harás con dos reglas:

la regla nat (deberá ir arriba de la regla de redirección del proxy handycache)
Código: [Seleccionar]
/ip firewall nat
add chain=dstnat comment="Sacar listas IPs Web Fuera del Proxy" dst-address-list=IPs_Fuera

Address List (Listas ips las cuales no pasarán por el proxy)(este ejemplo es para la página Ivpaste)
Código: [Seleccionar]
/ip firewall address-list
add address=109.236.81.213 comment=ivpaste list=IPs_Fuera

gracias probare ya q necesito hacer eso por el sistema de cobro

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #15 : Junio 21, 2016, 12:10:10 pm »
hasta ahora bien pero... lo q veo esq demora en cargar un poquito las paguina ?

Desconectado josemanuel155

  • Full Member
  • ***
  • Mensajes: 113
  • Ubicación: maracaibo estado zulia
  • cada dia aprendo mas e entiendo menos
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #16 : Junio 21, 2016, 01:42:38 pm »
un saludo a todos
la rv5 esta bien solo que carga lento las paginas y a veces deja sin internet tube que volver a la rv4 :'( :'( :'(
un saludos para todos desde venezuela

Desconectado ninohwifi

  • Jr. Member
  • **
  • Mensajes: 61
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #17 : Junio 21, 2016, 04:04:13 pm »
a cuantas conecciones llega esta rev ?? la estoy probando y he visto que llega hasta 469 no se si mas??

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #18 : Junio 21, 2016, 05:20:54 pm »
a cuantas conecciones llega esta rev ?? la estoy probando y he visto que llega hasta 469 no se si mas??

con cuantos clientes men porq yo tengo 30 y solo me llega hasta 10/45   el otro q tenia me llegaba hasta 300

y lo q decia mas arriba de lo lento se vuelve un poquito al abrir las paguinas.....

compañero JV porque sera ?????

Desconectado JHOELIT

  • Newbie
  • *
  • Mensajes: 12
  • Ubicación:
  • Dios los Bendiga
    • Ver Perfil
    • Facebook
  • Me Gusta: 0
Re:HandyCache Rev 5 en español (20/06/2016)
« Respuesta #19 : Junio 21, 2016, 05:36:52 pm »
 ??? Fue algo difícil  :-X bastante trabajo en handy  :'( agradezco a JVProducciones por todo su esfuerzo en ello... Hace un año pasó que por primera ves use handycache paralelo a mikrotik, cuando aun youtube funcionaba en http:// después de poco tiempo llegamos a usar la función del wpad. Quedó muy satisfecho, opcional mente eh trabajado en handy y pronto lo decidí compartir con JV, para que quede al beneficio de todos ustedes...

Por cierto vamos a seguir aportando para mejorar esta versión 5 de HC

Saludos...