RaptorCache 2 - Instalacion Script

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 629
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 94
RaptorCache 2 - Instalacion Script
« : septiembre 29, 2016, 06:36:53 pm »
Instalación Raptorcache 2.0.5b

Changelog:

Instalación en Debian 8
https://cdimage.debian.org/mirror/cdimage/archive/8.10.0/amd64/iso-cd/debian-8.10.0-amd64-netinst.iso


Para usar Putty con el usuario root en Debian 8
Despues de instalar el ssh en el servidor("apt-get install ssh") se necesita configurar el ssh para el accesso al usuario "root" que por defecto está deshabilitado en Debian 8.
Editar por terminal el archivo de configuración del ssh, para eso efectuamos los siguientes comandos
Código:
  1. nano /etc/ssh/sshd_config

Dentro del editor buscar la línea "PermitRootLogin Without-Password" y cambiarlo a "PermitRootLogin yes" guardar con Ctrl + o y salir Ctrl + x , luego reiniciar el ssh
Código:
  1. /etc/init.d/ssh restart
y con eso se tendría acceso a Putty con el usuario root.

Instalar Raptor
Ejecutar los siguientes comandos para iniciar la instalación de Raptor, el proceso es automático hasta que finalice la instalación.
Código:
  1. wget http://www.raptor.alterserv.com/install_raptor2_d8.sh
  2. chmod 777 install_raptor2_d8.sh
  3. bash install_raptor2_d8.sh

Redirección y priorización de tráfico Mikrotik por Mangle
- Modificar el IP del servidor(192.168.10.2) y su segmento(192.168.10.0/24) en el caso que estén usando otros valores
- Modificar "LAN" en "in-interface" por el nombre de su interface de usuarios en la regla "action=mark-routing"
Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/24
  3. /ip route
  4. add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=raptor_route scope=30 target-scope=10
  5. /ip firewall mangle
  6. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=\
  7.     no protocol=tcp
  8. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=443 in-interface=LAN new-routing-mark=raptor_route \
  9.     passthrough=no protocol=tcp src-address-list=https_users
  10. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" new-connection-mark=raptor-connection
  11. add action=mark-connection chain=forward dscp=18 new-connection-mark=raptor-connection
  12. add action=mark-packet chain=forward connection-mark=raptor-connection new-packet-mark=raptor-packs passthrough=no
  13. /queue simple
  14. add max-limit=30M/30M name=RaptorCache packet-marks=raptor-packs queue=pcq-upload-default/pcq-download-default target="" total-queue=default

Agregar en el Firewall del raptor el segmento de red de sus usuarios(en la imagen está como ejemplo el segmento 192.168.1.0/24), y activar las reglas de redirección al puerto 3128 y 3127


Dentro de las reglas de redirección del Mikrotik está la que redirecciona el puerto 443, esta regla está por defecto para que asigne a un address list(lista de usuarios); solo los que estén en esta lista se redireccionarán para el caché a HTTPS. Se puede administrar esta lista desde el WebPanel conectando al Mikrotik median su API



Cómo Importar Certificado

Versión Actual 2.0.5b
RaptorCache Developer

Desconectado Derrumbadas

  • Newbie
  • *
  • Mensajes: 37
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #1 : septiembre 29, 2016, 06:59:14 pm »
ya se puede hacer la instalacion, como esta el tea de los usuarios soportados?. de antemano gracias y exitos

Desconectado vagalume

  • Jr. Member
  • **
  • Mensajes: 58
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #2 : septiembre 29, 2016, 07:19:10 pm »
precisa configura augunha coisa no painel do raptor...ou instalar augum certificado?

Desconectado wifirv

  • Newbie
  • *
  • Mensajes: 17
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 1
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #3 : septiembre 29, 2016, 07:35:14 pm »
 :-* que bien mi pregunta es , el certificado es dinamico  como tal o el cliente tiene q instalar el certificado para poder usar el cache https?

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #4 : septiembre 29, 2016, 07:52:08 pm »
excelente
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #5 : septiembre 29, 2016, 08:00:36 pm »
Quien lo ha instalado?
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve

Desconectado vagalume

  • Jr. Member
  • **
  • Mensajes: 58
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #6 : septiembre 29, 2016, 08:09:50 pm »
Estado de Squid   offine

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #7 : septiembre 29, 2016, 08:11:42 pm »
Estado de Squid   offine

yo como que me espero aun tengo la version anterior andando cacheando y no esta de mas dar gracias a joemg
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve

Desconectado venezu

  • Hero Member
  • *****
  • Mensajes: 508
  • Ubicación: miranda venezuela
    • Ver Perfil
  • Me Gusta: 9
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #8 : septiembre 29, 2016, 08:13:21 pm »
Estado de Squid   offine
lean bien el post debe ser instalado en debian 8

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #9 : septiembre 29, 2016, 08:15:43 pm »
lean bien el post debe ser instalado en debian 8

eso es correcto
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve

Desconectado juanslayer

  • Jr. Member
  • **
  • Mensajes: 98
  • Ubicación:
    • Ver Perfil
    • FiltroAntilagLancenter
  • Me Gusta: 2
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #10 : septiembre 29, 2016, 08:21:38 pm »
BUENISIMO,

hasta donde veo las reglas el direccionamiento es para http y https esta en transparente genial descargando el debían y procedo a probar.

nota espero se pueda cambien por reglas NAT

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #11 : septiembre 29, 2016, 08:32:50 pm »
BUNISIMO,

hasta donde veo las reglas el direccionamiento es para http y https en transparente genial descargando el debían y procedo a probar
excelente
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve

Desconectado Oscar

  • Newbie
  • *
  • Mensajes: 39
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 1
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #12 : septiembre 29, 2016, 08:44:17 pm »
 :-* Hay una falla al descargar el archivo http://www.alterserv.com/raptor/upload.cgi

Código: [Seleccionar]
--2016-09-29 21:39:54--  http://www.alterserv.com/raptor/upload.cgi
Resolviendo www.alterserv.com (www.alterserv.com)... 69.162.113.22
Conectando con www.alterserv.com (www.alterserv.com)[69.162.113.22]:80... conectado.
Petición HTTP enviada, esperando respuesta... 500 Internal Server Error
2016-09-29 21:39:54 ERROR 500: Internal Server Error.

Desconectado roldes1

  • Newbie
  • *
  • Mensajes: 25
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #13 : septiembre 29, 2016, 08:49:09 pm »
Gracias joemg lo esperaba mucho , mas tarde instalo.

Desconectado zatarra

  • Newbie
  • *
  • Mensajes: 29
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #14 : septiembre 29, 2016, 09:08:28 pm »
Gracias joemg6!!! Instalando!!! 8)
La Necesidad Agudiza el Ingenio

Desconectado jaikel gutierrez

  • Jr. Member
  • **
  • Mensajes: 79
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 4
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #15 : septiembre 29, 2016, 09:27:10 pm »
excelente amigo, muchas gracias joemg. en estos momentos instalando el debian 8 .! :-*

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #16 : septiembre 29, 2016, 09:29:25 pm »
:-* Hay una falla al descargar el archivo http://www.alterserv.com/raptor/upload.cgi

Código: [Seleccionar]
--2016-09-29 21:39:54--  http://www.alterserv.com/raptor/upload.cgi
Resolviendo www.alterserv.com (www.alterserv.com)... 69.162.113.22
Conectando con www.alterserv.com (www.alterserv.com)[69.162.113.22]:80... conectado.
Petición HTTP enviada, esperando respuesta... 500 Internal Server Error
2016-09-29 21:39:54 ERROR 500: Internal Server Error.

esa es la ruta del archivo en el hosting
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve

Desconectado jsuarez

  • Jr. Member
  • **
  • Mensajes: 97
  • Ubicación: Caracas, Venezuela
  • J Soluciones IP, C.A
    • Ver Perfil
    • J Soluciones IP, C.A
  • Me Gusta: 1
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #17 : septiembre 29, 2016, 10:03:01 pm »
Buenas Noches a todos lo de la comunidad de RaptorCache, y mucha gracias al amigo joemg6 que siempre esta atento en su proyecto del raptorcache y asi seguir avanzando en este proyecto felicidades, a disfrutar el raptor beta 
J Soluciones IP, C.A
Especialista en redes Mikrotik - Ubiquiti - TP Link
Tel: 0412-934 1664
Correo:jsolucionesip@gmail.com
josesuarez@jsolucionesip.com.ve
Pagina web: http://www.jsolucionesip.com.ve

Desconectado jsuarez

  • Jr. Member
  • **
  • Mensajes: 97
  • Ubicación: Caracas, Venezuela
  • J Soluciones IP, C.A
    • Ver Perfil
    • J Soluciones IP, C.A
  • Me Gusta: 1
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #18 : septiembre 29, 2016, 10:15:29 pm »
ya instalando el debian 8 para hacer la prueba, quien tenga problema en la instalación comentarla.
J Soluciones IP, C.A
Especialista en redes Mikrotik - Ubiquiti - TP Link
Tel: 0412-934 1664
Correo:jsolucionesip@gmail.com
josesuarez@jsolucionesip.com.ve
Pagina web: http://www.jsolucionesip.com.ve

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:RaptorCache 2 - Youtube HTTPS beta
« Respuesta #19 : septiembre 29, 2016, 10:15:59 pm »
Instalación Raptorcache 2.0.4.1b
Instalación de la versión beta con soporte para YouTube HTTPS
Changelog:

Instalación en Debian 8
http://cdimage.debian.org/debian-cd/8.6.0/amd64/iso-cd/debian-8.6.0-amd64-netinst.iso

El proceso de instalación es similar a la versión 7

Código:
  1. wget http://www.alterserv.com/raptor/install_raptor2_d8.sh
  2. chmod 777 install_raptor2_d8.sh
  3. bash install_raptor2_d8.sh

Redirección y priorización de tráfico Mikrotik por Mangle (modificar "in-interface" por el nombre de su interface en la regla mark-routing)
Código:
  1. /ip firewall mangle
  2. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=\
  3.     no protocol=tcp src-address-list=https_users
  4. add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================>" dst-port=443 in-interface=LAN new-routing-mark=raptor_route \
  5.     passthrough=no protocol=tcp src-address-list=https_users
  6. add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" new-connection-mark=raptor-connection
  7. add action=mark-connection chain=forward dscp=18 new-connection-mark=raptor-connection
  8. add action=mark-packet chain=forward connection-mark=raptor-connection new-packet-mark=raptor-packs passthrough=no
  9. add action=mark-connection chain=postrouting comment="== RAPTORCACHE ==" content="X-Cache: HIT from Raptor" disabled=yes new-connection-mark=raptor-connection \
  10.     protocol=tcp src-address=192.168.10.2

Agregar en el Firewall del raptor el segmento de red de sus usuarios(en la imagen está como ejemplo el segmento 192.168.1.0/24), y activar las reglas de redirección al puerto 3128 y 3127


Dentro de las reglas de redirección del Mikrotik está la que redirecciona el puerto 443, esta regla está por defecto para que asigne a un address list(lista de usuarios); solo los que estén en esta lista se redireccionarán para el caché a HTTPS. Se puede administrar esta lista desde el WebPanel conectando al Mikrotik median su API




En Construcción

Joemg Gracias por todo una pregunta en mi caso yo activo y corto por address-list no quiero duplicar ip hablar una manera de que cuando el cliente tenga un perfil excepto bloqueados no pase por la regla del raptor que anterior mensionas?

En mi caso trabajo por PCQ y hago los marcado por mangles y el trafico lo veo por queue tre
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve