THOMECACHE - Servidor Cache HTTP e HTTPS

Desconectado madarajackk

  • Newbie
  • *
  • Mensajes: 29
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 2
THOMECACHE - Servidor Cache HTTP e HTTPS
« : noviembre 09, 2016, 12:07:24 am »
El ThomeCache Profesional revoluciona el servicio de Internet sin la necesidad de un enlace de actualización. Mejora la conexión de sus clientes, aumentando la velocidad de las descargas y el acceso a sitios web dinámicos de tallo (redes de distribución de contenido) de CDN o cualquier otra URL, permite actualizaciones de software de acceso local y evita la formación de hielo vídeos debido a la falta de enlace o congestionada redes troncales internacionales.

De alto rendimiento, la estabilidad y la semántica de servicios de almacenamiento en caché de objetos únicos y extremadamente inteligentes, hacen ThomeCache un sistema sin precedentes en el mercado, tanto por su alta calidad y rendimiento, y por el valor de la inversión asequible para todas las redes y cualquier tamaño, esta receta se volvió ThomeCache la herramienta preferida para miles y miles de redes en todo el mundo.

La instalación del sistema es práctico y rápido, hecho de una imagen en la memoria USB o en formato ISO, no tomar más de cinco minutos para instalar, muy adaptables y fáciles de integrar la inmensa mayoría de las topologías de red utilizadas. También el ThomeCache permite una gestión profesional de su red en tiempo real con gráficos dinámicos, la vigilancia del IP, control de ahorro, informes de tráfico y eficiencia de control. Poniendo en sus manos las herramientas para poner en práctica técnicas de aceleración de navegación y la creación de un modelo de negocio de la publicidad sitio web. Saber ThomeCache y todas sus herramientas que van a revolucionar la red y garantizar la completa satisfacción de sus clientes.

He estado usando este servidor por ya 4 meses y me ha resultado muy bueno para ser un proxy sin interfaz, pero muy completo se podría decir, aquí les compartiré un pequeño tutorial desde como instalarlo, configurarlo y el uso de licencia para su uso.

Primero Thomecache es un servidor de brazil, he me ha costado poder comunicarme con su creador para poder entenderle como poder configurarlo y que quede al 100%, iré avanzando poco a poco con este tutorial.

LA FUNCION QUE CUMPLE ES CACHE HTTP TRANSPARENTE Y HTTPS POR CERTIFICADO, LA CUAL HACE CACHE TODO DE INTERNET, UNA DE LAS MEJORES ES QUE TIENE SERVIDOR DNS. SE PODRÍA DECIR QUE ES COMPLETO, TANTO PARA PEQUEÑOS WISP O PARA CABINAS DE INTERNET, ya les ire comentado sus maravillas, aparte que cache dota2, puedes contralar speetest la bajada y subida, totalmente efectiva. Adaptable a HOST SPOT, PPPOE, SIMPLEQUEUES.

Bueno ante todo la capacidad requerida mínima para hacer funcionar thomecache:

Hardware mínimo para 500 clientes simultáneos:

   Memoria: Igual o mayor que 8GB
   Procesador: Quad-Core, i3, i5, i7 # En mi caso uso AMD FX x4
   HDD: Inicialmente de 500GB sistema, # En mi caso uso HDD Solido de 120GB para sistema.
   HDD-Cache: 1Tera
   Nota: No utilizar memorias ram abajo de 4GB


1. INSTALACION THOMECACHE.

Primero descargar el archivo thome de esta dirección o directamente de su pagina:(http://www.thomecache.com/site/download/), que es lo mismo.

Código: [Seleccionar]
https://mega.nz/#!ldNHUCZR!6vieIVWtN8g04nllYV2cAitv34kSR1DkXDyahBCDQ5E

Segundo Montar la ISO en su USB: Tamaño de la iso 285MB. Aquí les dejo como montarlo con Rufus 2.9. Clic empezar y listo.



Procedemos con la Instalación:
















2. CONFIGURAR MIKROTIK PARA DIRECCIONAMIENTO THOMECACHE.


MODIFICAR LA INTERFAZ PARA THOME
Código: [Seleccionar]
/interface ethernet
set [ find default-name=ether3 ] advertise=1000M-full name=ThomeCache

IP THOME
Código: [Seleccionar]
/ip address
add address=201.90.0.1/30 comment=THOMECACHE interface=ThomeCache network=201.90.0.0

ENMASCARADO PARA THOME DIRECTO!
Código: [Seleccionar]
/ip firewall nat
add action=masquerade chain=srcnat disabled=yes out-interface=Wan src-address=201.90.0.2
add action=masquerade chain=srcnat disabled=yes out-interface=Wan src-address=!201.90.0.2

REDIRECCIONAMIENTO CLIENTES A THOME
Código: [Seleccionar]
/ip firewall mangle
add action=mark-routing chain=prerouting comment=THOMECACHE dst-port=80,8777 in-interface=!ThomeCache
new-routing-mark=Thome passthrough=yes protocol=tcp src-address-list=CLIENTES

add action=mark-routing chain=prerouting dst-address=!201.90.0.2 dst-port=53 in-interface=!ThomeCache
new-routing-mark=Thome passthrough=yes protocol=tcp src-address-list=CLIENTES

add action=mark-routing chain=prerouting dst-address=!201.90.0.2 dst-port=53 in-interface=!ThomeCache
new-routing-mark=Thome passthrough=no protocol=udp src-address-list=CLIENTES
Código: [Seleccionar]
/ip firewall address-list
add address=172.24.0.0/16 list=CLIENTES
add address=172.23.0.0/16 list=CLIENTES


FULL CACHE VERSIÓN 6 MIKROTIK
Código: [Seleccionar]
add action=mark-packet chain=postrouting comment=FULLCACHE dscp=12 new-packet-mark=Hit-Thome passthrough=no
FAILOVER PARA THOME
Código: [Seleccionar]
/ip route
add check-gateway=ping distance=1 gateway=201.90.0.2 routing-mark=Thome

LIBERANDO VELOCIDAD THOME
Código: [Seleccionar]
/queue type
add kind=pcq name=DOWNLOAD-THOME pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=5M
pcq-src-address6-mask=64

Código: [Seleccionar]
/queue simple
add limit-at=0/100M max-limit=0/100M name=FULL-CACHE-5MB packet-marks=Hit-Thome priority=1/1
queue=default-small/DOWNLOAD_5MB

MANTENER SIEMPRE FULLCACHE AL INICIO DE SIMPLE QUEUES
Código: [Seleccionar]
/system scheduler
add interval=10s name=Prioridades on-event=/queue simple move [find packet-marks=Hit-Thome-5mb] [:pick [find] 0]
policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=startup

DESACTIVAR Y ACTIVAR LAS REGLAS THOME EN CASO DE APAGON!
Código: [Seleccionar]
/tool netwatch
add down-script="ip firewall mangle set [ find new-routing-mark=Thome ] disabled=yes
ip route set [ find routing-mark=Thome ] disabled=yes host=201.90.0.2 interval=3s timeout=5s
up-script="ip firewall mangle set [ find new-routing-mark=Thome ] disabled=no ip route set
[ find routing-mark=Thome ] disabled=no"



3. CONFIGURAR THOMECACHE.

El acceso es por vía SSH:

MIKOTIK: Tools=>Telnet=>SSH
IP: 201.90.0.2
USER: root
PASS: 123



Apartir del 2.5.0

USER: thome
PASS: 1234



AQUÍ LO PRINCIPAL ES ACTUALIZAR EL SISTEMA THOMECACHE:



Aquí actualizan primero Sistema, y luego Binario!



Hasta esta parte seria todo y para empezar de tan 15 días de prueba gratis, ni bien instalas Thome ya queda registrada tu pc en su servicio, osea pasando los 15 días de prueba ya pagas para darle uso de acuerdo a tu necesidad, en todo caso los planes mas básicos son estos:

Para 60 clientes, te sale 25 dolares
Para 40 clientes, te sale 20 dolares
Para 20 clientes, te sale 15 dolares

Para mas información les dejo la pagina en Precios, los pago son vía paypal: http://www.thomecache.com/site/valores/

Aquí su página de Facebook: https://www.facebook.com/groups/1617485961850667/?fref=ts
Aquí su página de Youtube: https://www.youtube.com/channel/UCQBAUH1sYFCNzEFH6fjX7YQ/videos
E-mail: contacto@thomecache.com
E-mail: thomecache@gmail.com




4. USO DEL HTTPS: PROXY TURBO


PRIMERO se configura las DNS: No es necesario configurar la PC del cliente agregar nada, solo se descarga un ejecutable desde el mismo navegador y automáticamente configurar todos los navegadores(chrome, mozilla, explorer) con el certificado.

Angregan esas direcciones y lo configuran tal cual esta la imagen:


SEGUNDO Ingresan a Thome por SSH y descargan los archivos ejecutables para poder descargar en los clientes:

MIKOTIK: Tools=>Telnet=>SSH
IP: 201.90.0.2
USER: root
PASS: 123

Apartir del 2.5.0
USER: thome
PASS: 1234






TERCERO: Hacen la prueba de ping a las 3 direcciones:



CUARTO, Se diregen a su navegador preferido y escriben en la barra de direcciones: http://www.certificado.lan y les empezara a descargar el ejecutable:



QUINTO, instalan el ejecutable ProxyTurbo!






POR ULTIMO REVISEN QUE ESTE ACTIVADO: (Usar scripts de configuración automática) con esa dirección ya configurada automáticamente por haber instalado el Proxy Turbo.




5 PRUEBAS:


CONTINUARA.....

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 29
Re:THOMECACHE - Servidor Cache HTTP e HTTPS
« Respuesta #1 : noviembre 09, 2016, 09:42:29 am »
Lastimosamente es comun que este tipo de proyectos sean abandonados, por lo demas veo que tiene un consumo bastante grande de Ram, Saludos

Desconectado madarajackk

  • Newbie
  • *
  • Mensajes: 29
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 2
Re:THOMECACHE - Servidor Cache HTTP e HTTPS
« Respuesta #2 : noviembre 09, 2016, 11:14:37 am »
Buenas, También tiene un buen ahorro, esperen a que termine todo el tutorial, les dejare pruebas de todo para que vean lo bueno que es este servidor, saludos...