Apagado y encendido automático de nuestro server

Desconectado JVProducciones

  • Sr. Member
  • ****
  • Mensajes: 448
  • Ubicación: AQP
  • Intentando lo imposible se realiza lo posible!!
    • Ver Perfil
  • Me Gusta: 2
Apagado y encendido automático de nuestro server
« : octubre 31, 2012, 01:48:49 pm »
Hola amigos... quisiera dar un pequeño aporte para las personas que quieren que su servidor pueda apagarse de manera automática en los horarios muertos, generalmente en la madrugada.

Para esto necesitamos el programa WinSCP cliente gráfico q emplea SSH para poder ver el contenido de nuestro servidor. Una vez dentro buscamos la ruta  /etc y el archivo crontab y lo editamos agregando debajo de:
Código: [Seleccionar]
## Agendamiento Thunder
# min(0-59)  hora(0-23)  diames(1-31)  mes(1-12)  diasem(0-7)  user   comando

Esta línea:
Código: [Seleccionar]
# Apagado automatico Thunder
30              1               *       *               *       root    /sbin/shutdown -h now

En este caso se está programado para que se apague a las 1 y 30 de la mañana solo sería cuestión de cambiar la hora que quieran ponerlo…  guardan y listo! con esto ya quedaría configurado el apagado automático de  nuestro server...

Ahora para el encendido automático usaremos el scheduler de mikrotik  agregando esta regla:
Código: [Seleccionar]
/system scheduler
add disabled=no interval=1d name="Prende Thunder" on-event="/tool wol interface=PROXY mac=00:00:00:00:00:00"

Donde dice mac=00:00:00:00:00:00  lo cambian por la mac de su thunder.

Recuerden que nuestra placa debe tener activa la función Wake on Lan activa.
aquí un video explicativo que encontré en la web para activarla


Bueno, por ahora, eso es todo….. Saludos para todos  :-*

Desconectado JVProducciones

  • Sr. Member
  • ****
  • Mensajes: 448
  • Ubicación: AQP
  • Intentando lo imposible se realiza lo posible!!
    • Ver Perfil
  • Me Gusta: 2
Re:Apagado y encendido automático de nuestro server
« Respuesta #1 : noviembre 01, 2012, 02:30:27 pm »
y me olvidaba para que no se queden sin internet nuestros usuarios por apagar el server, sigan este tuto para el mikrotik del gran Joel... :)

http://www.alterserv.com/foros/index.php?topic=6.0;topicseen

Desconectado cabp68

  • Newbie
  • *
  • Mensajes: 13
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Apagado y encendido automático de nuestro server
« Respuesta #2 : noviembre 07, 2012, 01:57:46 pm »
#!/bin/sh
clear
echo "****Bienvenido al Sitema de Apagado Automatico programado por Jose Vicente****"
echo ""
echo ""
echo "MENU"
echo " 1.-Apagar PC ahora"
echo " 2.-Reiniciar PC ahora"
echo " 3.-Apagar PC en una hora determinada"
echo " 4.-Apagar PC en un lapso determinado"
echo " 5.-Salir"
echo ""
read -p "Seleccionar Opcion: " OPCION
case $OPCION in
1) sudo halt;;
2) sudo reboot;;
3) echo -n "Ingresa la hora de apagado: "
read hora
sudo shutdown -h $hora;;
4)echo -n "Ingresa el numero de minutos, tras cual el Servidor se apagara: "
read minutos
sudo shutdown -h $minutos;;
5) exit;;
*) echo "Usted ingreso una opcion que no esta en el menu"
exit 1;;
esac
exit 0
este archivo le sera util ya que con esto se puede determinar la hora que uno quiere que se apage

Desconectado danteviera

  • Newbie
  • *
  • Mensajes: 15
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Apagado y encendido automático de nuestro server
« Respuesta #3 : noviembre 24, 2012, 08:27:01 am »
#!/bin/sh
clear
echo "****Bienvenido al Sitema de Apagado Automatico programado por Jose Vicente****"
echo ""
echo ""
echo "MENU"
echo " 1.-Apagar PC ahora"
echo " 2.-Reiniciar PC ahora"
echo " 3.-Apagar PC en una hora determinada"
echo " 4.-Apagar PC en un lapso determinado"
echo " 5.-Salir"
echo ""
read -p "Seleccionar Opcion: " OPCION
case $OPCION in
1) sudo halt;;
2) sudo reboot;;
3) echo -n "Ingresa la hora de apagado: "
read hora
sudo shutdown -h $hora;;
4)echo -n "Ingresa el numero de minutos, tras cual el Servidor se apagara: "
read minutos
sudo shutdown -h $minutos;;
5) exit;;
*) echo "Usted ingreso una opcion que no esta en el menu"
exit 1;;
esac
exit 0
este archivo le sera util ya que con esto se puede determinar la hora que uno quiere que se apage


Hola gracias por tu aporte amigo, una preguntita donde coloco ese script ??? como lo utilizo ?? gracias disculpa la ignorancia.
"Raptor 2.0.2" - C2D, 4Gb ram ddr2 , Hdd Seagate 1Tera.
"Mkt" Intel P4 1.2Ghz,  256Gb Ram, Placa Intel
Speedy 20Mb 1 linea - 30 User(20 simultaneos)

Desconectado josueflat

  • Full Member
  • ***
  • Mensajes: 116
  • Ubicación: Republica Dominicana
    • Ver Perfil
  • Me Gusta: 1
Re:Apagado y encendido automático de nuestro server
« Respuesta #4 : noviembre 24, 2012, 09:48:06 am »
Gracias por la información................
Xtreme-Net Internet Con Nivel....

Desconectado josueflat

  • Full Member
  • ***
  • Mensajes: 116
  • Ubicación: Republica Dominicana
    • Ver Perfil
  • Me Gusta: 1
Re:Apagado y encendido automático de nuestro server
« Respuesta #5 : noviembre 26, 2012, 11:58:10 pm »
Hola amigos... quisiera dar un pequeño aporte para las personas que quieren que su servidor pueda apagarse de manera automática en los horarios muertos, generalmente en la madrugada.

Para esto necesitamos el programa WinSCP cliente gráfico q emplea SSH para poder ver el contenido de nuestro servidor. Una vez dentro buscamos la ruta  /etc y el archivo crontab y lo editamos agregando debajo de:
Código: [Seleccionar]
## Agendamiento Thunder
# min(0-59)  hora(0-23)  diames(1-31)  mes(1-12)  diasem(0-7)  user   comando

Esta línea:
Código: [Seleccionar]
# Apagado automatico Thunder
30              1               *       *               *       root    /sbin/shutdown -h now

En este caso se está programado para que se apague a las 1 y 30 de la mañana solo sería cuestión de cambiar la hora que quieran ponerlo…  guardan y listo! con esto ya quedaría configurado el apagado automático de  nuestro server...

Ahora para el encendido automático usaremos el scheduler de mikrotik  agregando esta regla:
Código: [Seleccionar]
/system scheduler
add disabled=no interval=1d name="Prende Thunder" on-event="/tool wol interface=PROXY mac=00:00:00:00:00:00"

Donde dice mac=00:00:00:00:00:00  lo cambian por la mac de su thunder.

Recuerden que nuestra placa debe tener activa la función Wake on Lan activa.
aquí un video explicativo que encontré en la web para activarla


Bueno, por ahora, eso es todo….. Saludos para todos  :-*

buenas noche hice todo tal cual esta aqui el apagado me funciona 100%,  pero el encendido no por casualidda  hace falta algun script por ahi¿? nota tengo el wake on lan activo y todo,,,
Xtreme-Net Internet Con Nivel....

Desconectado willysantana

  • Sr. Member
  • ****
  • Mensajes: 250
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Apagado y encendido automático de nuestro server
« Respuesta #6 : noviembre 28, 2012, 08:53:45 am »
#!/bin/sh
clear
echo "****Bienvenido al Sitema de Apagado Automatico programado por Jose Vicente****"
echo ""
echo ""
echo "MENU"
echo " 1.-Apagar PC ahora"
echo " 2.-Reiniciar PC ahora"
echo " 3.-Apagar PC en una hora determinada"
echo " 4.-Apagar PC en un lapso determinado"
echo " 5.-Salir"
echo ""
read -p "Seleccionar Opcion: " OPCION
case $OPCION in
1) sudo halt;;
2) sudo reboot;;
3) echo -n "Ingresa la hora de apagado: "
read hora
sudo shutdown -h $hora;;
4)echo -n "Ingresa el numero de minutos, tras cual el Servidor se apagara: "
read minutos
sudo shutdown -h $minutos;;
5) exit;;
*) echo "Usted ingreso una opcion que no esta en el menu"
exit 1;;
esac
exit 0
este archivo le sera util ya que con esto se puede determinar la hora que uno quiere que se apage

amigo puedes explicar como usarlo.
me interesa esto para mi server.
gracias.

Desconectado Deivico

  • Newbie
  • *
  • Mensajes: 28
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Apagado y encendido automático de nuestro server
« Respuesta #7 : marzo 07, 2013, 06:00:28 pm »
Buenas a todos, quiero agradecer a este foro por haberme ayudado a montar mi primer server raptor y ya teniéndolo montado y trabajando bien se me presenta el problema de intentar agregarle un disco de 2TB y al comienzo todo bien hasta q intente montar los grupos y volumenes y no me deja esto es lo q me aparece agradezco cualquier ayuda para poder seguir adelante con el proceso.



Desconectado unointernet

  • Newbie
  • *
  • Mensajes: 45
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Apagado y encendido automático de nuestro server
« Respuesta #8 : mayo 14, 2013, 10:01:50 am »
Soy nuevo en esto y me llega un idea que no puedo concretar.

Como le hago para que el thundercache monitoree la interfaz ether1 de mikrotik y si el trafico de esta baja por debajo de 500kbps, se apague hasta que el mikrotik desee que este inicie a trabajar.

Osea mikrotik /tool traffic-monitor al ether1>1200kbps, la sentencia /tool wol interface=PROXY mac=00:00:00:00:00:00

thundercache monitorea su ether<500kbps, la sentencia de  root    /sbin/shutdown -h now

Espero me puedan ayudar.