Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 629
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 94
Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7

Como sabemos Thundercache es un sistema de proxy cache que se característica por guardar el contenido dinámico de las páginas web y el contenido estático se encarga el squid. Para instalar el Thundercache primero se tiene que tener en cuenta que nuestra infraestructura de red este en optimas condiciones (que tenga buen througput) por que sino en lugar de mejorar seria perjudicial para nuestra red, también se tiene que tener en cuenta que el hardware a utilizar estea en exelente condición y que sus componentes no sean de bajo nivel, como recomendación minima tiene que ser una P4 de 3.0 Ghz , 2 Ghz de RAM, disco duro de 500 Ghz, si se va a utilizar en escenarios donde haya un mayor tráfico de red no se recomienda usar Pcs de escritorio se recomienda usar servidores dedicados para este trabajo.


Para instalar tenemos que seguir los siguientes pasos.

1.- Primero tenemos que instalar Debían, se puede descargar de los siguientes enlaces.

32 bits
http://cdimage.debian.org/debian-cd/6.0.6/i386/iso-cd/debian-6.0.6-i386-netinst.iso

64 bits
http://cdimage.debian.org/debian-cd/6.0.6/amd64/iso-cd/debian-6.0.6-amd64-netinst.iso

Luego procedemos a instalar el Debian como se muestra en el video, se debe de poner el IP 192.168.10.2, ya posteriormente a la instlación del thunder se puede cambiar el IP que uno quiera.


2.- Instalamos el Thundercache en Debian para eso procedemos a ingresar los siguientes comandos por el terminal que ejecutara el script de instalación (se puede hacer tambien esto utilizando putty).

Es importante que durante la instalación del thunder poner la contraseña del Mysql: thunder31
32 bits
Código:
  1. wget http://www.joemg.host56.com/tc/thunder312-32.sh
  2. chmod 777 thunder312-32.sh
  3. ./thunder312-32.sh

64 bits
Código:
  1. wget http://www.joemg.host56.com/tc/thunder312-64.sh
  2. chmod 777 thunder312-64.sh
  3. ./thunder312-64.sh

3.- Redireccionamos y priorizamos el trafico de Thunder en Mikrotik con las siguientes reglas.

Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta thunder 3.1.x" disabled=no \
  3.     src-address=192.168.10.0/30
  4. /ip firewall nat
  5. add action=dst-nat chain=dstnat comment="Redirect Thunder 3.1.x" disabled=no \
  6.     dst-port=80 protocol=tcp src-address=!192.168.10.2 to-addresses=\
  7.     192.168.10.2 to-ports=3128
  8. /ip firewall mangle
  9. add action=mark-connection chain=postrouting comment="THUNDER CACHE FULL(TC 3.\
  10.    1.x) =======================================================================\
  11.    ===============================" content="X-Cache: HIT from Thunder" \
  12.     disabled=no new-connection-mark=thunder-connection passthrough=yes \
  13.     protocol=tcp src-address=192.168.10.2
  14. add action=mark-packet chain=postrouting connection-mark=thunder-connection \
  15.     disabled=no new-packet-mark=thunder-packs passthrough=yes
  16. add action=mark-connection chain=postrouting comment="TOS 12 (TC 3.1.x)=========\
  17.    ==========================================================================\
  18.    ==================================" disabled=no dscp=12 \
  19.     new-connection-mark=proxy-hits passthrough=yes protocol=tcp src-address=\
  20.     192.168.10.2
  21. add action=mark-packet chain=postrouting connection-mark=proxy-hits disabled=\
  22.     no new-packet-mark=proxy-squid passthrough=yes
  23. /queue tree
  24. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  25.     max-limit=4M name="T-cache_hits" packet-mark=proxy-squid parent=\
  26.     global-out priority=4 queue=default
  27. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  28.     max-limit=4M name=ThunderCache packet-mark=thunder-packs parent=\
  29.     global-out priority=4 queue=default

4.- Entramos por el navegador web para ver la interface gráfica ThundeReport.
http://192.168.10.2/thunder/


Contraseña ThundeReport:
 usuario:admin
 password:admin

Si nos sale como en la imagen quiere decir que la instalación fue un exito.

Para Instalar el ThunderCache 3.1.2 en Ubuntu Server se tiene que ingresar como root
Para eso activamos el usuario root
Código: [Seleccionar]
sudo passwd rootReiniciamos e ingresamos como root y se procede a ejecutar el script de instalación.
RaptorCache Developer

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 629
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 94
Re:Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7
« Respuesta #1 : octubre 27, 2012, 09:58:28 pm »
Ahí unos videos en el que se muestra el proceso de instalación del ThunderCache 3.1.2.

Instalación 32 bits

Instalación 64 bits
RaptorCache Developer

Desconectado saivercon

  • Newbie
  • *
  • Mensajes: 2
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7
« Respuesta #2 : diciembre 04, 2012, 09:44:26 pm »
.

Desconectado zonaoeste

  • Newbie
  • *
  • Mensajes: 3
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7
« Respuesta #3 : febrero 02, 2013, 07:54:03 pm »
Ola, estou tendo problemas para implantar as regras de redirecionamento no Mikrotik por que minha versão é a V 2.9.27 grande amigo você pode me ajudar nesse caso? Desde já agradeço a atenção.

Hola, estoy teniendo problemas para implementar reglas de redireccionamiento en Mikrotik versión es por eso que mi amigo V 2.9.27 bueno me puede ayudar en este caso? Ahora apreciamos la atención.

Desconectado epoy

  • Newbie
  • *
  • Mensajes: 2
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7
« Respuesta #4 : septiembre 25, 2013, 12:47:08 am »
i check http://joemg.host56.com/tc31/web.zip but file not found

thanks,

Desconectado Calamardo

  • Jr. Member
  • **
  • Mensajes: 95
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7
« Respuesta #5 : mayo 14, 2015, 11:22:01 am »
Aun se puede instalar este thunder o ya de plano se migro a raptorcache este mismo sistema??

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 26
Re:Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7
« Respuesta #6 : mayo 14, 2015, 06:33:38 pm »
Aun se puede instalar este thunder o ya de plano se migro a raptorcache este mismo sistema??

Fijate amigo que el script es descargable, sin ningun problema, el problema que comentan es con el ThunderReport, pero ahorita se lo reporte a Joemg6 el dira y yo les comento o en todo caso el atendera la duda, Saludos

Desconectado Calamardo

  • Jr. Member
  • **
  • Mensajes: 95
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7
« Respuesta #7 : mayo 14, 2015, 06:38:12 pm »
Deacuerdo pero estoy mirando que es lo mismo que raptorcache inclusive es mejor raptor aunque no he probado el thunder   

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 26
Re:Instalación de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 2.7
« Respuesta #8 : mayo 14, 2015, 11:09:40 pm »
Deacuerdo pero estoy mirando que es lo mismo que raptorcache inclusive es mejor raptor aunque no he probado el thunder

Si mi amigo es mejor RaptorCache y ojo que me hizo ver Joemg6 que Thunder 3.1.2 era para Debian 6 y puede que no halla una total compatibilidad con las nuevas versiones de Debian 7 u 8, Saludos