Liberar y priorizar tráfico Webshare

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 630
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 101
Liberar y priorizar tráfico Webshare
« : noviembre 01, 2012, 03:50:47 pm »
Para liberar y priorizar el tráfico tenemos que identificar las cabeceras que utiliza el Webshare, para esto que veremos la información que nos da para marcar el contenido, esto lo podemos ver en el panel de administración del Webshare
http://192.168.10.2/web/admin/
En la pestaña información buscamos la parte de HTTP Response Headers y buscamos la parte de "X-Powered-By:" como se ve marcada en la imagen



Se ha identificado que el contenido tiene la marca de:
X-Powered-By: PHP/5.3.3-7+squeeze14

Con este dato partiremos a hacer el marcado en el mikrotik.

Entonces la regla de marcado y priorización sería de esta forma
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment="FILE SERVER WEBSHARE\
  3.    =======================================================================\
  4.    ===============================" content="X-Powered-By: PHP/5.3.3-7+squeeze14" \
  5.     disabled=no new-connection-mark=file_serv-conn passthrough=yes \
  6.     protocol=tcp src-address=192.168.10.2
  7. add action=mark-packet chain=postrouting connection-mark=file_serv-conn \
  8.     disabled=no new-packet-mark=file-serv passthrough=yes
  9. /queue tree
  10. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  11.     max-limit=4M name="File Server webshare" packet-mark=file-serv parent=\
  12.     global-out priority=6 queue=default

Reemplazar "X-Powered-By: PHP/5.3.3-7+squeeze14" en content de acuerdo a la versión que tengamos.
RaptorCache Developer

Desconectado JOtiniano

  • Newbie
  • *
  • Mensajes: 21
  • Ubicación: Calle Tnt. Diego Ferre # 153 - Urb. Pando - San Miguel
  • Telecomunicaciones
    • Ver Perfil
    • Conexiones y Sistemas para el Mundo
  • Me Gusta: 0
Re:Liberar y priorizar tráfico Webshare
« Respuesta #1 : noviembre 02, 2012, 12:05:47 am »
Estimado JOEMG,
Acabo de probar la regla con una maquina que tiene 128/128Kbps y la Descarga de un Archivo que tengo en el WebShare es de 16 a 18Kbps.
Al parecer no esta funcionado, eh colocado el Marcado de Paquetes por ensima de todas mis reglas en el Mangle, me eh percatado que mi PHP es: X-Powered-By: PHP/5.3.3-7+squeeze13, tambien eh modificado eso.
Nose que podra ser
SL2.
Internet Satelital.
Servidores Firewall / Proxy.
Centrales Telefónicas / PBX.
Telefonía VOIP.
Sistemas de Información.

Desconectado luistec

  • Moderador
  • *
  • Mensajes: 1501
  • Ubicación: Los Olivos - Perú
    • Ver Perfil
  • Me Gusta: 52
Re:Liberar y priorizar tráfico Webshare
« Respuesta #2 : noviembre 02, 2012, 12:47:54 pm »
Buena regla joemg   :-*

Estimado JOEMG,
Acabo de probar la regla con una maquina que tiene 128/128Kbps y la Descarga de un Archivo que tengo en el WebShare es de 16 a 18Kbps.
Al parecer no esta funcionado, eh colocado el Marcado de Paquetes por ensima de todas mis reglas en el Mangle, me eh percatado que mi PHP es: X-Powered-By: PHP/5.3.3-7+squeeze13, tambien eh modificado eso.
Nose que podra ser
SL2.
Fijate si el mangle y en el queues tree hay tráfico, acabo de probar esta regla y si funciona, ahi una captura


Desconectado JOtiniano

  • Newbie
  • *
  • Mensajes: 21
  • Ubicación: Calle Tnt. Diego Ferre # 153 - Urb. Pando - San Miguel
  • Telecomunicaciones
    • Ver Perfil
    • Conexiones y Sistemas para el Mundo
  • Me Gusta: 0
Re:Liberar y priorizar tráfico Webshare
« Respuesta #3 : noviembre 05, 2012, 12:02:07 am »
Es Correcto Funciona.
El inconveniente era en la posición de las Reglas en el Mangle, voy a tratar de acomodarlos.
Gracias.
SL2.
Internet Satelital.
Servidores Firewall / Proxy.
Centrales Telefónicas / PBX.
Telefonía VOIP.
Sistemas de Información.

Desconectado leandro1979

  • Jr. Member
  • **
  • Mensajes: 72
  • Ubicación: Ecuador
    • Ver Perfil
  • Me Gusta: 2
Re:Liberar y priorizar tráfico Webshare
« Respuesta #4 : diciembre 19, 2012, 09:19:07 pm »
Buenas noches
Como podria agregar mi propio headers a mis servidores
para poder hacer un servidor de video y poder dar libre en mi LAN

saludos
leandro

Desconectado darkhammer

  • Newbie
  • *
  • Mensajes: 19
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Liberar y priorizar tráfico Webshare
« Respuesta #5 : enero 18, 2013, 12:15:16 am »
Para liberar y priorizar el tráfico tenemos que identificar las cabeceras que utiliza el Webshare, para esto que veremos la información que nos da para marcar el contenido, esto lo podemos ver en el panel de administración del Webshare
http://192.168.10.2/web/admin/
En la pestaña información buscamos la parte de HTTP Response Headers y buscamos la parte de "X-Powered-By:" como se ve marcada en la imagen



Se ha identificado que el contenido tiene la marca de:
X-Powered-By: PHP/5.3.3-7+squeeze14

Con este dato partiremos a hacer el marcado en el mikrotik.

Entonces la regla de marcado y priorización sería de esta forma
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment="FILE SERVER WEBSHARE\
  3.    =======================================================================\
  4.    ===============================" content="X-Powered-By: PHP/5.3.3-7+squeeze14" \
  5.     disabled=no new-connection-mark=file_serv-conn passthrough=yes \
  6.     protocol=tcp src-address=192.168.10.2
  7. add action=mark-packet chain=postrouting connection-mark=file_serv-conn \
  8.     disabled=no new-packet-mark=file-serv passthrough=yes
  9. /queue tree
  10. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  11.     max-limit=4M name="File Server webshare" packet-mark=file-serv parent=\
  12.     global-out priority=6 queue=default

Reemplazar "X-Powered-By: PHP/5.3.3-7+squeeze14" en content de acuerdo a la versión que tengamos.
AESTIMADO AMIGO JOEMG PODRIAS PUBLICAR TODO LO REFERENTE A WEBMIN Y CREACION DE IPS VIRTUALES... GRACIAS

Desconectado Mark

  • Newbie
  • *
  • Mensajes: 2
  • Ubicación: Argentina
  • Todo suma
    • Ver Perfil
  • Me Gusta: 0
Re:Liberar y priorizar tráfico Webshare
« Respuesta #6 : febrero 02, 2013, 11:51:48 pm »
Hola. Como se podria agregar un disco solo para webshare. Aparte tengo uno para el sistema y otro para el chache del thunder. Se puede? Y si se puede poner horarios para la utilizacion de webshare. Saludos muchas gracias.
Todo suma. Si te sirve -- son $2

Desconectado josueflat

  • Full Member
  • ***
  • Mensajes: 116
  • Ubicación: Republica Dominicana
    • Ver Perfil
  • Me Gusta: 1
Re:Liberar y priorizar tráfico Webshare
« Respuesta #7 : febrero 03, 2013, 09:24:30 pm »
Buenas noche, por casualidad existe alguna forma de reproducir peliculas en webshare¿?
Xtreme-Net Internet Con Nivel....

Desconectado btocarmona

  • Full Member
  • ***
  • Mensajes: 216
  • Ubicación: Argentina
    • Ver Perfil
  • Me Gusta: 1
Re:Liberar y priorizar tráfico Webshare
« Respuesta #8 : marzo 29, 2013, 12:59:46 am »
marque los paqutes y me salio todo barbaro amigo JoemG ahora me hago una pregunta se podra liberar para que los usuarios puedan subir mas rapido los archivos y no entre en juego la limitacion de subida que tengo en mikrotik a cada usuario ?

Desconectado seth750km

  • Jr. Member
  • **
  • Mensajes: 53
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Liberar y priorizar tráfico Webshare
« Respuesta #9 : abril 01, 2014, 04:25:45 pm »
alguien sabe como seria esto pero para subsonic?

Desconectado luistec

  • Moderador
  • *
  • Mensajes: 1501
  • Ubicación: Los Olivos - Perú
    • Ver Perfil
  • Me Gusta: 52
Re:Liberar y priorizar tráfico Webshare
« Respuesta #10 : abril 01, 2014, 06:41:11 pm »
alguien sabe como seria esto pero para subsonic?
Puedes marcar por el puerto que esta usando subsonic, por ejemplo
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=Subsonic disabled=no new-connection-mark=subsonic-conn passthrough=yes protocol=tcp src-address=192.168.10.2 src-port=4040
  3. add action=mark-packet chain=postrouting connection-mark=subsonic-conn disabled=no new-packet-mark=subsonic passthrough=no

Saludos.

Desconectado GTE_NETWORK

  • Newbie
  • *
  • Mensajes: 27
  • Ubicación: Puerto Ordaz - Venezuela
  • Vive Siempre Conectado a la Mejor Velocidad
    • Ver Perfil
    • Xtremenet / Internet - Redes - Enlaces
  • Me Gusta: 0
Re:Liberar y priorizar tráfico Webshare
« Respuesta #11 : octubre 25, 2015, 12:14:04 am »
Puedes marcar por el puerto que esta usando subsonic, por ejemplo
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=Subsonic disabled=no new-connection-mark=subsonic-conn passthrough=yes protocol=tcp src-address=192.168.10.2 src-port=4040
  3. add action=mark-packet chain=postrouting connection-mark=subsonic-conn disabled=no new-packet-mark=subsonic passthrough=no


Saludos.
Excelente me ayudo en mi server multimedia Agradecido..
Telecomunicaciones GteNetwork
Internet - Redes - Enlaces
Email:info@gte.com.ve
Web: www.gte.com.ve

Desconectado danteviera

  • Newbie
  • *
  • Mensajes: 15
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Liberar y priorizar tráfico Webshare
« Respuesta #12 : diciembre 14, 2015, 11:40:04 pm »
Hola, antes que nada gracias JOEMG6, firecold, etc, por el RAPTOR, lo estoy probando recien con 20 usuarios. Tengo una consulta: - El webshare aun es funcional ? ya que he probado ingresar al ip http://192.168.10.2/web/admin/ pero no he podido lograr accecder me sale mensaje de error NOT FOUND.

De antemano gracias.
"Raptor 2.0.2" - C2D, 4Gb ram ddr2 , Hdd Seagate 1Tera.
"Mkt" Intel P4 1.2Ghz,  256Gb Ram, Placa Intel
Speedy 20Mb 1 linea - 30 User(20 simultaneos)

Desconectado luistec

  • Moderador
  • *
  • Mensajes: 1501
  • Ubicación: Los Olivos - Perú
    • Ver Perfil
  • Me Gusta: 52
Re:Liberar y priorizar tráfico Webshare
« Respuesta #13 : diciembre 17, 2015, 11:35:41 am »
Hola, antes que nada gracias JOEMG6, firecold, etc, por el RAPTOR, lo estoy probando recien con 20 usuarios. Tengo una consulta: - El webshare aun es funcional ? ya que he probado ingresar al ip http://192.168.10.2/web/admin/ pero no he podido lograr accecder me sale mensaje de error NOT FOUND.

De antemano gracias.
Ahora ya no viene por defecto en la instalación de Raptor webshare, también webshare a quedado descontinuado su desarrollo, pero puedes instalar Pydio una solución que tiene más mejoras y un desarrollo más continuo.
https://pydio.com

Saludos.

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:Liberar y priorizar tráfico Webshare
« Respuesta #14 : mayo 29, 2016, 11:03:30 am »
Para liberar y priorizar el tráfico tenemos que identificar las cabeceras que utiliza el Webshare, para esto que veremos la información que nos da para marcar el contenido, esto lo podemos ver en el panel de administración del Webshare
http://192.168.10.2/web/admin/
En la pestaña información buscamos la parte de HTTP Response Headers y buscamos la parte de "X-Powered-By:" como se ve marcada en la imagen



Se ha identificado que el contenido tiene la marca de:
X-Powered-By: PHP/5.3.3-7+squeeze14

Con este dato partiremos a hacer el marcado en el mikrotik.

Entonces la regla de marcado y priorización sería de esta forma
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment="FILE SERVER WEBSHARE\
  3.    =======================================================================\
  4.    ===============================" content="X-Powered-By: PHP/5.3.3-7+squeeze14" \
  5.     disabled=no new-connection-mark=file_serv-conn passthrough=yes \
  6.     protocol=tcp src-address=192.168.10.2
  7. add action=mark-packet chain=postrouting connection-mark=file_serv-conn \
  8.     disabled=no new-packet-mark=file-serv passthrough=yes
  9. /queue tree
  10. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
  11.     max-limit=4M name="File Server webshare" packet-mark=file-serv parent=\
  12.     global-out priority=6 queue=default

Reemplazar "X-Powered-By: PHP/5.3.3-7+squeeze14" en content de acuerdo a la versión que tengamos.

como saber el X-Powered-By: PHP/5.3.3-7+squeeze14 que tengamos en cualquier sistema ????????
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve