REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE

Desconectado manrrique

  • Newbie
  • *
  • Mensajes: 7
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« : marzo 26, 2013, 03:36:05 pm »
Hola amigos, quiero implementar lo siguiente: Cuando falla la conexion de internet de mi proveedor, necesito que mikrotik redireccione a una pagina web alojada en mi server Debian (donde esta el thundercache 3.1 instalado), y que me sirva como comunicado a mis clientes sobre la situacion o el problema.  espero sus respuestas.  Gracias y saludos.

Desconectado Zero

  • Jr. Member
  • **
  • Mensajes: 78
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #1 : marzo 26, 2013, 07:07:37 pm »
Hola,

Eso se hace por medio de un Servidor de DNS (y no por medio de iptables), pero pues no uso mikrotik así que no se como se manejará ese tema en mikrotik.

Saludos,


Lelouch
facebook.com/zerolinux
En GNU/Linux formatear por cualquier cosa es de noobs, tu decides si eres uno...

Desconectado josueflat

  • Full Member
  • ***
  • Mensajes: 116
  • Ubicación: Republica Dominicana
    • Ver Perfil
  • Me Gusta: 1
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #2 : marzo 26, 2013, 09:09:44 pm »
Hola amigos, quiero implementar lo siguiente: Cuando falla la conexion de internet de mi proveedor, necesito que mikrotik redireccione a una pagina web alojada en mi server Debian (donde esta el thundercache 3.1 instalado), y que me sirva como comunicado a mis clientes sobre la situacion o el problema.  espero sus respuestas.  Gracias y saludos.
Buenas noche yo tambien me sumo, desde ase tiempo quiero implementar una pagina en caso de no tener acceso a internet....
Xtreme-Net Internet Con Nivel....

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
tc3.1.2
« Respuesta #3 : marzo 26, 2013, 09:40:34 pm »
amigo les comento q hoy me llevo la solpresa q me esta fallando el tc...... lo raro es qtenia ya cacheada uno video ya hace rato porq ese siempre lo veia pero justo hoy instala a un cliente veo este video me la sale error  amigo joem a q se debe esto ayudaporfa..............Ya lo apague porq me dio problemas gracias por a ayuda

Desconectado dahuar

  • Full Member
  • ***
  • Mensajes: 118
  • Ubicación: Mexico
    • Ver Perfil
  • Me Gusta: 3
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #4 : mayo 31, 2013, 06:56:09 pm »
Tambien me gustaría poder brindar esa opción cuando falle el internet.
 Saludos
ISP en mexico, Skype: dahuar

Desconectado venezuela

  • Newbie
  • *
  • Mensajes: 29
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #5 : mayo 31, 2013, 11:23:35 pm »
AMIGOS TAMBIÉN ME SUMO A LA MISMA SITUACIÓN QUISIERA CONTAR CON UN DIRECCIONAMIENTO SI FALLAN LOS DNS DONDE LOS CLIENTES PUEDAN APRECIAR UNA NOTIFICACIÓN DE LA FALLA QUE SE ESTA PRESENTANDO AGRADECEMOS SI ALGUIEN SABE SI ES POSIBLE ESTA OPCIÓN UN SALUDO A TODA LA COMUNIDAD GRACIAS.

Desconectado Zero

  • Jr. Member
  • **
  • Mensajes: 78
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #6 : junio 01, 2013, 07:52:39 pm »
Bueno creo que podríamos hacer algo, pero primero se necesitarían establecer algunos parámetros, como por ejemplo: cuantos de aquí usan balanceo de carga?, que usan para balancear?.

Abrazos,


Lelouch
LimeRooT Development Team
En GNU/Linux formatear por cualquier cosa es de noobs, tu decides si eres uno...

Desconectado venezuela

  • Newbie
  • *
  • Mensajes: 29
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #7 : junio 01, 2013, 10:24:37 pm »
amigo yo uso balaceo de carga con tp-link tengo 2 lineas de cantv, 1na rb 1200mk y por supuesto el raptor como podrias ayudarnos gracias saludos......

Desconectado dahuar

  • Full Member
  • ***
  • Mensajes: 118
  • Ubicación: Mexico
    • Ver Perfil
  • Me Gusta: 3
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #8 : junio 02, 2013, 09:48:24 pm »
Por ahora no requiero de balanceo pero a medida que aumenten mis clientes seguro que si, y sera una RB 750

Saludos
ISP en mexico, Skype: dahuar

Desconectado r0dr160

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #9 : junio 05, 2013, 11:03:37 pm »
Soy brasileño no parecen ser muy bien el español, así que utiliza el traductor de google.
Tengo en mi proveedor de Internet un sistema similar y quiero compartir ayuda y esperanza.
Funciona bien cuando la señal cayó el enlace para recibir un mensaje de servicio se informará en la pantalla o en otro sitio.
La regla está desactivada por defecto y se activa automáticamente cuando el enlace se destacan.

IP y el puerto del sitio serán redirigidos
/ip firewall nat add action=dst-nat chain=dstnat comment="LINK OFF" to-addresses=[IP OU SITE] to-ports=[PORTA] src-address=0.0.0.0/0 src-port=!80 protocol=tcp disabled=yes

Obtenga respuestas de un sitio web que usted elija ip desbloqueable y para deshabilitar la redirección
/tool netwatch add comment="Status del link" disabled=no down-script=\ "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=no\r\ \n" host=[IP DE UM SITIO PARA TESTE DEL LINK] interval=30s timeout=2s up-script=\ "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=yes"

Los créditos no son mías pero espero ayudar
subistitui la [IP o puerto] los datos necesarios.

freedarwuin

  • Visitante
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #10 : junio 07, 2013, 10:30:45 am »
Soy brasileño no parecen ser muy bien el español, así que utiliza el traductor de google.
Tengo en mi proveedor de Internet un sistema similar y quiero compartir ayuda y esperanza.
Funciona bien cuando la señal cayó el enlace para recibir un mensaje de servicio se informará en la pantalla o en otro sitio.
La regla está desactivada por defecto y se activa automáticamente cuando el enlace se destacan.

IP y el puerto del sitio serán redirigidos
/ip firewall nat add action=dst-nat chain=dstnat comment="LINK OFF" to-addresses=[IP OU SITE] to-ports=[PORTA] src-address=0.0.0.0/0 src-port=!80 protocol=tcp disabled=yes

Obtenga respuestas de un sitio web que usted elija ip desbloqueable y para deshabilitar la redirección
/tool netwatch add comment="Status del link" disabled=no down-script=\ "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=no\r\ \n" host=[IP DE UM SITIO PARA TESTE DEL LINK] interval=30s timeout=2s up-script=\ "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=yes"

Los créditos no son mías pero espero ayudar
subistitui la [IP o puerto] los datos necesarios.


Gracias amigo cuando dices addresses=[IP OU SITE] to-ports=[PORTA] que te refieres con eso puerto 80 de internet? ip ou site es el rango de ip del mikrotik?

Desconectado dahuar

  • Full Member
  • ***
  • Mensajes: 118
  • Ubicación: Mexico
    • Ver Perfil
  • Me Gusta: 3
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #11 : junio 14, 2013, 12:45:31 pm »
Alguien me podria explicar como poner una pagina web in mikrotik y acceder a ella desde la misma red? es para el redireccionamiento de este hilo. ya que las reglas que nos da el amigo r0dr160 nos pide una pagina web a redirijir cuando esta caida la red.
 Saludos
ISP en mexico, Skype: dahuar

Desconectado r0dr160

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #12 : junio 16, 2013, 01:45:00 pm »

Gracias amigo cuando dices addresses=[IP OU SITE] to-ports=[PORTA] que te refieres con eso puerto 80 de internet? ip ou site es el rango de ip del mikrotik?

Este caso sería la IP y el puerto a optar por recibir la redirección cuando falla la internet.
addresses=Recibir redirección ip, port = dirección del puerto
Ejemplo: address=192.168.10.2 port=85

Desconectado r0dr160

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #13 : junio 16, 2013, 02:07:29 pm »
Alguien me podria explicar como poner una pagina web in mikrotik y acceder a ella desde la misma red? es para el redireccionamiento de este hilo. ya que las reglas que nos da el amigo r0dr160 nos pide una pagina web a redirijir cuando esta caida la red.
 Saludos

Utilice la ip y una página y un puerto del squid donde esta lo raptor con las reglas informados, recuerde que u puede acceder al panel de raptor es la puerta 82, crea un puerto y redirigir la página a exibir

Desconectado charlesjavier

  • Newbie
  • *
  • Mensajes: 7
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #14 : octubre 28, 2013, 02:33:16 am »
Muy buen aporte lo estoy probando y funciona a la perfección

Desconectado centronick

  • Jr. Member
  • **
  • Mensajes: 99
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 1
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #15 : octubre 28, 2013, 01:00:54 pm »
Amigo lo estoy bando y no me funciona y lo tengo asi.

/ip firewall nat
add action=dst-nat chain=dstnat comment="LINK OFF" disabled=yes protocol=tcp \
    src-address=0.0.0.0/0 src-port=!80 to-addresses=192.168.10.2 to-ports=80

/tool netwatch
add comment="Status del link" disabled=no down-script=\
    "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=no\r\
    \n" host=192.168.10.2 interval=30s timeout=2s up-script=\
    "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=yes"

Que tengo malo y las gracias

Desconectado btocarmona

  • Full Member
  • ***
  • Mensajes: 216
  • Ubicación: Argentina
    • Ver Perfil
  • Me Gusta: 2
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #16 : noviembre 02, 2013, 05:08:15 pm »
Amigo lo estoy bando y no me funciona y lo tengo asi.

/ip firewall nat
add action=dst-nat chain=dstnat comment="LINK OFF" disabled=yes protocol=tcp \
    src-address=0.0.0.0/0 src-port=!80 to-addresses=192.168.10.2 to-ports=80

/tool netwatch
add comment="Status del link" disabled=no down-script=\
    "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=no\r\
    \n" host=192.168.10.2 interval=30s timeout=2s up-script=\
    "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=yes"

Que tengo malo y las gracias

Amigo si prestas atención el script de Netwach busca la regla en Nat que tenga como Comentario MANTENIMIENTO si te fijas el nombre de la misma es LINK OFF cambiaselo porque sino cuando busca para redireccionar no encuentra esa regla.

Les dejo mis reglas pasadas en limpio a alguien más le puede servir yo apunto al puerto 83 porque en el 80 tengo el corte del servicio en el 82 raptor en el 83 MANTENIMIENTO y en el 84 Sarg, esto se hace agregando un servidor virtual yo lo tengo asi:

Código: [Seleccionar]
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
Listen 82
<VirtualHost *:82>
 DocumentRoot /var/raptor
 ServerName www.raptorcache.com
 ErrorLog /var/log/virtual82-error_log
 CustomLog /var/log/virtual82-access_log common
 </VirtualHost>
Listen 83
<VirtualHost *:83>
 DocumentRoot /var/www/corte
 ServerName www.raptorcache.com
 ErrorLog /var/log/virtual83-error_log
 CustomLog /var/log/virtual83-access_log common
 </VirtualHost>
 Listen 84
<VirtualHost *:84>
 DocumentRoot /var/www/sarg
 ServerName www.raptorcache.com
 </VirtualHost>

y en mikrotik estas reglas

Código: [Seleccionar]
/ip firewall nat
add action=dst-nat chain=dstnat comment=MANTENIMIENTO disabled=yes protocol=tcp src-address=0.0.0.0/0 \
    src-port=!80 to-addresses=192.168.10.2 to-ports=83

/tool netwatch
add comment="Status del link" disabled=no down-script=\
    "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=no\r\
    \n" host=204.79.197.200 interval=30s timeout=4s up-script=\
    "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=yes"


Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #17 : noviembre 02, 2013, 05:31:20 pm »
Amigo si prestas atención el script de Netwach busca la regla en Nat que tenga como Comentario MANTENIMIENTO si te fijas el nombre de la misma es LINK OFF cambiaselo porque sino cuando busca para redireccionar no encuentra esa regla.

Les dejo mis reglas pasadas en limpio a alguien más le puede servir yo apunto al puerto 83 porque en el 80 tengo el corte del servicio en el 82 raptor en el 83 MANTENIMIENTO y en el 84 Sarg, esto se hace agregando un servidor virtual yo lo tengo asi:

Código: [Seleccionar]
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<irectory />
Options FollowSymLinks
AllowOverride None
</Directory>
<irectory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<irectory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
Listen 82
<VirtualHost *:82>
 DocumentRoot /var/raptor
 ServerName www.raptorcache.com
 ErrorLog /var/log/virtual82-error_log
 CustomLog /var/log/virtual82-access_log common
 </VirtualHost>
Listen 83
<VirtualHost *:83>
 DocumentRoot /var/www/corte
 ServerName www.raptorcache.com
 ErrorLog /var/log/virtual83-error_log
 CustomLog /var/log/virtual83-access_log common
 </VirtualHost>
 Listen 84
<VirtualHost *:84>
 DocumentRoot /var/www/sarg
 ServerName www.raptorcache.com
 </VirtualHost>

y en mikrotik estas reglas

Código: [Seleccionar]
/ip firewall nat
add action=dst-nat chain=dstnat comment=MANTENIMIENTO disabled=yes protocol=tcp src-address=0.0.0.0/0 \
    src-port=!80 to-addresses=192.168.10.2 to-ports=83

/tool netwatch
add comment="Status del link" disabled=no down-script=\
    "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=no\r\
    \n" host=204.79.197.200 interval=30s timeout=4s up-script=\
    "/ip firewall nat set [find comment=\"MANTENIMIENTO\"] disabled=yes"

Las he visto bastante estas reglas cuando me puedes ayudar en esto?
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve

Desconectado btocarmona

  • Full Member
  • ***
  • Mensajes: 216
  • Ubicación: Argentina
    • Ver Perfil
  • Me Gusta: 2
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #18 : noviembre 02, 2013, 11:41:37 pm »
Las he visto bastante estas reglas cuando me puedes ayudar en esto?
Si amigo cuando digas decime donde tenes la duda y trataremos de hacerlo funcionar

Desconectado btocarmona

  • Full Member
  • ***
  • Mensajes: 216
  • Ubicación: Argentina
    • Ver Perfil
  • Me Gusta: 2
Re:REDIRECCIONAR A UNA PAGINA WEB CUANDO EL INTERNET SE CAE
« Respuesta #19 : diciembre 12, 2013, 01:37:41 pm »
Posteo una explicacion que hice por MP a mdcomputacion a alguien le puede servir

Amigo primeramente create una carpeta dentro de /var/www por ejemplo ccon el nombre corte y ahi dentro copias tu index.hml con todos los archivos que mencionas luego no olvides de crear un host virtual esto lo hace editando el archivo 000-default que esta dentro de  /etc/apache2/sites-enabled al final del archivo agrega Listen 83

<VirtualHost *:83>
 DocumentRoot /var/www/corte
 ServerName www.raptorcache.com
 ErrorLog /var/log/virtual83-error_log
 CustomLog /var/log/virtual83-access_log common
 </VirtualHost>

y le das guardar, una vez guardado tan solo copias las reglas tal cual estan copiadas en el post, a tu mikrotik,y deberia funcionar sin problemas, como detalle no debes tener habilitado bloquear los ping desde afuera.

Creo que ya está todo mas que claro amigos espero les funcione, si no peguen el grito,Saludos