Instalación de RaptorCache en Debian 7

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 630
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 103
Instalación de RaptorCache en Debian 7
« : mayo 27, 2013, 09:31:50 am »
Instalación de RaptorCache en Debian 7
Para la instalación tomaremos como ejemplo el siguiente esquema.


Es importante que durante la instalación del RaptorCache poner la contraseña del Mysql: raptor

64 bits
Código:
  1. wget http://www.raptorcache.netii.net/raptor64-d7.sh
  2. chmod 777 raptor64-d7.sh
  3. bash raptor64-d7.sh

Redireccionamos y priorizamos el trafico de Raptor en Mikrotik con las siguientes reglas.
Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/30
  3. /ip firewall nat
  4. add action=dst-nat chain=dstnat comment="Redirect Raptorcache" disabled=no dst-port=80 protocol=tcp src-address=!192.168.10.2 to-addresses=192.168.10.2 to-ports=3128
  5. /ip firewall mangle
  6. add action=mark-connection chain=postrouting comment="== RAPTORCACHE ==" content="X-Cache: HIT from Raptor" disabled=no new-connection-mark=raptor-connection passthrough=yes src-address=192.168.10.2 protocol=tcp
  7. add action=mark-packet chain=postrouting connection-mark=raptor-connection disabled=no new-packet-mark=raptor-packs passthrough=yes
  8. add action=mark-connection chain=postrouting comment="== SQUID ==" content="X-Cache: HIT from proxy.os.com" disabled=no new-connection-mark=squid-connection passthrough=yes src-address=192.168.10.2 protocol=tcp
  9. add action=mark-packet chain=postrouting connection-mark=squid-connection disabled=no new-packet-mark=squid-packs passthrough=yes
  10. /queue tree
  11. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="RaptorCache" packet-mark=raptor-packs parent=global-out priority=4 queue=default
  12. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="Squid 3.x" packet-mark=squid-packs parent=global-out priority=4 queue=default

Entramos por el navegador web para ver la interface gráfica Raptor Webpanel.
Para visualizar el Webpanel ingresamos la siguiente dirección en el navegador web.
http://IP_DEL_SERVIDOR:82

Nombre de Usuario=admin
Contraseña=admin

Todo el proceso del script durante la Instalación de RaptorCache en Debian 7

Para los que extrañaban la configuración del TOS en el Squid, en esta versión soporta esa configuración sin necesidad de compilar, para mayores detalles pueden revisar este post
http://www.alterserv.com/foros/index.php?topic=21.0
La regla de marcado en el caso de esta configuración sería (solo la regla de squid)
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment="==SQUID - TOS 12==" disabled=no dscp=12 \
  3. new-connection-mark=squid-connection passthrough=yes protocol=tcp src-address=192.168.10.2
  4. add action=mark-packet chain=postrouting connection-mark=squid-connection disabled=\
  5. no new-packet-mark=squid-packs passthrough=yes
RaptorCache Developer

WALYN

  • Visitante
Re:Instalación de RaptorCache en Debian 7
« Respuesta #1 : mayo 27, 2013, 03:20:36 pm »
debian 7 para instalar Raptorcache                 http://www.debian.org/distrib/

Desconectado haroldbb24

  • Newbie
  • *
  • Mensajes: 29
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #2 : mayo 27, 2013, 04:45:03 pm »
esta actualizacion tiene problema de la memoria que no refresca o ya esta corregido? que mejoras mas traen?

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 496
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 5
Re:Instalación de RaptorCache en Debian 7
« Respuesta #3 : mayo 27, 2013, 09:35:03 pm »
se agradece ::) , pero dime es necesario usar nat o ya no
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado rjfz

  • Jr. Member
  • **
  • Mensajes: 51
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #4 : mayo 27, 2013, 09:36:20 pm »
amigo joemg puedes revisar el script de 32 bit creo que tiene un error en esto wget http://www.raptorcache.com/install/lib/64/libmysqlclient.so.16 creo que instala la libreria de 64 bit en lugar de la de 32 bit

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 630
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 103
Re:Instalación de RaptorCache en Debian 7
« Respuesta #5 : mayo 28, 2013, 10:48:35 am »
se agradece ::) , pero dime es necesario usar nat o ya no
También se puede configurar por mangle, revisa por esta parte
http://www.alterserv.com/foros/index.php?topic=532.0
RaptorCache Developer

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 630
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 103
Re:Instalación de RaptorCache en Debian 7
« Respuesta #6 : mayo 28, 2013, 10:49:40 am »
amigo joemg puedes revisar el script de 32 bit creo que tiene un error en esto wget http://www.raptorcache.com/install/lib/64/libmysqlclient.so.16 creo que instala la libreria de 64 bit en lugar de la de 32 bit
Cierto, ya fue corregido ese detalle.
RaptorCache Developer

Desconectado NETFACIL

  • Newbie
  • *
  • Mensajes: 4
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #7 : mayo 29, 2013, 12:20:31 pm »
Saludos mi querido Joemg, quisiera saber si estos cambios se aplican a nuestro raptor? ??
Otro de los puntos si es posible que alguien haga un video del tutorial del sistema de modo que nuestra mara vilhoso Raptor porque tenía algunos dificudades como foratação la segunda Hd.Sei que usted es una persona muy ocupada más conscientes de que algunos no tienen mucho de conhcimento linux sería bueno encrementação estas explicaciones le doy las gracias por su atención un fuerte abrazo a uno de sus muchos fans en todo el mundo Leandro Brito, Campina grande, Brasil.

Desconectado Jeremy

  • Newbie
  • *
  • Mensajes: 26
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #8 : mayo 29, 2013, 09:57:17 pm »
Disculpen, los plugins se trabajarian de la misma forma que para los de 32bits? ya que hice un plugin de una pagina y me funcionaba en el 32bits y ahora la coloque en el de 64bit y no me aparece en los reportes de los domios, sera ese el problema?? gracias por su respuesta, exelente aporte!!!!!!!

Desconectado ninohwifi

  • Jr. Member
  • **
  • Mensajes: 61
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #9 : mayo 30, 2013, 03:35:06 pm »
Joemg hay alguna forma de actualizar esto en debian 6... sin que haya necesidad de instalar el sistema debian 7  ???

 Squid 3.1.20
- MySQL 5.5.30
- Apache 2.2.22
- PHP 5.4.4

esos son los componentes que pregunto si se pueden actualizar.... los mismo que tu dijistes que venian actualizados con debian 7 !!

Desconectado rjfz

  • Jr. Member
  • **
  • Mensajes: 51
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #10 : junio 01, 2013, 02:25:28 pm »
quien me ayuda con este error del (syslog)
Jun  1 14:50:01 proxy /USR/SBIN/CRON[13006]: (www-data) CMD (php --define suhosin.memory_limit=512M /usr/share/cacti/site/poller.php 2>&1 >/dev/null | if [ -f /usr/bin/ts ] ; then ts ; else tee ; fi >> /var/log/cacti/poller-error.log)

Desconectado tacioandrade

  • Newbie
  • *
  • Mensajes: 3
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #11 : junio 01, 2013, 03:57:07 pm »
Buenas tardes, instalé Debian 7 netinstall de 32 bits en virtualbox para probar raptorcache después de instalar raptorcache (cuya instalación se realizó sin errores aparentes), el squid3 no arranque.
Cuando trato de ejecutar de forma manual:

root@proxy:~# /etc/init.d/squid3 start
[....] Starting Squid HTTP Proxy 3.x: squid32013/06/01 17:51:24| WARNING: Unknown neighbor type: 8080
FATAL: Bungled squid.conf line 178: cache_peer  parent 8080 0 proxy-only no-digest
Squid Cache (Version 3.1.20): Terminated abnormally.
CPU Usage: 0.028 seconds = 0.000 user + 0.028 sys
Maximum Resident Size: 17584 KB
Page faults with physical i/o: 0
 failed!
root@proxy:~# /etc/init.d/raptor restart
Restarting Raptor ...
Starting Raptor 1.0.2b


¿Alguien sabe qué podría ser?

Desconectado alfiloro

  • Newbie
  • *
  • Mensajes: 39
  • Ubicación: charallave.miranda
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #12 : junio 02, 2013, 09:56:52 pm »
hola joemg disculpa la pregunta cuales son las mejoras de este raptor en debían 7 y aparte tengo el siguiente problema mi raptor esta en una tarjeta g41m-vs3, procesador core 2quad, ram 4gb, disco de 320gb y todavía asi el cacheo sale máximo a 8mb a mis clientes y e visto en otros raptor que sale asta en 74mb por favor me indica que debo hacer para alcanzar esa velocidad gracias de antemano.....
el que puede puede por que cree que puede

Desconectado carlx

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #13 : junio 04, 2013, 12:55:06 pm »
Cierto, ya fue corregido ese detalle.

joemg6, saludos gracias por tu trabajo, al igual que otros usuarios tengo la duda si debemos usar solo las reglas que posteaste en este tutorial de instalacion de raptor sobre debian 7, o si por el contrario hay que agregar las anteriores de debian 6.0.7 y solo modificar las /ip firewall mangle de mikrotik. muchas gracias.

Desconectado ajbg

  • Newbie
  • *
  • Mensajes: 10
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #14 : junio 04, 2013, 05:42:54 pm »
he cambiado mi sistema operativo de 32 a 64bit  he instalado debian 7 y esta version de raptor, he agregado la regla que pones arriba y el desabilitado la que se supone que esta sustituye pero ahora no redirecciona, pone lenta la red, y no me hace ningun tipo de cache en que falle si agregue todo tal cual lo muestras en esta pagina

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 630
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 103
Re:Instalación de RaptorCache en Debian 7
« Respuesta #15 : junio 04, 2013, 06:17:15 pm »
joemg6, saludos gracias por tu trabajo, al igual que otros usuarios tengo la duda si debemos usar solo las reglas que posteaste en este tutorial de instalacion de raptor sobre debian 7, o si por el contrario hay que agregar las anteriores de debian 6.0.7 y solo modificar las /ip firewall mangle de mikrotik. muchas gracias.
Las reglas de marcado del mangle ==SQUID - TOS 12== remplazan a las reglas del == SQUID == , para identificar el contenido por TOS (Tipo de Servicio) esto a partir de versiones posteriores al squid 3.1.18.
RaptorCache Developer

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 630
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 103
Re:Instalación de RaptorCache en Debian 7
« Respuesta #16 : junio 04, 2013, 06:23:04 pm »
he cambiado mi sistema operativo de 32 a 64bit  he instalado debian 7 y esta version de raptor, he agregado la regla que pones arriba y el desabilitado la que se supone que esta sustituye pero ahora no redirecciona, pone lenta la red, y no me hace ningun tipo de cache en que falle si agregue todo tal cual lo muestras en esta pagina
Las reglas del mangle que estan en la parte superior no hacen ningún cambio en la redirección solo hace el cambio en el modo de identificar el contenido del Squid y esto para su posterior priorización.
Para que utilicen estas reglas tienen que aumentar las directivas correspondientes en el squid.conf para que haga esta identificación, por ese motivo puse el enlace al post que hace esa referencia.
http://www.alterserv.com/foros/index.php?topic=21.0
RaptorCache Developer

Desconectado ajbg

  • Newbie
  • *
  • Mensajes: 10
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #17 : junio 05, 2013, 12:10:06 pm »
ya logre que redireccionara todo bien, ahora me surge un problema que por lo visto a otros tambien le esta sucediendo, es que cuando el raptor esta enviando el cache se supone que lo tiene que hacer a 4M pero solo lo manda a 200 y 400Kbps como minimo y maximo, le subi a 10M a ver si era por eso y aun asi no logro hacer que la velocidad de envio sea la correcta, porque entonces el video cacheado en la pc se pega peor que verlo online (en tiempo real) he leido y buscado antes de expresar mi inquietud personal

Desconectado luistec

  • Moderador
  • *
  • Mensajes: 1501
  • Ubicación: Los Olivos - Perú
    • Ver Perfil
  • Me Gusta: 52
Re:Instalación de RaptorCache en Debian 7
« Respuesta #18 : junio 05, 2013, 12:28:48 pm »
ya logre que redireccionara todo bien, ahora me surge un problema que por lo visto a otros tambien le esta sucediendo, es que cuando el raptor esta enviando el cache se supone que lo tiene que hacer a 4M pero solo lo manda a 200 y 400Kbps como minimo y maximo, le subi a 10M a ver si era por eso y aun asi no logro hacer que la velocidad de envio sea la correcta, porque entonces el video cacheado en la pc se pega peor que verlo online (en tiempo real) he leido y buscado antes de expresar mi inquietud personal
Que reglas estas utilizando por nat o por mangle? eso mas parece una mala configuracion en el mikrotik seria que revises tus reglas.

Saludos.

Desconectado ajbg

  • Newbie
  • *
  • Mensajes: 10
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Instalación de RaptorCache en Debian 7
« Respuesta #19 : junio 05, 2013, 12:49:33 pm »
estas son mis reglas

/ip firewall nat
add action=dst-nat chain=dstnat comment="Redireccionar RaptorCache" disabled=no \
    dst-port=80 protocol=tcp src-address=!192.168.10.2 to-addresses=\
    192.168.10.2 to-ports=3128
add action=redirect chain=dstnat comment="DNS Cache Transparente" disabled=no \
    dst-port=53 in-interface=Lan protocol=udp to-ports=53
add action=masquerade chain=srcnat comment="Permitir Internet" disabled=no \
    out-interface=Internet

/ip firewall mangle
add action=mark-connection chain=postrouting comment="== RAPTORCACHE ==" \
    content="X-Cache: HIT from Raptor" disabled=no new-connection-mark=\
    raptor-connection passthrough=yes protocol=tcp src-address=192.168.10.2
add action=mark-packet chain=postrouting connection-mark=raptor-connection \
    disabled=no new-packet-mark=raptor-packs passthrough=yes
add action=mark-connection chain=postrouting comment="==SQUID - TOS 12==" \
    disabled=no dscp=12 new-connection-mark=squid-connection passthrough=yes \
    protocol=tcp src-address=192.168.10.2
add action=mark-packet chain=postrouting connection-mark=squid-connection \
    disabled=no new-packet-mark=squid-packs passthrough=yes

/ip firewall filter
add action=drop chain=input comment="Cancelar Conexiones Invalidas" \
    connection-state=invalid disabled=no
add action=accept chain=input comment="Permitir conexiones establecidas" \
    connection-state=established disabled=no
add action=accept chain=input comment="Permitir ICMP" disabled=no protocol=icmp
add action=drop chain=input comment="Cancelar todo lo demas" disabled=no \
    dst-port=!1812,1813,8291,80,2210,2211,81,514,82 protocol=tcp
add action=drop chain=forward comment="Cancelar Conexiones invalidas" \
    connection-state=invalid disabled=no protocol=tcp
add action=accept chain=forward comment="Permitir las conexiones establecidas" \
    connection-state=established disabled=no
add action=accept chain=forward comment="Permitir conexiones relacionadas" \
    connection-state=related disabled=no
add action=drop chain=forward comment="Bloquear Direcciones IPs Vagas" \
    disabled=no src-address=0.0.0.0/8
add action=drop chain=forward disabled=no dst-address=0.0.0.0/8
add action=drop chain=forward disabled=no src-address=127.0.0.0/8
add action=drop chain=forward disabled=no dst-address=127.0.0.0/8
add action=drop chain=forward disabled=no src-address=224.0.0.0/3
add action=drop chain=forward disabled=no dst-address=224.0.0.0/3
add action=jump chain=forward comment="Hacer saltos a nuevas cadenas" disabled=\
    no jump-target=tcp protocol=tcp
add action=jump chain=forward comment="Hacer saltos a nuevas cadenas" disabled=\
    no jump-target=udp protocol=udp
add action=jump chain=forward comment="Hacer saltos a nuevas cadenas" disabled=\
    no jump-target=icmp protocol=icmp
add action=drop chain=tcp comment=\
    "Crea cadena tcp y negar algunos puertos tcp en ella (Cancelar TFTP)" \
    disabled=no dst-port=69 protocol=tcp
add action=drop chain=tcp comment="Negar Puerto Asignado RPC" disabled=no \
    dst-port=111 protocol=tcp
add action=drop chain=tcp comment="Negar NBT" disabled=no dst-port=135 \
    protocol=tcp
add action=drop chain=tcp comment="Negar CIFS" disabled=no dst-port=445 \
    protocol=tcp
add action=drop chain=tcp comment="Negar NFS" disabled=no dst-port=2049 \
    protocol=tcp
add action=drop chain=tcp comment="Negar NetBus" disabled=no dst-port=\
    12345-12346 protocol=tcp
add action=drop chain=tcp comment="Negar NetBus" disabled=no dst-port=20034 \
    protocol=tcp
add action=drop chain=tcp comment="Negar BackOriffice" disabled=no dst-port=\
    3133 protocol=tcp
add action=drop chain=tcp comment="Negar DHCP" disabled=no dst-port=67-68 \
    protocol=tcp
add action=drop chain=udp comment=\
    "Denegar puertos UDP en cadena udp (Negar TFTP)" disabled=no dst-port=69 \
    protocol=udp
add action=drop chain=udp comment="Negar PRC portmapper" disabled=no dst-port=\
    111 protocol=udp
add action=drop chain=udp comment="Negar PRC portmapper" disabled=no dst-port=\
    135 protocol=udp
add action=drop chain=udp comment="Negar NBT" disabled=no dst-port=137-139 \
    protocol=udp
add action=drop chain=udp comment="Negar NFS" disabled=no dst-port=2049 \
    protocol=udp
add action=drop chain=udp comment="Negar BackOriffice" disabled=no dst-port=\
    3133 protocol=udp
add action=accept chain=icmp comment=\
    "Permitir solo codigos ICMP necesarios en la cadena de icmp (Echo reply)" \
    disabled=no icmp-options=0:0 protocol=icmp
add action=accept chain=icmp comment="net unreachable" disabled=no \
    icmp-options=3:0 protocol=icmp
add action=accept chain=icmp comment="host unreachable" disabled=no \
    icmp-options=3:1 protocol=icmp
add action=accept chain=icmp comment="host unreachable fragmentation required" \
    disabled=no icmp-options=3:4 protocol=icmp
add action=accept chain=icmp comment="allow source quench" disabled=no \
    icmp-options=4:0 protocol=icmp
add action=accept chain=icmp comment="allow echo request" disabled=no \
    icmp-options=8:0 protocol=icmp
add action=accept chain=icmp comment="allow time exceed" disabled=no \
    icmp-options=11:0 protocol=icmp
add action=accept chain=icmp disabled=no icmp-options=12:0 protocol=icmp
add action=drop chain=icmp comment="deny all other types" disabled=no
add action=drop chain=input comment="solo permite acceso FTP 10 respuestas incor\
    rectas por minuto (drop ftp brute forcers)" disabled=no dst-port=21 \
    protocol=tcp src-address-list=ftp_blacklist
add action=accept chain=output content="530 Login incorrect" disabled=no \
    dst-limit=1/1m,9,dst-address/1m protocol=tcp
add action=add-dst-to-address-list address-list=ftp_blacklist \
    address-list-timeout=3h chain=output content="530 Login incorrect" \
    disabled=no protocol=tcp
add action=drop chain=input comment="Esto evitara un forzador bruta SSH que se p\
    rohiba por 10 dias despuus de los intentos repetitivos. Cambiar los tiempos \
    de espera segun sea necesario (drop ssh brute forcers)" disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_blacklist
add action=add-src-to-address-list address-list=ssh_blacklist \
    address-list-timeout=1w3d chain=input connection-state=new disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_stage3
add action=add-src-to-address-list address-list=ssh_stage3 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_stage2
add action=add-src-to-address-list address-list=ssh_stage2 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_stage1
add action=add-src-to-address-list address-list=ssh_stage1 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-port=22 protocol=tcp
add action=drop chain=forward comment="drop ssh brute downstream" disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_blacklist
add action=drop chain=forward comment="Bloqueo P2P" disabled=no in-interface=\
    Lan p2p=all-p2p
add action=accept chain=forward comment="Acepta RaptorCache" disabled=no \
    src-address=192.168.10.0/30


/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=
    max-limit=10M name=RaptorCache packet-mark=raptor-packs
    priority=4 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=
    max-limit=10M name="Squid 3.x" packet-mark=squid-packs
    priority=4 queue=default