Qos

Desconectado dargoros

  • Newbie
  • *
  • Mensajes: 9
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Qos
« : junio 16, 2013, 07:43:43 pm »
amigos, quien me ayuda con Qos funcional, para crearlo de acurdo a la red y asi nos aydemos todos en crear este Qos

Desconectado si_faisal

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación: Jakarta, Indonesia
    • Ver Perfil
    • www.astainformatics.com
  • Me Gusta: 1
Re:Qos
« Respuesta #1 : agosto 09, 2013, 10:58:31 pm »
i just want to share my QoS configuration,

it can classify and prioritize traffic so the user can have a better internet experience
this can work in routing mode (put this rules in R1) or brigde mode (transparent traffic shaper)

the thunder/raptorcache hit full bandwitdh is NOT in this rules



this code below :
/ip firewall mangle
Código:
  1. /ip firewall mangle
  2. add action=jump chain=forward comment="SERVICE CLASSIFIER" jump-target=\
  3.     services-classifier protocol=tcp
  4. add action=jump chain=forward jump-target=services-classifier protocol=udp
  5. add action=jump chain=forward jump-target=services-classifier protocol=!ospf
  6. add action=mark-connection chain=services-classifier comment=ICMP \
  7.     new-connection-mark=cm_icmp protocol=icmp
  8. add action=mark-packet chain=services-classifier connection-mark=cm_icmp \
  9.     new-packet-mark=pm_icmp passthrough=no
  10. add action=mark-connection chain=services-classifier comment=SSH dst-port=22 \
  11.     new-connection-mark=cm_ssh protocol=tcp
  12. add action=mark-connection chain=services-classifier new-connection-mark=\
  13.     cm_ssh protocol=tcp src-port=22
  14. add action=mark-packet chain=services-classifier connection-mark=cm_ssh \
  15.     new-packet-mark=pm_ssh passthrough=no
  16. add action=mark-connection chain=services-classifier comment="DNS TCP" \
  17.     dst-port=53 new-connection-mark=cm_dns protocol=tcp
  18. add action=mark-connection chain=services-classifier new-connection-mark=\
  19.     cm_dns protocol=tcp src-port=53
  20. add action=mark-packet chain=services-classifier connection-mark=cm_dns \
  21.     new-packet-mark=pm_dns passthrough=no
  22. add action=mark-connection chain=services-classifier comment="SKYPE TCP" \
  23.     dst-port=!80 layer7-protocol=skypetoskype new-connection-mark=cm_skype \
  24.     protocol=tcp
  25. add action=mark-connection chain=services-classifier dst-port=!80 \
  26.     layer7-protocol=skype new-connection-mark=cm_skype protocol=tcp
  27. add action=mark-packet chain=services-classifier connection-mark=cm_skype \
  28.     new-packet-mark=pm_skype passthrough=no
  29. add action=mark-connection chain=services-classifier comment=PROXMOX \
  30.     dst-port=8006 new-connection-mark=cm_proxmox protocol=tcp
  31. add action=mark-connection chain=services-classifier new-connection-mark=\
  32.     cm_proxmox protocol=tcp src-port=8006
  33. add action=mark-packet chain=services-classifier connection-mark=cm_proxmox \
  34.     new-packet-mark=pm_proxmox passthrough=no
  35. add action=mark-connection chain=services-classifier comment=FTP dst-port=21 \
  36.     new-connection-mark=cm_ftp protocol=tcp
  37. add action=mark-packet chain=services-classifier connection-mark=cm_ftp \
  38.     new-packet-mark=pm_ftp passthrough=no
  39. add action=mark-connection chain=services-classifier comment="THE DUDE" \
  40.     dst-port=2210,2211 new-connection-mark=cm_dude protocol=tcp
  41. add action=mark-connection chain=services-classifier dst-port=2210,2211 \
  42.     new-connection-mark=cm_dude protocol=tcp
  43. add action=mark-packet chain=services-classifier connection-mark=cm_dude \
  44.     new-packet-mark=pm_dude passthrough=no
  45. add action=mark-connection chain=services-classifier comment=HTTP dst-port=\
  46.     80,3128,8080 new-connection-mark=cm_http protocol=tcp
  47. add action=mark-connection chain=services-classifier new-connection-mark=\
  48.     cm_http protocol=tcp src-port=80,3128,8080
  49. add action=mark-packet chain=services-classifier comment="HTTP PRIO #3" \
  50.     connection-bytes=0-128000 connection-mark=cm_http new-packet-mark=\
  51.     pm_http_prio3 passthrough=no protocol=tcp
  52. add action=mark-packet chain=services-classifier comment="HTTP PRIO #4" \
  53.     connection-bytes=128001-1024000 connection-mark=cm_http new-packet-mark=\
  54.     pm_http_prio4 passthrough=no protocol=tcp
  55. add action=mark-packet chain=services-classifier comment="HTTP PRIO #5" \
  56.     connection-bytes=1024001-4096000 connection-mark=cm_http new-packet-mark=\
  57.     pm_http_prio5 passthrough=no protocol=tcp
  58. add action=mark-packet chain=services-classifier comment="HTTP PRIO #6" \
  59.     connection-bytes=4096001-20480000 connection-mark=cm_http \
  60.     new-packet-mark=pm_http_prio6 passthrough=no protocol=tcp
  61. add action=mark-packet chain=services-classifier comment="HTTP PRIO #8" \
  62.     connection-bytes=20480001-0 connection-mark=cm_http new-packet-mark=\
  63.     pm_http_prio8 passthrough=no protocol=tcp
  64. add action=mark-connection chain=services-classifier comment=HTTPS dst-port=\
  65.     443 new-connection-mark=cm_https protocol=tcp
  66. add action=mark-connection chain=services-classifier new-connection-mark=\
  67.     cm_https protocol=tcp src-port=443
  68. add action=mark-packet chain=services-classifier connection-mark=cm_https \
  69.     new-packet-mark=pm_https passthrough=no
  70. add action=mark-connection chain=services-classifier comment=EMAIL dst-port=\
  71.     25,110,143,465,585,993,995 new-connection-mark=cm_email protocol=tcp
  72. add action=mark-connection chain=services-classifier new-connection-mark=\
  73.     cm_email protocol=tcp src-port=25,110,143,465,585,993,995
  74. add action=mark-packet chain=services-classifier connection-mark=cm_email \
  75.     new-packet-mark=pm_email passthrough=no
  76. add action=mark-connection chain=services-classifier comment=STREAMING \
  77.     dst-port=1935 new-connection-mark=cm_streaming protocol=tcp
  78. add action=mark-connection chain=services-classifier new-connection-mark=\
  79.     cm_streaming protocol=tcp src-port=1935
  80. add action=mark-packet chain=services-classifier connection-mark=cm_streaming \
  81.     new-packet-mark=pm_streaming passthrough=no
  82. add action=mark-connection chain=services-classifier comment=\
  83.     "YAHOO MESSENGER" dst-port=5050 new-connection-mark=cm_ym protocol=tcp
  84. add action=mark-connection chain=services-classifier new-connection-mark=\
  85.     cm_ym protocol=tcp src-port=5050
  86. add action=mark-packet chain=services-classifier connection-mark=cm_ym \
  87.     new-packet-mark=pm_ym passthrough=no
  88. add action=mark-connection chain=services-classifier comment=TEAMVIEWER \
  89.     dst-port=5938 new-connection-mark=cm_teamviewer protocol=tcp
  90. add action=mark-connection chain=services-classifier dst-port="" \
  91.     new-connection-mark=cm_teamviewer protocol=tcp src-port=5938
  92. add action=mark-packet chain=services-classifier connection-mark=\
  93.     cm_teamviewer new-packet-mark=pm_teamviewer passthrough=no
  94. add action=mark-connection chain=services-classifier comment=WINBOX dst-port=\
  95.     8291 new-connection-mark=cm_winbox protocol=tcp
  96. add action=mark-connection chain=services-classifier new-connection-mark=\
  97.     cm_winbox protocol=tcp src-port=8291
  98. add action=mark-packet chain=services-classifier connection-mark=cm_winbox \
  99.     new-packet-mark=pm_winbox passthrough=no
  100. add action=mark-connection chain=services-classifier comment=VNC dst-port=\
  101.     5900-5950 new-connection-mark=cm_vnc protocol=tcp
  102. add action=mark-connection chain=services-classifier new-connection-mark=\
  103.     cm_vnc protocol=tcp src-port=5900-5950
  104. add action=mark-packet chain=services-classifier connection-mark=cm_vnc \
  105.     new-packet-mark=pm_vnc passthrough=no
  106. add action=mark-connection chain=services-classifier comment="P2P TORRENT" \
  107.     new-connection-mark=cm_p2p p2p=all-p2p
  108. add action=mark-packet chain=services-classifier connection-mark=cm_p2p \
  109.     new-packet-mark=pm_p2p passthrough=no
  110. add action=mark-connection chain=services-classifier comment="OTHER TCP" \
  111.     new-connection-mark=cm_other-tcp protocol=tcp
  112. add action=mark-packet chain=services-classifier connection-mark=cm_other-tcp \
  113.     new-packet-mark=pm_other-tcp passthrough=no
  114. add action=mark-connection chain=services-classifier comment=" UDP" dst-port=\
  115.     53 new-connection-mark=cm_dns protocol=udp
  116. add action=mark-connection chain=services-classifier new-connection-mark=\
  117.     cm_dns protocol=udp src-port=53
  118. add action=mark-packet chain=services-classifier connection-mark=cm_dns \
  119.     new-packet-mark=pm_dns passthrough=no
  120. add action=mark-connection chain=services-classifier comment=NTP dst-port=123 \
  121.     new-connection-mark=cm_ntp protocol=udp
  122. add action=mark-packet chain=services-classifier connection-mark=cm_ntp \
  123.     new-packet-mark=pm_ntp passthrough=no
  124. add action=mark-connection chain=services-classifier comment=\
  125.     "YAHOO MESSENGER UDP" dst-port=3478 new-connection-mark=cm_ym_udp \
  126.     protocol=udp src-port=1024-5000
  127. add action=mark-connection chain=services-classifier dst-port=1024-5000 \
  128.     new-connection-mark=cm_ym_udp protocol=udp src-port=3478
  129. add action=mark-packet chain=services-classifier connection-mark=cm_ym_udp \
  130.     new-packet-mark=pm_ym_udp
  131. add action=mark-connection chain=services-classifier comment=SIP/VOIP \
  132.     dst-port=5060 new-connection-mark=cm_voip protocol=udp
  133. add action=mark-connection chain=services-classifier new-connection-mark=\
  134.     cm_voip protocol=udp src-port=5060
  135. add action=mark-packet chain=services-classifier connection-mark=cm_voip \
  136.     new-packet-mark=pm_voip
  137. add action=mark-connection chain=services-classifier comment=SNMP dst-port=\
  138.     161,162 new-connection-mark=cm_snmp protocol=udp
  139. add action=mark-connection chain=services-classifier new-connection-mark=\
  140.     cm_snmp protocol=udp src-port=161,162
  141. add action=mark-packet chain=services-classifier connection-mark=cm_snmp \
  142.     new-packet-mark=pm_snmp passthrough=no
  143. add action=mark-connection chain=services-classifier comment="SKYPE UDP L7" \
  144.     layer7-protocol=skype new-connection-mark=cm_skype_udp protocol=udp
  145. add action=mark-connection chain=services-classifier layer7-protocol=\
  146.     skypetoskype new-connection-mark=cm_skype_udp protocol=udp
  147. add action=mark-packet chain=services-classifier connection-mark=cm_skype_udp \
  148.     new-packet-mark=pm_skype_udp passthrough=no
  149. add action=mark-connection chain=services-classifier comment="OTHER UDP" \
  150.     new-connection-mark=cm_other-udp protocol=udp
  151. add action=mark-packet chain=services-classifier connection-mark=cm_other-udp \
  152.     new-packet-mark=pm_other-udp passthrough=no
  153. add action=return chain=services-classifier

Queue Tree Configuration - in this example, bandwitdh is set for 5 Mbps.
please change according to your network
keep in mind that maximum sum of limit-at of the child, cannot larger that the parent max-limit value

Código:
  1. /queue tree
  2. add max-limit=5M name=INTERNET parent=global-out priority=3
  3. add limit-at=256k max-limit=5M name=PRIO#1 parent=INTERNET priority=1
  4. add limit-at=512k max-limit=4M name=PRIO#2 parent=INTERNET priority=2
  5. add limit-at=384k max-limit=3M name=PRIO#3 parent=INTERNET priority=3
  6. add limit-at=256k max-limit=2M name=PRIO#4 parent=INTERNET priority=4
  7. add limit-at=256k max-limit=2M name=PRIO#5 parent=INTERNET priority=5
  8. add limit-at=128k max-limit=1536k name=PRIO#6 parent=INTERNET priority=6
  9. add limit-at=96k max-limit=1M name=PRIO#7 parent=INTERNET priority=7
  10. add limit-at=128k max-limit=1M name=PRIO#8 parent=INTERNET
  11. add name=icmp packet-mark=pm_icmp parent=PRIO#1 priority=1
  12. add name=dns packet-mark=pm_dns parent=PRIO#1 priority=1
  13. add name=ssh packet-mark=pm_ssh parent=PRIO#1 priority=1
  14. add name=vnc packet-mark=pm_vnc parent=PRIO#2 priority=2
  15. add name=winbox packet-mark=pm_winbox parent=PRIO#2 priority=2
  16. add name=ntp packet-mark=pm_ntp parent=PRIO#2 priority=2
  17. add name=skype packet-mark=pm_skype parent=PRIO#2 priority=2
  18. add name=email packet-mark=pm_email parent=PRIO#3 priority=3
  19. add name=https packet-mark=pm_https parent=PRIO#4 priority=4
  20. add name=http_small packet-mark=pm_http_prio3 parent=PRIO#3 priority=3
  21. add name=ftp packet-mark=pm_ftp parent=PRIO#4 priority=4
  22. add name=other-tcp packet-mark=pm_other-tcp parent=PRIO#8
  23. add name=other-udp packet-mark=pm_other-udp parent=PRIO#8
  24. add name=pve-mgmnt packet-mark=pm_proxmox parent=PRIO#2 priority=2
  25. add name=snmp packet-mark=pm_snmp parent=PRIO#2 priority=2
  26. add name=thedude packet-mark=pm_dude parent=PRIO#2 priority=2
  27. add name=http_heavy packet-mark=pm_http_prio8 parent=PRIO#7 priority=7 queue=\
  28.     pcq-http
  29. add name=p2p-torrent packet-mark=pm_p2p parent=PRIO#8
  30. add name=http_medium packet-mark=pm_http_prio5 parent=PRIO#5 priority=5 \
  31.     queue=pcq-http
  32. add name=http_large packet-mark=pm_http_prio6 parent=PRIO#6 priority=6 queue=\
  33.     pcq-http
  34. add name=http_light packet-mark=pm_http_prio4 parent=PRIO#4 priority=4 queue=\
  35.     pcq-http
  36. add name=voip packet-mark=pm_voip parent=PRIO#2 priority=2
  37. add name=stream-rtmp packet-mark=pm_streaming parent=PRIO#3 priority=3
  38. add name=skype-udp packet-mark=pm_skype_udp parent=PRIO#2 priority=2
  39. add name=teamviewer packet-mark=pm_teamviewer parent=PRIO#2 priority=2
  40. add name=ym-tcp packet-mark=pm_ym parent=PRIO#2 priority=2
  41. add name=ym-udp packet-mark=pm_ym_udp parent=PRIO#2 priority=2

in routeros v6 change parent global-out to global
Código:
  1. add max-limit=5M name=INTERNET parent=global priority=3


Queue Types
Código:
  1. /queue type
  2. set 0 pfifo-limit=500
  3. add kind=sfq name=default-sfq sfq-perturb=8
  4. add kind=pcq name=pcq-http pcq-burst-time=16s pcq-classifier=dst-address \
  5.     pcq-dst-address6-mask=64 pcq-limit=500 pcq-src-address6-mask=64 \
  6.     pcq-total-limit=20000
  7. set 9 pfifo-limit=100

hope this help
greetings from Indonesia
:)
greetings from Indonesia

Desconectado si_faisal

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación: Jakarta, Indonesia
    • Ver Perfil
    • www.astainformatics.com
  • Me Gusta: 1
Re:Qos
« Respuesta #2 : agosto 09, 2013, 11:00:05 pm »
this l7 filter for capturing Skype Traffic

Código:
  1. /ip firewall layer7-protocol
  2. add name=skypetoskype regexp="^..\\x02............."
  3. add name=skype regexp="^(\\x01.\?.\?.\?.\?.\?.\?.\?.\?\\x01|\\x02.\?.\?.\?.\?.\
  4.    \?.\?.\?.\?\\x02|\\x03.\?.\?.\?.\?.\?.\?.\?.\?\\x03|\\x04.\?.\?.\?.\?.\?.\
  5.    \?.\?.\?\\x04|\\x05.\?.\?.\?.\?.\?.\?.\?.\?\\x05|\\x06.\?.\?.\?.\?.\?.\?.\
  6.    \?.\?\\x06|\\x07.\?.\?.\?.\?.\?.\?.\?.\?\\x07|\\x08.\?.\?.\?.\?.\?.\?.\?.\
  7.    \?\\x08|\\x09.\?.\?.\?.\?.\?.\?.\?.\?\\x09|\\x0a.\?.\?.\?.\?.\?.\?.\?.\?\\\
  8.    x0a|\\x0b.\?.\?.\?.\?.\?.\?.\?.\?\\x0b|\\x0c.\?.\?.\?.\?.\?.\?.\?.\?\\x0c|\
  9.    \\x0d.\?.\?.\?.\?.\?.\?.\?.\?\\x0d|\\x0e.\?.\?.\?.\?.\?.\?.\?.\?\\x0e|\\x0\
  10.    f.\?.\?.\?.\?.\?.\?.\?.\?\\x0f|\\x10.\?.\?.\?.\?.\?.\?.\?.\?\\x10|\\x11.\?\
  11.    .\?.\?.\?.\?.\?.\?.\?\\x11|\\x12.\?.\?.\?.\?.\?.\?.\?.\?\\x12|\\x13.\?.\?.\
  12.    \?.\?.\?.\?.\?.\?\\x13|\\x14.\?.\?.\?.\?.\?.\?.\?.\?\\x14|\\x15.\?.\?.\?.\
  13.    \?.\?.\?.\?.\?\\x15|\\x16.\?.\?.\?.\?.\?.\?.\?.\?\\x16|\\x17.\?.\?.\?.\?.\
  14.    \?.\?.\?.\?\\x17|\\x18.\?.\?.\?.\?.\?.\?.\?.\?\\x18|\\x19.\?.\?.\?.\?.\?.\
  15.    \?.\?.\?\\x19|\\x1a.\?.\?.\?.\?.\?.\?.\?.\?\\x1a|\\x1b.\?.\?.\?.\?.\?.\?.\
  16.    \?.\?\\x1b|\\x1c.\?.\?.\?.\?.\?.\?.\?.\?\\x1c|\\x1d.\?.\?.\?.\?.\?.\?.\?.\
  17.    \?\\x1d|\\x1e.\?.\?.\?.\?.\?.\?.\?.\?\\x1e|\\x1f.\?.\?.\?.\?.\?.\?.\?.\?\\\
  18.    x1f|\\x20.\?.\?.\?.\?.\?.\?.\?.\?\\x20|\\x21.\?.\?.\?.\?.\?.\?.\?.\?\\x21|\
  19.    \\x22.\?.\?.\?.\?.\?.\?.\?.\?\\x22|\\x23.\?.\?.\?.\?.\?.\?.\?.\?\\x23|\\\$\
  20.    .\?.\?.\?.\?.\?.\?.\?.\?\\\$|\\x25.\?.\?.\?.\?.\?.\?.\?.\?\\x25|\\x26.\?.\
  21.    \?.\?.\?.\?.\?.\?.\?\\x26|\\x27.\?.\?.\?.\?.\?.\?.\?.\?\\x27|\\(.\?.\?.\?.\
  22.    \?.\?.\?.\?.\?\\(|\\).\?.\?.\?.\?.\?.\?.\?.\?\\)|\\*.\?.\?.\?.\?.\?.\?.\?.\
  23.    \?\\*|\\+.\?.\?.\?.\?.\?.\?.\?.\?\\+|\\x2c.\?.\?.\?.\?.\?.\?.\?.\?\\x2c|\\\
  24.    x2d.\?.\?.\?.\?.\?.\?.\?.\?\\x2d|\\..\?.\?.\?.\?.\?.\?.\?.\?\\.|\\x2f.\?.\
  25.    \?.\?.\?.\?.\?.\?.\?\\x2f|\\x30.\?.\?.\?.\?.\?.\?.\?.\?\\x30|\\x31.\?.\?.\
  26.    \?.\?.\?.\?.\?.\?\\x31|\\x32.\?.\?.\?.\?.\?.\?.\?.\?\\x32|\\x33.\?.\?.\?.\
  27.    \?.\?.\?.\?.\?\\x33|\\x34.\?.\?.\?.\?.\?.\?.\?.\?\\x34|\\x35.\?.\?.\?.\?.\
  28.    \?.\?.\?.\?\\x35|\\x36.\?.\?.\?.\?.\?.\?.\?.\?\\x36|\\x37.\?.\?.\?.\?.\?.\
  29.    \?.\?.\?\\x37|\\x38.\?.\?.\?.\?.\?.\?.\?.\?\\x38|\\x39.\?.\?.\?.\?.\?.\?.\
  30.    \?.\?\\x39|\\x3a.\?.\?.\?.\?.\?.\?.\?.\?\\x3a|\\x3b.\?.\?.\?.\?.\?.\?.\?.\
  31.    \?\\x3b|\\x3c.\?.\?.\?.\?.\?.\?.\?.\?\\x3c|\\x3d.\?.\?.\?.\?.\?.\?.\?.\?\\\
  32.    x3d|\\x3e.\?.\?.\?.\?.\?.\?.\?.\?\\x3e|\\\?.\?.\?.\?.\?.\?.\?.\?.\?\\\?|\\\
  33.    x40.\?.\?.\?.\?.\?.\?.\?.\?\\x40|\\x41.\?.\?.\?.\?.\?.\?.\?.\?\\x41|\\x42.\
  34.    \?.\?.\?.\?.\?.\?.\?.\?\\x42|\\x43.\?.\?.\?.\?.\?.\?.\?.\?\\x43|\\x44.\?.\
  35.    \?.\?.\?.\?.\?.\?.\?\\x44|\\x45.\?.\?.\?.\?.\?.\?.\?.\?\\x45|\\x46.\?.\?.\
  36.    \?.\?.\?.\?.\?.\?\\x46|\\x47.\?.\?.\?.\?.\?.\?.\?.\?\\x47|\\x48.\?.\?.\?.\
  37.    \?.\?.\?.\?.\?\\x48|\\x49.\?.\?.\?.\?.\?.\?.\?.\?\\x49|\\x4a.\?.\?.\?.\?.\
  38.    \?.\?.\?.\?\\x4a|\\x4b.\?.\?.\?.\?.\?.\?.\?.\?\\x4b|\\x4c.\?.\?.\?.\?.\?.\
  39.    \?.\?.\?\\x4c|\\x4d.\?.\?.\?.\?.\?.\?.\?.\?\\x4d|\\x4e.\?.\?.\?.\?.\?.\?.\
  40.    \?.\?\\x4e|\\x4f.\?.\?.\?.\?.\?.\?.\?.\?\\x4f|\\x50.\?.\?.\?.\?.\?.\?.\?.\
  41.    \?\\x50|\\x51.\?.\?.\?.\?.\?.\?.\?.\?\\x51|\\x52.\?.\?.\?.\?.\?.\?.\?.\?\\\
  42.    x52|\\x53.\?.\?.\?.\?.\?.\?.\?.\?\\x53|\\x54.\?.\?.\?.\?.\?.\?.\?.\?\\x54|\
  43.    \\x55.\?.\?.\?.\?.\?.\?.\?.\?\\x55|\\x56.\?.\?.\?.\?.\?.\?.\?.\?\\x56|\\x5\
  44.    7.\?.\?.\?.\?.\?.\?.\?.\?\\x57|\\x58.\?.\?.\?.\?.\?.\?.\?.\?\\x58|\\x59.\?\
  45.    .\?.\?.\?.\?.\?.\?.\?\\x59|\\x5a.\?.\?.\?.\?.\?.\?.\?.\?\\x5a|\\[.\?.\?.\?\
  46.    .\?.\?.\?.\?.\?\\[|\\\\.\?.\?.\?.\?.\?.\?.\?.\?\\\\|\\].\?.\?.\?.\?.\?.\?.\
  47.    \?.\?\\]|\\^.\?.\?.\?.\?.\?.\?.\?.\?\\^|\\x5f.\?.\?.\?.\?.\?.\?.\?.\?\\x5f\
  48.    |\\x60.\?.\?.\?.\?.\?.\?.\?.\?\\x60|\\x61.\?.\?.\?.\?.\?.\?.\?.\?\\x61|\\x\
  49.    62.\?.\?.\?.\?.\?.\?.\?.\?\\x62|\\x63.\?.\?.\?.\?.\?.\?.\?.\?\\x63|\\x64.\
  50.    \?.\?.\?.\?.\?.\?.\?.\?\\x64|\\x65.\?.\?.\?.\?.\?.\?.\?.\?\\x65|\\x66.\?.\
  51.    \?.\?.\?.\?.\?.\?.\?\\x66|\\x67.\?.\?.\?.\?.\?.\?.\?.\?\\x67|\\x68.\?.\?.\
  52.    \?.\?.\?.\?.\?.\?\\x68|\\x69.\?.\?.\?.\?.\?.\?.\?.\?\\x69|\\x6a.\?.\?.\?.\
  53.    \?.\?.\?.\?.\?\\x6a|\\x6b.\?.\?.\?.\?.\?.\?.\?.\?\\x6b|\\x6c.\?.\?.\?.\?.\
  54.    \?.\?.\?.\?\\x6c|\\x6d.\?.\?.\?.\?.\?.\?.\?.\?\\x6d|\\x6e.\?.\?.\?.\?.\?.\
  55.    \?.\?.\?\\x6e|\\x6f.\?.\?.\?.\?.\?.\?.\?.\?\\x6f|\\x70.\?.\?.\?.\?.\?.\?.\
  56.    \?.\?\\x70|\\x71.\?.\?.\?.\?.\?.\?.\?.\?\\x71|\\x72.\?.\?.\?.\?.\?.\?.\?.\
  57.    \?\\x72|\\x73.\?.\?.\?.\?.\?.\?.\?.\?\\x73|\\x74.\?.\?.\?.\?.\?.\?.\?.\?\\\
  58.    x74|\\x75.\?.\?.\?.\?.\?.\?.\?.\?\\x75|\\x76.\?.\?.\?.\?.\?.\?.\?.\?\\x76|\
  59.    \\x77.\?.\?.\?.\?.\?.\?.\?.\?\\x77|\\x78.\?.\?.\?.\?.\?.\?.\?.\?\\x78|\\x7\
  60.    9.\?.\?.\?.\?.\?.\?.\?.\?\\x79|\\x7a.\?.\?.\?.\?.\?.\?.\?.\?\\x7a|\\{.\?.\
  61.    \?.\?.\?.\?.\?.\?.\?\\{|\\|.\?.\?.\?.\?.\?.\?.\?.\?\\||\\}.\?.\?.\?.\?.\?.\
  62.    \?.\?.\?\\}|\\x7e.\?.\?.\?.\?.\?.\?.\?.\?\\x7e|\\x7f.\?.\?.\?.\?.\?.\?.\?.\
  63.    \?\\x7f|\\x80.\?.\?.\?.\?.\?.\?.\?.\?\\x80|\\x81.\?.\?.\?.\?.\?.\?.\?.\?\\\
  64.    x81|\\x82.\?.\?.\?.\?.\?.\?.\?.\?\\x82|\\x83.\?.\?.\?.\?.\?.\?.\?.\?\\x83|\
  65.    \\x84.\?.\?.\?.\?.\?.\?.\?.\?\\x84|\\x85.\?.\?.\?.\?.\?.\?.\?.\?\\x85|\\x8\
  66.    6.\?.\?.\?.\?.\?.\?.\?.\?\\x86|\\x87.\?.\?.\?.\?.\?.\?.\?.\?\\x87|\\x88.\?\
  67.    .\?.\?.\?.\?.\?.\?.\?\\x88|\\x89.\?.\?.\?.\?.\?.\?.\?.\?\\x89|\\x8a.\?.\?.\
  68.    \?.\?.\?.\?.\?.\?\\x8a|\\x8b.\?.\?.\?.\?.\?.\?.\?.\?\\x8b|\\x8c.\?.\?.\?.\
  69.    \?.\?.\?.\?.\?\\x8c|\\x8d.\?.\?.\?.\?.\?.\?.\?.\?\\x8d|\\x8e.\?.\?.\?.\?.\
  70.    \?.\?.\?.\?\\x8e|\\x8f.\?.\?.\?.\?.\?.\?.\?.\?\\x8f|\\x90.\?.\?.\?.\?.\?.\
  71.    \?.\?.\?\\x90|\\x91.\?.\?.\?.\?.\?.\?.\?.\?\\x91|\\x92.\?.\?.\?.\?.\?.\?.\
  72.    \?.\?\\x92|\\x93.\?.\?.\?.\?.\?.\?.\?.\?\\x93|\\x94.\?.\?.\?.\?.\?.\?.\?.\
  73.    \?\\x94|\\x95.\?.\?.\?.\?.\?.\?.\?.\?\\x95|\\x96.\?.\?.\?.\?.\?.\?.\?.\?\\\
  74.    x96|\\x97.\?.\?.\?.\?.\?.\?.\?.\?\\x97|\\x98.\?.\?.\?.\?.\?.\?.\?.\?\\x98|\
  75.    \\x99.\?.\?.\?.\?.\?.\?.\?.\?\\x99|\\x9a.\?.\?.\?.\?.\?.\?.\?.\?\\x9a|\\x9\
  76.    b.\?.\?.\?.\?.\?.\?.\?.\?\\x9b|\\x9c.\?.\?.\?.\?.\?.\?.\?.\?\\x9c|\\x9d.\?\
  77.    .\?.\?.\?.\?.\?.\?.\?\\x9d|\\x9e.\?.\?.\?.\?.\?.\?.\?.\?\\x9e|\\x9f.\?.\?.\
  78.    \?.\?.\?.\?.\?.\?\\x9f|\\xa0.\?.\?.\?.\?.\?.\?.\?.\?\\xa0|\\xa1.\?.\?.\?.\
  79.    \?.\?.\?.\?.\?\\xa1|\\xa2.\?.\?.\?.\?.\?.\?.\?.\?\\xa2|\\xa3.\?.\?.\?.\?.\
  80.    \?.\?.\?.\?\\xa3|\\xa4.\?.\?.\?.\?.\?.\?.\?.\?\\xa4|\\xa5.\?.\?.\?.\?.\?.\
  81.    \?.\?.\?\\xa5|\\xa6.\?.\?.\?.\?.\?.\?.\?.\?\\xa6|\\xa7.\?.\?.\?.\?.\?.\?.\
  82.    \?.\?\\xa7|\\xa8.\?.\?.\?.\?.\?.\?.\?.\?\\xa8|\\xa9.\?.\?.\?.\?.\?.\?.\?.\
  83.    \?\\xa9|\\xaa.\?.\?.\?.\?.\?.\?.\?.\?\\xaa|\\xab.\?.\?.\?.\?.\?.\?.\?.\?\\\
  84.    xab|\\xac.\?.\?.\?.\?.\?.\?.\?.\?\\xac|\\xad.\?.\?.\?.\?.\?.\?.\?.\?\\xad|\
  85.    \\xae.\?.\?.\?.\?.\?.\?.\?.\?\\xae|\\xaf.\?.\?.\?.\?.\?.\?.\?.\?\\xaf|\\xb\
  86.    0.\?.\?.\?.\?.\?.\?.\?.\?\\xb0|\\xb1.\?.\?.\?.\?.\?.\?.\?.\?\\xb1|\\xb2.\?\
  87.    .\?.\?.\?.\?.\?.\?.\?\\xb2|\\xb3.\?.\?.\?.\?.\?.\?.\?.\?\\xb3|\\xb4.\?.\?.\
  88.    \?.\?.\?.\?.\?.\?\\xb4|\\xb5.\?.\?.\?.\?.\?.\?.\?.\?\\xb5|\\xb6.\?.\?.\?.\
  89.    \?.\?.\?.\?.\?\\xb6|\\xb7.\?.\?.\?.\?.\?.\?.\?.\?\\xb7|\\xb8.\?.\?.\?.\?.\
  90.    \?.\?.\?.\?\\xb8|\\xb9.\?.\?.\?.\?.\?.\?.\?.\?\\xb9|\\xba.\?.\?.\?.\?.\?.\
  91.    \?.\?.\?\\xba|\\xbb.\?.\?.\?.\?.\?.\?.\?.\?\\xbb|\\xbc.\?.\?.\?.\?.\?.\?.\
  92.    \?.\?\\xbc|\\xbd.\?.\?.\?.\?.\?.\?.\?.\?\\xbd|\\xbe.\?.\?.\?.\?.\?.\?.\?.\
  93.    \?\\xbe|\\xbf.\?.\?.\?.\?.\?.\?.\?.\?\\xbf|\\xc0.\?.\?.\?.\?.\?.\?.\?.\?\\\
  94.    xc0|\\xc1.\?.\?.\?.\?.\?.\?.\?.\?\\xc1|\\xc2.\?.\?.\?.\?.\?.\?.\?.\?\\xc2|\
  95.    \\xc3.\?.\?.\?.\?.\?.\?.\?.\?\\xc3|\\xc4.\?.\?.\?.\?.\?.\?.\?.\?\\xc4|\\xc\
  96.    5.\?.\?.\?.\?.\?.\?.\?.\?\\xc5|\\xc6.\?.\?.\?.\?.\?.\?.\?.\?\\xc6|\\xc7.\?\
  97.    .\?.\?.\?.\?.\?.\?.\?\\xc7|\\xc8.\?.\?.\?.\?.\?.\?.\?.\?\\xc8|\\xc9.\?.\?.\
  98.    \?.\?.\?.\?.\?.\?\\xc9|\\xca.\?.\?.\?.\?.\?.\?.\?.\?\\xca|\\xcb.\?.\?.\?.\
  99.    \?.\?.\?.\?.\?\\xcb|\\xcc.\?.\?.\?.\?.\?.\?.\?.\?\\xcc|\\xcd.\?.\?.\?.\?.\
  100.    \?.\?.\?.\?\\xcd|\\xce.\?.\?.\?.\?.\?.\?.\?.\?\\xce|\\xcf.\?.\?.\?.\?.\?.\
  101.    \?.\?.\?\\xcf|\\xd0.\?.\?.\?.\?.\?.\?.\?.\?\\xd0|\\xd1.\?.\?.\?.\?.\?.\?.\
  102.    \?.\?\\xd1|\\xd2.\?.\?.\?.\?.\?.\?.\?.\?\\xd2|\\xd3.\?.\?.\?.\?.\?.\?.\?.\
  103.    \?\\xd3|\\xd4.\?.\?.\?.\?.\?.\?.\?.\?\\xd4|\\xd5.\?.\?.\?.\?.\?.\?.\?.\?\\\
  104.    xd5|\\xd6.\?.\?.\?.\?.\?.\?.\?.\?\\xd6|\\xd7.\?.\?.\?.\?.\?.\?.\?.\?\\xd7|\
  105.    \\xd8.\?.\?.\?.\?.\?.\?.\?.\?\\xd8|\\xd9.\?.\?.\?.\?.\?.\?.\?.\?\\xd9|\\xd\
  106.    a.\?.\?.\?.\?.\?.\?.\?.\?\\xda|\\xdb.\?.\?.\?.\?.\?.\?.\?.\?\\xdb|\\xdc.\?\
  107.    .\?.\?.\?.\?.\?.\?.\?\\xdc|\\xdd.\?.\?.\?.\?.\?.\?.\?.\?\\xdd|\\xde.\?.\?.\
  108.    \?.\?.\?.\?.\?.\?\\xde|\\xdf.\?.\?.\?.\?.\?.\?.\?.\?\\xdf|\\xe0.\?.\?.\?.\
  109.    \?.\?.\?.\?.\?\\xe0|\\xe1.\?.\?.\?.\?.\?.\?.\?.\?\\xe1|\\xe2.\?.\?.\?.\?.\
  110.    \?.\?.\?.\?\\xe2|\\xe3.\?.\?.\?.\?.\?.\?.\?.\?\\xe3|\\xe4.\?.\?.\?.\?.\?.\
  111.    \?.\?.\?\\xe4|\\xe5.\?.\?.\?.\?.\?.\?.\?.\?\\xe5|\\xe6.\?.\?.\?.\?.\?.\?.\
  112.    \?.\?\\xe6|\\xe7.\?.\?.\?.\?.\?.\?.\?.\?\\xe7|\\xe8.\?.\?.\?.\?.\?.\?.\?.\
  113.    \?\\xe8|\\xe9.\?.\?.\?.\?.\?.\?.\?.\?\\xe9|\\xea.\?.\?.\?.\?.\?.\?.\?.\?\\\
  114.    xea|\\xeb.\?.\?.\?.\?.\?.\?.\?.\?\\xeb|\\xec.\?.\?.\?.\?.\?.\?.\?.\?\\xec|\
  115.    \\xed.\?.\?.\?.\?.\?.\?.\?.\?\\xed|\\xee.\?.\?.\?.\?.\?.\?.\?.\?\\xee|\\xe\
  116.    f.\?.\?.\?.\?.\?.\?.\?.\?\\xef|\\xf0.\?.\?.\?.\?.\?.\?.\?.\?\\xf0|\\xf1.\?\
  117.    .\?.\?.\?.\?.\?.\?.\?\\xf1|\\xf2.\?.\?.\?.\?.\?.\?.\?.\?\\xf2|\\xf3.\?.\?.\
  118.    \?.\?.\?.\?.\?.\?\\xf3|\\xf4.\?.\?.\?.\?.\?.\?.\?.\?\\xf4|\\xf5.\?.\?.\?.\
  119.    \?.\?.\?.\?.\?\\xf5|\\xf6.\?.\?.\?.\?.\?.\?.\?.\?\\xf6|\\xf7.\?.\?.\?.\?.\
  120.    \?.\?.\?.\?\\xf7|\\xf8.\?.\?.\?.\?.\?.\?.\?.\?\\xf8|\\xf9.\?.\?.\?.\?.\?.\
  121.    \?.\?.\?\\xf9|\\xfa.\?.\?.\?.\?.\?.\?.\?.\?\\xfa|\\xfb.\?.\?.\?.\?.\?.\?.\
  122.    \?.\?\\xfb|\\xfc.\?.\?.\?.\?.\?.\?.\?.\?\\xfc|\\xfd.\?.\?.\?.\?.\?.\?.\?.\
  123.    \?\\xfd|\\xfe.\?.\?.\?.\?.\?.\?.\?.\?\\xfe|\\xff.\?.\?.\?.\?.\?.\?.\?.\?\\\
  124.    xff)"
greetings from Indonesia

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #3 : agosto 09, 2013, 11:22:10 pm »
amigo si nos explica algo de como se utiliza o algo mas detallado

Desconectado si_faisal

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación: Jakarta, Indonesia
    • Ver Perfil
    • www.astainformatics.com
  • Me Gusta: 1
Re:Qos
« Respuesta #4 : agosto 10, 2013, 12:17:22 am »
hello rifranco202325

it will look like this, the purpose is to group some traffic and make prioritization in Queue Tree


if you give it try, please make some review

gracias :)
greetings from Indonesia

Desconectado odon

  • Newbie
  • *
  • Mensajes: 26
  • Ubicación: South Sumatera - Indonesia
  • Powered by RaptorCache-2.0.3
    • Ver Perfil
    • Bengkel Oprek
  • Me Gusta: 0
Re:Qos
« Respuesta #5 : agosto 10, 2013, 03:47:41 am »
Bravo Om Faisal  :-*

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 490
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #6 : agosto 10, 2013, 10:19:29 pm »
 ;) una en version 6 para core  ;)
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado si_faisal

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación: Jakarta, Indonesia
    • Ver Perfil
    • www.astainformatics.com
  • Me Gusta: 1
Re:Qos
« Respuesta #7 : agosto 11, 2013, 12:49:51 am »
hello ingjaab

sure, it can be implemented in core router
in routing mode or bridge mode it also works

this configuration is tested in routeros version 5 and 6

:)
greetings from Indonesia

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 490
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #8 : agosto 11, 2013, 05:06:25 am »
pero en 6 no hay global out ni global in  :( solo global  :( buuuuu
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado si_faisal

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación: Jakarta, Indonesia
    • Ver Perfil
    • www.astainformatics.com
  • Me Gusta: 1
Re:Qos
« Respuesta #9 : agosto 11, 2013, 06:23:34 am »
yes you are right

please change the parent global-out to global at routeros version 6

thats it
greetings from Indonesia

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 490
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #10 : agosto 11, 2013, 11:15:47 am »
haste un ejemplo para verlo por que he intentado sin exito
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 490
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #11 : agosto 11, 2013, 07:30:37 pm »
asi veo que no has puesto queue type pcq
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado si_faisal

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación: Jakarta, Indonesia
    • Ver Perfil
    • www.astainformatics.com
  • Me Gusta: 1
Re:Qos
« Respuesta #12 : agosto 14, 2013, 07:49:25 pm »
ingjaab

i have edited my post
please check in thread #2
greetings from Indonesia

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #13 : agosto 14, 2013, 09:36:05 pm »
q men corregistre tu pos de nuevo

Desconectado luistec

  • Moderador
  • *
  • Mensajes: 1501
  • Ubicación: Los Olivos - Perú
    • Ver Perfil
  • Me Gusta: 50
Re:Qos
« Respuesta #14 : agosto 14, 2013, 09:43:07 pm »
q men corregistre tu pos de nuevo
Actualizó su post con más información.

Good info si_faisal

Saludos

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #15 : agosto 14, 2013, 09:45:54 pm »
Actualizó su post con más información.

Saludos

men y ya lo provaste o no

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 490
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #16 : agosto 15, 2013, 04:24:58 pm »
yo lo he probado y lo que no me entra en cabeza es la subida , lo otro es es si raptor lo uso por forward tiene conflicto con el qos , pero que type haz cambiando eso es bueno

pd: ya tengo tres amanecidas intentando en sacar el QoS con global del core con raptor y todo con forward y la verdad ya me duele mi cabeza , haber si me das una o dos manos
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado loquitoslack

  • Full Member
  • ***
  • Mensajes: 142
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 1
Re:Qos
« Respuesta #17 : agosto 15, 2013, 05:15:03 pm »
QOS in debian for iptables ? T_T

Desconectado si_faisal

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación: Jakarta, Indonesia
    • Ver Perfil
    • www.astainformatics.com
  • Me Gusta: 1
Re:Qos
« Respuesta #18 : agosto 15, 2013, 08:45:14 pm »
ingjaab

how is your configuration / network diagram?

in my configuration, the raptor cache is not connected with this qos router,
raptor is connected in the core that can use different qos and limit the distribution router

loquitoslack

do you mean, you are using debian for a router?
you can use htb or cbq with mangle an conntrack using tc command

here's more reading http://www.lartc.org/howto/

saludos
greetings from Indonesia

Desconectado loquitoslack

  • Full Member
  • ***
  • Mensajes: 142
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 1
Re:Qos
« Respuesta #19 : agosto 16, 2013, 08:08:23 am »
ok, thanks reading MAN QOS