Qos

Desconectado si_faisal

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación: Jakarta, Indonesia
    • Ver Perfil
    • www.astainformatics.com
  • Me Gusta: 1
Re:Qos
« Respuesta #20 : agosto 16, 2013, 11:29:35 am »
loquitoslack

you can also use the simple way, use webhtb for manage traffic

http://www.webhtb.ro/

modified webhtb with squid & zph tos (indonesian language)
http://opensource.telkomspeedy.com/forum/viewtopic.php?id=5530

saludos
greetings from Indonesia

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 492
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #21 : agosto 16, 2013, 04:56:47 pm »
??? QoS versi 6 con proxy raptor para un core solo  ???

http://mum.mikrotik.com/presentations/HR13/valens.pdf
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado luis24

  • Newbie
  • *
  • Mensajes: 32
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Qos
« Respuesta #22 : agosto 21, 2013, 07:14:08 am »
No estoy de acuerdo en copiar y pegar reglas...Puede servir como también puede hacer un desastre en la Red...Hay que ver cada caso en particular ya que cada Red es totalmente diferente...para la gente que usa Simple Queue deben cambiar el parent Global Out por la Interface real de Salida.

freedarwuin

  • Visitante
Re:Qos
« Respuesta #23 : agosto 21, 2013, 08:53:58 am »
i just want to share my QoS configuration,

it can classify and prioritize traffic so the user can have a better internet experience
this can work in routing mode (put this rules in R1) or brigde mode (transparent traffic shaper)

the thunder/raptorcache hit full bandwitdh is NOT in this rules



this code below :
/ip firewall mangle
Código:
  1. /ip firewall mangle
  2. add action=jump chain=forward comment="SERVICE CLASSIFIER" jump-target=\
  3.     services-classifier protocol=tcp
  4. add action=jump chain=forward jump-target=services-classifier protocol=udp
  5. add action=jump chain=forward jump-target=services-classifier protocol=!ospf
  6. add action=mark-connection chain=services-classifier comment=ICMP \
  7.     new-connection-mark=cm_icmp protocol=icmp
  8. add action=mark-packet chain=services-classifier connection-mark=cm_icmp \
  9.     new-packet-mark=pm_icmp passthrough=no
  10. add action=mark-connection chain=services-classifier comment=SSH dst-port=22 \
  11.     new-connection-mark=cm_ssh protocol=tcp
  12. add action=mark-connection chain=services-classifier new-connection-mark=\
  13.     cm_ssh protocol=tcp src-port=22
  14. add action=mark-packet chain=services-classifier connection-mark=cm_ssh \
  15.     new-packet-mark=pm_ssh passthrough=no
  16. add action=mark-connection chain=services-classifier comment="DNS TCP" \
  17.     dst-port=53 new-connection-mark=cm_dns protocol=tcp
  18. add action=mark-connection chain=services-classifier new-connection-mark=\
  19.     cm_dns protocol=tcp src-port=53
  20. add action=mark-packet chain=services-classifier connection-mark=cm_dns \
  21.     new-packet-mark=pm_dns passthrough=no
  22. add action=mark-connection chain=services-classifier comment="SKYPE TCP" \
  23.     dst-port=!80 layer7-protocol=skypetoskype new-connection-mark=cm_skype \
  24.     protocol=tcp
  25. add action=mark-connection chain=services-classifier dst-port=!80 \
  26.     layer7-protocol=skype new-connection-mark=cm_skype protocol=tcp
  27. add action=mark-packet chain=services-classifier connection-mark=cm_skype \
  28.     new-packet-mark=pm_skype passthrough=no
  29. add action=mark-connection chain=services-classifier comment=PROXMOX \
  30.     dst-port=8006 new-connection-mark=cm_proxmox protocol=tcp
  31. add action=mark-connection chain=services-classifier new-connection-mark=\
  32.     cm_proxmox protocol=tcp src-port=8006
  33. add action=mark-packet chain=services-classifier connection-mark=cm_proxmox \
  34.     new-packet-mark=pm_proxmox passthrough=no
  35. add action=mark-connection chain=services-classifier comment=FTP dst-port=21 \
  36.     new-connection-mark=cm_ftp protocol=tcp
  37. add action=mark-packet chain=services-classifier connection-mark=cm_ftp \
  38.     new-packet-mark=pm_ftp passthrough=no
  39. add action=mark-connection chain=services-classifier comment="THE DUDE" \
  40.     dst-port=2210,2211 new-connection-mark=cm_dude protocol=tcp
  41. add action=mark-connection chain=services-classifier dst-port=2210,2211 \
  42.     new-connection-mark=cm_dude protocol=tcp
  43. add action=mark-packet chain=services-classifier connection-mark=cm_dude \
  44.     new-packet-mark=pm_dude passthrough=no
  45. add action=mark-connection chain=services-classifier comment=HTTP dst-port=\
  46.     80,3128,8080 new-connection-mark=cm_http protocol=tcp
  47. add action=mark-connection chain=services-classifier new-connection-mark=\
  48.     cm_http protocol=tcp src-port=80,3128,8080
  49. add action=mark-packet chain=services-classifier comment="HTTP PRIO #3" \
  50.     connection-bytes=0-128000 connection-mark=cm_http new-packet-mark=\
  51.     pm_http_prio3 passthrough=no protocol=tcp
  52. add action=mark-packet chain=services-classifier comment="HTTP PRIO #4" \
  53.     connection-bytes=128001-1024000 connection-mark=cm_http new-packet-mark=\
  54.     pm_http_prio4 passthrough=no protocol=tcp
  55. add action=mark-packet chain=services-classifier comment="HTTP PRIO #5" \
  56.     connection-bytes=1024001-4096000 connection-mark=cm_http new-packet-mark=\
  57.     pm_http_prio5 passthrough=no protocol=tcp
  58. add action=mark-packet chain=services-classifier comment="HTTP PRIO #6" \
  59.     connection-bytes=4096001-20480000 connection-mark=cm_http \
  60.     new-packet-mark=pm_http_prio6 passthrough=no protocol=tcp
  61. add action=mark-packet chain=services-classifier comment="HTTP PRIO #8" \
  62.     connection-bytes=20480001-0 connection-mark=cm_http new-packet-mark=\
  63.     pm_http_prio8 passthrough=no protocol=tcp
  64. add action=mark-connection chain=services-classifier comment=HTTPS dst-port=\
  65.     443 new-connection-mark=cm_https protocol=tcp
  66. add action=mark-connection chain=services-classifier new-connection-mark=\
  67.     cm_https protocol=tcp src-port=443
  68. add action=mark-packet chain=services-classifier connection-mark=cm_https \
  69.     new-packet-mark=pm_https passthrough=no
  70. add action=mark-connection chain=services-classifier comment=EMAIL dst-port=\
  71.     25,110,143,465,585,993,995 new-connection-mark=cm_email protocol=tcp
  72. add action=mark-connection chain=services-classifier new-connection-mark=\
  73.     cm_email protocol=tcp src-port=25,110,143,465,585,993,995
  74. add action=mark-packet chain=services-classifier connection-mark=cm_email \
  75.     new-packet-mark=pm_email passthrough=no
  76. add action=mark-connection chain=services-classifier comment=STREAMING \
  77.     dst-port=1935 new-connection-mark=cm_streaming protocol=tcp
  78. add action=mark-connection chain=services-classifier new-connection-mark=\
  79.     cm_streaming protocol=tcp src-port=1935
  80. add action=mark-packet chain=services-classifier connection-mark=cm_streaming \
  81.     new-packet-mark=pm_streaming passthrough=no
  82. add action=mark-connection chain=services-classifier comment=\
  83.     "YAHOO MESSENGER" dst-port=5050 new-connection-mark=cm_ym protocol=tcp
  84. add action=mark-connection chain=services-classifier new-connection-mark=\
  85.     cm_ym protocol=tcp src-port=5050
  86. add action=mark-packet chain=services-classifier connection-mark=cm_ym \
  87.     new-packet-mark=pm_ym passthrough=no
  88. add action=mark-connection chain=services-classifier comment=TEAMVIEWER \
  89.     dst-port=5938 new-connection-mark=cm_teamviewer protocol=tcp
  90. add action=mark-connection chain=services-classifier dst-port="" \
  91.     new-connection-mark=cm_teamviewer protocol=tcp src-port=5938
  92. add action=mark-packet chain=services-classifier connection-mark=\
  93.     cm_teamviewer new-packet-mark=pm_teamviewer passthrough=no
  94. add action=mark-connection chain=services-classifier comment=WINBOX dst-port=\
  95.     8291 new-connection-mark=cm_winbox protocol=tcp
  96. add action=mark-connection chain=services-classifier new-connection-mark=\
  97.     cm_winbox protocol=tcp src-port=8291
  98. add action=mark-packet chain=services-classifier connection-mark=cm_winbox \
  99.     new-packet-mark=pm_winbox passthrough=no
  100. add action=mark-connection chain=services-classifier comment=VNC dst-port=\
  101.     5900-5950 new-connection-mark=cm_vnc protocol=tcp
  102. add action=mark-connection chain=services-classifier new-connection-mark=\
  103.     cm_vnc protocol=tcp src-port=5900-5950
  104. add action=mark-packet chain=services-classifier connection-mark=cm_vnc \
  105.     new-packet-mark=pm_vnc passthrough=no
  106. add action=mark-connection chain=services-classifier comment="P2P TORRENT" \
  107.     new-connection-mark=cm_p2p p2p=all-p2p
  108. add action=mark-packet chain=services-classifier connection-mark=cm_p2p \
  109.     new-packet-mark=pm_p2p passthrough=no
  110. add action=mark-connection chain=services-classifier comment="OTHER TCP" \
  111.     new-connection-mark=cm_other-tcp protocol=tcp
  112. add action=mark-packet chain=services-classifier connection-mark=cm_other-tcp \
  113.     new-packet-mark=pm_other-tcp passthrough=no
  114. add action=mark-connection chain=services-classifier comment=" UDP" dst-port=\
  115.     53 new-connection-mark=cm_dns protocol=udp
  116. add action=mark-connection chain=services-classifier new-connection-mark=\
  117.     cm_dns protocol=udp src-port=53
  118. add action=mark-packet chain=services-classifier connection-mark=cm_dns \
  119.     new-packet-mark=pm_dns passthrough=no
  120. add action=mark-connection chain=services-classifier comment=NTP dst-port=123 \
  121.     new-connection-mark=cm_ntp protocol=udp
  122. add action=mark-packet chain=services-classifier connection-mark=cm_ntp \
  123.     new-packet-mark=pm_ntp passthrough=no
  124. add action=mark-connection chain=services-classifier comment=\
  125.     "YAHOO MESSENGER UDP" dst-port=3478 new-connection-mark=cm_ym_udp \
  126.     protocol=udp src-port=1024-5000
  127. add action=mark-connection chain=services-classifier dst-port=1024-5000 \
  128.     new-connection-mark=cm_ym_udp protocol=udp src-port=3478
  129. add action=mark-packet chain=services-classifier connection-mark=cm_ym_udp \
  130.     new-packet-mark=pm_ym_udp
  131. add action=mark-connection chain=services-classifier comment=SIP/VOIP \
  132.     dst-port=5060 new-connection-mark=cm_voip protocol=udp
  133. add action=mark-connection chain=services-classifier new-connection-mark=\
  134.     cm_voip protocol=udp src-port=5060
  135. add action=mark-packet chain=services-classifier connection-mark=cm_voip \
  136.     new-packet-mark=pm_voip
  137. add action=mark-connection chain=services-classifier comment=SNMP dst-port=\
  138.     161,162 new-connection-mark=cm_snmp protocol=udp
  139. add action=mark-connection chain=services-classifier new-connection-mark=\
  140.     cm_snmp protocol=udp src-port=161,162
  141. add action=mark-packet chain=services-classifier connection-mark=cm_snmp \
  142.     new-packet-mark=pm_snmp passthrough=no
  143. add action=mark-connection chain=services-classifier comment="SKYPE UDP L7" \
  144.     layer7-protocol=skype new-connection-mark=cm_skype_udp protocol=udp
  145. add action=mark-connection chain=services-classifier layer7-protocol=\
  146.     skypetoskype new-connection-mark=cm_skype_udp protocol=udp
  147. add action=mark-packet chain=services-classifier connection-mark=cm_skype_udp \
  148.     new-packet-mark=pm_skype_udp passthrough=no
  149. add action=mark-connection chain=services-classifier comment="OTHER UDP" \
  150.     new-connection-mark=cm_other-udp protocol=udp
  151. add action=mark-packet chain=services-classifier connection-mark=cm_other-udp \
  152.     new-packet-mark=pm_other-udp passthrough=no
  153. add action=return chain=services-classifier

Queue Tree Configuration - in this example, bandwitdh is set for 5 Mbps.
please change according to your network
keep in mind that maximum sum of limit-at of the child, cannot larger that the parent max-limit value

Código:
  1. /queue tree
  2. add max-limit=5M name=INTERNET parent=global-out priority=3
  3. add limit-at=256k max-limit=5M name=PRIO#1 parent=INTERNET priority=1
  4. add limit-at=512k max-limit=4M name=PRIO#2 parent=INTERNET priority=2
  5. add limit-at=384k max-limit=3M name=PRIO#3 parent=INTERNET priority=3
  6. add limit-at=256k max-limit=2M name=PRIO#4 parent=INTERNET priority=4
  7. add limit-at=256k max-limit=2M name=PRIO#5 parent=INTERNET priority=5
  8. add limit-at=128k max-limit=1536k name=PRIO#6 parent=INTERNET priority=6
  9. add limit-at=96k max-limit=1M name=PRIO#7 parent=INTERNET priority=7
  10. add limit-at=128k max-limit=1M name=PRIO#8 parent=INTERNET
  11. add name=icmp packet-mark=pm_icmp parent=PRIO#1 priority=1
  12. add name=dns packet-mark=pm_dns parent=PRIO#1 priority=1
  13. add name=ssh packet-mark=pm_ssh parent=PRIO#1 priority=1
  14. add name=vnc packet-mark=pm_vnc parent=PRIO#2 priority=2
  15. add name=winbox packet-mark=pm_winbox parent=PRIO#2 priority=2
  16. add name=ntp packet-mark=pm_ntp parent=PRIO#2 priority=2
  17. add name=skype packet-mark=pm_skype parent=PRIO#2 priority=2
  18. add name=email packet-mark=pm_email parent=PRIO#3 priority=3
  19. add name=https packet-mark=pm_https parent=PRIO#4 priority=4
  20. add name=http_small packet-mark=pm_http_prio3 parent=PRIO#3 priority=3
  21. add name=ftp packet-mark=pm_ftp parent=PRIO#4 priority=4
  22. add name=other-tcp packet-mark=pm_other-tcp parent=PRIO#8
  23. add name=other-udp packet-mark=pm_other-udp parent=PRIO#8
  24. add name=pve-mgmnt packet-mark=pm_proxmox parent=PRIO#2 priority=2
  25. add name=snmp packet-mark=pm_snmp parent=PRIO#2 priority=2
  26. add name=thedude packet-mark=pm_dude parent=PRIO#2 priority=2
  27. add name=http_heavy packet-mark=pm_http_prio8 parent=PRIO#7 priority=7 queue=\
  28.     pcq-http
  29. add name=p2p-torrent packet-mark=pm_p2p parent=PRIO#8
  30. add name=http_medium packet-mark=pm_http_prio5 parent=PRIO#5 priority=5 \
  31.     queue=pcq-http
  32. add name=http_large packet-mark=pm_http_prio6 parent=PRIO#6 priority=6 queue=\
  33.     pcq-http
  34. add name=http_light packet-mark=pm_http_prio4 parent=PRIO#4 priority=4 queue=\
  35.     pcq-http
  36. add name=voip packet-mark=pm_voip parent=PRIO#2 priority=2
  37. add name=stream-rtmp packet-mark=pm_streaming parent=PRIO#3 priority=3
  38. add name=skype-udp packet-mark=pm_skype_udp parent=PRIO#2 priority=2
  39. add name=teamviewer packet-mark=pm_teamviewer parent=PRIO#2 priority=2
  40. add name=ym-tcp packet-mark=pm_ym parent=PRIO#2 priority=2
  41. add name=ym-udp packet-mark=pm_ym_udp parent=PRIO#2 priority=2

in routeros v6 change parent global-out to global
Código:
  1. add max-limit=5M name=INTERNET parent=global priority=3


Queue Types
Código:
  1. /queue type
  2. set 0 pfifo-limit=500
  3. add kind=sfq name=default-sfq sfq-perturb=8
  4. add kind=pcq name=pcq-http pcq-burst-time=16s pcq-classifier=dst-address \
  5.     pcq-dst-address6-mask=64 pcq-limit=500 pcq-src-address6-mask=64 \
  6.     pcq-total-limit=20000
  7. set 9 pfifo-limit=100

hope this help
greetings from Indonesia
:)


Los coloque y no me funciono me tardeaba mucho para abrir Google nada mas se imaginan el resto de los clientes yo que estoy ilimitados y mis clientes si peor aun

Desconectado luis24

  • Newbie
  • *
  • Mensajes: 32
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Qos
« Respuesta #24 : agosto 21, 2013, 03:44:20 pm »
Por eso repito,no copien y peguen...deben analizar que hace cada regla y como se marca,todo depende del tipo de servicio que deseen brindar...cualquier cosa que necesiten puedo colaborar con un Qos acorde a su Red.....Saludos.

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 492
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #25 : agosto 24, 2013, 12:10:17 am »
No estoy de acuerdo en copiar y pegar reglas...Puede servir como también puede hacer un desastre en la Red...Hay que ver cada caso en particular ya que cada Red es totalmente diferente...para la gente que usa Simple Queue deben cambiar el parent Global Out por la Interface real de Salida.
haber como lo cambio global out si no exite solo dice global nada mas si uso version 6
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado luis24

  • Newbie
  • *
  • Mensajes: 32
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Qos
« Respuesta #26 : agosto 24, 2013, 08:14:02 pm »
Ponete en Contacto y te doy una mano....Saludos.

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #27 : agosto 24, 2013, 08:54:13 pm »
Ponete en Contacto y te doy una mano....Saludos.

men  tu tienes para la comparticion de los clientes

Desconectado leandro1979

  • Jr. Member
  • **
  • Mensajes: 72
  • Ubicación: Ecuador
    • Ver Perfil
  • Me Gusta: 2
Re:Qos
« Respuesta #28 : septiembre 03, 2013, 08:18:39 pm »
Buenas Noches

Les dejo mi aportación
son 100% modificables para cualquier red y muy simples de entender
Espero les sea de utilidad para que entiendan como funciona un  qos
y recuerden lo siempre lo complicado es lo mejor aveces lo sencillo resulta mas util

Saludos Cordiales,
Leandro Segovia

PD. La ether1 es por donde entra el internet o conexion a tu borde depende como lo utilices

Código: [Seleccionar]
/ip firewall mangle
add action=mark-packet chain=prerouting comment=QoS_1 disabled=no \
    in-interface=ether1 new-packet-mark=QoS_1_In passthrough=no protocol=tcp \
    src-port=80,53,443,3074,1863,22,8291,3389,21
add action=mark-packet chain=postrouting disabled=no dst-port=\
    80,53,443,3074,1863,22,8291,3389,21 new-packet-mark=QoS_1_Out \
    out-interface=ether1 passthrough=no protocol=tcp tcp-flags=syn
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_1_In passthrough=no protocol=udp src-port=\
    53,88,3074,1863
add action=mark-packet chain=postrouting disabled=no dst-port=53,88,3074,1863 \
    new-packet-mark=QoS_1_Out out-interface=ether1 passthrough=no protocol=\
    udp
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_1_In passthrough=no protocol=icmp
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_1_Out out-interface=ether1 passthrough=no protocol=icmp
add action=mark-packet chain=prerouting comment=QoS_2 disabled=no \
    in-interface=ether1 new-packet-mark=QoS_2_In passthrough=no protocol=tcp \
    src-port=110,25,995,465,587,113
add action=mark-packet chain=postrouting disabled=no dst-port=\
    110,25,995,465,587,113 new-packet-mark=QoS_2_Out out-interface=ether1 \
    passthrough=no protocol=tcp
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_2_In passthrough=no protocol=udp src-port=123,113
add action=mark-packet chain=postrouting disabled=no dst-port=123,113 \
    new-packet-mark=QoS_2_Out out-interface=ether1 passthrough=no protocol=\
    udp
add action=mark-packet chain=prerouting comment=Qos_7 disabled=no \
    in-interface=ether1 new-packet-mark=QoS_7_In passthrough=no protocol=tcp
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_7_Out out-interface=ether1 passthrough=no protocol=tcp
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_7_In passthrough=no protocol=udp
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_7_Out out-interface=ether1 passthrough=no protocol=udp
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_7_In passthrough=no
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_7_Out out-interface=ether1 passthrough=no
add action=mark-packet chain=prerouting comment=QoS_8 disabled=no \
    in-interface=ether1 new-packet-mark=QoS_8_In p2p=all-p2p passthrough=no
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_8_Out out-interface=ether1 p2p=all-p2p passthrough=no

Código: [Seleccionar]
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_Download packet-mark="" parent=global-in priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_1_In packet-mark=QoS_1_In parent=QoS_Download \
    priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_2_In packet-mark=QoS_2_In parent=QoS_Download \
    priority=2 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_7_In packet-mark=QoS_7_In parent=QoS_Download \
    priority=7 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_8_In packet-mark=QoS_8_In parent=QoS_Download \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_Upload packet-mark="" parent=global-out priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_1_Out packet-mark=QoS_1_Out parent=QoS_Upload \
    priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_2_Out packet-mark=QoS_2_Out parent=QoS_Upload \
    priority=2 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_7_Out packet-mark=QoS_7_Out parent=QoS_Upload \
    priority=7 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_8_Out packet-mark=QoS_8_Out parent=QoS_Upload \
    priority=8 queue=default

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 492
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #29 : octubre 18, 2013, 09:16:55 pm »
 ??? aqui dejo un link de QoS en version 6:

http://forum.mikrotik.com/viewtopic.php?t=73214&p=384066
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #30 : octubre 20, 2013, 12:24:44 am »
HOLA AMIGOS AKI DEJANDO MI GRANITO DE ARENA ESPERO Q LE SIRVA A MUCHOS DE USTEDES
/ip firewall mangle
add action=mark-packet chain=postrouting connection-mark=squid-connection disabled=no new-packet-mark=squid-packs passthrough=yes
add action=mark-connection chain=prerouting comment="HOME 2.1Mbps/700k-A" disabled=no dst-address-list="HOME 2Mbps8-1-A" new-connection-mark=HOME-RJ_2Mbps_in passthrough=yes
add action=mark-connection chain=forward disabled=no new-connection-mark=HOME-RJ_2Mbps_out passthrough=yes src-address-list="HOME 2Mbps8-1-A"
add action=mark-packet chain=prerouting connection-mark=HOME-RJ_2Mbps_in disabled=no new-packet-mark=HOME-FM_2Mbps_in passthrough=no
add action=mark-packet chain=forward connection-mark=HOME-RJ_2Mbps_out disabled=no new-packet-mark=HOME-FM_2Mbps_out passthrough=no

/queue type
 add kind=sfq name=RJ_QoS sfq-allot=1514 sfq-perturb=5
add kind=pcq name=2.1MB-Down pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50 \
    pcq-rate=2100k pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000
add kind=pcq name=2.1MB-Up pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50 \
    pcq-rate=2100k pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000




/ques tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Rj_Main_DOWN packet-mark="" parent=global-out priority=5
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Rj_Main_UP packet-mark="" parent=global-out priority=5
add burst-limit=0 burst-threshold=2100k burst-time=10s comment="Group HOME 2Mbps/2Mbps Download" disabled=no limit-at=700k max-limit=2100k name="HOME 2Mbps8-1-A_DOWN" packet-mark=\
    HOME-FM_2Mbps_in parent=Rj_Main_DOWN priority=8 queue=2.1MB-Down
add burst-limit=0 burst-threshold=2100k burst-time=10s comment="Group HOME 2Mbps/2Mbps Upload" disabled=no limit-at=700k max-limit=2100k name="HOME 2Mbps8-1-A_UP" packet-mark=\
    HOME-FM_2Mbps_out parent=Rj_Main_UP priority=8 queue=700k-Up

PUES SI ALGO NO ESTA BIEN PUES AYUDEMEN A CORREGIR PERO A MI ME TRABAJA BIEN
Y DE IGUALMANERA NO DEJEN DE PONER UN LIKE

















Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
Re:Qos
« Respuesta #31 : octubre 20, 2013, 12:26:30 am »
y no se porq no salieron las imagenes porq si estaban para la prueba.............

si lo ponen en otro foro no olvidar de agradecer a rifranco202325

Desconectado RASTAMAN

  • Newbie
  • *
  • Mensajes: 21
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Qos
« Respuesta #32 : diciembre 11, 2013, 01:50:28 pm »
Buenas Noches

Les dejo mi aportación
son 100% modificables para cualquier red y muy simples de entender
Espero les sea de utilidad para que entiendan como funciona un  qos
y recuerden lo siempre lo complicado es lo mejor aveces lo sencillo resulta mas util

Saludos Cordiales,
Leandro Segovia

PD. La ether1 es por donde entra el internet o conexion a tu borde depende como lo utilices

Código: [Seleccionar]
/ip firewall mangle
add action=mark-packet chain=prerouting comment=QoS_1 disabled=no \
    in-interface=ether1 new-packet-mark=QoS_1_In passthrough=no protocol=tcp \
    src-port=80,53,443,3074,1863,22,8291,3389,21
add action=mark-packet chain=postrouting disabled=no dst-port=\
    80,53,443,3074,1863,22,8291,3389,21 new-packet-mark=QoS_1_Out \
    out-interface=ether1 passthrough=no protocol=tcp tcp-flags=syn
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_1_In passthrough=no protocol=udp src-port=\
    53,88,3074,1863
add action=mark-packet chain=postrouting disabled=no dst-port=53,88,3074,1863 \
    new-packet-mark=QoS_1_Out out-interface=ether1 passthrough=no protocol=\
    udp
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_1_In passthrough=no protocol=icmp
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_1_Out out-interface=ether1 passthrough=no protocol=icmp
add action=mark-packet chain=prerouting comment=QoS_2 disabled=no \
    in-interface=ether1 new-packet-mark=QoS_2_In passthrough=no protocol=tcp \
    src-port=110,25,995,465,587,113
add action=mark-packet chain=postrouting disabled=no dst-port=\
    110,25,995,465,587,113 new-packet-mark=QoS_2_Out out-interface=ether1 \
    passthrough=no protocol=tcp
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_2_In passthrough=no protocol=udp src-port=123,113
add action=mark-packet chain=postrouting disabled=no dst-port=123,113 \
    new-packet-mark=QoS_2_Out out-interface=ether1 passthrough=no protocol=\
    udp
add action=mark-packet chain=prerouting comment=Qos_7 disabled=no \
    in-interface=ether1 new-packet-mark=QoS_7_In passthrough=no protocol=tcp
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_7_Out out-interface=ether1 passthrough=no protocol=tcp
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_7_In passthrough=no protocol=udp
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_7_Out out-interface=ether1 passthrough=no protocol=udp
add action=mark-packet chain=prerouting disabled=no in-interface=ether1 \
    new-packet-mark=QoS_7_In passthrough=no
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_7_Out out-interface=ether1 passthrough=no
add action=mark-packet chain=prerouting comment=QoS_8 disabled=no \
    in-interface=ether1 new-packet-mark=QoS_8_In p2p=all-p2p passthrough=no
add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
    QoS_8_Out out-interface=ether1 p2p=all-p2p passthrough=no

Código: [Seleccionar]
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_Download packet-mark="" parent=global-in priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_1_In packet-mark=QoS_1_In parent=QoS_Download \
    priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_2_In packet-mark=QoS_2_In parent=QoS_Download \
    priority=2 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_7_In packet-mark=QoS_7_In parent=QoS_Download \
    priority=7 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_8_In packet-mark=QoS_8_In parent=QoS_Download \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_Upload packet-mark="" parent=global-out priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_1_Out packet-mark=QoS_1_Out parent=QoS_Upload \
    priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_2_Out packet-mark=QoS_2_Out parent=QoS_Upload \
    priority=2 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_7_Out packet-mark=QoS_7_Out parent=QoS_Upload \
    priority=7 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=QoS_8_Out packet-mark=QoS_8_Out parent=QoS_Upload \
    priority=8 queue=default


mi hermano disculpe pero no tiene ningun limite estas colas

Desconectado centronick

  • Jr. Member
  • **
  • Mensajes: 99
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 1
Re:Qos
« Respuesta #33 : diciembre 12, 2013, 10:31:33 am »

mi hermano disculpe pero no tiene ningun limite estas colas

Donde me funciona mejor en un balanceador mikrotik o el administrador mikrotik

y mas que todo cual es la funcion de todas estas reglas

Gracias

Desconectado WebNewbie

  • Newbie
  • *
  • Mensajes: 8
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Qos
« Respuesta #34 : julio 28, 2014, 07:57:59 pm »
Para aquellos que tienen en su configuración a Internet a través de una interfaz pppoe, se habrán dado cuenta que hay dos reglas dinámicas creadas cuando se inicia una conexión a internet dentro de Mangle. Estas 2 reglas tienen que estar al inicio para que el QoS de si_faisal funcione.

Primero desactivamos el valor por defecto de una conexión pppoe-out:
Código: [Seleccionar]
/ppp profile set default name="default" change-tcp-mss=no
Luego creamos nuestra propia MSS:

Código: [Seleccionar]
/ip firewall mangle
add chain=forward in-interface=all-ppp protocol=tcp \
tcp-mss=1411-65535 tcp-flags=syn action=change-mss new-mss=1410 place-before=0
add chain=forward out-interface=all-ppp protocol=tcp \
tcp-mss=1411-65535 tcp-flags=syn action=change-mss new-mss=1410 place-before=1
Luego lo mueves al principio de todas las demás reglas existentes en Manglo.

Ojo que para poner el valor de new-mss debes considerarlo según http://www.mikrotik.com/download/MUM-crachiolo.zip

tomando como modelo el siguiente codigo:
Código: [Seleccionar]
/ip firewall mangle add chain=forward protocol=tcp in-interface=all-ppp tcp-flags=syn tcp-mss={Whatever the MTU is, subtract 40 and add 1}-65535 action=change-mss passthrough=yes new-mss={Whatever the MTU is, subtract 40}