Evitar que Raptor corte el Servicio de Internet por apagado del Servidor

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 629
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 94
Evitar que Raptor corte el Servicio de Internet por apagado del Servidor
Si el servidor se llegase a apagar por algún motivo ya sea por un corte de energía u otro detalle, se puede evitar que el servicio se quede sin internet, para eso implementamos siguiente regla.

En el caso de la redirección por NAT
Código:
  1. /tool netwatch
  2.  add comment=RaptorCache disabled=no down-script=\
  3.  "/ip firewall nat set [find comment=\"Redirect Raptor\"] disabled=yes" \
  4.  host=192.168.10.2 interval=2s timeout=2s up-script=\
  5.  "/ip firewall nat set [find comment=\"Redirect Raptor\"] disabled=no"

La redirección por Mangle trae una verificación por ping en la regla route, que desactiva la regla, pero si se quiere implementar la regla netwatch sería de la siguiente manera
Código:
  1. /tool netwatch
  2. add comment=\
  3.     "Redirect Raptor Mangle ======================================================================================>" \
  4.     disabled=no down-script=\
  5.     "/ip firewall mangle set [find comment=\"Raptor - Mangle ====================>\"] disabled=yes" host=\
  6.     192.168.10.2 interval=2s timeout=2s up-script=\
  7.     "/ip firewall mangle set [find comment=\"Raptor - Mangle ====================>\"] disabled=no"

La regla verificara si hay ping al servidor, en el caso no haya desconectará la regla de redirección, esto lo hara identificando el comentario de la regla.
RaptorCache Developer

Desconectado leandro1979

  • Jr. Member
  • **
  • Mensajes: 72
  • Ubicación: Ecuador
    • Ver Perfil
  • Me Gusta: 2
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #1 : octubre 29, 2012, 03:38:15 pm »
Buenas tardes
este es el caso de que el servidor se apague que no es muy común
hay forma que hacer lo mismo pero que sea por el puerto de thunder o squid
ya que es mas común que el squid deje de funcionar o se colapse antes que lo haga el servidor

saludos
leandro

Desconectado dgonzaleznet

  • Full Member
  • ***
  • Mensajes: 107
  • Ubicación: Ecuador
    • Ver Perfil
  • Me Gusta: 0
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #2 : octubre 29, 2012, 07:57:18 pm »
Buena sugerencia Leandro y si me ha pasado una vez tuve problemas con el thunder y era por el squid, entonces como el ping seguía activo al thunder entonces la regla del netwatch no se cambiaba a down, tuve que entrar por teamviewer desde mi celular a una pc de la oficina y mandar abajo el puerto....
Saludos Cordiales,
Daniel González Peña

Desconectado JhOnCA

  • Newbie
  • *
  • Mensajes: 12
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #3 : octubre 30, 2012, 08:50:38 am »
Gracias por el script me sirvio de mucho.

Desconectado xagitario

  • Newbie
  • *
  • Mensajes: 11
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #4 : noviembre 01, 2012, 09:46:06 am »
Hola amigos muy buenos días en especial al amigo joem, quisiera de antemano agradecerle por el apoyo que nos brinda mil gracias amigo.
Bueno amigos yo utilizaría este script aparte de la función mencionada por el amigo joem en las horas en que desearía que mi servidor descanse y no estén conectados muchos clientes, así los que tenemos una pc como servidor alargaríamos su vida útil, no se amigos que opinan o estoy equivocado?.
La creatividad nace de la angustia como el día nace de la noche oscura.      Albert Einstein

Desconectado bravel03

  • Newbie
  • *
  • Mensajes: 3
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #5 : noviembre 11, 2012, 10:38:15 pm »
muchas gracias

Desconectado dargoros

  • Newbie
  • *
  • Mensajes: 9
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #6 : abril 20, 2013, 06:18:26 pm »
para el Raptor seria lo mismo????

Desconectado alternet

  • Newbie
  • *
  • Mensajes: 20
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #7 : abril 21, 2013, 02:39:11 pm »
solo se tendría que cambiar el comentario, considerando que el raptor tenga el mismo IP
saludos

freedarwuin

  • Visitante
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #8 : junio 24, 2013, 12:01:57 am »
En este caso por si el servidor llegase a apagar por algún motivo y así evitar que el servicio se quede sin internet se puede utilizar la siguiente regla.

Código:
  1. /tool netwatch
  2.  add comment=ThunderCache disabled=no down-script=\
  3.  "/ip firewall nat set [find comment=\"Redirect Thunder 3.1.x\"] disabled=yes" \
  4.  host=192.168.10.2 interval=2s timeout=2s up-script=\
  5.  "/ip firewall nat set [find comment=\"Redirect Thunder 3.1.x\"] disabled=no"

La regla verificara si hay ping al servidor, en el caso no haya desconectará la regla de redirección, esto lo hara identificando el comentario de la regla.


Gracias !00% funcionando

Desconectado juanslayer

  • Jr. Member
  • **
  • Mensajes: 98
  • Ubicación:
    • Ver Perfil
    • FiltroAntilagLancenter
  • Me Gusta: 2
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #9 : noviembre 02, 2013, 06:21:45 am »
joem6 yo uso el siguiente script y lo llamo en schulde también funcionado bien a quien le sirva lo aporto
*********************script**************************
:global r
:if ([/ping 192.168.10.2 count=5] = 0 && $r != 1) do={
:set r 1
:log info "cambio a proxy mikrotik";
 /ip firewall nat
disable 8
 /ip firewall nat
enable 6}

:if ([/ping 192.168.10.2 count=5] != 0 && $r != 0) do={
:set r 0
:log info "cambio a proxy squid";
 /ip firewall nat
 enable 8
 /ip firewall nat
disable 6}
*******************************************+
Código: [Seleccionar]
/system ntp client
set enabled=yes mode=unicast primary-ntp=129.6.15.28 secondary-ntp=129.6.15.29

/system scheduler
add disabled=no interval=10s name=schedule1 on-event=script1 policy=\
    ftp,reboot,read,write,policy,test,winbox,sniff,sensitive,api start-time=startup

/system script
add name=script1 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source=":global r \r\
    \n:if ([/ping 192.168.10.2 count=5] = 0 && \$r != 1) do={\r\
    \n:set r 1\r\
    \n:log info \"cambio a proxy mikrotik\";\r\
    \n /ip firewall nat \r\
    \ndisable 8\r\
    \n /ip firewall nat \r\
    \nenable 6} \r\
    \n\r\
    \n:if ([/ping 192.168.10.2 count=5] != 0 && \$r != 0) do={\r\
    \n:set r 0\r\
    \n:log info \"cambio a proxy squid\";\r\
    \n /ip firewall nat \r\
    \n enable 8\r\
    \n /ip firewall nat \r\
    \ndisable 6}"
********************************
olvide mencionara el numedo despues de enable es la posision de la regla que quieren habilitar o inhabilitar fijarse la pocicion en nat esto difiere sengun el script.

Desconectado freedarwuin

  • Sr. Member
  • ****
  • Mensajes: 499
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 7
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #10 : noviembre 02, 2013, 06:45:25 am »
joem6 yo uso el siguiente script y lo llamo en schulde también funcionado bien a quien le sirva lo aporto
*********************script**************************
:global r
:if ([/ping 192.168.10.2 count=5] = 0 && $r != 1) do={
:set r 1
:log info "cambio a proxy mikrotik";
 /ip firewall nat
disable 8
 /ip firewall nat
enable 6}

:if ([/ping 192.168.10.2 count=5] != 0 && $r != 0) do={
:set r 0
:log info "cambio a proxy squid";
 /ip firewall nat
 enable 8
 /ip firewall nat
disable 6}
*******************************************+
/system ntp client
set enabled=yes mode=unicast primary-ntp=129.6.15.28 secondary-ntp=129.6.15.29

/system scheduler
add disabled=no interval=10s name=schedule1 on-event=script1 policy=\
    ftp,reboot,read,write,policy,test,winbox,sniff,sensitive,api start-time=startup

/system script
add name=script1 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source=":global r \r\
    \n:if ([/ping 192.168.10.2 count=5] = 0 && \$r != 1) do={\r\
    \n:set r 1\r\
    \n:log info \"cambio a proxy mikrotik\";\r\
    \n /ip firewall nat \r\
    \ndisable 8\r\
    \n /ip firewall nat \r\
    \nenable 6} \r\
    \n\r\
    \n:if ([/ping 192.168.10.2 count=5] != 0 && \$r != 0) do={\r\
    \n:set r 0\r\
    \n:log info \"cambio a proxy squid\";\r\
    \n /ip firewall nat \r\
    \n enable 8\r\
    \n /ip firewall nat \r\
    \ndisable 6}"

Muy bueno tu aporte
>Si te gusta dale LIKE<

Entre las redes cableadas y las que no, el Mikrotik, ThunderCache y Tp-Link no hay nada Oculto... Para todo lo demás solo hay que "Guglear".
Mikrotik, Raptor, Ubiquiti, Tplink.
Prestamos Soporte en cuanto a Redes se refiere a Empresas, Wisp y hogares!!!
www.mikronet.com.ve

Desconectado oscartzgz

  • Newbie
  • *
  • Mensajes: 24
  • Ubicación:
    • Ver Perfil
    • LinuxPl4y
  • Me Gusta: 1
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #11 : enero 23, 2014, 01:29:28 am »
Gracias por el código, alguien me podría explicar que hace exactamente esta parte  [find comment=\"Redirect Thunder 3.1.x\"]  ?, si tengo raptor con la misma ip no tendria que cambiar nada?, disculpen la molestia, saludos.
Proyectos raros

Desconectado Calamardo

  • Jr. Member
  • **
  • Mensajes: 95
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #12 : enero 27, 2015, 12:48:34 am »
Interesante justo lo que buscaba se me hace algo complicado comparado a lo que se me ocurre hacerlo de manera en circuito asi lo apago cuando quiera y enciendo cuando se nececite ya que el server lo tengo a 6 kilometros de donde administro luego les subo fotos nomas seria que tengo que apagar la regla manualmente . buen foro  ;D

Desconectado andret1719

  • Full Member
  • ***
  • Mensajes: 114
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #13 : enero 27, 2015, 10:07:15 pm »
Gracias por el código, alguien me podría explicar que hace exactamente esta parte  [find comment=\"Redirect Thunder 3.1.x\"]  ?, si tengo raptor con la misma ip no tendria que cambiar nada?, disculpen la molestia, saludos.

Segun entiendo esa parte testea el comentario "Redirect Thunder 3.1.x\" o el comentario que le tengas a la regla de direccionamiento, dependiendo el estado desactiva la regla o la activa..

Desconectado luistec

  • Moderador
  • *
  • Mensajes: 1501
  • Ubicación: Los Olivos - Perú
    • Ver Perfil
  • Me Gusta: 50
Re:Evitar que Thunder corte el Servicio de Internet por apagado del Servidor
« Respuesta #14 : enero 27, 2015, 10:16:59 pm »
Segun entiendo esa parte testea el comentario "Redirect Thunder 3.1.x\" o el comentario que le tengas a la regla de direccionamiento, dependiendo el estado desactiva la regla o la activa..
Claro, esta regla actua de acuerdo al estado de conectividad al servidor, en caso este se desconecte desactiva a la regla en "IP/FIREWALL/NAT" que tenga el comentario coincidente, en caso vuelva la comectividad activa la regla.

Saludos.

Desconectado ccarhuass

  • Newbie
  • *
  • Mensajes: 5
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Evitar que Raptor corte el Servicio de Internet por apagado del Servidor
« Respuesta #15 : diciembre 03, 2015, 06:20:51 pm »
Evitar que Raptor corte el Servicio de Internet por apagado del Servidor, redirecciónado por Mangle, funciona en el Raptorcache2?

Desconectado joemg6

  • Administrador
  • *
  • Mensajes: 629
  • Ubicación: Hz.
    • Ver Perfil
  • Me Gusta: 94
Re:Evitar que Raptor corte el Servicio de Internet por apagado del Servidor
« Respuesta #16 : diciembre 03, 2015, 08:07:09 pm »
Evitar que Raptor corte el Servicio de Internet por apagado del Servidor, redirecciónado por Mangle, funciona en el Raptorcache2?
Claro, funciona para Raptorcache 2, si se usa la redirección por mangle la regla de route corta la redirección en caso de no obtener ping a los 20 seg. la regla de netwatch en el caso de la redirección por mangle solo está como algo adicional.
RaptorCache Developer