RaptorCache e Lusca - script de instalação para debian 7 com redirecionamento

Desconectado fsouza

  • Newbie
  • *
  • Mensajes: 14
  • Ubicación: Brazil
    • Ver Perfil
  • Me Gusta: 0
RaptorCache e Lusca - script de instalação para debian 7 com redirecionamento

Bon dia a todos.
     Contribuindo com o fórum fiz uma pequena modificação no script de instalação do grande mestre Joemg, substituído o squid pelo o lusca cache..     
 
Instruções para instalação:
Descompacte a pasta Raptor-Lusca (usando uma maquina on Windows) dentro dessa pasta existe uma sub_pasta chamada configs e o sript de instalação com o nome de instalador.
 
Atenção para aquele apressados e os famosos  ctrl+C e ctrl+V esses passos são de suma importância para que a instalação seja bem sucedida, portanto recomendo uma leitura mínima para entender o assunto.
Acesse seu debian recen instalado (via winsp) o qual devera estar com os ips, conforme descrito nesse tutorial.
Copie a sub_pasta configs  e o script instalador para dentro da pasta /usr/src
Depois acesse novamente o seu debian (dessa vez utilizando o puty) ou se preferir pode usar o próprio terminal, e digite esses comando (como usuário root)
Código: [Seleccionar]
cd /usr/src
chmod 777 /usr/src/*
./instalador
Nem preciso lembrar que a cada comando precisar pressionar a tecla enter
 
 
para integrar ao mikrotik paralelo
Passo a Passo

Usaremos seguinte conf.
No RaptorCache
Código: [Seleccionar]
IP Address = 192.168.10.2
Subnet Mask = 255.255.255.252
Default Router = 192.168.10.1

No Mikrotik
Código: [Seleccionar]
Interface ligada ao Raptor = ether2
IP da ether2 = 192.168.10.1/30
Interface ligada ao Link = ether1
Interface ligada aos Clientes = ether3
Range de IP dos Clientes = 10.0.0.0/8

1° Passo
Marcar os pacotes que serão enviados para o cache.
(ATENÇÃO ESSA REGRA TEM QUE FICAR ACIMA DE QUALQUER OUTRA EXISTENTE, CASO CONTRARIO A PAGINA E CORTA NÃO FUNCIONARÁ E O REDIRECIONAMENTO NÃO FICA LEGAL, APANHEI PARA DESCOBRIR ISSO, INCLUSIVE ESSAS REGRAS VALEM TAMBÉM PARA O THUNDER 7,1)
Código:
  1. /ip firewall mangle
  2. add action=mark-routing chain=prerouting src-address=10.0.0.0/8 dst-address-list=!Site_fora_do_cache src-address-list=!Cliente_fora_do_cache in-interface=!ether2 comment=RAPTOR-CACHE disabled=yes protocol=tcp dst-port=80 new-routing-mark=to_cache passthrough=yes

2° Passo
Criar a rota que enviará os pacotes marcados ao Raptor
Código:
  1. /ip route
  2. add comment=ROTA-RAPTOR disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=to_cache scope=30 target-scope=10

3° Passo
Iremos aqui criar duas listas.
A dos clientes que não passarão pelo cache e a dos sites que será entregue ao cliente sem passar pelo cache.
Código:
  1. /ip firewall address-list
  2. add address=192.168.10.2 list=Cliente_fora_do_cache comment="Cliente Fora do Cache" disabled=no
  3. add address=192.168.10.2 list=Site_fora_do_cache comment="Site Fora do Cache" disabled=no

4° Passo
Redirecionando porta para acesso externo ao servidor RaptorCache, e criando uma nat de saída.
Código:
  1. /ip firewall nat
  2. add action=dst-nat chain=dstnat dst-port=2200 protocol=tcp to-addresses=192.168.10.2 to-ports=22 comment=SSH_Raptor disabled=no
  3. add action=dst-nat chain=dstnat dst-port=82 protocol=tcp to-addresses=192.168.10.2 to-ports=82 comment=WEBADMIN_Raptor disabled=no
  4. add action=masquerade chain=srcnat out-interface=ether1 src-address=192.168.10.0/24 comment="NAT_Raptor" disabled=no

5° Passo
Marcar pacotes para que fazer o cache full
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=\
  3.     "\\\\\\\\\\\\\\\\\\\\Cache Full Lusca//////////" disabled=no dscp=12 \
  4.     new-connection-mark=Lusca-Cache passthrough=yes protocol=tcp \
  5.     src-address-list=""
  6. add action=mark-packet chain=postrouting connection-mark=Lusca-Cache \
  7.     disabled=no new-packet-mark=Cache-Full passthrough=yes
  8. add action=mark-connection chain=postrouting comment="Cache Full Raptor" \
  9.     content="X-Cache: HIT from Raptor" disabled=no new-connection-mark=\
  10.     raptor-connection passthrough=yes
  11. add action=mark-packet chain=postrouting connection-mark=raptor-connection \
  12.     disabled=no new-packet-mark=raptor-packs passthrough=no

5° Passo
Criar classes para cache full
Código:
  1. /queue tree
  2. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=10M max-limit=20M name=RaptorCache \
  3.     packet-mark=raptor-packs parent=global-out priority=4 queue=default
  4. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=10M max-limit=20M name=LuscaCache \
  5.     packet-mark=Cache-Full parent=global-out priority=4 queue=default

Desconectado abcwarbot

  • Jr. Member
  • **
  • Mensajes: 86
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 1
Hola,

Squid vs Lusca.

Cuales son las diferencias.?



Cordialmente

Desconectado ingjaab

  • Sr. Member
  • ****
  • Mensajes: 488
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
deberías hacer un vídeo como si instala
Mueres siendo un héroe, o vives lo suficiente para convertirte en villano

Desconectado luistec

  • Moderador
  • *
  • Mensajes: 1497
  • Ubicación: Los Olivos - Perú
    • Ver Perfil
  • Me Gusta: 49
Interesante post ya que lusca es un fork (arreglo) de squid.

Saludos.

Desconectado cmoya

  • Newbie
  • *
  • Mensajes: 28
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Una consulta hay que desabilitar el plugins de video verdad para que haga cache el squid con el luzca verdad o me equivoco

Desconectado fsouza

  • Newbie
  • *
  • Mensajes: 14
  • Ubicación: Brazil
    • Ver Perfil
  • Me Gusta: 0
Una consulta hay que desabilitar el plugins de video verdad para que haga cache el squid con el luzca verdad o me equivoco

não ha necessidade de alteração, basta coloca-lo em produção

Desconectado cmoya

  • Newbie
  • *
  • Mensajes: 28
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Gracias por responder y ya no vamos a tener problemas con los videos verdad, en este momento voy a montar el server en caso de que se me deficulte de manera especial solicito me ayude via teamviewr por favor

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 26
não ha necessidade de alteração, basta coloca-lo em produção

Amigo fsouza cual es la diferencia entre squid y lusca, hay alguna diferencia entre uno y otro, pues para despertar el interes de la comunidad de implementar Lusca en sus entornos, Saludos

Fsouza amigo é a diferença entre lula e lusca, há alguma diferença entre os dois, como para despertar o interesse da comunidade para implementar Lusca em seus ambientes, cumprimentos


Desconectado cmoya

  • Newbie
  • *
  • Mensajes: 28
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
logre configurar como dice el amigo pero sigo teniendo el mismo problema  con los videos solo modifica el squid mas nada alguien tiene alguna solucion con los videos que me ayude

Desconectado fsouza

  • Newbie
  • *
  • Mensajes: 14
  • Ubicación: Brazil
    • Ver Perfil
  • Me Gusta: 0
Amigo fsouza cual es la diferencia entre squid y lusca, hay alguna diferencia entre uno y otro, pues para despertar el interes de la comunidad de implementar Lusca en sus entornos, Saludos

Fsouza amigo é a diferença entre lula e lusca, há alguma diferença entre os dois, como para despertar o interesse da comunidade para implementar Lusca em seus ambientes, cumprimentos


creio que este poste responda a questão entre squid x lusca
http://intranet.btelway.com.br/wiki/index.php/Proxy_com_freeBSD_%2B_LUSCA%28Fork_do_Squid%29

Desconectado fsouza

  • Newbie
  • *
  • Mensajes: 14
  • Ubicación: Brazil
    • Ver Perfil
  • Me Gusta: 0
logre configurar como dice el amigo pero sigo teniendo el mismo problema  con los videos solo modifica el squid mas nada alguien tiene alguna solucion con los videos que me ayude

os problemas com videos, sao raros mas referentes ao raptor, ja que o lusca faz apenas o cache estatico. tenho usado aqui sem nenhum problema.

Desconectado fsouza

  • Newbie
  • *
  • Mensajes: 14
  • Ubicación: Brazil
    • Ver Perfil
  • Me Gusta: 0
Una consulta hay que desabilitar el plugins de video verdad para que haga cache el squid con el luzca verdad o me equivoco

precisa remover o squid compelamente, caso esta instalado, com o comando
apt-get purge squid (para o squid 2.7) ou apt-get purge squid3 (para o squid 3.x) e so depois fazer a instalaçao do raptor + lusca.

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 26

creio que este poste responda a questão entre squid x lusca
http://intranet.btelway.com.br/wiki/index.php/Proxy_com_freeBSD_%2B_LUSCA%28Fork_do_Squid%29

Comprendo lo que dice en el enlace que pusiste, pero respecto a squid3.1.20, que es la version estable en este momento y me gustaria saber cada cuanto hacen actualizaciones con respecto a lusca y si de abril de 2012 a la fecha a habido un cambio de version en lusca, perdona mi preguntadera, pero me gusta estar informado, Saludos

Desconectado fsouza

  • Newbie
  • *
  • Mensajes: 14
  • Ubicación: Brazil
    • Ver Perfil
  • Me Gusta: 0
Comprendo lo que dice en el enlace que pusiste, pero respecto a squid3.1.20, que es la version estable en este momento y me gustaria saber cada cuanto hacen actualizaciones con respecto a lusca y si de abril de 2012 a la fecha a habido un cambio de version en lusca, perdona mi preguntadera, pero me gusta estar informado, Saludos

em minhas experiencias, o lusca se mostrou mas eficiente e estavel que qualquer versao do squid, em uma rede com 300 maquinas on-line, abaixo consta o link do projeto com todas as informações tecnicas
 http://www.lusca.org/

WALYN

  • Visitante
me gustaría hacer una pregunta a joeMG por que en ves de descargar raptorcache de Internet porque no hacerlo desde un cd un ejemplo cuando tiras una versión de raptorcache que sea por iso y así nos evitamos descargar tanto archivos tanto de debían como de raptorcache..saludo

Desconectado nqm74

  • Full Member
  • ***
  • Mensajes: 188
  • Ubicación: Venezuela
    • Ver Perfil
  • Me Gusta: 0
Muy buena la idea, solo que faltaria un video, que explique los pasos de instalacion y configuracion, haber quien lo pueda aportar.. saludos a todos...

WALYN

  • Visitante
y hacerlo desde un iso nos ayuda a que si se daña el raptorcache solo tenemos que instalar desde el CD o de un USB sin necesidad de bajarlo de   nuevo desde Internet ..saludos..

Desconectado rifranco202325

  • Sr. Member
  • ****
  • Mensajes: 267
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 3
no se vallan del tema del pana........alguien q lo aya probado y le este funcionando bien pero segun eso el q esta haciendo el cache es el lucas no el raptor   

Desconectado Zero

  • Jr. Member
  • **
  • Mensajes: 78
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
y hacerlo desde un iso nos ayuda a que si se daña el raptorcache solo tenemos que instalar desde el CD o de un USB sin necesidad de bajarlo de   nuevo desde Internet ..saludos..

Hola WALYN, con la llegada de GNU/Linux Limeroot creo que eso quedaría en el pasado, la idea es trabajar de la mano con proyectos como este de joem (raptor), haarp (kei kurono), y thunder3x (vfeitoza?), la idea es que desde el webadmin podas instalar cualquiera de estos con un solo clic, estamos trabajando duro para que la version r3 salga  con muchas cosas interesantes y el tan esperado plugin manager.
En GNU/Linux formatear por cualquier cosa es de noobs, tu decides si eres uno...

Desconectado Franco

  • Newbie
  • *
  • Mensajes: 42
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 1
La verdad que es muy interesante este Squid modificado. Pero debo decir que, es muy tentador tener a RaptorCache funcionando sobre "Lusca". Ya que si es estable como se dice a por tara mas estabilidad  de la que ya tiene RaptorCache. También debo decir que al día de hoy RaptorCache funciona muy bien, es mas a superado mis expectativas.