RaptorCache e Lusca - script de instalação para debian 7 com redirecionamento

Desconectado tonyvzla

  • Hero Member
  • *****
  • Mensajes: 700
  • Ubicación: Venezuela
  • Continuaremos el legado de HUGO CHAVEZ
    • Ver Perfil
  • Me Gusta: 1
Esperemos como te va abc, si todo va bien publica un tuto de como hacerlo funcionar, gracias
En ayuda de los mas desprotegidos

Desconectado johnwin98

  • Newbie
  • *
  • Mensajes: 5
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
hola necesito de tu ayuda

Qual tu problema!

manda mp com tu skype

Desconectado mac86

  • Newbie
  • *
  • Mensajes: 10
  • Ubicación: bahia blanca
    • Ver Perfil
  • Me Gusta: 0
lo voy a probar....
squid 3.X con mas de 1000 clientes se traba mucho.... incluso compilandolo con el makefile modificado.

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 26
lo voy a probar....
squid 3.X con mas de 1000 clientes se traba mucho.... incluso compilandolo con el makefile modificado.

Eso dependera de los requerimientos de su servidor, procesador, memoria ram y disco duro, no de squid, squid3 solo usa lo que tiene a su disposicion, aparte para recompilar squid necesitas saber varios detalles para dejarlo a la medida de los requerimientos de tu servidor, entonces squid dependera de lo que tu haces, Saludos

Desconectado robertjs

  • Full Member
  • ***
  • Mensajes: 163
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
Hola con todos.. alguien lo pudo hacer funcionar... les comento la experiencia que estoy teniendo ahora
..

instale raptor y lusca todo bien... agrege las reglas tal y como estan ... solo modifque en el marcado por mi red que es LAN

pero no logro hacer full cache en nada...

haber alguien que me una info.. si logro hacerlo funcionar. saludos

Desconectado thefirem2008

  • Newbie
  • *
  • Mensajes: 9
  • Ubicación: REPUBLICA DOMINICANA
    • Ver Perfil
  • Me Gusta: 0
Re:RaptorCache e Lusca - script de instalação para debian 7 com redirecionamento
« Respuesta #45 : diciembre 24, 2014, 04:57:14 am »
a quien le a funcionado este scrip ?
Dios es mi todo.
Un verdadero maestro enseña.

Desconectado firecold

  • Moderador
  • *
  • Mensajes: 3444
  • Ubicación: Guatemala
  • Todo lo puedo en Cristo que me fortalece.
    • Ver Perfil
  • Me Gusta: 26
Re:RaptorCache e Lusca - script de instalação para debian 7 com redirecionamento
« Respuesta #46 : diciembre 24, 2014, 10:56:51 am »
a quien le a funcionado este scrip ?

Es que esta un poco desactualizado y lusca como tal es muy bueno, pero tambien algo desactualizado, si puedes ver su ultimo paquete fue hace buen tiempo, Saludos

Desconectado andrelprata

  • Newbie
  • *
  • Mensajes: 1
  • Ubicación:
    • Ver Perfil
  • Me Gusta: 0
RaptorCache e Lusca - script de instalação para debian 7 com redirecionamento

Bon dia a todos.
     Contribuindo com o fórum fiz uma pequena modificação no script de instalação do grande mestre Joemg, substituído o squid pelo o lusca cache..     
 
Instruções para instalação:
Descompacte a pasta Raptor-Lusca (usando uma maquina on Windows) dentro dessa pasta existe uma sub_pasta chamada configs e o sript de instalação com o nome de instalador.
 
Atenção para aquele apressados e os famosos  ctrl+C e ctrl+V esses passos são de suma importância para que a instalação seja bem sucedida, portanto recomendo uma leitura mínima para entender o assunto.
Acesse seu debian recen instalado (via winsp) o qual devera estar com os ips, conforme descrito nesse tutorial.
Copie a sub_pasta configs  e o script instalador para dentro da pasta /usr/src
Depois acesse novamente o seu debian (dessa vez utilizando o puty) ou se preferir pode usar o próprio terminal, e digite esses comando (como usuário root)
Código: [Seleccionar]
cd /usr/src
chmod 777 /usr/src/*
./instalador
Nem preciso lembrar que a cada comando precisar pressionar a tecla enter
 
 
para integrar ao mikrotik paralelo
Passo a Passo

Usaremos seguinte conf.
No RaptorCache
Código: [Seleccionar]
IP Address = 192.168.10.2
Subnet Mask = 255.255.255.252
Default Router = 192.168.10.1

No Mikrotik
Código: [Seleccionar]
Interface ligada ao Raptor = ether2
IP da ether2 = 192.168.10.1/30
Interface ligada ao Link = ether1
Interface ligada aos Clientes = ether3
Range de IP dos Clientes = 10.0.0.0/8

1° Passo
Marcar os pacotes que serão enviados para o cache.
(ATENÇÃO ESSA REGRA TEM QUE FICAR ACIMA DE QUALQUER OUTRA EXISTENTE, CASO CONTRARIO A PAGINA E CORTA NÃO FUNCIONARÁ E O REDIRECIONAMENTO NÃO FICA LEGAL, APANHEI PARA DESCOBRIR ISSO, INCLUSIVE ESSAS REGRAS VALEM TAMBÉM PARA O THUNDER 7,1)
Código:
  1. /ip firewall mangle
  2. add action=mark-routing chain=prerouting src-address=10.0.0.0/8 dst-address-list=!Site_fora_do_cache src-address-list=!Cliente_fora_do_cache in-interface=!ether2 comment=RAPTOR-CACHE disabled=yes protocol=tcp dst-port=80 new-routing-mark=to_cache passthrough=yes

2° Passo
Criar a rota que enviará os pacotes marcados ao Raptor
Código:
  1. /ip route
  2. add comment=ROTA-RAPTOR disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=to_cache scope=30 target-scope=10

3° Passo
Iremos aqui criar duas listas.
A dos clientes que não passarão pelo cache e a dos sites que será entregue ao cliente sem passar pelo cache.
Código:
  1. /ip firewall address-list
  2. add address=192.168.10.2 list=Cliente_fora_do_cache comment="Cliente Fora do Cache" disabled=no
  3. add address=192.168.10.2 list=Site_fora_do_cache comment="Site Fora do Cache" disabled=no

4° Passo
Redirecionando porta para acesso externo ao servidor RaptorCache, e criando uma nat de saída.
Código:
  1. /ip firewall nat
  2. add action=dst-nat chain=dstnat dst-port=2200 protocol=tcp to-addresses=192.168.10.2 to-ports=22 comment=SSH_Raptor disabled=no
  3. add action=dst-nat chain=dstnat dst-port=82 protocol=tcp to-addresses=192.168.10.2 to-ports=82 comment=WEBADMIN_Raptor disabled=no
  4. add action=masquerade chain=srcnat out-interface=ether1 src-address=192.168.10.0/24 comment="NAT_Raptor" disabled=no

5° Passo
Marcar pacotes para que fazer o cache full
Código:
  1. /ip firewall mangle
  2. add action=mark-connection chain=postrouting comment=\
  3.     "\\\\\\\\\\\\\\\\\\\\Cache Full Lusca//////////" disabled=no dscp=12 \
  4.     new-connection-mark=Lusca-Cache passthrough=yes protocol=tcp \
  5.     src-address-list=""
  6. add action=mark-packet chain=postrouting connection-mark=Lusca-Cache \
  7.     disabled=no new-packet-mark=Cache-Full passthrough=yes
  8. add action=mark-connection chain=postrouting comment="Cache Full Raptor" \
  9.     content="X-Cache: HIT from Raptor" disabled=no new-connection-mark=\
  10.     raptor-connection passthrough=yes
  11. add action=mark-packet chain=postrouting connection-mark=raptor-connection \
  12.     disabled=no new-packet-mark=raptor-packs passthrough=no

5° Passo
Criar classes para cache full
Código:
  1. /queue tree
  2. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=10M max-limit=20M name=RaptorCache \
  3.     packet-mark=raptor-packs parent=global-out priority=4 queue=default
  4. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=10M max-limit=20M name=LuscaCache \
  5.     packet-mark=Cache-Full parent=global-out priority=4 queue=default


Onde acho os arquivos citados para download?